• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OFFICIAL] LineageOS 18.1 for the Moto G7

Search This thread

Kiki B

New member
May 6, 2021
4
1
Great job on the ROM, my G7 Plus is running like clockwork. The built-in update process is very smooth too. And even the FM Radio app is working - but who needs that? ;-)

I may have found a small glitch (if it's not my system playing wild): as per the notification and clock display I have an alarm set, but I haven't. Setting one and turning it off again does not make a difference. Did anybody else notice this?

Anyway, I am as happy as a clam with the system. Thanks a lot for this!
I apologize for calling out showing non-existent alarm as a glitch in the OS. It took some (a lot of, actually) time to find out that Tasker creates an "invisible" alarm for tasks that are triggered by time. Makes sense. Sort of. If you turn off "reliable alarms" in Tasker, the OS clock works as expected. This seems to be a new "feature" since Android 10. Just make sure you know of and test the implications of turning off reliable alarms.
 

andromanicos

New member
May 3, 2017
1
0
En mi caso, de momento está funcionando bien, todavía lo estoy probando.

Debería intentar informar del error:
  • "¿Encontraste alguno? Denúncialo de acuerdo con esta guía "
Falla en esta sección de pantalla de la versión 18.1, opciones avanzadas, colores, si se configura en saturado luego de estacionar la pantalla hace algunos tonos extraños, ejemplo colores invertidos, por favor solucione eso
 

PMDPhD

Member
Nov 18, 2013
20
0
Moto G7
Samsung Galaxy Tab S5e
Does anyone have experience with dealing with carrier/data issues on this ROM? I have had zero issues with LOS 18.1 for the G7. Runs great. For years I have been using AT&T as a carrier and this ROM works great calls/text/data all fine. I recently attempted to switch to US Mobile's "Super LTE" service (Basically this is a MVNO for Verizon which uses LTE/CDMA), I know this phone has the hardware for Verizon but I cannot get data to work with them. There are a lot of selections for carrier preference type in settings, there are several that will allow calls and texts (always with a roaming indicator), but pretty much none will give mobile data. I have updated APNs with US Mobiles guidance, with no luck. I also have taken the SIM out and tried in other phones...a stock ROM moto g7 will work fine, and old Nexus 5x with Lineage OS 18.1 Unofficial will work fine. I have been on chats with US Mobile for hours and can't figure this out, I assume there is some setting in the ROM I need to tick. Any help would be much appreciated, the folks here seem to be far more knowledgeable than the US Mobile reps.
 

Fede79

Senior Member
Mar 9, 2010
94
18
Casilda
Moto G7
I have a couple of questions: install copy partitions, LOS 18, TWRP and opengaps, used the automatic system updater and it replaced the recovery (TWRP to LOS recovery)

Boot TWRP without installing and try to install it as ramdisk, error. The idea is to reinstall everything from 0. What should I do? Currently the system is using slot a
 

TomOehser

Member
Jan 12, 2018
11
3
I have a couple of questions: install copy partitions, LOS 18, TWRP and opengaps, used the automatic system updater and it replaced the recovery (TWRP to LOS recovery)

Boot TWRP without installing and try to install it as ramdisk, error. The idea is to reinstall everything from 0. What should I do? Currently the system is using slot a
First, I always use mindthegapps not opengapps now - had some problem with opengapps, I forget now what... Second, I only install twrp now (from los recovery) when I need it for something - it always will replace it with los recovery, but you can always do as a first step to reinstall twrp before rebooting... my sequence is install los then reboot and install magisk and mindthegapps from losrecovery. Losrecovery is bare-bones but good enough to install magisk and mindthegapps and twrp (though I don't bother with twrp usually anymore since I can always reinstall it from sdcard).
 
  • Like
Reactions: Fede79

JShan

Senior Member
Jan 15, 2013
55
10
Amazon Fire HD 8 and HD 10
Moto G7
Happy with this rom installed. Thanks, devs! This is something of a n00b question, but here goes: I'm assuming each nightly release is a small tweak from what came before. So I'm not imagining flashing a new rom every day. So what's the best way to know how often to flash new nightlies, and when a new nightly is more than just a minor improvement? Thanks, all.
 

PMDPhD

Member
Nov 18, 2013
20
0
Moto G7
Samsung Galaxy Tab S5e
Happy with this rom installed. Thanks, devs! This is something of a n00b question, but here goes: I'm assuming each nightly release is a small tweak from what came before. So I'm not imagining flashing a new rom every day. So what's the best way to know how often to flash new nightlies, and when a new nightly is more than just a minor improvement? Thanks, all.
These "nightly" updates are typically weekly. I update every week if it's available. So far they are very stable. Except for today which has a weird inverted color display bug mentioned earlier in this thread.
You can look at the changes on the lineage download site to see what changes were made for this device or any other ones.
 

TomOehser

Member
Jan 12, 2018
11
3
10/3 update breaks the color palette in livedisplay. I recommend stick with 9/26 until it is fixed!
 

JShan

Senior Member
Jan 15, 2013
55
10
Amazon Fire HD 8 and HD 10
Moto G7
Installed 10/10 nightly; still getting color problems on restart. Easy to fix by toggling color settings, and the fix seems to stick until the next restart.

Sorry, the update had not installed. After I installed the 10/10 update, color seems to be fine even on restart.
 
Last edited:
  • Like
Reactions: npjohnson
Installed 10/10 nightly; still getting color problems on restart. Easy to fix by toggling color settings, and the fix seems to stick until the next restart.

Sorry, the update had not installed. After I installed the 10/10 update, color seems to be fine even on restart.
So, but this had been the workaround for the issue in 10/4.
Unfortunately it took me a whole week, that felt like on crazy drugs, due to the color issue, to find that workaround...
I tried it while downloading 10/10, and works just fine.
So if there is some similar issue again, toggling color settings may help
 
  • Like
Reactions: npjohnson

npjohnson

Recognized Developer
So, but this had been the workaround for the issue in 10/4.
Unfortunately it took me a whole week, that felt like on crazy drugs, due to the color issue, to find that workaround...
I tried it while downloading 10/10, and works just fine.
So if there is some similar issue again, toggling color settings may help
it was my fault - removed a property I shouldn't have, sorry!
 
  • Like
Reactions: user9192
it was my fault - removed a property I shouldn't have, sorry!
Accepted :)
You shouldn't say sorry...
I feel a bit bad almost.
As someone who is not so fit with all that technical stuff, and mostly just using what I find here - I really appreciate everyone who brings in their knowledge.
So I'm really happy with that good work done here...

Errors occurs, and that wasn't even a real problem for me (more some kind of funny incident)

So again thank you.
And keep up that good work :)
 
  • Like
Reactions: npjohnson

kdm6389

Senior Member
Dec 25, 2014
476
83
Deoghar
Can I install on my "XT1962-1"/"Moto G7, Software Channel: Google Fi"?
Does VoLTE work on this device?
 
Last edited:

Sjtaylor75

New member
Nov 21, 2014
4
0
So, but this had been the workaround for the issue in 10/4.
Unfortunately it took me a whole week, that felt like on crazy drugs, due to the color issue, to find that workaround...
I tried it while downloading 10/10, and works just fine.
So if there is some similar issue again, toggling color settings may help
I'm stuck on 2October release, can't update to 9October or 16October, even with ADB sideload the updates fail.

I'm living with the inverted colours issue by changing the display from Saturated to Normal or Boosted each time I see the problem. Annoying.

Will persevere with trying latest versions, but my updater isn't happy and I may need to do a full reinstall.
 

npjohnson

Recognized Developer
Can I install on my "XT1962-1"/"Moto G7, Software Channel: Google Fi"?
Does VoLTE work on this device?
Probably?
I'm stuck on 2October release, can't update to 9October or 16October, even with ADB sideload the updates fail.

I'm living with the inverted colours issue by changing the display from Saturated to Normal or Boosted each time I see the problem. Annoying.

Will persevere with trying latest versions, but my updater isn't happy and I may need to do a full reinstall.
Oof. That's weird. Probably.
 
I upgraded to 11 from 10, I made titanium backup of all my programs on 10, a few of the programs won't restore correct as they would if I were putting them back on 10. Problem is if I restore app+data for chrome beta, titanium says element failed, then when I go to open chome beta , it'll open for like 2 seconds and then close. Only fix I found Is uninstalling the program then reinstalling program straight from Google play, but then I'm missing all my bookmarks passwords and settings. I have about 6 programs that have this exact problem. Is there a fix for this and is this a known problem?

Thank you
 

npjohnson

Recognized Developer
I upgraded to 11 from 10, I made titanium backup of all my programs on 10, a few of the programs won't restore correct as they would if I were putting them back on 10. Problem is if I restore app+data for chrome beta, titanium says element failed, then when I go to open chome beta , it'll open for like 2 seconds and then close. Only fix I found Is uninstalling the program then reinstalling program straight from Google play, but then I'm missing all my bookmarks passwords and settings. I have about 6 programs that have this exact problem. Is there a fix for this and is this a known problem?

Thank you
Nope, that problem has nothing to do with LineageOS, it's something to do with incompatible app data.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    lineage-os-logo.png

    Moto G7

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the Moto G7.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • None.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_motorola_sdm632
    1
    I've heard that some people, including myself, have had issues with upgrading to 18.1 on some devices because it results in a broken lock screen. Is this an issue with 18.1 on the G7? I just want to make sure before I upgrade.
    In my case, at the moment it is working well, I am still testing it.

    You should try to report the bug:
    • "Find any? Report them according to this guide"
    1
    I've heard that some people, including myself, have had issues with upgrading to 18.1 on some devices because it results in a broken lock screen. Is this an issue with 18.1 on the G7? I just want to make sure before I upgrade.
    Only on really really old devices like bacon , etc.
    1
    Only on really really old devices like bacon , etc.
    Thanks for letting me know. I decided to go with a clean flash anyway just because I think my encryption on my data partition was preventing boot and restoring from a 17.1 nandroid backup broke the system completely. So far, the ROM is very good and I'm happy that I'm now on Android 11!
    1
    Hi there. I upgraded 17.1 to 18.1 recently. Seems working fine on first day until I installed vanced app (i think).
    Now, every time the screen go off and when it back on, i see glitches and bad palette color. And can't fix it without a reboot (and then when the screen go off the screen glitches comes back)
    Maybe is related with Vanced and microG, any one has this issue too?

    The display glitches with the messed up color palette might be the same bug from 17.1. To fix that I had to change the Color mode from Saturated to Boosted and it stopped.

    Settings > Display > Advanced > Color

    Might be a different path in Android 11, though.

    Basically if the inverted color thing happens again, going to that setting and switch it to a different Color type will reset the colors back to normal without restarting. After doing that once or twice it hasn't happened after. Again, on 17.1, can't speak to 18.1 yet.