[OFFICIAL] LineageOS 18.1 for the Moto X 2014

Search This thread
lineage-os-logo.png

Moto X 2014

Code:
- Your warranty is now void.
- You have been warned.
- Use at your own risk.

Introduction:
This is the Official Lineage OS 18.1 thread for the Moto X 2014.

Downloads:
Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

Known Bugs:
  • Front camera can be a little bright and blown out in indoor lighting, we're working on it.
  • Find any? Report them according to this guide.
Notes:
  • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
Kernel Source: https://github.com/LineageOS/android_kernel_motorola_msm8974
 
Last edited:

douglasmarx

Member
Jan 12, 2016
6
1
Hi npjohnson!

I've follow all the steps for the upgrade, that happened without fails (the only unusual thing that i've noticed is that process finshed as OK on the device screen when progress was around 47% on pc cmd adb screen, for the rom and for the mindthegapps), but the device do not unlock when I enter my pin. The screen turns black for a moment and return to lock screen. Any idea of how to solve this?

Update: After restore the backup, I've remove screen lock pin and try again. Now the device is rebooting when try to load the first screen after the boot...
 
Last edited:
Moto X 2014 victara Upgrade to LineageOS 18.1 Fail & Workaround

...I've follow all the steps for the upgrade, that happened without fails (the only unusual thing that i've noticed is that process finshed as OK on the device screen when progress was around 47% on pc cmd adb screen, for the rom and for the mindthegapps), but the device do not unlock when I enter my pin. The screen turns black for a moment and return to lock screen. Any idea of how to solve this?...

For the Motorola Moto X 2014 (victara) the LineageOS upgrade wiki page now says that you need to format data before installing LineageOS 18.1: https://wiki.lineageos.org/devices/victara/upgrade

In this LineageOS subreddit thread Can't go past locking screen after installing 18.1 on bacon (OnePlus 1) there is a post made by haggertk who is one of the 9 Lineage directors that explains why.

The workaround in that thread posted by OffizierMichael to avoid formatting the Data partition & losing your apps, data & settings was confirmed by a few OnePlus One users but not for the victara yet confirmed by victara user @douglasmarx:

Ok, I got this to work on my Oneplus One, setup before installation:

  • Lineage OS 17.1
  • TWRP 3.5.1
  • Deactivate your unlock protection (pattern, PIN etc.) so it unlocks by simply sliding up
Now, boot into TWRP and install (in same order and without rebooting inbetween)

  • Lineage OS 18.1
  • GApps (must be Android 11 of course, like https://nikgapps.com/ - I used Open GApps before but they don't have version 11 out yet)
  • Remove or rename the file /data/system/locksettings.db by using TWRPs explorer functionality
  • Reboot and unlock into Lineage 18.1 like normal and reactivate your unlock protection of choice
As mentioned by developers already, it is adviced to format every partition (therefore resetting and removing all settings/apps/files on your phone, be aware of course!) before going for the update.
 
Last edited:
  • Like
Reactions: douglasmarx

douglasmarx

Member
Jan 12, 2016
6
1
Moto X 2014 victara Upgrade to LineageOS 18.1 Fail & Workaround



For the Motorola Moto X 2014 (victara) the LineageOS upgrade wiki page now says that you need to format data before installing LineageOS 18.1: https://wiki.lineageos.org/devices/victara/upgrade

In this LineageOS subreddit thread Can't go past locking screen after installing 18.1 on bacon (OnePlus 1) there is a post made by haggertk who is one of the 9 Lineage directors that explains why.

The workaround in that thread posted by OffizierMichael to avoid formatting the Data partition & losing your apps, data & settings was confirmed by a few OnePlus One users but not for the victara yet confirmed by victara user @douglasmarx:
Works for me too (the workaround)! Thank you very much, again!
 
  • Like
Reactions: curiousrom

Stk14

New member
Apr 15, 2021
1
0
Hello,

I'm very new here.
I've been able to install the update without any problem (formatted the phone before installing the update).

I would only like to tell that since the update, my phone is unable to connect to Netflix. It's stuck at "Netflix" with black background. I've already reinstalled the app, deleted cache and data multiple times. No luck.

Also, Chrome is now unusable (works for a couple of seconds then it freezes). I'm using Opera right now.

Last, maybe it's my internet, but the phone seems to lose the WiFi connexion more frequently since the update and often doesn't reconnect to our network even if it's within range (I have to either restart my router or reset my phone's network settings).

That said, thanks for all the devs for making my old Moto X still work and compatible with newer apps ^^
 
Hello,

I'm very new here.
I've been able to install the update without any problem (formatted the phone before installing the update).

I would only like to tell that since the update, my phone is unable to connect to Netflix. It's stuck at "Netflix" with black background. I've already reinstalled the app, deleted cache and data multiple times. No luck.

Also, Chrome is now unusable (works for a couple of seconds then it freezes). I'm using Opera right now.

Last, maybe it's my internet, but the phone seems to lose the WiFi connexion more frequently since the update and often doesn't reconnect to our network even if it's within range (I have to either restart my router or reset my phone's network settings).

That said, thanks for all the devs for making my old Moto X still work and compatible with newer apps ^^
1. Netflix should be fixed next build, update and let me know
2. Looking into it
3. Not sure, seems fine to me
 

juanchotazo99

Senior Member
May 9, 2013
265
285
Lovely work! Thank you for this.

I think both cameras are misbehaving a bit.

For example, lets say I open up the default LOS camera or Open Camera. If I'm pointing at something that's bright while the camera app is opening, then exposure will be correct on screen for that scene and the live preview is fast and snappy as you'd expect on good lighting conditions.

While having the camera app open, if I point it to something dark or black, exposure adjusts a few stops up to compensate, but then it won't readjust back when pointing back to what was bright. Camera preview gets laggy and stays laggy, as if shutter speed got too low.

Front camera tends to always get exposure wrong, too bright, blown out and laggy. I'd guess auto exposure is not working correctly, shutter speed being the problem. Closing and opening the camera app again fixes the issue until it happens again.

Camera behaved as expected on 17.1.


How can I collect and provide more information about this? A logcat? I'm on 18.1-20210418-NIGHTLY-victara, phone is a XT1097, latest Marshmallow firmware. 18.1 was clean installed, the usual factory reset wipes and /data formatted in TWRP.
 

muni_es

New member
Apr 22, 2021
3
1
Thanks a lot for this build!
My old Moto X is a new phone now!
I have some problems with the flash when taking pictures, the Photo App crashes...not very important for me though...
Other than that, everything seems to work smoothly!!
 

muni_es

New member
Apr 22, 2021
3
1
Here are the logs:
I rebooted the phone, then I opened the camera and try to take a picture. This happened around 14:15:29.661
The flash was on by default. The timer (3 seconds) started but the picture was not taken. Then I tried few times more, but then the application get non responsive and crashed.

I hope it helps!
Kind regards
 

Attachments

  • logcat_out2.zip
    306 KB · Views: 1

ptitrusse

Senior Member
Feb 21, 2008
140
13
Hi

Thanks for the update, just performed a clean install, coming from LOS 17.1.

The echo during calls in Signal is still an issue, as previously reported in the 17.1 thread.

Camera works, indeed it sometimes starts completely overexposed but not always, so closing it starting it again seems to fix it. Strange. Video recording seems to work, it didn't work in 17.1.

Also, there is no AOSP email app. Could be a problem with Mindthegapps, I usually never install Gapps but this is not my phone :)

To me the major problem is the echo during VoIP calls. Using signal with video and or speaker is just not possible.

Thanks !
 

juanchotazo99

Senior Member
May 9, 2013
265
285
Can you guys do a logcat while using and post steps to reproduce? It will be really helpful for us. Thanks in advance

Here you go. This is on yesterday's build, 20210425

First opened OpenCamera while pointing at sunlight, confirmed fluid camera preview with correct exposure, then pointed to something black, reproduced behavior as per my previous post (laggy camera preview as if shutter speed got too low to get the correct exposure on something black, as expected), then pointed back to sunlight to confirm bad behavior (shutter speed stuck too low, camera preview laggy and completely white, too much light captured, not auto correcting back to initial status as you'd expect).

Closed OpenCamera, opened LOS' stock camera, did the same steps, reproduced same behavior, then closed it.

Let me know if you need anything else. Thank you!
 
Last edited:
  • Like
Reactions: jeferson1979
Hi

Thanks for the update, just performed a clean install, coming from LOS 17.1.

The echo during calls in Signal is still an issue, as previously reported in the 17.1 thread.

Camera works, indeed it sometimes starts completely overexposed but not always, so closing it starting it again seems to fix it. Strange. Video recording seems to work, it didn't work in 17.1.

Also, there is no AOSP email app. Could be a problem with Mindthegapps, I usually never install Gapps but this is not my phone :)

To me the major problem is the echo during VoIP calls. Using signal with video and or speaker is just not possible.

Thanks !
The echo: we're working on it, its quite tough.

The AOSP email app: It was dropped, old and insecure.
 

sumomogg

Member
Sep 12, 2018
24
8
Well, i've installed this build (lineage-18.1-20210425-nightly-victara-signed.zip) and I have to say its incredible. I've installed Lineage on a number of devices (LG G Pad 8.3, Galaxy S5 Plus, LG G2) and none of the builds are as smooth and bug free as this one. I followed the install guide on the Lineage Wiki page and it went exactly as planned (though I did find some old youtube videos to help point in the right direction sometimes such as when going through the Motorola website unlock bootloader process)

I'd given up my old Moto X 2014 but this has breathed new life into it. Many thanks npjohnson!

The only minor thing I can't fix is that I had planned to give this to my 10 year old son and use Google Family Link, but it wont let me do this as it gets stuck in a loop - I think this may be an issue with mindthegapps. Either way, its not a big problem, just happy to have an all new Victara on the latest build :)

SInce putting this OS on I've also re-discovered what a lovely phone it is - great to hold in the hand (one hand unlike todays huge slabs) and the glass is so smooth. Its just a really nice phone.
 
Well, i've installed this build (lineage-18.1-20210425-nightly-victara-signed.zip) and I have to say its incredible. I've installed Lineage on a number of devices (LG G Pad 8.3, Galaxy S5 Plus, LG G2) and none of the builds are as smooth and bug free as this one. I followed the install guide on the Lineage Wiki page and it went exactly as planned (though I did find some old youtube videos to help point in the right direction sometimes such as when going through the Motorola website unlock bootloader process)

I'd given up my old Moto X 2014 but this has breathed new life into it. Many thanks npjohnson!

The only minor thing I can't fix is that I had planned to give this to my 10 year old son and use Google Family Link, but it wont let me do this as it gets stuck in a loop - I think this may be an issue with mindthegapps. Either way, its not a big problem, just happy to have an all new Victara on the latest build :)

SInce putting this OS on I've also re-discovered what a lovely phone it is - great to hold in the hand (one hand unlike todays huge slabs) and the glass is so smooth. Its just a really nice phone.
FamilyLink is Safety net related I think :/
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Sure, I will try to do it this weekend
    1
    Can you guys do a logcat while using and post steps to reproduce? It will be really helpful for us. Thanks in advance

    Here you go. This is on yesterday's build, 20210425

    First opened OpenCamera while pointing at sunlight, confirmed fluid camera preview with correct exposure, then pointed to something black, reproduced behavior as per my previous post (laggy camera preview as if shutter speed got too low to get the correct exposure on something black, as expected), then pointed back to sunlight to confirm bad behavior (shutter speed stuck too low, camera preview laggy and completely white, too much light captured, not auto correcting back to initial status as you'd expect).

    Closed OpenCamera, opened LOS' stock camera, did the same steps, reproduced same behavior, then closed it.

    Let me know if you need anything else. Thank you!
  • 2
    lineage-os-logo.png

    Moto X 2014

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the Moto X 2014.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • Front camera can be a little bright and blown out in indoor lighting, we're working on it.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_motorola_msm8974
    1
    Update: we are now in the official build roster and queued to get an official 18.1 build on Sunday morning :)
    1
    Moto X 2014 victara Upgrade to LineageOS 18.1 Fail & Workaround

    ...I've follow all the steps for the upgrade, that happened without fails (the only unusual thing that i've noticed is that process finshed as OK on the device screen when progress was around 47% on pc cmd adb screen, for the rom and for the mindthegapps), but the device do not unlock when I enter my pin. The screen turns black for a moment and return to lock screen. Any idea of how to solve this?...

    For the Motorola Moto X 2014 (victara) the LineageOS upgrade wiki page now says that you need to format data before installing LineageOS 18.1: https://wiki.lineageos.org/devices/victara/upgrade

    In this LineageOS subreddit thread Can't go past locking screen after installing 18.1 on bacon (OnePlus 1) there is a post made by haggertk who is one of the 9 Lineage directors that explains why.

    The workaround in that thread posted by OffizierMichael to avoid formatting the Data partition & losing your apps, data & settings was confirmed by a few OnePlus One users but not for the victara yet confirmed by victara user @douglasmarx:

    Ok, I got this to work on my Oneplus One, setup before installation:

    • Lineage OS 17.1
    • TWRP 3.5.1
    • Deactivate your unlock protection (pattern, PIN etc.) so it unlocks by simply sliding up
    Now, boot into TWRP and install (in same order and without rebooting inbetween)

    • Lineage OS 18.1
    • GApps (must be Android 11 of course, like https://nikgapps.com/ - I used Open GApps before but they don't have version 11 out yet)
    • Remove or rename the file /data/system/locksettings.db by using TWRPs explorer functionality
    • Reboot and unlock into Lineage 18.1 like normal and reactivate your unlock protection of choice
    As mentioned by developers already, it is adviced to format every partition (therefore resetting and removing all settings/apps/files on your phone, be aware of course!) before going for the update.
    1
    Moto X 2014 victara Upgrade to LineageOS 18.1 Fail & Workaround



    For the Motorola Moto X 2014 (victara) the LineageOS upgrade wiki page now says that you need to format data before installing LineageOS 18.1: https://wiki.lineageos.org/devices/victara/upgrade

    In this LineageOS subreddit thread Can't go past locking screen after installing 18.1 on bacon (OnePlus 1) there is a post made by haggertk who is one of the 9 Lineage directors that explains why.

    The workaround in that thread posted by OffizierMichael to avoid formatting the Data partition & losing your apps, data & settings was confirmed by a few OnePlus One users but not for the victara yet confirmed by victara user @douglasmarx:
    Works for me too (the workaround)! Thank you very much, again!
    1
    Sure, I will try to do it this weekend
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone