• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OFFICIAL] LineageOS 18.1 for the Moto Z2 Force

Search This thread

BeingHuzzii

Member
Apr 2, 2021
6
0
Hy i want to ask i just upgraded via phone update to linage os 18.1 android 11.but this updates maybe killing apps too aggressive on this phone too? multitasking on this rom is impossible with apps getting refreshed every time.any solution ?
 

npjohnson

Recognized Developer
Anyone having issues with Mods? I am getting the Mod not lined up correctly error after the last couple updates. Maybe my Mod is actually bad.
It does happen, the pin wears out :/

My first battery mod met that fate.
Miracast not work in lineage 18.1 :( , and sim card works randomly after reboot
Yeah, Miricast is dead from 17.1 onward for our SoC. May be able to fix it if we get proper blobs someday for sdm660/msm8998.
 

cdarlow

New member
Jul 5, 2021
1
0
I've installed custom ROMs before, so I thought I could handle upgrading my Z2 Force to 18.1. I unlocked the bootloader fine, but couldn't install TWRP - I could only boot it temporarily. I couldn't flash or boot the Lineage recovery either. So from the temporary TWRP I made a backup and tried flashing the ROM and GAPPS. That seemed to go fine, but when I tried to reboot it warned there was no OS installed. I tried swapping the partitions, but when I rebooted I got the Lineage logo animation continuously for about 45 minutes until I gave up and went back to bootloader, booted TWRP again, and did a restore. But then when booting I always got the message "Your device cannot be checked for corruption. Lock the bootloader" before the system loaded. So I locked the bootloader again. But then I started getting the error "Your device cannot be trusted and will not boot". Somehow I was able to get it to boot back into the original OS, but now everytime before booting I get the message "Your device has loaded a different operating system". Also wifi and network access isn't working. I can get into the bootloader, but I can't boot or flash a recovery. Any suggestions? Did I ruin it?
 

WitchDoc758

New member
Jul 9, 2021
1
0
Does this solve The issue of frequent WiFi drops and/or disconnections on either the 1789-03 or 06?
This is still experienced with a later Lineage version (lineage_nash-userdebug 11 RQ3A.210605.005 1328f2a61b | 20210622)
WiFi is dropping at the moment regularly in a Multi-Router environment, the WiFi connection at home with a Single-Router is more or less stable for a day (Nash device reboot mitigates)

To be info complete:
My device was falling on hard ground at least 2 times and had issues after getting wet in heavy rain (power off button without function for hours, date and time set back by 1 week).

Also the LTE call issue I read about in the Resurrection Remix forum and the SIM card issue mentioned here by @magaiverzinho happens.
Rebooting several times leads to SimPIN request and disabling 4G calls will be tested in the next days.
 

sir_overthrow

Senior Member
Apr 1, 2014
74
4
Móstoles
Hello Sirs!

I have recently changed from 17.1 to 18.1 because I started having trouble unlocking the phone with the fingerprint. in version 18.1 it also happens but less frequently.

what happens is like the sensors go to sleep or disable them. The screen does not activate when passing the hand, shaking the mobile for the flashlight does not work and the fingerprint does not unlock the mobile. Any app that hijacks the sensors? Weather app? Vlc?

It also happens to me that I lose the SIM.

I am also from the group that Wi-Fi does not work well (since 17.1), can it be the model?

thanks for all your work and for reading me. : *
 
Last edited:

johnathanamber

Senior Member
Sep 26, 2008
211
24
Hey everyone!

So, I am already running Lineage OS 17.1 (latest available), I assume I cannot upgrade directly to 18.1, correct?

With that, looking at the install instructions (https://wiki.lineageos.org/devices/nash/install) running the following, I get nothing in return:
adb shell getprop ro.boot.hardware.sku

Running the following and searching the txt file, I do not get a model:
adb shell getprop>getprop.txt

I am pretty confident that it is the XT1789-04 model though. I've only had one of these model phones to use and I used it in my previous thread:
https://forum.xda-developers.com/t/...brid-of-sprint-pie-and-tmo-oreo-roms.4019311/

Is this good enough to continue with the install or must this "ro.boot.hardware.sku" variable be present before installing Lineage 18.1?

Thoughts?

Thank you!
 

npjohnson

Recognized Developer
I've installed custom ROMs before, so I thought I could handle upgrading my Z2 Force to 18.1. I unlocked the bootloader fine, but couldn't install TWRP - I could only boot it temporarily. I couldn't flash or boot the Lineage recovery either. So from the temporary TWRP I made a backup and tried flashing the ROM and GAPPS. That seemed to go fine, but when I tried to reboot it warned there was no OS installed. I tried swapping the partitions, but when I rebooted I got the Lineage logo animation continuously for about 45 minutes until I gave up and went back to bootloader, booted TWRP again, and did a restore. But then when booting I always got the message "Your device cannot be checked for corruption. Lock the bootloader" before the system loaded. So I locked the bootloader again. But then I started getting the error "Your device cannot be trusted and will not boot". Somehow I was able to get it to boot back into the original OS, but now everytime before booting I get the message "Your device has loaded a different operating system". Also wifi and network access isn't working. I can get into the bootloader, but I can't boot or flash a recovery. Any suggestions? Did I ruin it?
no, you're fine most likely.

you really should have just followed the guide on our wiki though. Would have saved you all this headache ;p
 

npjohnson

Recognized Developer
Hey everyone!

So, I am already running Lineage OS 17.1 (latest available), I assume I cannot upgrade directly to 18.1, correct?

With that, looking at the install instructions (https://wiki.lineageos.org/devices/nash/install) running the following, I get nothing in return:


Running the following and searching the txt file, I do not get a model:


I am pretty confident that it is the XT1789-04 model though. I've only had one of these model phones to use and I used it in my previous thread:
https://forum.xda-developers.com/t/...brid-of-sprint-pie-and-tmo-oreo-roms.4019311/

Is this good enough to continue with the install or must this "ro.boot.hardware.sku" variable be present before installing Lineage 18.1?

Thoughts?

Thank you!
follow the guide under "Upgrade" on the wiki, you can directly upgrade. model is only set on stock.
 

johnathanamber

Senior Member
Sep 26, 2008
211
24
The adb sideload options seems to be working great! Went ahead and wiped for a factory reset since it has been a while.

One thing I did notice is that the LOS 17.1 update tool did show that 18.1 was available, which brought me to this thread. So, I assume that would have bricked the phone is I used the update tool?
 

johnathanamber

Senior Member
Sep 26, 2008
211
24
Sweet! Manual upgrading via adb sideload over 17.1 worked perfectly.

I was thinking I could setup a Work Profile only on this phone, but I guess not. sigh
 

npjohnson

Recognized Developer
The adb sideload options seems to be working great! Went ahead and wiped for a factory reset since it has been a while.

One thing I did notice is that the LOS 17.1 update tool did show that 18.1 was available, which brought me to this thread. So, I assume that would have bricked the phone is I used the update tool?
the update tool wouldn't let you do major versions if you tried, it would point you to the wiki lol
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    lineage-os-logo.png

    Moto Z2 Force

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the Moto Z2 Force.

    Join our Moto Z2 Force Discord!

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • The EQ Apps for Audio Mods (eg. JBL2 App) won't work, and will crash.
    • Ultrasonic Proximity Sensor doesn't work -- No support present in the OSS Audio HAL. If it was written in, it wouldn't be used by anything in LineageOS, as the normal proximity sensor works fine.
    • Audio Mods have no alarm or notification audio through them.
    • Camera Mods don't (and won't ever) work.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    • Official Lineage OS builds for nash ship with full Project Treble compatibility! Flash GSI's to your heart's content after flashing Lineage. Please don't report GSI bugs here, report them instead to the GSI's maker.
      Code:
      Technical details on our Treble implementation:
      Treble is enabled with VNDK30, and VNDK runtime enforcement. VNDK runtime enforcement means that unlike most "ported treble" you'll see, ours is just as it would be from the OEM, and can run GSIs. without need for hacks or additional flashable zips. We relabeled /oem to /vendor (as /oem isn't wasn't used in custom ROMs anyway). To use a GSI, flash official Lineage, then flash your GSI, it's that simple! Flashing a factory image will likely write over /oem and remove the mock vendor image.
    Kernel Source: https://github.com/LineageOS/android_kernel_motorola_msm8998
    4
    How did you find this? I got an alert that lineage 18 came out but went to the website less than five minutes ago and it wasn't available for nash yet ?

    *Edit* I just checked again it's not available for download even though it's listed ..weird
    Am the developer - and it is building on official servers tonight, check back in 24 hours.
    3
    Am the developer - and it is building on official servers tonight, check back in 24 hours.
    Oh awesome. Thank you for the hard work ! Glad to see roms still being made for this phone
    2
    Hey everyone!

    So, I am already running Lineage OS 17.1 (latest available), I assume I cannot upgrade directly to 18.1, correct?

    With that, looking at the install instructions (https://wiki.lineageos.org/devices/nash/install) running the following, I get nothing in return:


    Running the following and searching the txt file, I do not get a model:


    I am pretty confident that it is the XT1789-04 model though. I've only had one of these model phones to use and I used it in my previous thread:
    https://forum.xda-developers.com/t/...brid-of-sprint-pie-and-tmo-oreo-roms.4019311/

    Is this good enough to continue with the install or must this "ro.boot.hardware.sku" variable be present before installing Lineage 18.1?

    Thoughts?

    Thank you!
    follow the guide under "Upgrade" on the wiki, you can directly upgrade. model is only set on stock.
    2
    Thanks a ton for keeping our device up to date! I see that the efficiency mode is working for the battery mod, amazing!!
    Yup! And will from here on out :)
    The clock app is not working and I think usb tethering is not working.
    Clock app works, maybe gapps overwrite it with a broken one? Will try usb tethering locally.
    Vibration is not working
    It works, your motor may have died.
    Firstly, THANKS FOR THIS!

    I get the following error when opening the Camera app: dlopen failed: library "libmcf-jni.so" not found.

    HDR mode is missing and you still can't save to SD - otherwise seems to work OK

    Install steps taken:
    1. adb sideload lineage-18.1-20210401-nightly-nash-signed.zip
    2. Reboot into the newly-updated 18.1 recovery
    3. adb sideload MindTheGapps-11.0.0-arm64-20210328_143848.zip

    Since I was updating from 17.1 with Google Apps, I did not perform a factory reset per the upgrade instructions here: https://wiki.lineageos.org/devices/nash/upgrade

    Was this wrong? Should I have done a clean install?
    dlopen, HDR, and save to SD: all expected and WIP. Working on them :)