• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[OFFICIAL] LineageOS 18.1 for the Nextbit Robin

Search This thread

blackuriel

Member
Nov 25, 2017
24
6
Chrome on Lineage OS 18.1
Does anyone else also has a problem with Chrome closing/crashing by itself?
Tried updating the app, also tried installing the newest Android Web View and tried the newest MindtheGapps. Nothing works and Chrome closes itself after 1-2 sec. Opening it copule of times makes Chrome freeze.
I don't know if this is a problem with Robin or maybe something bigger.
 
Last edited:

AiZ_fr

New member
Apr 18, 2021
2
0
Hello,

First post here. I recently flash my Robin with 18.1 and I'm a really noob! Well, I had previously flash an Acer Iconia Tab A500 a long time ago but this is my first smartphone mod. I can use it everyday but I have some (not really annoying) problems.

The battery is getting old, I own the phone since September 2017 but it depletes really quickly when I use the phone. It's quite good in standby mode but when the screen is on, ouch! Anyway, I'm not an avid user, some texting and light Internet access so it's Ok.

As said above, Chrome only worked one time, just after installing it. Since then, it closes itself almost immediately. I've installed Firefox, which works well.

Can someone explain me where is the fingerprint configuration menu? I can't see it in the settings, even after the adb log trick.

Last thing, do you have quick GPS fix? I've discovered the new access rights brought by Android 11 so all GPS apps seems to start from zero when they launch. It takes ages to (not always) have positioning. I use GPS Test for example and it's weird: there must be at least 8 sat in use to have fix, when it works and these 8 sat are always GPS ones, never GLONASS nor BEIDOU, even if they have better signal.

Thanks to all people involved in this project!

AiZ
 

blackuriel

Member
Nov 25, 2017
24
6
Hello,

First post here. I recently flash my Robin with 18.1 and I'm a really noob! Well, I had previously flash an Acer Iconia Tab A500 a long time ago but this is my first smartphone mod. I can use it everyday but I have some (not really annoying) problems.

The battery is getting old, I own the phone since September 2017 but it depletes really quickly when I use the phone. It's quite good in standby mode but when the screen is on, ouch! Anyway, I'm not an avid user, some texting and light Internet access so it's Ok.

As said above, Chrome only worked one time, just after installing it. Since then, it closes itself almost immediately. I've installed Firefox, which works well.

Can someone explain me where is the fingerprint configuration menu? I can't see it in the settings, even after the adb log trick.

Last thing, do you have quick GPS fix? I've discovered the new access rights brought by Android 11 so all GPS apps seems to start from zero when they launch. It takes ages to (not always) have positioning. I use GPS Test for example and it's weird: there must be at least 8 sat in use to have fix, when it works and these 8 sat are always GPS ones, never GLONASS nor BEIDOU, even if they have better signal.

Thanks to all people involved in this project!

AiZ
Hi, welcome to the group!

For the fingerprint configuration menu, it should be under Settings > Security.
To be able to set a fingerprint you may have to set a lock screen PIN or pattern.

For the battery, I bought two new batteries at AliExpress. Work like a charm.
 

AiZ_fr

New member
Apr 18, 2021
2
0
Hello,

Hi, welcome to the group!

For the fingerprint configuration menu, it should be under Settings > Security.
To be able to set a fingerprint you may have to set a lock screen PIN or pattern.

For the battery, I bought two new batteries at AliExpress. Work like a charm.

Thanks!

Even if I set a PIN or pattern, nothing appears under Settings > Security. Well, I'll see what happens with future updates...

Have you some recommendations for AliExpress sellers providing those batteries? I've watched some Youtube tutorials, it doesn't look that hard to open the phone.

Have a nice day,

AiZ​
 

namikiri

Member
Sep 7, 2012
30
23
radio.nyan.pw
Hello!

I've installed 18.1-20210418-nightly and it seems that this version has big issues with storage. No app can write files to internal storage. I've tried several apps: Telegram, TikTok and some other apps. They work fine with their app-specific storages but fail when trying to save files to /sdcard. Telegram can create directories and empty files but can't fill them with data, other apps can't do anything. Seems like a FUSE bug because when Telegram attempts to write a file, this message appears in logcat:
Code:
fusedaemon: Failed to check lock: Invalid argument

Does anyone have any solutions for this?
 

blackuriel

Member
Nov 25, 2017
24
6
Hello,



Thanks!

Even if I set a PIN or pattern, nothing appears under Settings > Security. Well, I'll see what happens with future updates...

Have you some recommendations for AliExpress sellers providing those batteries? I've watched some Youtube tutorials, it doesn't look that hard to open the phone.

Have a nice day,

AiZ​
Sorry for a late reply. Suddenly a lot of work in real life which had to be done asap (as always everything is)...

For the batteries, I bought this one with a strange name but works without a problem.
Here

As for opening Robin it is quite easy. I just watched and followed this video on Youtube.
Here

Mind that when you remove the upper piece of plastic, the glass that covers front camera tends to fall off.
Be careful not to lose it!
 

blackuriel

Member
Nov 25, 2017
24
6
@npjohnson Just checked the May 9th build.
There is a very short lag before the FP sensor starts to work but works perfectly!
Tested both during the initial setup, as well as adding a fingerprint from the settings.
Also with and without Gapps.

Thank you very much!
 
  • Like
Reactions: Raiz

Raiz

Forum Moderator
Staff member
@npjohnson Just checked the May 9th build.
There is a very short lag before the FP sensor starts to work but works perfectly!
Tested both during the initial setup, as well as adding a fingerprint from the settings.
Also with and without Gapps.

Thank you very much!
The "little bug" the first time you register the FP is from long before LOS 18.1 and isn't really a big deal so I consider it fully functional.
Great job @npjohnson
 

npjohnson

Recognized Developer
@npjohnson Just checked the May 9th build.
There is a very short lag before the FP sensor starts to work but works perfectly!
Tested both during the initial setup, as well as adding a fingerprint from the settings.
Also with and without Gapps.

Thank you very much!

The "little bug" the first time you register the FP is from long before LOS 18.1 and isn't really a big deal so I consider it fully functional.
Great job @npjohnson
super happy to hear it. Yeah, the lag is it firing up lol, I mean it is old hardware at this point ;p - after it's up, all is fine.
 
Last edited:
  • Like
Reactions: blackuriel and Raiz

blackuriel

Member
Nov 25, 2017
24
6
Thanks again!
I've been using this build for couple of days now and basically everything works great.

I have a problem with headphones though.
It seems that LOS is pushing the sound almost only through the left channel. As long as for the speakers it's not much of a problem, it is a big problem for the headphones. I think it's not giving two equal channels through the jack.
I tried changing the LR balance in the accessibility settings but then the L channel gets lower but R channel doesn't change much.
Anyone having a similar experience?

@npjohnson @Raiz Any ideas? Is this a new problem for LOS or something that nothing can be done about?
 

Raiz

Forum Moderator
Staff member
Thanks again!
I've been using this build for couple of days now and basically everything works great.

I have a problem with headphones though.
It seems that LOS is pushing the sound almost only through the left channel. As long as for the speakers it's not much of a problem, it is a big problem for the headphones. I think it's not giving two equal channels through the jack.
I tried changing the LR balance in the accessibility settings but then the L channel gets lower but R channel doesn't change much.
Anyone having a similar experience?

@npjohnson @Raiz Any ideas? Is this a new problem for LOS or something that nothing can be done about?
No problem on my side (using LOS without GApps).
Do you use Gapps, or did you flash any sound mod like Viper4Android or Dolby ?
 

blackuriel

Member
Nov 25, 2017
24
6
That's interesting, thanks!
Yes, I use MindtheGapps. The sound didn't work well so I flashed Viper4android.

If your's all right then I'll try to do a clean install of the ROM and check what was the reason.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    lineage-os-logo.png

    Nextbit Robin

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the Nextbit Robin.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • IMS (VoLTE/Wi-Fi Calling) doesn't work on LineageOS 16.0 and above - it's possible this feature may return in the future, though it unlikely, due to severely outdated proprietary blobs.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_nextbit_msm8992
    2
    @npjohnson Just checked the May 9th build.
    There is a very short lag before the FP sensor starts to work but works perfectly!
    Tested both during the initial setup, as well as adding a fingerprint from the settings.
    Also with and without Gapps.

    Thank you very much!

    The "little bug" the first time you register the FP is from long before LOS 18.1 and isn't really a big deal so I consider it fully functional.
    Great job @npjohnson
    super happy to hear it. Yeah, the lag is it firing up lol, I mean it is old hardware at this point ;p - after it's up, all is fine.
    2
    yeah, I've seen this once! Thought it was a fluke! Ticket would be awesome!
    Here's the bug ticket
    Bug ticket

    If you could please look into it.
    Thank you!
    2
    noob qustion, how to crate log with adb? and what is registering FP on step 5
    thx
    registering FP (=fingerprint) is when you add a new fingerprint. To create a log with adb use this command:
    Code:
    adb logcat -v long > FPR.txt

    You need to have adb up and running of course but since you unlocked your bootloader I don't think it's an issue for you.

    And this may not solve your problem, I was just lucky when doing it. If you're lucky it'll fix it for you too, but otherwise I won't be suprised if you tell me that it didn't worked
    2
    @npjohnson Here is the bug ticket.
    https://gitlab.com/LineageOS/issues/android/-/issues/3416

    If you could please look into it.
    Thank you!
    I will! On vacation for 2 weeks, but after that, sure!