[OFFICIAL] LineageOS 18.1 for the Nexus 6

Search This thread

psychoela

Senior Member
Dec 21, 2014
369
155
OnePlus 7 Pro
Hi, I have the same problem, in the past (including on another device on A11, Poco F1) I was always able to get it working. Here is what I attempted and that in the past at the end worked:
  • Installed Viper 2.7.2.1 Magisk module, rebooted, granted SU permission.
  • V4A prompted for the installation of the driver, granted, rebooted and V4A asks again. So the problem is that the installation of the driver in the system fails.
  • Attempted to install Busybox in various ways (Meefik in play store, both via the app and via the Recovery zip method, and Stericson via play store, which usually works because it allows tro try system/xbin and system/bin, but this as well failed) . I am pretty sure that V4A uses Busybox in some way to install the driver so since Busybox fails to install, V4A fails to install the driver too.
  • OR, Busybox is no longer required for the installation of V4A, BUT.... the fact that there is no way to install Busybox in the system has the same root cause of the failed installation of V4A driver too! So I investigated this more
  • It turns out that there is no way to mount the system as RW in this version of LOS? I tried everything and it just doesn't mount as RW, so I am not wondering why both Busybox and V4A fails to install.
Maybe can this be tackled in some way by the DEVs? This was definitely working in the previous version 17.1
Try again with latest magisk canary
 
  • Like
Reactions: michele72

michele72

Senior Member
May 30, 2010
93
40
Nexus 6
Xiaomi Poco F1
Try again with latest magisk canary

Wow many thanks for this! It actually worked on CRDROID 7.5 (which is based on LOS) which has the same exact problem. And this worked! So, for everybody on LOS18.1 (Android 11) and derived roms, you can get Magisk Canary from here: https://raw.githubusercontent.com/topjohnwu/magisk-files/canary/app-debug.apk . After getting the apk file and installing it, also rename the same file changing the extension to .zip. Restart to recovery and flash. Reboot. After that install Viper 2.7.2.1 from Magisk repository, don't reboot yet, just execute Viper and it will prompt to install driver. Reboot. Viper will work on music apps, however if you want to make it work for Youtube or other apps, go to the preferences and enable the Legacy mode. Works amazingly well!!!
 

aja100

Member
Oct 9, 2018
8
3
Install big games from play store like Asphalt 9, Call of duty mobile and Dead trigger 2, PUBG mobile they start download and at end give error. Other small games no problem.
Can be fixed?
 
Last edited:

ExpertMC

Senior Member
Feb 18, 2016
91
24
Did anyone report issues attempting to use Google Camera during testing? This didn't happen on 17.1, but I'm having an issue where the app appears to not connect with the hardware, with the end result being the settings are unavailable and the viewfinder doesn't display anything. It's not a huge issue for me, as this no longer is my primary device and the LineageOS camera does work. But it would be nice. :)

I'll get you guys a logcat later if needed, but the brief look I had at it revealed an informational comment in the log regarding not being able to find a symbol in a .so file.

EDIT: Additional information. If I use the "Take a selfie" or "Take a video" long-press menus both functions work. As soon as I switch to the back camera to take a still photo the app crashes.
Has anyone had a chance to look into this? Lineage camera doesn't take as good pictures as the stock one
 

npjohnson

Recognized Developer
Does anyone have Netflix working? I use a DRM Checker and it shows that this ROM (or maybe it's because of the MindTheGApps package?) doesn't have Widevine at all. So Netflix won't work - I don't even get a sign in screen, just an error. I assume this is because it can't initalise the Widevine DRM.

I did a full wipe before installing!
I'll take a look. Can you file a bug report according to wiki guide with logcat?
 
  • Like
Reactions: BDroidz and aja100

Josephson47

Member
Mar 13, 2017
45
17
Does anyone else have back camera problems? Camera won't focus, blurry all the time. If any one has solved this problem please let me know. Love this ROM it's the best! :)
 

Uplander

Member
Jan 7, 2016
23
9
Having carrier stability issue possibly due to apns config fix for giffgaff merged early April (14.04.21). Carrier issue (giffgaff ) also on official crDroid thread (7.5 update, April) posts #922 & #923.
 

dahawthorne

Senior Member
Nov 15, 2014
1,992
1,837
Brighton
To add a bit more info to Uplander's comment above, I have a Nexus 5 and a Nexus 6, both running crDroid 7.6. I understand that crDroid is based on LOS sources.
I didn't know about the Giffgaff commit until Uplander mentioned it, but the timeline makes it look as if this was the cause of the instability.
My Nexus 6 has a Giffgaff SIM. (Giffgaff is a virtual UK network running on the larger O2 network). On crDroid 7.4 (March) mobile data was stable. 7.5 and 7.6 (April/May) have a mobile data signal which blinks in and out second by second. The same happens with LOS 18.1 10th May.
My Nexus 5 has an O2 SIM. The mobile data is stable on crDroid 7.6.
To me this indicates that the problem is with the Giffgaff component.
 

BDroidz

New member
May 14, 2021
4
1
Does anyone have Netflix working? I use a DRM Checker and it shows that this ROM (or maybe it's because of the MindTheGApps package?) doesn't have Widevine at all. So Netflix won't work - I don't even get a sign in screen, just an error. I assume this is because it can't initalise the Widevine DRM.

I did a full wipe before installing!

Running into the same issue as well even with Magisk 23.0 installed and SafetyNet checks passing. "DRM Info" doesn't show Widevine at all.

Symptoms:
1. Netflix encounters error on load.
2. Disney+ encounters error on playback start.
3. Udemy videos appear to play but have no image or audio.
4. Udemy videos within Chrome attempt to play multiple times but ultimately report a video error.

No issue with YouTube or other videos on the web so does appear to be DRM related.
 

Attachments

  • Screenshot_20210513-233219_Magic.png
    Screenshot_20210513-233219_Magic.png
    131.2 KB · Views: 20
  • Screenshot_20210513-233034_DRM_Info.png
    Screenshot_20210513-233034_DRM_Info.png
    359.1 KB · Views: 18
  • Screenshot_20210513-233128_DRM_Info.png
    Screenshot_20210513-233128_DRM_Info.png
    262.5 KB · Views: 19
  • Screenshot_20210513-235752_Chrome.png
    Screenshot_20210513-235752_Chrome.png
    543.2 KB · Views: 20
Last edited:

Elektroschmock

Recognized Developer
Dec 25, 2010
1,046
4,627
Winnenden
Nexus 7 (2013)
Nexus 6
  • Like
Reactions: barnettejd

dvdram

Senior Member
Jun 30, 2014
164
45
I encountered a small problem concerning smart lock: when adding a trusted device to keep the phone unlocked, the list of BT devices does not show the name of the devices any more, if you renamed them, like "my car" or "kitchen radio". If you run two identical devices it's hard to tell them apart in that list. LOS 17 used the personalized names there.
 

McMannes

Senior Member
Oct 12, 2012
151
9
Thank you very much for this nice rom. The volume is a little low, I wonder if there is a way to raise this. however the proximity sensor does not work sometimes
 

npjohnson

Recognized Developer
Does anyone else have back camera problems? Camera won't focus, blurry all the time. If any one has solved this problem please let me know. Love this ROM it's the best! :)
I don't. Can you toss a log up according to the bug report page on wiki.lineageos.org?
Having carrier stability issue possibly due to apns config fix for giffgaff merged early April (14.04.21). Carrier issue (giffgaff ) also on official crDroid thread (7.5 update, April) posts #922 & #923.
Give me the right APN and I'll push a fix.
To add a bit more info to Uplander's comment above, I have a Nexus 5 and a Nexus 6, both running crDroid 7.6. I understand that crDroid is based on LOS sources.
I didn't know about the Giffgaff commit until Uplander mentioned it, but the timeline makes it look as if this was the cause of the instability.
My Nexus 6 has a Giffgaff SIM. (Giffgaff is a virtual UK network running on the larger O2 network). On crDroid 7.4 (March) mobile data was stable. 7.5 and 7.6 (April/May) have a mobile data signal which blinks in and out second by second. The same happens with LOS 18.1 10th May.
My Nexus 5 has an O2 SIM. The mobile data is stable on crDroid 7.6.
To me this indicates that the problem is with the Giffgaff component.
Give me the right APN and I'll push a fix.
Running into the same issue as well even with Magisk 23.0 installed and SafetyNet checks passing. "DRM Info" doesn't show Widevine at all.

Symptoms:
1. Netflix encounters error on load.
2. Disney+ encounters error on playback start.
3. Udemy videos appear to play but have no image or audio.
4. Udemy videos within Chrome attempt to play multiple times but ultimately report a video error.

No issue with YouTube or other videos on the web so does appear to be DRM related.
I'll look into it! Probably easy to fix.
For anyone having issues with giffgaff (UK carrier) instability see posts #926 & #927 on official crDroid Android 11 v7.6 Shamu thread for possible workaround.
Give me the right APN and I'll push a fix.
Thank you very much for this nice rom. The volume is a little low, I wonder if there is a way to raise this. however the proximity sensor does not work sometimes
volume matches stock, proximity sensor die after some years, possible it's getting flakey, make sure it doesn't happen on stock too.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    My Nexus 6 is on the latest nightly and has this issue as well. Any chance of a fix? And thank you for keeping this device updated!
    Fixed by https://review.lineageos.org/c/LineageOS/android_device_moto_shamu/+/313599 - next build should be fine.
    5
    Flashed latest nightly and still having problems with Netflix. Netflix shows error code "502.-1006" immediately when launching, disabling DRM/liboemcrypto lets it load a little further but then reports error code "501.-109" instead. Did you or anyone else manage to get it working successfully? Thanks
    Looking into it.
    4
    Can I flash this on Nexus's 6 latest TWRP instead of installing Lineage OS Recovery?
    This was asked and answered 8 posts above.
    It might work, but we just don't know it.
    TWRP for Shamu is maintained by nobody and is probably outdated.
    4
    Echo in Hangouts an other apps using webrtc should be fixed with lineage-18.1-20210721-nightly-shamu-signed
    2
    lineage-18.1-20210721-nightly-shamu-signed upgrade results no camera application...
    Edit: some reboots and camera is back
    :)
    This is a well known bug since 15.1 which we unfortunately can't fix.
  • 23
    lineage-os-logo.png

    Nexus 6

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 18.1 thread for the Nexus 6.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • IMS (VoLTE/Wi-Fi Calling) doesn't work on LineageOS 16.0 and above - it's possible this feature may return in the future, though it unlikely, due to severely outdated proprietary blobs.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_moto_shamu
    8
    Awesome to see the continued development!!

    I assume the IMS development has been dropped? https://github.com/wavedashdoc/android_device_moto_shamu
    No I'm just crazy busy, it's on my to-do list albeit low atm :)
    7
    I can't believe my eyes!! Thanks!!!

    EDIT: Wait... is this an april fools joke? -__-
    Nope! Builds are rolling right now!
    6
    Seeing about the same as your 2.
    I don't have a sim in it (not my main phone) but can't get in after inputting pin code... screen goes dark and then comes back to asking for pin code (as if lockscreen reboot).
    No adb acces (since not pin unlocked) to grab a logcat.

    Have a full twrp backup so did some tests :
    * Tried deactivating pin in 17.1 before upgrading --> same issue (upon swipping up from lockscreen instead of entering pin)
    * Tried fresh 18.1 install after data wipe --> works...

    Maybe deleting the .key files like explained here could be a workaround.

    I am very pleased to see the next Android version coming to my N6. Thank you very, very much for your work!

    But...


    Than bothers me a bit. Having to re-setup every personal data and app is something I would rather avoid. Is there any chance that upgrading from 17.1 without loosing all data and apps will be possible in the near future? That would really be the icing.

    Google removed the support for our legacy hardware based hashing of passwords/pins/patterns, ..
    Our wiki unfortunatly doesn't state that a wipe is needed. I'll be adding that.

    Like said above maybe deleting the .key files is a workaround, but we can't make it the default install method for obvious reasons.
    6
    Maybe deleting the .key files like explained here could be a workaround.



    Google removed the support for our legacy hardware based hashing of passwords/pins/patterns, ..
    Our wiki unfortunatly doesn't state that a wipe is needed. I'll be adding that.

    Like said above maybe deleting the .key files is a workaround, but we can't make it the default install method for obvious reasons.
    Thank you for the tip an nudge in the right direction !!!
    Here is what worked for me :)
    1. In 17.1 turned off pin code locking in settings
    2. Rebooted to twrp
    3. Deleted /data/system/locksettings.db file
    I didn't have any of the "*.key" files and no other locksettings.* files (probably because I had deactived pin in settings before hand)
    4. flashed 18.1 zip [+gapps + magisk]
    5. Rebooted
    6. Started enjoying 18.1 on my shamu