[OFFICIAL] LineageOS 19.1 for Moto G6 Plus

Search This thread

jeferson1979

Recognized Developer
Jan 15, 2018
510
700
Taió
sourceforge.net
Moto X
Moto X 2014
lineage-os-logo.png

LineageOS is a free, community built, aftermarket firmware distribution of Android 12 (R), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

GPL compliance:
Working:
  • Camera (and flashlight)
  • WiFi
  • Bluetooth
  • Telephony (Calls and Data)
  • Audio (Record and Playback)
  • Video Playback
  • Sensors
  • GPS
  • Crypto

Broken:
  • Nothing (?)


Downloads:

Notice:
  • No custom kernels are supported in this thread. Only stock kernel and official builds will be supported. No bug reports if that's not the case.

Installation:
Important notes:
  • * Required * Patience.
  • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
  • Formatting data (all user data is wiped, including internal storage) when comming from other roms.

Credits & collaborations:
All LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!​

Device wiki:

LineageOS 19.1, ROM for the Moto G6 Plus

Contributors
jro1979oliver
ROM OS Version: Android 12.1
ROM Kernel: Linux 4.4.x
ROM Firmware Required: latest stock

Version Information
Status: Official

Created 2022-04-25
Last Updated 2022-04-25
 

ew

Senior Member
Sep 28, 2010
741
184
Can I upgrade from the unofficial build to the official - or do I need to wipe all and start from scratch?
 

jeferson1979

Recognized Developer
Jan 15, 2018
510
700
Taió
sourceforge.net
Moto X
Moto X 2014
@jeferson1979 hola bro es que la rom instalo correctamente pero al arrancar se queda cargando en el logo y dura mas de 5 horas alli y no sigue que hago
You can press power button with vol - and enter recovery mode, then select format data (hint: you will loose your data), then things should work.
Make sure to follow wiki steps before install anything.
 

ew

Senior Member
Sep 28, 2010
741
184
I am on the official build with the recommended gapps (MindtheGapps-latest version) installed.

I am getting the following error with I try to run Google Opinion Rewards:
google opinion rewards won't run without google play service which are not supported on your device

I have tried clearing data/cash for Google Play, Google Play Services and the Opinion Rewards, restarting and that doesn't help.

Any ideas/suggestions? Thank you in advance for your assistance.
 

jeferson1979

Recognized Developer
Jan 15, 2018
510
700
Taió
sourceforge.net
Moto X
Moto X 2014
I am on the official build with the recommended gapps (MindtheGapps-latest version) installed.

I am getting the following error with I try to run Google Opinion Rewards:
google opinion rewards won't run without google play service which are not supported on your device

I have tried clearing data/cash for Google Play, Google Play Services and the Opinion Rewards, restarting and that doesn't help.

Any ideas/suggestions? Thank you in advance for your assistance.
How was the install procces? Some people said about similar stuff ( another kind of gapps issues) and what fixed was install rom, finsish this install, reboot to recovery and then install gapps. Otherwise, send us a log here if still remains bugging
 
  • Like
Reactions: ew

ew

Senior Member
Sep 28, 2010
741
184
How was the install procces? Some people said about similar stuff ( another kind of gapps issues) and what fixed was install rom, finsish this install, reboot to recovery and then install gapps. Otherwise, send us a log here if still remains bugging
Thanks for the assistance. For background, I was coming from the unofficial and upgraded to the official. I believe it was working, but I may have done something (and I don't know what) and it stopped working.

I even tried wiping the system partition and reinstalling - and that didn't help.

I wound up wiping my entire system (flashing back to stock) - and installing the official (including the recommended gapps) - and all is good.

And (by the way) I did reboot to recovery before installing gapps.

Thanks for the help. I guess this one will remain a bit of a mystery (as to what happened) but it is all working now.
 

jeferson1979

Recognized Developer
Jan 15, 2018
510
700
Taió
sourceforge.net
Moto X
Moto X 2014
Thanks for the assistance. For background, I was coming from the unofficial and upgraded to the official. I believe it was working, but I may have done something (and I don't know what) and it stopped working.

I even tried wiping the system partition and reinstalling - and that didn't help.

I wound up wiping my entire system (flashing back to stock) - and installing the official (including the recommended gapps) - and all is good.

And (by the way) I did reboot to recovery before installing gapps.

Thanks for the help. I guess this one will remain a bit of a mystery (as to what happened) but it is all working now.
It's the annoying part of a release early days XD
 
  • Like
Reactions: the_15th and ew

the_15th

Member
Sep 4, 2020
15
2
Hi, I've installed both the mod and Gapps following the instructions on the website (I had a PixelExperience ROM before) and - from what I am seeing - all went smooth.
Thanks a lot for your effort.

P.S. Is there a Telegram channel for LineageOS?


edit: the only "weirdness" I've seen: two apps warn me that phone is rooted. For one I can continue the installation, for the other is not possible. Not a big issue, but this did not happen with the Pixel Experience ROM.
Thanks again.
 
Last edited:
Dec 8, 2014
6
0
Hello, guys!

I recently installed the official 1.19.1 ROM and the Gapps provided and I'm getting "Offline" even if I am connected on WiFi. Browsing on internet works perfecly, but I get the messages as on the image below:

WhatsApp Image 2022-05-03 at 08.39.16.jpeg


Also, when I click in Google, from the Settings Menu, I get the message: Unable to start the App.

I think its something related to the Gapps.. Maybe?

Or the issue is because I'm not using a simCard at the moment?

Imma using the MindTheGapps-12.1.0-arm64-20220416_174313, on my Moto G6 Plus Evert, and used lineage-19.1-20220426-nightly-evert-signed zip package to format.

Is this a common issue?

I reinstalled the ROM just to be sure, but I still get this.
 

Attachments

  • WhatsApp Image 2022-05-03 at 08.39.16.jpeg
    WhatsApp Image 2022-05-03 at 08.39.16.jpeg
    61.3 KB · Views: 31
Last edited:

ew

Senior Member
Sep 28, 2010
741
184
I have been on this ROM for a day now - and it is very smooth. No major issues and thanks to the OP for the time and support!

A few small items that I have mostly found workarounds for but wanted to mention them for anybody that is interested:
  • I really like TWRP over the lineage recovery. On LOS 18.1 I was able to flash TWRP and use it. That doesn't seem to be an option for 19.1. Even though I have turned encryption off (so the encryption is not an issue) - it seems like it doesn't boot properly after installing TWRP. So, I guess I need to live with lineage recovery.
  • The green flash & dot that comes up when location is used is really annoying. The dot not as much as the flash - especially since I have apps that use location all of the time and the flash is distracting and removes other elements on the notification bar. I was able to use the information https://forums.oneplus.com/threads/android-12-little-green-dot-location.1572637/ and https://forum.xda-developers.com/t/...nsor-indicator-microphone-and-camera.4388359/ to help things, however sometimes after a reboot I have to turn the switch back off in developer options. Bit of a pain, and I have not found a way to turn it off automatically through tasker.
  • Auto brightness - in dark my screen gets too dark. I have to raise it - and it doesn't seem to be learning to use a higher minimum - like some other versions of android.
Relatively speaking - these are minor and maybe just things that bug me. The ROM is very smooth, fast and much appreciated!
 
  • Like
Reactions: the_15th

the_15th

Member
Sep 4, 2020
15
2
I also want to report what seems a minor bug: when the display auto-rotation is enabled, no icon is shown in the status bar, but instead an icon is shown when it is not. In stock version and Pixel Experience mod the feature had the opposite behavior (so an icon was shown only when auto-rotation was enabled).

Thanks again, all seems to work pretty well.
 

shiversc

Member
Mar 22, 2010
6
1
Hello, guys!

I recently installed the official 1.19.1 ROM and the Gapps provided and I'm getting "Offline" even if I am connected on WiFi. Browsing on internet works perfecly, but I get the messages as on the image below:

View attachment 5604917

Also, when I click in Google, from the Settings Menu, I get the message: Unable to start the App.

I think its something related to the Gapps.. Maybe?

Or the issue is because I'm not using a simCard at the moment?

Imma using the MindTheGapps-12.1.0-arm64-20220416_174313, on my Moto G6 Plus Evert, and used lineage-19.1-20220426-nightly-evert-signed zip package to format.

Is this a common issue?

I reinstalled the ROM just to be sure, but I still get this.

Same issue for me and my evert.
 

cipajzcz

New member
Sep 20, 2018
3
0
now, 3 month later finish guarantee, my charger burned out
happy, becase i was in the same room and stop fire, if i wasnt-maybe burnt all house!!!!!
be carefull-when are you charging everething
 
  • Wow
Reactions: jeferson1979

the_15th

Member
Sep 4, 2020
15
2

It is possible to disable the "green dot" when geolocation is used using the developers' options. I have an Italian-localized OS but it should be the last option in the menu, named sort of "Location indicator in the status bar". When the option is disabled, the green dot doesn't appear anymore and when an app uses the GPS only the standard icon is shown.

This thing has come handy with the last update (2022-05-17) since it introduces an annoying bug that should be fixed with the next update

 
  • Like
Reactions: ew

ew

Senior Member
Sep 28, 2010
741
184
It is possible to disable the "green dot" when geolocation is used using the developers' options. I have an Italian-localized OS but it should be the last option in the menu, named sort of "Location indicator in the status bar". When the option is disabled, the green dot doesn't appear anymore and when an app uses the GPS only the standard icon is shown.

This thing has come handy with the last update (2022-05-17) since it introduces an annoying bug that should be fixed with the next update

Thanks for your help. I found that the switch in the developer options got reset after reboot.

The following is my solution as implemented in Tasker. I run this at system start.

Task: Green Dot Location Suppress (A12)

<need to have the following commands in the following sequence for it to work:
-device_config put privacy location_indicators_endabled false default
-device_config put privacy camera_mic_icons_enabled false default
-device_config put privacy camera_mic_icons_enabled true default

Per my testing, the commands need to be executed in the sequence listed above - otherwise it does not work.

see https://forums.oneplus.com/threads/android-12-little-green-dot-location.1572637/

https://forum.xda-developers.com/t/...nsor-indicator-microphone-and-camera.4388359/>
A1: Anchor

A2: Run Shell [
Command: device_config put privacy location_indicators_enabled false default
Timeout (Seconds): 0
Use Root: On
Use Global Namespace: On ]

A3: Run Shell [
Command: device_config put privacy camera_mic_icons_enabled false default
Timeout (Seconds): 0
Use Root: On
Use Global Namespace: On ]

A4: Run Shell [
Command: device_config put privacy camera_mic_icons_enabled true default
Timeout (Seconds): 0
Use Root: On
Use Global Namespace: On ]
 
  • Like
Reactions: the_15th

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I'm a brand new first timer with custom roms and wanted to thank everyone involved here for their amazing work!
    After hours and hours of reading/googling I've manged to succesfully install this latest version of Lineage to my old Motorola :)

    Just one quick question if I may (couldn't find a definitive answer on Google): does Lineage offer OTA updates on itself? Like security updates?
    I ask this because Instagram isn't compatible (yet?) with Android 12.1

    Thanks again :)
    1
    I'm a brand new first timer with custom roms and wanted to thank everyone involved here for their amazing work!
    After hours and hours of reading/googling I've manged to succesfully install this latest version of Lineage to my old Motorola :)

    Just one quick question if I may (couldn't find a definitive answer on Google): does Lineage offer OTA updates on itself? Like security updates?
    I ask this because Instagram isn't compatible (yet?) with Android 12.1

    Thanks again :)
    OTA updates are available weekly
  • 5
    lineage-os-logo.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 12 (R), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    GPL compliance:
    Working:
    • Camera (and flashlight)
    • WiFi
    • Bluetooth
    • Telephony (Calls and Data)
    • Audio (Record and Playback)
    • Video Playback
    • Sensors
    • GPS
    • Crypto

    Broken:
    • Nothing (?)


    Downloads:

    Notice:
    • No custom kernels are supported in this thread. Only stock kernel and official builds will be supported. No bug reports if that's not the case.

    Installation:
    Important notes:
    • * Required * Patience.
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    • Formatting data (all user data is wiped, including internal storage) when comming from other roms.

    Credits & collaborations:
    All LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!​

    Device wiki:

    LineageOS 19.1, ROM for the Moto G6 Plus

    Contributors
    jro1979oliver
    ROM OS Version: Android 12.1
    ROM Kernel: Linux 4.4.x
    ROM Firmware Required: latest stock

    Version Information
    Status: Official

    Created 2022-04-25
    Last Updated 2022-04-25
    2
    I'm a brand new first timer with custom roms and wanted to thank everyone involved here for their amazing work!
    After hours and hours of reading/googling I've manged to succesfully install this latest version of Lineage to my old Motorola :)

    Just one quick question if I may (couldn't find a definitive answer on Google): does Lineage offer OTA updates on itself? Like security updates?
    I ask this because Instagram isn't compatible (yet?) with Android 12.1

    Thanks again :)
    2
    Thanks for the assistance. For background, I was coming from the unofficial and upgraded to the official. I believe it was working, but I may have done something (and I don't know what) and it stopped working.

    I even tried wiping the system partition and reinstalling - and that didn't help.

    I wound up wiping my entire system (flashing back to stock) - and installing the official (including the recommended gapps) - and all is good.

    And (by the way) I did reboot to recovery before installing gapps.

    Thanks for the help. I guess this one will remain a bit of a mystery (as to what happened) but it is all working now.
    It's the annoying part of a release early days XD
    1
    I prefer you start clean, but you can try, if you flash mindthegapps as Gapps package, it will be the same as shipped on unnoficial build
    1
    Unofficial builds are still the best