[OFFICIAL] LineageOS 19.1 for Moto G7 Plus

Search This thread

fankool

Senior Member
Yeah, it's a system camera and that feature just won't work. Not much we can do if anything to fix it.
First of all, thank you for your work!
I'm faced with the same problem of choosing root folder of sd card for 2 different app. Any way to disable this "feature"?
Is it possible to disable the sliding of background image when I switch left or right screen? I hope you understand what I mean, I just want to keep the background always at the same position.
thanks!
 

proza

Senior Member
Sep 18, 2012
167
2
I installed TWRP, copy-partition and the other custom ROM.
What are the best steps to install this ROM?
 

proza

Senior Member
Sep 18, 2012
167
2
Is it necessary to sideload the copy-partition again?
 
Last edited:

leonardobat

New member
Apr 29, 2022
2
1
Hello,
I installed it yesterday, and everything seems to work fine. It was a clean install since I went from stock to lineage, but my USB C headset isn't working correctly.
I've added more information; I tested with the newer builds on May 5 and 10. Issue still present.
 

rodrigomolinari

New member
May 17, 2022
1
0
When I take screenshots, edit button is not doing anything 🤔

I'm using the unofficial build with pixel features
20220515-UNOFFICIAL-lake
 

petexd

Senior Member
Dec 2, 2017
78
6
I mark twrp to reflash after installing rom. Then install rom and reboot twrp to make sure it's using the correct A/B. Then I install flamegapps followed by magisk and reboot.
 
Last edited:

fankool

Senior Member
I had a great experiene yesterday, upgrading lineage with the last release. I decided to upgrade from twrp because I thought it should be faster than online upgrade. Bad idea: it is really much faster, but at the end of flashing there was a laconic error mounting /system_root (or something similar). Then just bootloops, and after 2 hours I decided to restart from scratch.
My question: is still useful TWRP? /data is encrypted, it's impossible to make a nandroid backup. Or there's a possibility? I think TWRP could be only useful to copy/paste quickly files from recovery.
 

ZubaZ

Senior Member
Mar 27, 2013
232
470
Anyone else having an issue with Lineage on Cricket Wireless? It has suddenly stopped letting me make phone calls/texts the last day or two. I was able to get back to stock today and it seems to be working on stock. I can attempt to reinstall the latest lineage again later tonight, but will stay on stock for the rest of the day so I can make a phone call. ha. Maybe something to do with certain bands/gsm/lte or something like that I am thinking?
 

retry0001-coffee

Senior Member
Oct 21, 2019
126
43
Did they officially close down all non VoLTE calls? That's coming to Tmob in several weeks. I am actually flashing my G7+ to stock today to try to fix the no VoLTE issue I'm having with LOS. I plan to reflash to LOS immediately afterwards though (and upgrade to 19.1 in the process). Suffice to say, today isn't going to be a fun day.
 

ZubaZ

Senior Member
Mar 27, 2013
232
470
Did they officially close down all non VoLTE calls? That's coming to Tmob in several weeks. I am actually flashing my G7+ to stock today to try to fix the no VoLTE issue I'm having with LOS. I plan to reflash to LOS immediately afterwards though (and upgrade to 19.1 in the process). Suffice to say, today isn't going to be a fun day.
On cricket wireless, yes, I think so. But I did have 'use volte/hd voice' or whatever it was called checked. Didn't seem to be helping. Although I was on a decently old version of Lineages. Maybe 17.1 something I think? I just am kind of noob at updating and re-doing all my settings and things so I try not to do it. Not sure if calling should be working on Lineage 19.1 or not? I did try a dirty flash, but it wasn't working. Seems fine right now on stock, but I don't want to stay on stock. ha.
 

ZubaZ

Senior Member
Mar 27, 2013
232
470
oh lame, I did a clean install and still no mobile data on the latest version of lineage with gapps. (lineage-18.1-20210729-microG-lake). Hmm....any thoughts from anyone?
 

retry0001-coffee

Senior Member
Oct 21, 2019
126
43
I just did flashed stock and then back to LOS (upgraded to 19.1) and still no VoLTE at Tmobile :( .. This sucks. I'm out of ideas. July 1st, the phone becomes trash if this can't get resolved.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Good news. Flashing to stock enabled VoLTE and calls over wifi. Then I reflashed to LOS 19.1 (with NikGapps core) . At first I got no mobile data connection to tmobile, but a restart fixed that problem. Now it shows the phone as registered and it's doing "HD" calls and wifi calls. Interestingly, my vendor security patch level still shows as Feb 2021. I expected it to be later.

    Stressful process, especially since I flashed the stock ROM entirely by hand with fastboot flash commands (I wasn't sure the 5-part sparse system image would copy correctly). But I'm so happy now that it all worked. Thanks so much npjohnson. I really appreciate your guidance here.
    1
    Interesting. I don't see that version here:
    It's very close to 2 of them in this folder, the retla, not TMO. https://mirrors.lolinet.com/firmware/moto/lake/official/RETLA/
    1
    The next build will have it. Look for the Security update line https://download.lineageos.org/lake/changes/ . Typically you won't see the current month's security patch level until the latter half of the month. Don't be surprised if it's not showing up until the last week of the month. It takes time to merge stuff.
  • 3
    lineage-os-logo.png

    Moto G7 Plus

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 19.1 thread for the Moto G7 Plus.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    • lake - Official builds
    • lake - My unofficial with Google Apps/Pixel goodies included. OTA's roll roughly once a month. Support not guaranteed or implied.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • None.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_motorola_msm8998
    2
    IMO mindthegapps, which only offers one package (stock) is gonna be far more bloated than the projects which offer minimal package installs (pico/nano for OpenGapps, core for NikGapps, basic for FlameGapps). I too am frustrated that opengapps seems way behind the curve here, but I don't want to wipe my phone to switch to one of the others...
    2
    Good news. Flashing to stock enabled VoLTE and calls over wifi. Then I reflashed to LOS 19.1 (with NikGapps core) . At first I got no mobile data connection to tmobile, but a restart fixed that problem. Now it shows the phone as registered and it's doing "HD" calls and wifi calls. Interestingly, my vendor security patch level still shows as Feb 2021. I expected it to be later.

    Stressful process, especially since I flashed the stock ROM entirely by hand with fastboot flash commands (I wasn't sure the 5-part sparse system image would copy correctly). But I'm so happy now that it all worked. Thanks so much npjohnson. I really appreciate your guidance here.
    1
    I looked for version 19.1 on the official website and didn't find anything to download. A few hours ago it was available. What happened?

    There is a new version built this night ( 20220427) now online. This worked now for me and even the first boot was really fast (~2 min). https://download.lineageos.org/lake

    Had issues the whole night with the 20220426 build. I was always in a boot loop after sideloading the 26 version.
    Later, I tried to go to Stock Rom first with the Lenovo Rescue and Smart Assistance (to my XT1965-3 (EU) ).
    Sideloaded Recovery and Lineage 19.1 again -> bootloop.
    Went to bed late, saw a new version right after getting up -> works as expected


    First, Thank you @npjohnson for your work!
    Do you have a personal donation link?
    1
    I installed it with the latest TWRP. It bootlooped with flamegapps but installed successfully with mindthegapps.
    I install twrp on the system and it has a handy choice to reflash itself after installing the rom. You then must reboot to twrp to add the gapps zip or it will not work.
    For anyone else interested I also installed magisk and it works perfectly but be aware of @npjohnson's point re loss of support.