[OFFICIAL] LineageOS 19.1 for Moto Z3 Play

Search This thread

MrDoc2

Member
Dec 8, 2009
11
0
Is more info available on the mods? I have the 360 and Hasselblad camera mods, Alexa speaker mod, battery mod, project mod (the coolest mod of them all), stereo speaker mod, maybe one or two others too.

Will I loose any of the functionality of the above mods? Hasselblad and the projector were the two I was most excited to get.
 

telly01

Member
Dec 11, 2010
16
4
Lowell
Is more info available on the mods? I have the 360 and Hasselblad camera mods, Alexa speaker mod, battery mod, project mod (the coolest mod of them all), stereo speaker mod, maybe one or two others too.

Will I loose any of the functionality of the above mods? Hasselblad and the projector were the two I was most excited to get.
The hasselblad does not work with lineage. im not sure about the projector

the battery mods work, the JBL speaker mod works as well.
 

maDIEmG

Member
Aug 11, 2011
41
2
I use my old Z3 Play to play movies while camping and I had the same questions cause I got bored and wanted to update my phone from android 8/9 whatever the last official version update was and I can confirm that yes the projector & speaker works.

Does the projector work: YES
Does the speak work: YES

Note: Moto Mods Manager has crashed sometimes twice so far out of 20 something times I've swapped from the Speaker to the Projector and vice versa but even when it crashed it just reset and displayed it properly without issue in the notification tray and doesn't impact the mods working.

Note note: Lineage is so much faster then the stock build rom for the Z3 I should have updated a long time ago.

I've included some screenshots for y'all if that helps.

Screenshot_20220929-171429_Trebuchet[1].png
Screenshot_20220929-171329_Trebuchet[1].png
Screenshot_20220929-171023_Trebuchet[2].png
Screenshot_20220929-171340_Moto_Mods_Manager[1].png
 

steliomota

New member
Jun 12, 2017
4
0
Hi Everyone, does someone have an issue where the mobile data dont work? The Stock ROM is ok, but using Lineage OS the mobile data doesnt. Has no signal. I use TIMBR
 

hodumx

New member
Dec 7, 2022
1
0
Google Pixel XL
Moto Z3 Play
Hello, I’m new to the forum and seem to have an issue with my moto z3 play. I’ve flashed the phone through terminal before, and can’t seem to be able to again, switched cables and usb on the computer. Some comands seem to go through, but when sending stuff like a recovery image it’s just stuck. Bootloader and usb debugging is unlocked, so I’m at a loss and any help is appreciated. I’m using linux manjaro, and adb and fastboot is installed. A picture is included for what my terminal is stuck on. Also, I’m wondering if verity mode being set to disabled would be part of the issue. Thanks in advance for any help.
 

Attachments

  • FAEFAD85-7D58-4759-83C6-CDFC44CA6AB2.jpeg
    FAEFAD85-7D58-4759-83C6-CDFC44CA6AB2.jpeg
    2 MB · Views: 19

trianglesis

New member
Jan 19, 2013
1
0
Strange thing, but LTE\3G is not working.

I only found out this after I've flashed my phone a while ago.

I'm using my main SIM and "cloned" one (for LTE internet) and found out that no mobile connection is working.
Not a critical issue, but I haven't found any similar problems mentioned here.
 

inphynithus

New member
Jan 29, 2023
3
2
Moto Z3 Play
I successfully installed LineageOS 20 on my device, that was kinda though considering I messed up a little bit in the process. That's my first time flashing a rom.
I don't know if it's appropriate or not to write it here, but before I share my experience with LOS 20, I want to give some advices for people that want to install it but it's new to this thing:
1. Backup your damn EFS files before proceeding to do anything, do some search on Google/XDA to find how to do that. This is REALLY important.
2. Find your RIGHT STOCK ROM or backup your current one, you will need that.
3. Read more about custom roms before trying to do any step-by-step tutorials. You should prepare yourself for unforeseen problems.
4. Make sure you know what you're doing, if you don't know, then search about it before doing it. The chances of you damage your device are really high if you do anything without properly knowledge.


After I installed LineageOS I noticed SIM1 data wasn't working. I can receive calls/text via SIM1 but no mobile data and LTE doesn't work, it just says
"Disconnected".
However, SIM2 is working perfect.
After I searched a little bit about it I found this on gitlab: https://gitlab.com/LineageOS/issues/android/-/issues/4524
It seems an issue or we both did something wrong during the install.
Besides that, I'm having other problems too:
Headset microphone gain is too low, even if I speak too close to the microphone it is still too low. I know there is a work around with root, I would do it if SIM1 data work properly.
Volume of calls are too low on headset, even using some audio booster apps couldn't solve that.
When I'm using wired headset and someone calls me the ringtone starts to chopping, it's really annoying.
Sometimes if I'm playing some audio and suddenly disconnect the adapter the speaker stops working, no audio at all until I reconnect the adapter.

Other than those issues everything is working fine. But I'm going to try PE to see if I get the same issues or not. I hope I get back on LOS 20 when it gets more stable.
 

EvilMonkey88

Member
Dec 10, 2018
21
3
I've upgraded 2 moto z3 play phones from los 19 and don't experience your problems . at least sim card/data one. I use Bluetooth earphones at times but not USB headset

Only issue Ive noticed over last few weeks , screen occasionally is not waking up ..its black but you hear unlocked phone and tap sounds
Its related to los 19 dissapearing notification bar as both are easily resolved by turning phone to landscape :)

PS still no WiFi calling or VoLTE :/
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    lineage-os-logo.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 12 (R), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    GPL compliance:
    yG18r6g.png
    Working:
    • Camera (and flashlight)
    • WiFi
    • Bluetooth
    • Telephony (Calls and Data)
    • Audio (Record and Playback)
    • Video Playback
    • Sensors
    • GPS
    • Crypto

    Broken:
    • Nothing (?)


    Downloads:

    Notice:
    • No custom kernels are supported in this thread. Only stock kernel and official builds will be supported. No bug reports if that's not the case.

    Installation:
    Important notes:
    • * Required * Patience.
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    • Formatting data (all user data is wiped, including internal storage) when comming from other roms.

    Credits & collaborations:
    All LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!​

    Device wiki:

    LineageOS 19.1, ROM for the Moto Z3 Play

    Contributors
    jro1979oliver
    ROM OS Version: Android 12.1
    ROM Kernel: Linux 4.4.x
    ROM Firmware Required: latest stock

    Version Information
    Status:
    Official

    Created 2022-04-25
    Last Updated 2022-04-25
    2
    Installed lineage 20 last night, with the Mind The Gapps addon. Didnt wipe the phone.

    So far so good!
    1
    I'm having issues with split screen functionality.
    Haptics click, but it does not split the app into side-by-side mode.
    Tried changing "Force activities to be resizeable" in dev options, but still didn't help.
    1
    Is there an easy way to get onto the right Android 9 in the official installation steps before installing recovery and LOS 19? Thx.
    Yes just install lenovo rescue_and_smart_assistant_v6.1.1.9_ .. it will find and install latest Android 9