[OFFICIAL] LineageOS 19.1 for the Google Pixel 2

Search This thread

sekret1

Senior Member
Jul 25, 2015
99
24
The official microG builds are VERY outdated. Does anyone know, what's the problem there? Unfortunately I need microG, so switching to the "normal" builds isn't an option for me.
 
I've tried installing the official 19.1 and same as with unofficial 20.0 (besides the read errors while sideloading the zip), the device won't boot.

It, again, got stuck on the Google logo screen while booting for the first time. I gave it 38 minutes to load but it didn't boot at all. Can someone tell me what's going on? It used to work fine on stock Android.
 
Last edited:

sekret1

Senior Member
Jul 25, 2015
99
24
edit: Had a problem, which I could solve by myself, but which is too difficult to explain here. That's why I didn't keep my original post.
 
Last edited:

js-xda

Senior Member
Aug 20, 2018
361
157
Samsung Galaxy S4
i9100
I am new to the Pixel 2 - so, I hope I am not missing something obvious for this device (took me e. g. a little while til I understood that the Active Edge is a feature - not a bug ;)).

I have two devices where I seem to run into an issue with low volume also described in a Google Pixel Help Community post and maybe here in another thread. Initially, one of the two devices (running /e/OS S dev based on LOS 19.1) had for all sounds (general, ring ton, alarm - not tested for call) significantly low volume. Maximum would be roughly around 50 % of regular volume when putting the two devices next to each other. I thought first it is a bug of /e/OS and flashed LOS 19.1 but situation unchanged. After powering off both devices for 1-2 h, they are at the same volume level - and I would dare to say both are low.

While there is a good chance that it is a hardware issue, the first referenced post indicates that some users experience this change after upgrading/updating their device. So, I still see the chance it could be a software bug but couldn´t find any information in the Pixel 2 ROM forum or beyond. Also, it would be a pretty unlikely coincedence that it happens to the second device right while I am testing it ...

So, anybody a clue or some information?

Just in case of any relevance:
  • Both LOS 19.1 installations without GApps and Magisk - plain LOS 19.1.
  • LOS 19.1 and /e/OS with their respective recovery - not using TWRP.
  • Both devices IMEI starting with 35 - I found some (vague) hints that there might be a different generation Pixel 2 with another IMEI format.
 

b00ster23

Senior Member
Feb 19, 2016
443
177
Moto E
Google Pixel
Something I'd like to share in reference to WiFi calling. I use Verizon and wanted to enable the feature, knowing that IMS was registered and VoLTE was working. However, whenever I tried to enable the feature the application crashed. After a bit of logcat captures I found the issue. Just updated the Carrier Setup app from https://apkcombo.com/emergency-address-management/com.google.android.wfcactivation/download/apk and all is right in the world again. Just thought I'd share in case anyone else runs into the issue with Big Red.
 
Last edited:

js-xda

Senior Member
Aug 20, 2018
361
157
Samsung Galaxy S4
i9100
And another question that I am having comparing the two above mentioned Pixel 2 that I bought both used and installed LOS 19.1: One of the two (left) is not reading a SIM card which is working on the other without any issues (right). According to the previous owner, SIM card reading was working without issues (but on stock). I noticed already before that the troublesome phone is not displaying a missing SIM card (top left corner on the first image) while the other one is. The images below (and subsequent test with the SIM card) were done after full factory reset of both devices (running plain LOS 19.1 230117).

I have seen some issues reported mid of last year but were judged as not related to LOS 19.1 by npjohnson. I see MicroG related issues being linked. So, I don't think this is in any way related to my issues (not using MicroG, GApps, Magisk, ...).

Anyone an idea what to check?

PS: Yes, I am aware of the different display of colors ... having some thoughts that one might not be original ...
 

Attachments

  • IMG_20230123_221055~(1).jpg
    IMG_20230123_221055~(1).jpg
    162.1 KB · Views: 9
  • IMG_20230123_221001~(1).jpg
    IMG_20230123_221001~(1).jpg
    186.4 KB · Views: 9

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    lineage-os-logo.png


    Google Pixel 2

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.[/CENTER]

    Introduction:
    This is the Official Lineage OS 19.1 thread for the Google Pixel 2.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    • walleye - My unofficial with Google Apps/Pixel goodies included. Passes SafetyNet by default. OTA's roll roughly once a month. Support not guaranteed or implied.​
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • None.​
    • Find any? Report them according to this guide.​
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.​
    • Firmware is shipped in the ROM package for this device, so no need to worry about updating it on your own!​
    Kernel Source: https://github.com/LineageOS/android_kernel_google_wahoo
    2
    Hey all! The final 19.1 unofficial are rolling right now.

    From here on it will be 20 builds for these devices only when it comes to unofficials.

    The device will continue receiving official 19.1 for some time, but 20 will launch soon enough, so get ready to migrate using the upgrade guides!
    2
    It's literally a brand new sealed in box old stock phone.

    Camera worked fine before lineage.
    I really don't know what to tell you. On Official 19.1 and Unofficial 19.1 (my builds), camera works fine.

    Google Camera will only work on my builds, as Pixel 2 support was dropped in Google Camera in a past version. I pin that version for Pixel 2 builds specifically.
    2
    Have you read the last few posts? No, it's not all that stable yet.

    And what do you mean by "good customization"? It's quite subjective what one considers good or bad. There are other ROMs with much more customization capabilities than official LineageOS. For me personally it's absolutely enough, for you it might not be.
    It is stable. No one is filing any bug reports, nor can I recreate any of this. Literally all of this works on both the Pixel 2 and 2 XL in my testing.

    If you're having issues like that, did you follow the wiki? Did you format data before you came to 19? What mods do you use?

    And logs/bug tickets would help.

    But statistically, hundreds and hundred of people are using 19.1 for wahoo and enjoying so it's either an edge or device specific case.
    1
    I just tried this and it all works except the Camera. When trying to open it, I'm getting

    Camera keeps stopping
    - App info
    - Close app

    Any idea why that might be?
    New build is up - fixed.