[OFFICIAL] LineageOS 19.1 for the Moto G7/G7 Power

Status
Not open for further replies.
Search This thread

IronTechmonkey

Recognized Contributor
Feb 12, 2013
9,115
15,124
Does anybody know how to change the default webview implementation on the Moto G7? I've installed the bromite system webview, from fdroid. I also tried installing from the root file manager and by using SystemAppMover from the instructions: https://github.com/bromite/bromite/wiki/Installing-SystemWebView

Any suggestions would be appreciated.

That's a bit out of scope for LOS ROM dev but FWIW, when I had to temporarily use an alternate webview (because a new one had a problem) the process was to install the alternate then select it in Android Settings > Developer options > Webview implementation.
 

wilderson

Member
Aug 6, 2016
16
1
My updater just advertised version 20. I'm on Pixelified, and it sates that it cannot be updated via updater.
What I should do?
 

iooxda

Senior Member
Dec 1, 2019
70
33
How can I store photos to the sd card using the camera all with river?

When I open the app it will not allow me to select the root:
Can't use this folder.. to protect your privacy, choose another folder...

okay I select the DCIM folder on the sd card and take a picture and Moto camera tells me:
sd card root directory must be selected

?? I am using the official Lineage image, I thought the basics needed to work for Lineage to be official?

Does anyone have a work around for saving photos to the sd card with river or is this function broken?
 

npjohnson

Recognized Developer
Hey all! The final 19.1 unofficial are rolling right now.

From here on it will be 20 builds for these devices only when it comes to unofficials.

The device will continue receiving official 19.1 for some time, but 20 will launch soon enough, so get ready to migrate using the upgrade guides!
 

SliverSeven

New member
Jul 17, 2013
4
1
Hi All. this is amazing thank you. I haven't done a Custom Rom in years and I'm having lots of fun doing this.
I'm having an issue with the MindTheGapps.
I followed the instructions on the wiki. I did it slowly so I hope I did not miss anything.
I unlocked the bootloader, I installed the recovery lineage-19.1-20221120-recovery-river.img
Did the firmware partitions thing with copy-partitions-20220613-signed.zip
I did the factory wipe
I then installed lineage-19.1-20221120-nightly-river-signed.zip.
Since this was lineage 19.1/Android 12L, and ARM64, I installed the add-on MindTheGapps-12.1.0-arm64-20220605_112439.zip

YAY! so I reboot; however I get to the lineage logo but it just reboots over and over again.
I did the factory wipe, Lineage install but this time did not install MindtheGapps, and it booted properly! but now I don't have gapps.

what am I doing wrong? Am I using the wrong MindTheGapps?
 
Last edited:

IronTechmonkey

Recognized Contributor
Feb 12, 2013
9,115
15,124
Hi All. this is amazing thank you. I haven't done a Custom Rom in years and I'm having lots of fun doing this.
I'm having an issue with the MindTheGapps.
I followed the instructions on the wiki. I did it slowly so I hope I did not miss anything.
I unlocked the bootloader, I installed the recovery lineage-19.1-20221120-recovery-river.img
Did the firmware partitions thing with copy-partitions-20220613-signed.zip
I did the factory wipe
I then installed lineage-19.1-20221120-nightly-river-signed.zip.
Since this was lineage 19.1/Android 12L, and ARM64, I installed the add-on MindTheGapps-12.1.0-arm64-20220605_112439.zip

YAY! so I reboot; however I get to the lineage logo but it just reboots over and over again.
I did the factory wipe, Lineage install but this time did not install MindtheGapps, and it booted properly! but now I don't have gapps.

what am I doing wrong? Am I using the wrong MindTheGapps?

Did you reboot from recovery directly back into recovery between flashing ROM and gapps?
 

PMDPhD

Member
Nov 18, 2013
30
3
Moto G7
Samsung Galaxy Tab S5e
Does anyone use this ROM with Google Fi? I can get nothing but 2G Edge service at multiple locations (not a coverage issue). If I pop the SIM in another phone I get 5G or LTE. Coverage maps all say I should have at least LTE everywhere I have tested. I have gone through troubleshooting with google fi reps (reset network, clear cache, blah blah) and still only get 2G data. Calls and SMS work fine but data is the issue. If I go into settings and change the "preferred network type" I either get 2G or nothing. I have cycled through every option on that list with no improvement. I only notice a LTE connection occasionally when I reboot but a few seconds after this it drops back down to 2G. Is there some setting buried in Lineage somewhere I need to tick?
 

npjohnson

Recognized Developer
Does anyone use this ROM with Google Fi? I can get nothing but 2G Edge service at multiple locations (not a coverage issue). If I pop the SIM in another phone I get 5G or LTE. Coverage maps all say I should have at least LTE everywhere I have tested. I have gone through troubleshooting with google fi reps (reset network, clear cache, blah blah) and still only get 2G data. Calls and SMS work fine but data is the issue. If I go into settings and change the "preferred network type" I either get 2G or nothing. I have cycled through every option on that list with no improvement. I only notice a LTE connection occasionally when I reboot but a few seconds after this it drops back down to 2G. Is there some setting buried in Lineage somewhere I need to tick?
did you activate through the Fi app? You need to do that.
 

PMDPhD

Member
Nov 18, 2013
30
3
Moto G7
Samsung Galaxy Tab S5e
did you activate through the Fi app? You need to do that.
Yes I did. It activates and connects fine...I just cannot get any LTE data connection on the g7, only 2G EDGE. I have checked at multiple locations, so it's not a coverage dead zone. The Fi reps are not very useful for troubleshooting, they just read through a script (install updates, clear cache, reinstall Fi app etc.). People here are far more knowledgeable so I figure I would try here. I just can't figure out if it is something in the ROM I need to fix, like a setting or something. I know the g7 has the compatible antenna and bands for Fi/T-Mobile, just can't figure out what else to try to fix this. I do see LTE connect on reboot then drop like I mentioned but that is it. I can't really find any published APN settings for Fi either, those can cause issues with many MVNOs if they are not set up perfectly.
 

9000RPM

Senior Member
Aug 27, 2012
50
6
Flashed this but noticed it wouldn't work on Verizon. Data worked but couldn't make calls or send text.
Had to flash back to stock rom.
 

lessmeat

Member
Jan 1, 2013
23
1
Thanks for updates but sorry to report that Lineage 20 also having Camera not able to save to SD card problem, just like Lineage 19.

1. Open Camera app.
2. SD card found, save there? Yes, then choose folder, unable to choose SD root, choosing any folder it wont complain.
3. Taking a picture, it'll complain "SD card root directory must be selected", not able to save and swtiching back to Phone internal storage.

This makes me shy away from 19 and 20.

Anyway to fix? Thanks,.
 

9000RPM

Senior Member
Aug 27, 2012
50
6
Lineageos roms don't have what Verizon needs. It'll never work. In fact no third party rom works.
Thanks for letting me know. My personal line is on AT&T and never had any issues with customs roms. This G7 is my work phone on Verizon and first time finding out. Guess it won't work with PixelExperience either then.
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    lineage-os-logo.png

    Moto G7/G7 Power

    Code:
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    Introduction:
    This is the Official Lineage OS 19.1 thread for the Moto G7/G7 Power.

    Downloads:
    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    • Moto G7
      • river - Official builds
      • river - My unofficial with Google Apps/Pixel goodies included. Passes SafetyNet by default. OTA's roll roughly once a month. Support not guaranteed or implied.
    • Moto G7 Power
      • ocean - Official builds
      • ocean - My unofficial with Google Apps/Pixel goodies included. Passes SafetyNet by default. OTA's roll roughly once a month. Support not guaranteed or implied.
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • None.
    • Find any? Report them according to this guide.
    Notes:
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.
    Kernel Source: https://github.com/LineageOS/android_kernel_motorola_sdm632
    4
    Hey all! The final 19.1 unofficial are rolling right now.

    From here on it will be 20 builds for these devices only when it comes to unofficials.

    The device will continue receiving official 19.1 for some time, but 20 will launch soon enough, so get ready to migrate using the upgrade guides!
    3
    Hi.
    For anyone having problem with sensor_SMD 2000000000 kernel wakelock battery drain problem. Solution to this problem is disabling Significant Motion Detector.

    You can do this by adding custom prop using MagiskHide Props Config Magisk module:

    ro.vendor.sensors.smd and set value to false.

    I hope someone will find this post helpful.
    River already had it, but fix merged for Channel and Ocean, sorry about missing that!

    3
    Only issue I have so far is a pop up telling me "Android System Intelligence keeps stopping".
    My brain notification service shows the same message from time to time as well: "System Intelligence keeps stopping" :)
    2
    I did. Just wanted to be sure because sometimes the guides leave out steps. Install was fine, looks like it is missing the FM Radio app, any reason why? Thanks.
    Fixing it.