[OFFICIAL] LineageOS 20 for the Google Pixel 4 XL

Search This thread


Recognized Developer
Thank you! And thank you @tasoskio for providing crash logs.

And duly noted for the future - I'll wait to update if I'm going to bed, so I'll be awake enough to capture crash logs to help with troubleshooting. That was on me 😅
No, this was on me, I have updated my release process to include extra checks.
  • Like
Reactions: digitalcircuit
Disregard my previous post. I also have a few random bugs, my original note is now innaccurate and this is a valid report. The latest 3/26 update has broken a few things, I use the OFFICIAL LOS so its upstream!

Good report!!!
For anyone in the future, OR wish to rollback ASAP, follow this method and it works 100% but you will data loss!!!

Using Google's factory firmware is all you need! Use the factory firmware with -w will allow the rollback for anyone rushing to restore LOS (use coral-tp1a.221005.002.b2-factory-db99b1f8) factory firmware. BACKUP EVERYTHING PRIOR as you will LOSE IT ALL (if you don't backup PRIOR to the -w batch), then factory reset using recovery, then flash the batch (flashall.bat) with -w wipe left in, reboot (or it will reboot on its own when done), then bypass all setup, reboot to BL, start over with LOS (using the previous week). I am back rockin LOS using this method!


* I erase /system /data in fastbootD, but this is optional, I do it so I always have a clean /system base, but a factory reset is enough for most users!
Last edited:
Is the 3/26 release good? Thanks!
Please confirm when you take the OTA (official LOS) and it works with the latest 3/26 ver so we all know and can update to it (launcher/services fixed). I am asking only users who used the 'Official LOS OTA Updater' and did an OTA update from a previous version (and it works afterwards). Please confirm the services and launcher issues are resolved with the latest official OTA (when a user has successfully done an OTA update with the fixed update).


Senior Member
Jan 27, 2010
Southern Indiana
OnePlus 9 Pro
Please confirm when you take the OTA (official LOS) and it works with the latest 3/26 ver so we all know and can update to it (launcher/services fixed). I am asking only users who used the 'Official LOS OTA Updater' and did an OTA update from a previous version (and it works afterwards). Please confirm the services and launcher issues are resolved with the latest official OTA (when a user has successfully done an OTA update with the fixed update).
I won't be taking an OTA.


Recognized Developer
Please confirm when you take the OTA (official LOS) and it works with the latest 3/26 ver so we all know and can update to it (launcher/services fixed). I am asking only users who used the 'Official LOS OTA Updater' and did an OTA update from a previous version (and it works afterwards). Please confirm the services and launcher issues are resolved with the latest official OTA (when a user has successfully done an OTA update with the fixed update).
it works fine.
  • Like
Is there any way I could get the Pixel fonts as a flashable zip, or magisk module? Or perhaps a guide to replace the fonts using root explorer? Every magisk module I've tried off of xda seems to be changing it to a single font (i.e bold, italicization etc, is all ignored, and replaced by a single regular font which is applied system wide, no matter the formatting of the original text.)
My safetynet is still not passing after complete factory reset. Can't use GPay.

No I'm not rooted and just factory reset after taking the March 26th update. Does it just not work anymore?
I wrote a lot about this and how to fix it, in this thread, but I use ROOT, SafetyNetFix, LSPosed, and MagiskProps, then I enable options 1 and 2 (only those two options are used, don't enable any others), then force both options 1 and 2 to use Google Pixel 4 XL A12, then wipe play store data, reboot, open play store and test. You should become certified in play, and pass SN (then Netflix will show up along with Hulu and such).

This is all with ROOT, I don't know what you should do if you don't plan to ROOT and your BL is locked with a Google factory firmware applied. If you have done all 3 (lock BL, factory reset firmware, -w WIPE /data) and its still not working, then who knows what happened. Make sure you backed up everything prior, then go through the lock BL, and factory firmware with the wipe left in the flashall.bat file from the firmware. If you do all 3 (BL lock, factory firmware, wipe data) you should be solid and NF shows up in Play, bank apps work, and so on.

Without ROOT, make sure you do all 3 things to make it re-official Google device, then let us know if its resolved or not. The other option would be to ROOT, then bypass ROOT for the bank apps (hide ROOT in MAGISK with DENYLIST).

Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I've got the latest downloaded and ready to connect to adb, but I realized I'm not sure how to even return to stock if needed? In the old days, I could restore a backup of the stock rom. Not sure how to accomplish it now.
    Flash.android.com will do that all for ya
    Thanks You @npjohnson how to tranfer from Official builds to your build?
    Step 1: flashboot unoffical recovery,
    Step 2: format all data
    Step 3 adb side load custom Rom
    It's right?
    yeah, it does have it's own wiki, just follow the install guide.
    My last pixel was the 2xl. it died and my brother gave me a S10. This morning it fell in the river. A decent 4XL can be found for under 200 especially if you only need the 64gb storage. Mine is on it's way and I am glad that samsung junk is sitting at the bottom of the river. And glad you're okay too
    Depending where you are you can get lucky and get a pixel for about 136 usd on swappa.
    Gotcha. I'm assuming I'll need to flash the newest recovery with every release in order for things to work?

    The lineage recovery can make nandroid backups right?
    No you don't need the newest recovery, in auto updates, this is an A/B device meaning that recovery comes packaged in The boot image.

    And as for full backups, no, lineage has something in the OS called seed vault that does OS level backups instead.
    Is there any chance you support hotspot unblocking? You have to pull it out of Google and add the provision to unblock/unmonitor it's usage.
  • 12

    Google Pixel 4 XL

    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    This is the Official Lineage OS 20 thread for the Google Pixel 4 XL.

    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed.
    • coral - Official builds​
    • coral - My unofficial with Google Apps/Pixel goodies included. Passes SafetyNet by default. OTA's roll roughly once a month. Support not guaranteed or implied.​
    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • None.​
    • Find any? Report them according to this guide.​
    • The only supported GApps package at the moment is MindTheGapps, linked on our Wiki page about gapps.​
    • Firmware is shipped in the ROM package for this device, so no need to worry about updating it on your own!​
    Kernel Source: https://github.com/LineageOS/android_kernel_google_msm-4.14
    @npjohnson HI can you please post the sources for your unofficial build its against the xda forum rules since you are providing 2 different versions of lineageOS so you should provide sources for both not just official which is not even released, The title of this thread says official and the official is not even released yet but an unofficial build so either create a different thread with unofficial version and add the sources for it and whenever official lineageOS is available create a different thread, Or add the sources for unofficial build as well in this thread.

    Which ever device i had i have always went through the source codes of all custom i used mostly lineageOS and i hope you dont get me wrong. i do a lot of research on custom roms and i need to understand why if something feels wrong.

    i will contact the moderators of this forum as well for more information.
    Wow. Threaten me right off the bat with contacting moderators?

    Hilarious. Stuff like this genuinely makes me dislike doing this.

    Let me address these individually:

    1. The official kernel source I link is the /only/ one there is - and I might add - the kernel is the only one that is a GPL component that has to be released.

    2. For your information, by choice, not by license, all sources for the official AND unofficial are public.

    Next time you want to threaten someone, do some preliminary research first - this is linked in multiple places - and I will take a moment to say, none of this is legally required to be released as it's all either apache or proprietary licensed, I do the work, structure, package, and publisize it because I believe in FOSS. https://gitlab.com/oddsolutions

    3. Seriously - I can't state enough how annoying threats are when it's a hobby - if you'd just said "hey, is there any kernel source difference in the unofficial? If so can I have it?" - I would have just said "No differences, but enjoy all the other stuff I open sourced too!"

    That said, have fun, I'm off to enjoy my Thanksgiving vacation :)

    EDIT: One additional piece here - the officials were supposed to launch a month ago - our infrastructure people have been struggling to get signing to work - 20.0 will literally launch randomly some day soon when they figure it out - so I made the threads to get feedback from users ahead of time on device-specific bugs so that when the official launched, I just un-strike through the download link and let people enjoy.
    Hey @npjohnson I am so sorry if you took this the wrong way It was never a threat bro 😔 and never will, I appreciate your hard work and all your doing for the community so please don't take this as a threat rather a misunderstanding, All I want to understand is the link to the source is for linked to official kernel source since you know unofficial builds does not pass safety net and never did so in order to do that framework-base and few other pieace of the source code needs to be modified so all I am saying is the source for the unofficial build should be provided as well jot just official.
    Every developer here provides the links to the source code, How is that a threat bro?
    If I do something Like this you can tell me the same thing and I would never take it personally and I will always provide links to all the source code.
    Everyone has the right to inspect the source code tell me If I am wrong?
    You are wrong on that point.

    From a legal perspective, there is no "right" to inspect source code.

    You may want to go read about licenses a little bit. Android - the frameworks and system side, is licensed Apache2 - which just states that you can use it - has no requirement to be published - at all - ever wondered why we don't get source for Samsung OneUI? Because they don't legally have to.

    The linux kernel, and a few other pieces of external modules are GPL licensed, which requires release of accompanying source code, which is linked as per the kernel source in the OP to comply with XDA requirements that GPL modules be linked in the OP.

    Again, regardless of that - I provide the source code anyway.

    I use a tool called ih8sn to pass safety net - if you looked at the link I provided in my last post, you'd see that, and find a link to coral's specific configuration to use with it.

    I even provide nice prebuilt local_manifests that you can snag and sync to build this 1:1 with ease.
    I didnt take anything personally, I could care less who reads my posts or what the user thinks of me, I ONLY CARE who I help. You didnt help, that was my problem, instead, you added in something that confuses a NEWB (new user)! You confused LOS forum with adding in something thats not part of LOS but a GSI (anything can GSI).
    Not quite...not all devices can run GSIs, generally only those that are Project Treble compliant
    GSI isnt an operating system to install as a standalone ROM but as an 'image' to boot/install from, so not the same thing at all!
    A Generic System Image is just that. It doesn't include a kernel or anything else and is designed to be used with a separate kernel. A ROM on the other hand generally means the "whole package" that includes a kernel. A system image cannot be "booted" as you describe; you can only do this with a boot image, which contains the kernel.

    But, this is all outside the scope of this thread.
    PLEASE be careful, as a mod, in your future who/what you reply to, and ONLY add in useful and HELPFUL info!!
    I try my best to ensure the information I share is accurate, but I'm only human. As far as I'm aware, I haven't stated anything that's untrue or incorrect in this discussion, and I can provide a source for everything I say.
    PLEASE reread what I said, you are way off base! BUT in the end, IDC what you or anyone thinks or feels about my posts. I help so many users, that in the end, I dont care anymore. Users who want my help, ask me, others, ignore and have issues.
    All I'm asking you to do is consider the tone of your messages and how they may be received by others. I'm just here to help people, as I'm sure you are as well. Try to avoid questioning someone's credibility, or telling them what they should or shouldn't share, but rather provide your insight as to why or why not something is relevant.

    I don't want to derail this thread any further, so if you wish to continue this discussion, PM me.
    Latest build won't run, "android setup keeps stopping" error


    I followed the instructions on https://wiki.oddsolutions.us/devices/coral/install, and everything went well until I rebooted after the sideload had finished.

    I got a message saying the "Android Setup" app is crashing. From there, there is nothing I can do. I can see a clock, the signal bar and the battery charging icon.

    The recovery: lineage-20.0-20221217-recovery-coral.img
    The build: lineage-20.0-20221218-UNOFFICIAL-coral.zip

    # Update

    I just installed the official LineageOS 19, and everything works fine. My phone was on the Google official ROM.
    pulled the build, fixing it. New one will be live tmrw.