• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OFFICIAL][ROM]Bootlegers ROM Oreo for Galaxy J5 [SM-J500H/F/FN/G/M/Y]

Status
Not open for further replies.
Search This thread

Cautious_C

Member
May 3, 2019
15
3
Warsaw
Trying to install on J530F (J5y17lte)

I am a relative newcomer to Android so apologies if what i say doesn´t make complete sense.

I am trying to install Bootlegger on a Samsung J530F (J5y17lte) using TWRP.
Bootlegger Install fails saying incompatible device.

In the list of compatible devices it prints there is a J5ylte. (I think that should be the J5y16lte and J5y17lte but not sure).
I believe the J530F is the same (or very nearly) as the J500F. LineageOS worked perfectly when I installed it having made that assumption.
Any advice on how to overcome this problem would be very welcome.
 

garylawwd

Forum Moderator
Staff member
I am a relative newcomer to Android so apologies if what i say doesn´t make complete sense.

I am trying to install Bootlegger on a Samsung J530F (J5y17lte) using TWRP.
Bootlegger Install fails saying incompatible device.

In the list of compatible devices it prints there is a J5ylte. (I think that should be the J5y16lte and J5y17lte but not sure).
I believe the J530F is the same (or very nearly) as the J500F. LineageOS worked perfectly when I installed it having made that assumption.
Any advice on how to overcome this problem would be very welcome.
Not a hope will it work.
Its a miracle that you got lineage to work because it shouldn't have.
Different chipset in both so no way will it work.
Like even the different models of 2015, j500f j500fn j500h j500Chinese model all have to flash different firmware or it wont work/boot.
And you have 2017 model which is completely different
 

Cautious_C

Member
May 3, 2019
15
3
Warsaw
Not a hope will it work.
Its a miracle that you got lineage to work because it shouldn't have.
Different chipset in both so no way will it work.
Like even the different models of 2015, j500f j500fn j500h j500Chinese model all have to flash different firmware or it wont work/boot.
And you have 2017 model which is completely different

I was hoping for some advice on how to make it work..something along the lines of:
The chipsets are different and so is....
BUT given that they are Android devices it is possible to build a variant of Bootlegger that should work by doing......
If you are prepared to take that on and help Bootlegger offer support for another variant of the J5 range I could point you in the right direction.
You know something in keeping with an Open-Source world view.

However thanks for your extremely rapid disavowal of any possiblity of success.
 

palmbeach05

Senior Member
Oct 12, 2012
4,345
1,844
Motorola Atrix HD
AT&T Samsung Galaxy S III
I'm new at this I do not understand how to install the twrp?

1. Download odin. Latest should be about 3.13

2. Download twrp. Version 3.2.1 or later is preferred.

3. Go into settings>about device>software info. Tap build number 7 times. Go back to settings and go into developer options. turn oem unlock on. Then power off device.

4. Press and hold home, vol down, and power button. Let menu appear.

5. Press vol up.

6. Connect phone to usb cable and to computer.

7. Open odin.

8. Click on AP, and find the twrp file.

9. Uncheck the options from the middle tab in the bottom left side of screen.

10. Hit start and wait for flash success.

11. Unplug phone and remove back of phone.

12. Remove battery, put battery back in.

13. Press and hold home, vol up, and power button.

14. In twrp, swipe the bar at the bottom of the screen before doing anything.

15. Enjoy!
 

palmbeach05

Senior Member
Oct 12, 2012
4,345
1,844
Motorola Atrix HD
AT&T Samsung Galaxy S III
Why don't you learn to make a point politely? As a senior member you ought to set an example of good behaviour.

I only just joined XDA and your attitude is not encouraging.

I get his frustration. It does tend to get a bit annoying when people ask for or about something that has already been covered or already been provided. Its a good habit to get into, search first before asking.
 

Cautious_C

Member
May 3, 2019
15
3
Warsaw
I get his frustration. It does tend to get a bit annoying when people ask for or about something that has already been covered or already been provided. Its a good habit to get into, search first before asking.
It is excusable to feel frustrated.
It's inexexcusable to take out personal frustration on others.
Many people do not have English as a first language and probably get VERY frustrated trying to find what they want. That does not make them or their actions stupid. They may be inconsiderate but then so was the response.
 
  • Like
Reactions: asliaral

palmbeach05

Senior Member
Oct 12, 2012
4,345
1,844
Motorola Atrix HD
AT&T Samsung Galaxy S III
It is excusable to feel frustrated.
It's inexexcusable to take out personal frustration on others.
Many people do not have English as a first language and probably get VERY frustrated trying to find what they want. That does not make them or their actions stupid. They may be inconsiderate but then so was the response.

I wasn't supporting how he said it, just understanding why he was frustrated. I can understand what you're saying too, and agree with your point about non english speaking/reading users
 

Cautious_C

Member
May 3, 2019
15
3
Warsaw
I wasn't supporting how he said it, just understanding why he was frustrated. I can understand what you're saying too, and agree with your point about non english speaking/reading users
The frustration and lack of emotional control in the response were obvious and required no explanation.
They did need challenging.
As we both agree this kind of response is inappropriate could we stop there?
 
  • Like
Reactions: palmbeach05
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 51
    Bootleggers.png


    Disclaimer
    Code:
    I am not responsible if flashing this ROM bricks your phone or causes thermonuclear war
    and ends the world as we know it.
    You have been warned.

    Rom-Information

    Bootleggers ROM 8.1.0 Official (Shishufied)
    More information about the rom can be found:
    Galaxy-MSM8916 device-tree from unofficial LineageOS 15.1
    no Gapps included

    What works

    same as unofficial LineageOs 15.1

    Bugs

    NFC (J500FN)

    Credits

    Sources
    I moved all my repos to gitlab so all repo-urls have changed, the local_manifests-file on github is updated accordingly.
    Downloads

    Instructions
    MarshMallow bootloader is required or you will not be able to boot the rom !
    Latest stock firmware is recommended before installing this rom, even if it might work with older versions !
    1. Use the TWRP from the download-link for your device above (needs to be flashed from existing TWRP, ODIN version might come)
    2. Download the latest build
    3. Put it on your device
    4. Reboot to TWRP
    5. If you want to be sure wipe the device
    6. Flash the latest build
    7. Clean Cache and Dalvik if you want
    8. Reboot and enjoy

    Others

    OTA is available with recent builds.
    As it's official now, I abandoned my own OTA-app for this Rom.

    Easily rootable with the great Magisk (stable) by @topjohnwu.

    Exchange2 for Oreo is included and will be installed as system-app (I need this for my work).

    I use it as daily driver without major issues.

    I use microG as google replacement and for push-services, signature-spoofing is already build into the rom but need to be granted manually (as root):
    Code:
    pm grant com.google.android.gms android.permission.FAKE_PACKAGE_SIGNATURE


    XDA:DevDB Information
    [OFFICIAL] Bootleggers ROM Oreo for J5 (2015), ROM for the Samsung Galaxy J5

    Contributors
    jenslody
    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: MarshMallow Bootloader
    Based On: AOSP

    Version Information
    Status: Abandoned

    Created 2018-05-14
    Last Updated 2019-06-25
    12
    New update is available via OTA and from OP.
    July security patch is included.
    I also made charging sounds configurable and (what's more) working.
    The option to scramble the layout of the pin on lockscreen is also added.
    11
    Finally I managed to build Bootleggers 3.0, the new shiny rebased version of this great rom.
    It does not use GZOSP anymore, but was rebase to use AOSP with LineageOS stuff.
    So a dirty flash might cause issues (even if I have no problems with it).
    But there is one annoying bug:
    the stock alarmclock from AOSP is broken and crashes if an alarm occurs, so do not rely on it.
    I did it and that's whay I do not (yet) update the OP or the OTA-stuff (I just slept a littler longer than I wanted this morning).
    Third party apps work.

    Nevertheless, you can manually download it from my server from the devices sub-folder with the actual date (20180822-HHMM) and flash it via TWRP.

    The actual (also rebased) device-tree for msm8916 is broken and bootloops, so it's based on the older (saved by Vince) revision.
    If you install the rom and face any issues please give feedback, either here or on telegram (same nickname as here).

    Edit:
    Just for the record: it has the August security patch of course.
    9
    New build of Bootleggers 3.0 is available, now via OTA and the OP.

    Alarmclock is now the google-clock, nightlight and do not disturb is now available via settings, was broken in first 3.0 build.

    No major issues on my device (FN), except low video sound when recording and a stock-camera bug, that leads to square pictures where the lower part of the chosen takes precedence (e.g. 4128x3096 becomes 3096x3096). Thirdparty cameras work fine (I use OpenCamera from F-Droid).