[Official][Stable]OrangeFox Recovery for realme X2 Pro [R11][RMX1931]

Search This thread

m.emdan

Member
Dec 9, 2014
21
0
can i install it in android 10?
can i install magisk 20.4 ?

---------- Post added at 09:05 AM ---------- Previous post was at 09:04 AM ----------

why we use f2fs
 

4j17h

Senior Member
Jun 16, 2014
176
366
Changelog
* Initial Official release

Check OP to download latest OrangeFox build (Check Beta section in Orangefox downloads page)
 

hack-os

Senior Member
Feb 3, 2018
73
31
Samsung Galaxy S5
OnePlus One
ota is not automatic, could install manually but everytime needs to install Vbmeta and magisk along with the update zip else it gives corrupted boot/recovery message. I am not sure if the script present in orangefox for not overwriting recovery with an ota update is even functional.

Could someone give tips if its possible to have the orangefox recovery be peristant over instaling ota without installing vbmeta everytime?
 

silverstream

Senior Member
Sep 24, 2009
759
70
I can't decrypt with my 4 digit PIN. Running LOS 18 with OF TWRP R11 beta. I've to remove my fingerprints and PIN in order to use the recover. Any idea why ?
 

4j17h

Senior Member
Jun 16, 2014
176
366
Changelog
* Sync with latest Orangefox sources
* Disabled AVB Patching
* Added pstore Support

Check OP to download latest OrangeFox build (Check Stable section in Orangefox downloads page)
 
  • Like
Reactions: santoshreddy

zee456

Senior Member
Feb 1, 2019
55
4
Changelog
* Sync with latest Orangefox sources
* Disabled AVB Patching
* Added pstore Support

Check OP to download latest OrangeFox build (Check Stable section in Orangefox downloads page)
still its asking patter or pin in recovery and showing error ..does this have fix
 

4j17h

Senior Member
Jun 16, 2014
176
366
still its asking patter or pin in recovery and showing error ..does this have fix

That's how it works. How do you expect something to decrypt encrypted data without unlocking it. Also if you are using A11 ROMS use Pattern lock only. Currently A11 ROMS data can't be decrypted using pin/password in custom recoveries.
 

clavelm80

Senior Member
Jan 9, 2017
94
21
Annecy
OnePlus 9 Pro
After magisk upgrade I Lost Orange recovery. Now when i try ti boot recovery mode smartphone reboot in normale mode. Any solution?
Thanks
Maybe re-installing it?
Reboot in fastboot (pressing the power button and one of the sound button, up or down, I never remember which one is recovery and which one is fastboot).
Then fastboot flash recovery path_to_recovery
 

fishersfish

Senior Member
Jun 9, 2016
79
15
OrangeFox does not compatible with multi-user, while the latest TWRP does. TWRP can decrypt all user's data when recovery starting up, but OrangeFox can only decrypt User 0's data.
So, after I created more than one users in the system, OrangeFox cannot backup my data partition, but TWRP can.

It's time to update OrangeFox now...
 
  • Like
Reactions: santoshreddy

ZenoDiac

Member
Dec 10, 2019
38
8
Cape Town
So... I can't get OrangeFox to work. Running CN version.

Steps I've taken:
I currently have TWRP installed, from this thread : https://forum.xda-developers.com/t/...ficial-twrp-for-realme-x2-pro-stable.3997879/ which is working.
Then I go to:
WIPE > data/cache/dalvik
FORMAT>yes
I then use "ADB push OrangeFox.zip /sdcard/OrangeFox.zip" to get the file onto TWRP.
Install > OrangeFox.zip
After auto-reboot, it fails to load into recovery. It stays in bootloader.
I've tried fastboot -w afterwards, but no luck.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 14
    OrangeFox Recovery Project
    ofrp.png


    Installation
    * Download Latest OrangeFox
    * Assuming you already have twrp installed, copy the downloaded zip to device. Then Install.
    * After successful installation it auto-reboots to OrangeFox recovery. Enjoy


    Working

    ADB
    Decryption of /data
    Screen brightness settings
    Correct screenshot color
    MTP
    Flashing (opengapps, roms, images and so on)
    Backup/Restore
    OZIP decryption
    Vibration support
    USB OTG


    Bugs

    Report with proper logs.​

    Credits:
    @MrYacha & @DarthJabba9 for this amazing custom Recovery
    And the most 4j17h for pushing me to make it...
    And whole HyperTeam for all the help in the beginning of my android development...


    XDA:DevDB Information
    [Official][Stable]OrangeFox Recovery for realme X2 Pro [R11][RMX1931], ROM for the Realme X2 Pro

    Contributors
    Jerry08, 4j17h
    Source Code: https://gitlab.com/OrangeFox/

    ROM OS Version: Android 10

    Version Information
    Status: Stable

    Created 2020-08-04
    Last Updated 2020-09-03
    4
    OrangeFox will be back soon, mostly likely official.

    While waiting for official you can test new R11 build, links updated.
    3
    So what needs to be done to have a working FP sensor? But it's broken even without root?

    ---------- Post added at 06:03 PM ---------- Previous post was at 05:55 PM ----------


    I know I could simply flash it from twrp and try but, except for OTG working, are there any particular reasons to use this instead of twrp?

    I've read that OrangeFox is based on twrp, but offers a better support to Treble than twrp.
    Having also magisk/app manager, flashlight(if anyone would ever use it in recovery), password change. Just try it and check yourself.
    2
    Sold phone, won't be supporting this anymore.

    Admins please lock this thread.
    2
    It's a issue with vbmeta. You have to flash vbmeta via fastboot with disable flags:


    Hi @Jerry08! I've tried that, many times, but no luck. I get the "fastboot.exe: unknown option -- disable-verity" error.

    I've tried to download all short of adb/fastboot versions, I've installed the latest android studio, minimal adb, etc., but I can't find a way to get a fastboot that works.

    I'm sure that my phone is seen after typing fastboot devices. I'm open my powershell window on the folder that has the files.

    Can you please help? I'm not sure what I'm doing wrong. Thanks! : )

    ---------- Post added at 12:39 PM ---------- Previous post was at 12:14 PM ----------

    [/COLOR @Jerry08, I think I get it to work:

    C:\vbmeta>fastboot devices
    513a895e fastboot

    C:\vbmeta>fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
    Rewriting vbmeta struct at offset: 0
    Sending 'vbmeta' (0 KB) OKAY [ 0.008s]
    Writing 'vbmeta' OKAY [ 0.002s]
    Finished. Total time: 0.031s

    After that, It keeps rebooting to recovery.

    How can I format and install everything from scratch?

    Here's what happened.

    Yesterday, I tried to reboot to TWRP but, for some reason I can think off, I couldn't. I thought to try oragefox. When I was installing oragefox, and since I got the fastboot error, I maybe installed vbmeta and then the recovery - or I installed it without vbmeta, can't be sure now. After that, it kept rebooting to recovery. After a while, since I could'n fix it, I eraser caches, system and data and tried to flash the rom from scratch. No luck, I can't pass the reboot to recovery. I switch back to twrp, oragefox sometime got a full black screen and only the flash worked by vol up and power, and it was difficult o restart the phone.

    Thanks! : )

    What can I do to get my phone back?

    Did you wipe or format data(option where you type "yes")? The best you can do now is to format data(option where you type "yes") and try boot to os. And if it does not help, than follow Updating colorOS via Custom Recovery and as last step format data(option where you type "yes").

    Now for the RUI users.
    There's still a lot issues i face in rui. So BEWARE! Like today I updated Magisk Canary to latest and got bootloop, couldn't boot to recovery and data partition got ****ed up. I had to flash ofox via fastboot and format data to get it back working.