[OFFICIAL] [Ten] Lineage 17.1

Search This thread

kubersharma

Recognized Developer
  • Dec 30, 2015
    1,155
    5,500
    New Delhi , India
    Thank you for the response DD3Boh and for your hard work on development all these years. I'm trying to figure out where to find official ZUI 3.5 or 4.0 and I've become very confused at this point. Does it matter if I install an Indian or a Chinese version? Is QPST the same as QFIL? I get the impression that the ZUI roms I'm finding have been modded and perhaps they aren't what I should be flashing. I don't want to brick my phone during quarantine because it would be difficult to find another one right now so I want ensure I get this right. If you could provide a link to the proper files I should be using I would greatly appreciate it.

    Edit: Also, is there any difference if I use 3.5 or 4.0 ? Is there any reason to prefer one over the other? Perhaps your testing has been done on one of them specifically and is less likely to have bugs?

    ZUI 3.5 CN: https://androidfilehost.com/?fid=6006931924117892400
    ZUI 4.0 CN: https://androidfilehost.com/?fid=6006931924117892419

    No, 4.0 or 3.5 wouldn't make much difference.
     

    DD3Boh

    Recognized Developer
    Feb 16, 2017
    305
    1,335
    Voghera
    lol I've been there, I updated my previous post, hope those links help.

    OTA didn't work for me.
    Try the Xiaomi Flash Tool!
    For build links just follow the message above from kuber, and just flash 4.0 while at it since I see no reasons to flash an older version.
    I never used mi flash ever on z2 since qpst/qfil (which can be more or less considered the same thing and are part of a single package) work just fine.
    Though it happened for me to use linaro's qdl release to flash directly from Linux instead of having to switch to windows (yeah that works)
    Just search some guides on zuk forums to flash correctly with qfil, changing the ROM package all the guides will be fine.
     

    louster35

    Member
    Aug 28, 2012
    15
    1
    Last edited:

    kubersharma

    Recognized Developer
  • Dec 30, 2015
    1,155
    5,500
    New Delhi , India
    1) Are you aware of whether I have to upgrade in steps starting from 1.9 in order to reach 4.0 or can I go straight to 4.0 ?
    2) Do you recommend QFIL as the flashing method or is MIFLASH fine too?

    Thank you

    ZUI 1.9 to 3.5 or 4.0 is fine. (Also, boot ZUI once before moving to custom)
    I recommend QPST/QFIL ONLY
     

    Ykiam

    Senior Member
    Mar 27, 2013
    61
    20

    Ykiam

    Senior Member
    Mar 27, 2013
    61
    20
    Yes, I noticed this too. It's the notification that seems to be stuck, I turned off the notification because the picture is already processed and saved, at least that is my understanding, I'm not an expert, I could be wrong.

    It didn't help, the photo doesn't go to the gallery, and the video recording isn't working either. In short, no gCam yet
     
    • Like
    Reactions: linuxnoobbbb

    louster35

    Member
    Aug 28, 2012
    15
    1
    For build links just follow the message above from kuber, and just flash 4.0 while at it since I see no reasons to flash an older version.
    I never used mi flash ever on z2 since qpst/qfil (which can be more or less considered the same thing and are part of a single package) work just fine.
    Though it happened for me to use linaro's qdl release to flash directly from Linux instead of having to switch to windows (yeah that works)
    Just search some guides on zuk forums to flash correctly with qfil, changing the ROM package all the guides will be fine.

    Okay so I used QFIL to install ZUI 4.0 , it locked my bootloader again so I had to unlock it and flashed the latest version of twrp.

    My question is the following:
    When I go to format and wipe through twrp, I get a red text that reads: "failed to mount '/vendor' (invalid argument)"
    is that normal? I had never flashed factory2vendor so this seems strange to me.

    Edit: I tried adb sideloading Lineage OS 17.1 regardless of the above and I still get the "No OS installed! Are you sure you wish to reboot?" message

    Edit 2: System Booted. It's Aliiiiive! Awesome
     
    Last edited:
    • Like
    Reactions: redchilis

    Dark0ne_

    Senior Member
    May 1, 2018
    107
    12
    Who has problem with the mic? For example recording videos or whatsapp voice. All goes silent after restart all goes back to normal.

    Sent from my Z2 Plus using Tapatalk
     

    siluok

    Member
    Dec 20, 2019
    20
    2
    GCAM + HDR + Gallery = Working

    It didn't help, the photo doesn't go to the gallery, and the video recording isn't working either. In short, no gCam yet

    This worked for me!

    In Version: MGC_7.2.014_Parrot043-v3.apk

    1. Go to Settings
    2. Go to Photo
    3. Go to Advanced
    4. Scroll down to "Save to /DCMI/Camera"
    5. Switch it on!
    6. :)
     

    Dark0ne_

    Senior Member
    May 1, 2018
    107
    12
    Can anyone give solution to the mic problem? What'sapp and video have no sound. I have to reboot all the time .

    Sent from my Z2 Plus using Tapatalk
     

    siluok

    Member
    Dec 20, 2019
    20
    2
    GCAM + HDR + Gallery = Working (incl. zukz2.xml)

    I don't have a solution I do have a temporary workaround. If you meant Whatsapp Video Calls, the other person used to complain they couldn't hear me properly. The next time around, I used a pair of headphones with mic to receive the call and after receiving it that way and chatting for a bit, when I pulled out the headphones and continued with the speaker and phone mic, it was fine.

    This is a workaround not a solution.

    Edit: I did a clean installation of LOS 17.1 while migrating from LOS 16

    ---------- Post added at 03:05 AM ---------- Previous post was at 02:33 AM ----------



    Thanks, based on your post and the one here I tried both "PMGC_7.0.009_FinalBuild_V14 by parrot" and "MGC_7.2.014_Parrot043-v3" from here https://www.celsoazevedo.com/files/android/google-camera/dev-parrot043/
    I followed the instructions to add the xml config file for "MGC_7.2.014_Parrot043-v3" but couldn't.
    The UI is not bad, pretty cool. However, the portrait mode gave a green tint and didn't work as well.

    #stayhome
    #staysafe

    To add "zukz2.xml":
    1. go to Settings, Photo, Advanced and "Save XML Config"
    2. save the actual settings under some name chosen by you
    3. open a file manager
    4. find a new directory in your phone called "GoogleCamera/ConfigsCamera7.2" in the main directory.
    (This has been created by the Application while you save your actual configuration, its not "GCAM"!)
    5. copy the zukz2.xml file to the directory
    6. i used a zukz2.xml file from www.celsoazevedo.com/files/android/google-camera/f/configs-parrot-02/
    7. tap on the main screen and find “zukz2.xml”.
    8. “activate” zukz2.xml by selecting "Restore" zukz2.xml
    9. works :) (including Portrait)

    Remark: this is no generic long term solution for the ROM development, since this only covers one GCAM installation. But it gives strong hints why GCams are not working right now.
     
    Last edited:

    Dark0ne_

    Senior Member
    May 1, 2018
    107
    12
    I don't have a solution I do have a temporary workaround. If you meant Whatsapp Video Calls, the other person used to complain they couldn't hear me properly. The next time around, I used a pair of headphones with mic to receive the call and after receiving it that way and chatting for a bit, when I pulled out the headphones and continued with the speaker and phone mic, it was fine.



    This is a workaround not a solution.



    Edit: I did a clean installation of LOS 17.1 while migrating from LOS 16



    ---------- Post added at 03:05 AM ---------- Previous post was at 02:33 AM ----------







    Thanks, based on your post and the one here I tried both "PMGC_7.0.009_FinalBuild_V14 by parrot" and "MGC_7.2.014_Parrot043-v3" from here https://www.celsoazevedo.com/files/android/google-camera/dev-parrot043/

    I followed the instructions to add the xml config file for "MGC_7.2.014_Parrot043-v3" but couldn't.

    The UI is not bad, pretty cool. However, the portrait mode gave a green tint and didn't work as well.



    #stayhome

    #staysafe
    I will try this. Thanks

    Sent from my Z2 Plus using Tapatalk
     

    siluok

    Member
    Dec 20, 2019
    20
    2
    Experience migrating form LineageOS 16

    Did the following:
    1. Downloaded lineage-17.1-20200403-recovery-z2_plus.img from https://download.lineageos.org/z2_plus
    2. Downloaded Open Gapps (ARM 64, Android 10, nano) from https://opengapps.org/
    3. Going into Recovery
    4. Going into TWRP
    5. Wiped Cache and Dalvik
    6. Install lineage-17.1-20200403-recovery-z2_plus.img
    7. Install Open Gapps (ARM 64, Android 10, nano)
    8. Reboot
    9. Works :)
    10. Install Magisk Manager from https://******************/ to root device
    11. Works :)

    Good and stable. Had to do minor things to get back to the old situation like “Rights” for applications and reinstall Lawnchair. No data was lost.

    No official addonsu-17.0-arm64-signed.zip. Found unofficial that didn’t work. I had to switch to Magisk. Magisk was found by several Apps. No hiding worked. So I always have to uninstall root via Magisk Manager and have to install it again when done. Bring back addonsu, please. This is not a ZUK Z2 issue only but generic for all devices.

    EX File Manager does not allow to install apk's and open pdf's. This seems to be a generic Android 10 problem?
    Update: I tried a lot of EX versions. Only the newest version worked. Since i don't like this version i switched to MIXPLORER. This seems to be a goog choice but i still miss unsing EX.

    GCam does not work. I found workaround that is no long term solution (see other thread). Maybe it has to do with the new right management in Android 10?

    Many thanks! Especially to DD3Boh!
     
    Last edited:

    siluok

    Member
    Dec 20, 2019
    20
    2
    Unfortunately, this didn't work for me!
    - The "tapping" instructions from here https://www.celsoazevedo.com/files/android/google-camera/f/settings09/ and the ones you gave to do it on the "main screen" didn't work
    - The folder "GoogleCamera/Configs/Camera7.2" did not get created even though I saved some settings just so tha it got generated, took some snaps as well.
    - I manually generated the folder but the tapping instructions didn't work
    - I did notice that a "camera_events" folder gets generated

    Cheers!

    You have to hit "Save XMLconfig" under "Advanced" in "Photo" in "Settings". Save your settings to generate the folder...
    I changed the "manual". Hope it works for you.

    Cheers
     
    Last edited:
    • Like
    Reactions: redchilis

    linuxnoobbbb

    Member
    Feb 25, 2012
    40
    12
    The wireless screen mirroring doesn't work for me. My laptop (Windows 10) was visible in the list, and the confirmation window also popped up on the laptop - however, it just couldn't complete the handshake.

    By the way, the Miracast protocol doesn't really require the phone to be connected to the same WiFi AP with the target device, does it? The screen mirroring icon is just greyed out if no AP is currently connected, which should be an unnecessary limitation.

    Anyway, thanks for porting the miracast support to LOS.
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 32
      2okPze5.png

      Code:
      /*
       * Your warranty is now void.
       *
       * I am not responsible for bricked devices, dead SD cards,
       * thermonuclear war, or you getting fired because the alarm app failed. Please
       * do some research if you have any concerns about features included in this ROM
       * before flashing it! YOU are choosing to make these modifications, and if
       * you point the finger at me for messing up your device, I will laugh at you.
       */

      LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

      LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

      All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.

      Bugs :
      • You tell me

      Instructions :
      • Download the latest build
      • Reboot to recovery
      • Flash the latest build
      • Reboot

      Downloads :

      Notes :
      • Only Clean Installation Please
      • Bug Report Without logs means nothing

      Reporting Bugs :
      • DO NOT Report bugs if you installed Xposed or weird magisk modules
      • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
      • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)

      Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

      Sources :

      XDA:DevDB Information
      LineageOS 17.1 for z2_plus, ROM for the Lenovo ZUK Z2 (Plus)

      Contributors
      DD3Boh, Kubersharma, dmd79
      Source Code: https://github.com/LineageOS

      ROM OS Version: Android 10
      ROM Kernel: Linux 4.x
      ROM Firmware Required: ZUI 3.5 bootloader
      Based On: AOSP

      Version Information
      Status: Stable

      Created 2020-01-14
      Last Updated 2020-04-02
      25
      Reserved

      Unofficial builds deleted on April 2nd 2020
      7
      Hey guys, despite me being inactive (as usual) with unofficial builds releases, lineage-17.1 official builds are finally here :D

      If you want to dirty flash from 17.1 unofficial builds, that can be done migrating keys with a guide located here

      Dirty flash from lineage-16.0 is supported but of course needs gapps to be reflashed.

      All useful links are in the first post as usual, enjoy and stay safe!
      3
      Huge thanks to the developer, very exciting to have Android 10 up and running on my device, with encryption in place! :)

      PS: I couldn't get the beta version of Open GApps to flash in TWRP - It complained about a missing file in the ROM - I didn't make a note of what it said but I tried BitGApps instead and that worked fine: https://bitgapps.cf/arm64/Q/

      The 20200115 gapps beta build was the problem. The next beta gapps should have it fixed.