[OFFICIAL/UNOFFICIAL] LineageOS 19.1 for Amlogic G12*/SM1 Family Devices

Search This thread


Aug 10, 2022
I just bought a new box..I decided to keep the bricked box as the experiment box..so we can continue the unbricking process and document it here with all due credits..


Aug 10, 2022
So far with the new box on stock I have been able to install Brave browser, but I dont get the onscreen keyboard..Kodi is kind of half working, if I add a private repo, some movies work but not all..Ethereum torrent client gives me a no permission error..I think the stock firmware after the update blocks or blacklists some UDP / TCP ports..


Senior Member
I don’t know what I’m doing wrong, but on the original firmware the set of otg cable plus usb hub plus ssd works fine, but on this firmware the ssd sees but does not open.
my flash drive worked but worked excruciatingly slowly as internal storage.
i do not recommend it because it is limited at usb 2.0 (because the usb connector on the box is usb micro, which is 2.0 only!). if your using it as external i dont see the point in using an ssd, and the speed might be causing compatibility issues.
also dont get mad at it because i did and now the flash drive turns into a usb-assisted heater...
  • Like
Reactions: BTK19


Senior Member
Apr 27, 2008
my flash drive worked but worked excruciatingly slowly as internal storage.
i do not recommend it because it is limited at usb 2.0 (because the usb connector on the box is usb micro, which is 2.0 only!). if your using it as external i dont see the point in using an ssd, and the speed might be causing compatibility issues.
also dont get mad at it because i did and now the flash drive turns into a usb-assisted heater...
The problem is not speed, but the fact that everything works on the original rom, but not on this rom.

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    wade and deadpool are official now!
    Hi all,
    quick question regarding the "Walmart Dynalink 4K Box". Can I use the same procedure/ image for the non Walmart Dynalink 4k box --> https://dynalink.life/products/dynalink-android-tv?

    i would like to install LOS on the dynlink 4k from Amazon (walmart does not exist here), same question at #1231.

    you write in #1233 that it is not possible - where are the differences there? from phones I know no problems in different regions and that only in the mobile area!

    Yes. You totally can.

    Sorry, I thought this was asking about the dynalink stick - that box is the same.
    Also, I solved the signing issue with Luca's help.

    Builds should hopefully roll for wade/Deadpool with no GMS tomorrow.

    I'll then look into tablet builds feasibility.
    However I run into a boot loop. I see the LinageOS Logo and sometimes the remote control but after that the box restarts. I installed several times with the same result.
    Do you have an idea what I could do?
    You could list, with precision, the steps that you repeatedly did and maybe someone will notice where you went wrong. Most problems lately seem to involve failure to flash the appropriate dtb/dtbo at the appropriate time(s).

    With the v18 builds, it was fortunate that dtb/dtbo were also compatible with stock and vice versa. For whatever reason (I don't know) there is not this same sort of dtb/dtbo compatibility between stock and v19 builds.
    For this you need to join the number of those people here who are waiting for the tablet builds arrival on the official release day. Take your ticket and have a seat beside me.
    Or just don't use google apps, you can build without them easily.

    ATV works fine enough without gapps.

    Tablet builds will follow.

    The official builds are queued but they fail to sign for some reason - working that out rn.
  • 26

    Amlogic G12*/SM1 Family Devices
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    This is the Official Lineage OS 19.1 thread for the Amlogic G12*/SM1 SoC family of devices.

    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed:

    Official Builds:
    Disclaimer: My unofficial builds have full Android TV Google Apps and some other goodies included. OTA's roll roughly once a month. Support not guaranteed or implied.

    Unofficial Builds:
    We also support a few development boards, but at least (for now, until we have time to write up instructions), you're on your own to figure out the install process and set things up:
    EDIT: The development boards don't boot on LineageOS 19.1 at the moment for some reason, we're looking into it.

    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • Recent apps/Multitasking menu doesn't launch.
    • (sabrina only) The remote firmware sometimes gets hung up, you can reboot to solve this issue.
    • (dopinder/sabrina) L1 is currently broken, this is what is holding up official builds for these devices.
    • GApps are baked in - No, I will not be building without GApps included for this device. These builds are built, packaged, and signed by me, and not affiliated with LineageOS whatsoever.
    • Firmware is shipped in the ROM package for this device, so you'll end up on the newest version of compatible firmware after install. Please don't touch firmware partitions after install.
    • On the unofficial OTA is provided the same way officials would have them.
    • Find any more on an official build? Report them according to this guide.
    • Does L1 Widevine DRM break when I unlock my bootloader?

      Nope, it works fine. L1 certificates, and the mechanism that reports is all still exist and work as expected.

    • Can I haz Netflix?

      Yup! Play Store has it for you.

    • Is this Android TV or Google TV?

      Android TV, with some of the better components of Google TV.

    • Can I go back to stock and relock the bootloader?

      Yeah, grab the factory image for your device and flash it just like you would for a Pixel device, you can find the factory images here. Don't know it I'd relock though, consider that process largely untested on these device. Especially on sabrina, where you can't necessarily re-unlock should you ever want to.

    • Are these the stock codenames for these devices?

      Astute observation, no, they are not. The ADT-3 is actaully `adt3`, but earlier in production is was `deadpool`, which is much cooler. The Dynalink box internally is extremely similar to the ADT-3, so we coined it `wade` after Wade Wilson, AKA deadpool. The Onn box is in the same family, but different enough to coin it `dopinder`, after, well, go watch Deadpool the movie I guess. sabrina is actually the codename given by Google - no clue as to the reason.

    • Does it pass SafetyNet?

      Maybe - the only sure fire way it Magisk, as our boot loader is unlocked and can't be relocked safely.

    • Does the stock remote work?

      Yup, just like it would on stock, in-remote-microphone and all! If it's an IR remote like wade's, it will even work in recovery!

    • Can we we support higher resolution than 4K, higher FPS, or HDR on non-certified screens?


    • I have a very similar device! Can I install these builds and use them?

      No. Please don't do that. You will brick your device, as we include firmware and bootloader images.

      If you're a developer looking to help port to a new device, contact me.

    Kernel Source: https://github.com/LineageOS/android_kernel_amlogic_linux-4.9

    • npjohnson
    • bgcngm
    • stricted
    • webgeek1234
    • deadman96385
    • trautamaki
    • luca020400
    • aleasto
    Yeah, you used the stock recovery. You need to fastboot flash, then fastboot boot recovery, I'll update the docs.

    For dopinder, it's needed right now.

    Found a procedure for dopinder without the need for keyboard/OTG.

    The docs under "Installing a custom recovery using fastboot" state to use "adb reboot fastboot" which doesn't work for booting recovery, needed to do "adb reboot bootloader" instead.

    Full command log (after unlocking bootloader and re-enabling USB debugging) of the install process with just a regular Micro USB to USB A cable:
    adb reboot bootloader
    fastboot flash recovery lineage-18.1-20210805-recovery-dopinder.img
    fastboot boot lineage-18.1-20210805-recovery-dopinder.img
    adb reboot sideload
    adb sideload lineage-18.1-20210805-UNOFFICIAL-dopinder.zip
    # if successful then load bootloader and factory reset
    adb reboot bootloader
    fastboot -w
    fastboot reboot

    Successfully booted to LineageOS after this!
    wade and deadpool are official now!

    Since the Lineage Android TV Builds for this little box (aka Boxes), are stable for the most part, but seems
    people are bouncing back in forth from Stock to Lineage and back to stock.

    I created a batch file that will auto flash the stock images and wipe data and so on.. pretty much it will
    make your box as it was when you first booted it after taking it home to try it.

    2nd, I also created a batch file that will backup current images.. No need for a fancy recovery or anything like the
    such. it will use the worldcup or what I like to say, USB Burn mode, and backup each and every partition.
    as well as some not so much needed ones like, misc and metadata. (Just for giggles)..

    backups will be copied to backup dir, I also created a separate batch file to restore your backup.

    I am one that hates doing things the long way over and over, so I always create ways to make things simple
    in the future for people.

    This way, you all can test your hearts out all the new lineages and still have your full Stock backup (including data).
    and restore back in forth as you wish.

    I will upload the backup_restore zip package as soon as I can and with @npjohnson permission I will link
    in thread. Otherwise you will have to just DM/PM me and ill link you the location.

    I am just trying to help the many that I seen complain and dont understand how to go back in forth.
    so with this script, it should take care of most on that. No Fancy Recovery needed...

    you will need worldcup driver for Amlogic........ you can find that on your own.

    Also, to get into USB Burn mode, press side button while plugging in USB cable.
    Keep pressing till you see the LOGO or hear the sound from your computer.

    then just run the batch file and wait..

    if its easier for you:

    Run the batch file, it will keep saying waiting for device..
    Just press the side button while plugging in USB, when you see it start, then release button...........
    and wait till finished..

    Only TESTED On Dopinder Boxes, but im sure they are all the same as for the partition layouts.
    I ultimately settled on 1126400000, gives ~1.1GB to the system and accommodates the app adjustments I've been making for my builds without tripping OpenGApps' space check for TV stock
    this ended up being _wayyyyy_ to much, as this is the full value of the partition vs just the space to reserve, both will work, but we want to split it amongst partitions. One of our guys recalculated it and got it working.

    Should be good to build now from breakfast/extract-files (or syncing the muppets).

    Only thing left is hardware OMX. Hopefully we can figure it out!