[OFFICIAL/UNOFFICIAL] LineageOS 19.1 for Amlogic G12*/SM1 Family Devices

Not open for further replies.
Search This thread


Senior Member
Aug 22, 2008
I just came back from a full brick (Black Screen - No Boot Logo on power up) on the Walmart Onn 4k (dopinder)..... so if you do mess anything up, you are able to bring factory back to the device without opening it. I will create a tool so it will automate the process within the next couple of days. I should be able to make it work with the other devices, but I don't have them to test with.

TOOL IS CREATED waiting on it to upload its big because it has all 4 devices factory images so it will unbrick all 4 devices. Link up soon
Last edited:
  • Like
Reactions: activadroid

Deleted member 11959327

I don't know if it was a Khadas developer or some other Amlogic developer, but they said that if your device was having issues and needed to wipe/erase the EMMC, you could use the Windows tool (if your device will still connect that is) and start installing a firmware, and once it gets to 20-25% when the SYSTEM.IMG is installing you disconnect the cord and the EMMC will be erased. Never tried it personally, haven't need too, but worth a shot if you have a problematic device.

Unlike the khadas devices, certified devices have been factory provisioned with high level drm keys that are unique to each individual device. Erasing the emmc in its entirety would blow away individualized data (based on those keys) contained in the tee and factory partitions and other hidden areas of the emmc. Even just erasing the bootloader can brick a device.

Erasing the data partition is often useful in restoring operation to a certified device, but erasing the entire emmc would not be useful.

Generally it is also a bad idea to use the windows gui usb burning tool on any certified device unless a single file amlogic image designed specifically for that device is used. Generally, when using burn mode with certified devices, only individual partitions should be flashed using the command line burn mode tool 'update'.

Deleted member 11959327

Install this driver: https://drive.google.com/file/d/1q3Hwrmx-YCrw9U5JGtI2Ocn06zPkjrEG/view?usp=sharing

Download the amlogic `update` tool http://openlinux2.amlogic.com/download/A113/Tool/flash-tool-v4.7/flash-tool/tools/windows/ and run `update.exe bulkcmd fastboot` - then you can flash the factory image as usual.

Sorry about this, AML DTB's are... weird compared to other devices.

does anyone have the flash-tool ??

link is broken

The files that were contained in the broken openlinux2 link are attached to this post in the file amlogic.zip. It just contains the windows version of the command line update utility and the associated dlls.

But the openlinux2 link was posted quite awhile ago. Newer versions are available from khadas and elsewhere.


Senior Member
Aug 22, 2008
I have uploaded my unbricking tool to my google drive.... Link is in my signature. It's made to be ran on Windows so you will need to install the ADB drivers for your device. If you have used Windows with your device in the past, then you already have the drivers. This should work with all 4 devices to bring them back to factory. Even if you have 18.1 or 19.1 it should take the device back to factory. Its big (7 parts) due to all the factory images.
  • Like
Reactions: c1724 and ascii79


Jun 8, 2019
Hey is it within the scope for Lineage to bake in cifs filesystem support? Would be great to have on a media center device.

Very happy with wade!


Recognized Developer
Hey is it within the scope for Lineage to bake in cifs filesystem support? Would be great to have on a media center device.

Very happy with wade!
Sure, I'll look into it
Does anyone know what has happened to wade official support?
Technical issue, but DTB.img isn't making it to the signing server so wifi is broken. I can't yet figure out how to get it transfered correctly basically. Hopefully I figure it out soon as it is just an infrastructure issue. Unofficial work fine.
If you're looking for the builds, they're still up.
Yeah they're broken though :/


Jun 10, 2022
Sure, I'll look into it

Technical issue, but DTB.img isn't making it to the signing server so wifi is broken. I can't yet figure out how to get it transfered correctly basically. Hopefully I figure it out soon as it is just an infrastructure issue. Unofficial work fine.

Yeah they're broken though :/
So official builds are "unmaintained" just temporarily until the wifi issue is fixed? Great news, thank you for your great work.


Senior Member
Feb 25, 2020
Google Pixel
Google Pixel XL
Sorry l was just whining. I am really bored with the same advices and useless adb commands etc. Can you offer stg, new?

it's walmart's onn. 4k box by the way.
Could you post how far you got in the installation process and what response you saw on your screen ?
Using Linux or Windows to try the install ?

I have followed the standard instructions for LineageOS on Google Pixel, Pixel XL (3 different ones), Walmart Onn4K TV and Dynalink devices, and in all cases the Bootloader Unlock process was NOT the problem. (had other issue later in the sequence of steps, that I am not sure if I am the only one who had the problem).


Senior Member
Feb 25, 2020
Google Pixel
Google Pixel XL
HELP: 'Free up storage' problem during install.
Running Dopinder with 2GB adopted USB flash stick.
I tried to install Termux from Play store, and it kept jumping to 'Free up storage' page, but it shows 651MB of 4.4GB used, & (now) NO app installed yet. [ I previously transferred (1 at a time) all (4) previously downloaded functional apps to the adopted stick - STILL have the problem ] [ edit: same problem in Play Store app trying to apply updates to 7 apps already on the device.]

Only option allowed is 'cancel'.

What am I doing wrong ?

[BTW: what I really want at the moment is to install Armbian onto Dynalink or Onn 4K box, because I am trying to see how close I can get to usable Linux PC for $20 or $40. I installed Google Chrome via APKM installer on Dopinder & works OK, except I can't get it to print (installed HP print services, but that did not solve it). I have Armbian on old Tronsmart S905 2GB/8GB box - on SD card - and I thought that might run Chrome & work with printer. Problem with that system is no DRM / Widevine, which is why I recently bought the Onn & Dynalink boxes. Other problem is developer (Balbes ?) for Armbian on Tronsmart ended support 2 years ago. I would consider a Radxa Zero, but I am not sure if Widevine runs on that yet, and already own RasPi 4b 4GB (audible fan), where Widevine runs fine. Would have bought more RasPi's, but not available ! ]

Any suggestions ?
Last edited:


Oct 13, 2022
Hello everone, you are my last chance 😇

I am currently trying to unlock my Wade device, yet do struggle already getting an ADB (and FASTBOOT) connection to the device.
- Normally, there should be an RSA approval window popping up (see a sample as picture attached) when putting the device in Developer settings into MTP/ PTP mode. Yet, this does NOT happen. USB debugging is naturally activated. Resetting previously granted authorizations does not change anything. Different USB cables and ports do not change the behavior.
- At the same time, I do NOT see any device in the Windows 7/10 Device Manager (not even hidden or with an exclamation mark!).
- If I put the Wade device into recovery mode (long pressing the side button during startup), I also do NOT get any ADB or Fastboot connection.

As a result, I need some community help:
- Are there any particular Wade specific USB drivers (note: Tried universal drivers, drivers from Google, etc.)?
- And how can I (manually) force the RSA authorization popup to occur granting access?

Thanks ahead!


  • B744A3C2-F5BB-48F6-9673-E41D1943D3FC.png
    332.8 KB · Views: 9
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    So anyone have this working on a radxa zero ?
    I just bought a dynalink (wade) device and trying to flash the LOS unofficial 20 on it. I followed the instructions as I have done also on 2 dopinder (ONN) devices. I can get into the LineageOS recovery fine but after following I cannot navigate using the button. I can only press and hold the button down which highlights "Reboot system now" by turning the selection green but nothing happens. Suprisingly I can use the remote control to navigate up and down on the LOS recovery, but when I hold down the circle (o) button, it does the same - just highlights the command green and thats it. So I cannot do `adb sideload` because in recovery I cannot select "Apply Update". I can only highlight it. I then tried to do the same with LOS19 recovery, but its doing the same thing. Am I missing sometime? The button appears to be working fine as it allows me to get into fastboot mode and reboot fine.
    use the power button to select stuff in recovery
  • 27

    Amlogic G12*/SM1 Family Devices
    - Your warranty is now void.
    - You have been warned.
    - Use at your own risk.

    This is the Official Lineage OS 19.1 thread for the Amlogic G12*/SM1 SoC family of devices.

    Please follow the install instructions in your device's Wiki page linked below exactly, and make sure your device's firmware matches the required firmware listed:

    Official Builds:

    Disclaimer: My unofficial builds have full Android TV Google Apps and some other goodies included. OTA's roll roughly once a month. Support not guaranteed or implied.

    Unofficial Builds:
    We also support a few development boards, but at least (for now, until we have time to write up instructions), you're on your own to figure out the install process and set things up:
    EDIT: The development boards don't boot on LineageOS 19.1 at the moment for some reason, we're looking into it.

    If you don't follow these instructions, or use 3rd party add-ons (like Magisk) please don't expect support here.

    Known Bugs:
    • Recent apps/Multitasking menu doesn't launch.
    • (sabrina only) The remote firmware sometimes gets hung up, you can reboot to solve this issue.
    • (dopinder/sabrina) L1 is currently broken, this is what is holding up official builds for these devices.
    • GApps are baked in on Unofficial builds - No, I will not be building without GApps included for this device. These builds are built, packaged, and signed by me, and not affiliated with LineageOS whatsoever.
    • Firmware is shipped in the ROM package for this device, so you'll end up on the newest version of compatible firmware after install. Please don't touch firmware partitions after install.
    • On the unofficial OTA is provided the same way officials would have them.
    • Find any more on an official build? Report them according to this guide.
    • Does L1 Widevine DRM break when I unlock my bootloader?

      Nope, it works fine. L1 certificates, and the mechanism that reports is all still exist and work as expected.

    • Can I haz Netflix?

      Yup! Play Store has it for you. Unless you're on dopinder or sabrina, but that will be fixed soon hopefully.

    • Is this Android TV or Google TV?

      Android TV, with some of the better components of Google TV.

    • Can I go back to stock and relock the bootloader?

      Yeah, grab the factory image for your device and flash it just like you would for a Pixel device, you can find the factory images here. Don't know it I'd relock though, consider that process largely untested on these device. Especially on sabrina, where you can't necessarily re-unlock should you ever want to.

    • Are these the stock codenames for these devices?

      Astute observation, no, they are not. The ADT-3 is actaully `adt3`, but earlier in production is was `deadpool`, which is much cooler. The Dynalink box internally is extremely similar to the ADT-3, so we coined it `wade` after Wade Wilson, AKA deadpool. The Onn box is in the same family, but different enough to coin it `dopinder`, after, well, go watch Deadpool the movie I guess. sabrina is actually the codename given by Google - no clue as to the reason.

    • Does it pass SafetyNet?

      Maybe - the only sure fire way it Magisk, as our boot loader is unlocked and can't be relocked safely.

    • Does the stock remote work?

      Yup, just like it would on stock, in-remote-microphone and all! If it's an IR remote like wade's, it will even work in recovery!

    • Can we we support higher resolution than 4K, higher FPS, or HDR on non-certified screens?


    • I have a very similar device! Can I install these builds and use them?

      No. Please don't do that. You will brick your device, as we include firmware and bootloader images.

      If you're a developer looking to help port to a new device, contact me.

    Kernel Source: https://github.com/LineageOS/android_kernel_amlogic_linux-4.9

    • npjohnson
    • bgcngm
    • stricted
    • webgeek1234
    • deadman96385
    • trautamaki
    • luca020400
    • aleasto
    Yeah, you used the stock recovery. You need to fastboot flash, then fastboot boot recovery, I'll update the docs.

    For dopinder, it's needed right now.

    Found a procedure for dopinder without the need for keyboard/OTG.

    The docs under "Installing a custom recovery using fastboot" state to use "adb reboot fastboot" which doesn't work for booting recovery, needed to do "adb reboot bootloader" instead.

    Full command log (after unlocking bootloader and re-enabling USB debugging) of the install process with just a regular Micro USB to USB A cable:
    adb reboot bootloader
    fastboot flash recovery lineage-18.1-20210805-recovery-dopinder.img
    fastboot boot lineage-18.1-20210805-recovery-dopinder.img
    adb reboot sideload
    adb sideload lineage-18.1-20210805-UNOFFICIAL-dopinder.zip
    # if successful then load bootloader and factory reset
    adb reboot bootloader
    fastboot -w
    fastboot reboot

    Successfully booted to LineageOS after this!
    deadpool an wade are official again, hopefully we got it all right this time around.

    onto dopinder and Sabrina. Hoping to get those shipped soon.

    Since the Lineage Android TV Builds for this little box (aka Boxes), are stable for the most part, but seems
    people are bouncing back in forth from Stock to Lineage and back to stock.

    I created a batch file that will auto flash the stock images and wipe data and so on.. pretty much it will
    make your box as it was when you first booted it after taking it home to try it.

    2nd, I also created a batch file that will backup current images.. No need for a fancy recovery or anything like the
    such. it will use the worldcup or what I like to say, USB Burn mode, and backup each and every partition.
    as well as some not so much needed ones like, misc and metadata. (Just for giggles)..

    backups will be copied to backup dir, I also created a separate batch file to restore your backup.

    I am one that hates doing things the long way over and over, so I always create ways to make things simple
    in the future for people.

    This way, you all can test your hearts out all the new lineages and still have your full Stock backup (including data).
    and restore back in forth as you wish.

    I will upload the backup_restore zip package as soon as I can and with @npjohnson permission I will link
    in thread. Otherwise you will have to just DM/PM me and ill link you the location.

    I am just trying to help the many that I seen complain and dont understand how to go back in forth.
    so with this script, it should take care of most on that. No Fancy Recovery needed...

    you will need worldcup driver for Amlogic........ you can find that on your own.

    Also, to get into USB Burn mode, press side button while plugging in USB cable.
    Keep pressing till you see the LOGO or hear the sound from your computer.

    then just run the batch file and wait..

    if its easier for you:

    Run the batch file, it will keep saying waiting for device..
    Just press the side button while plugging in USB, when you see it start, then release button...........
    and wait till finished..

    Only TESTED On Dopinder Boxes, but im sure they are all the same as for the partition layouts.
    wade and deadpool are official now!