[OFFICIAL][WEEKLY][7.1.2] LineageOS 14.1 for i9300

Search This thread

ejevr

Member
Apr 9, 2021
5
0
I would have a few questions,

- why must TWRP be used, why not Philiz touch?
- gappas - is gapps just a google service, is anything other than the goolge service lost if it is not installed?

@Sly Fox007
- why can't your rum be used for everyday use?

I apologize in bad English
 

kurtn

Senior Member
Jan 28, 2017
3,942
1,703
Small town in Bavaria
I would have a few questions,

- why must TWRP be used, why not Philiz touch?
- gappas - is gapps just a google service, is anything other than the goolge service lost if it is not installed?

@Sly Fox007
- why can't your rum be used for everyday use?

I apologize in bad English
Only job oft recovery is to wipe and flash. If yours does, that's OK
GApps provides services for other apps. Many people run lineageOS without GApps. It's a completely different phone then.
 

ejevr

Member
Apr 9, 2021
5
0
Thanks for your reply,
on my phone Philiz touch 6 and everything works properly.
Is it because some people don't install gapps, that it slows down the phone or is it some other reason, I would ask if you can clarify a bit?
 
Last edited:
  • Like
Reactions: ejevr

ejevr

Member
Apr 9, 2021
5
0
@Sly Fox007

Thanks for the answer, I solved the problem with the volume on the headphones. As for charging the battery, what values should I set?
Screenshot_20210504-203646.png


I have one question for everyone, do you use all the apps that come by default or do you change some apps with an app that work better?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    !! THIS IS A MODIFIED ROM, wait for orgert's build if you use that normally

    New build with April 2021 Security Patch

    Download: https://github.com/Mibo5354/i9300_builds/releases
    1
    Thank you for your excellent work.
    Can it be installed on top of Orgert's?
    If you try to dirty flash it over orgert's it'll throw an error because it's signed with different keys.

    You'll need to clean flash it.
    You could use oandbackup to backup and restore your apps.
    1
    @Sly Fox007
    I installed your rom, what I came across is a faint tone on the headphones, can it be amplified? I tried installing m0_speaker_Volume_Boost_62_curiousrom.zip, but there was no change.
    For volume and charging issues configure with SmartPack Kernel Manager or with an init.d script (example).
  • 181
    zYkSW7S.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 7.1 (Nougat), which is designed to increase performance and reliability over stock Android for your device.

    Code:
    #include "std_disclaimer.h"
    /*
     * Your warranty is void.
     *
     * I am not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.
     */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit Gerrit Code Review.

    Wiki
    Official LineageOS Wiki: http://wiki.lineageos.org/devices/i9300

    Known issues
    @curiousrom has a list of known issues/workarounds. You can see them here: https://forum.xda-developers.com/showpost.php?p=76224958&postcount=4419

    Installation
    (NOTE: if you experience robotic voice during calls: see the FAQ for a fix)
    Upgrading from CyanogenMod/unofficial LineageOS without wiping


    First time LineageOS 14.1 installation on your Galaxy S III:
    • Read the official Wiki page
    • Flash a custom recovery via Heimdall or Odin
    • Push GApps (arm) and the Lineage 14.1 zip to your device
    • Boot into Recovery
    • Perform factory reset
    • Flash the Lineage 14.1 zip from SD card
    • Flash GApps from SD card
    • Reboot

    Upgrading from earlier version of LineageOS:
    • Update your recovery - Lineage Recovery will be done automatically, TWRP can be downloaded from here (NOTE: you need 3.0.2-2 or higher to automatically install updates in Lineage 14.1)
    • Push the new Lineage 14.1 zip to your SD card
    • Boot into Recovery
    • Flash the Lineage 14.1 zip from SD card
    • Flash the most recent GApps for 7.1 if you are upgrading from earlier android version
    • Reboot

    Downloads

    Reporting bugs

    Bug reports belong on JIRA. See our wiki for more information on using JIRA.

    I do not check this thread regularly for bug reports. Using JIRA makes tracking down & debugging bugs a lot easier. Feel free to use this thread to discuss bugs, though :)

    • DO NOT report bugs if you're running a custom kernel
    • DO NOT report bugs if you've modified system files
    • DO NOT report bugs if you've installed xposed and/or other mods
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • See how to submit a bug report for the appropriate place to report your bug (NOTE: the majority of bugs need to go in the BUGBASH tracker, which is only open on weekends).
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues or bugs already reported on JIRA. Any bug not reported in the bug report format below may be ignored.

    Code:
    Phone Informations
    * Lineage version
    * Gapps version
    What you did:
    * Wipe data: y/n
    * Upgrade from previous official cm build: y/n
    * Restore with titanium backup: y/n
    You're using (if yes write which one) :
    * Task killer
    * Phone cleaner / Battery enhancer apps
    * Non-stock kernel
    * Modified kernel settings
    * Other mods
    Bug info:
    * Last version it worked on
    * Repro steps

    Getting help

    You can ask for help on our subreddit, on IRC: #LineageOS on Freenode

    F.A.Q.
    Root?
    Flashable zips to install/uninstall root can be found here. Download the "arm" variants.

    Robotic voice during calls?
    Try using the I9300XXUGMK6 modem. Instructions are here.

    GPS Issues?
    Probably a hardware issue. Try tightening the screws on the back of the device, or see this video for more information (thanks to @baltics for the link)

    The LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!

    XDA:DevDB Information
    LineageOS 14.1 for i9300, ROM for the Samsung Galaxy S III I9300

    Contributors
    forkbomb444
    Source Code: https://github.com/LineageOS

    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.0.x

    Version Information
    Status: Nightly

    Created 2017-01-25
    Last Updated 2018-04-30
    97
    A little Oreo update for you all...

    Linux 4.17 will have support for the S3/Note 2. (So with a little bit of modification, you could install a regular Linux distro and use it on your phone!). I'm working on getting the notification LED driver submitted upstream - it should land for 4.18, probably along with support for the back/menu keys.

    I've gotten audio working, but it's in need of more testing. I also manages to test the camera:
    Yq7qXCO.jpg


    I've managed to successfully load the firmware onto i9300/n7100's modem. Currently I'm working on rewriting the kernel driver that RIL communicates with - Samsung's old implementation was unnecessarily complex, and they made some interesting design decisions in the way the driver behaves... Hopefully that will be done relatively soon - you can watch the progress here
    75
    I've got a few updates for you all :)

    The bad news:
    A few things are broken with the HWC (Video recording is the main one at the moment). I've been quite busy recently IRL, so haven't had much time to work on this.
    Android 7.1.2 doesn't boot, something's super weird during very early boot (it hangs waiting for threads to finish before starting the system server). Fixing this is my priority for the moment.

    The good news:
    I understand a little better how the camera HAL works, hopefully I'll be able to properly fix video recording (instead of using a hack in frameworks like we do now).
    I may even have some more free time in the next few weeks (no promises...)
    67
    Hi!

    Android O has a lot of changes, including to the kernel. Google supports as far back as 3.10 (five years old!). Backporting these changes to Linux 3.0 (seven years old!) might be possible, but no matter how hard I try, the kernel will have huge numbers of vulnerabilities. Going forward, more and more effort will be required to continue maintaining it.

    So, before working on Oreo I've decided to port i9300/i9305/n7100/t0lte to mainline Linux. This is going to take a while - I started working on this in earnest at the end of last year. Currently, there's no OpenGL support - so instead I've been using a traditional Linux distribution to develop on.

    Currently, there's a pretty neat list of things working (keep in mind, I haven't even attempted to boot Android on this yet...):
    • Display + panel brightness (on S3 and Note 2)
    • USB
    • Capacitive keys
    • Hardware keys
    • Sensors (on S3 only)
    • Wifi
    • Notification LED
    • HDMI (untested)
    • Cameras (untested)
    • Touchscreen (on S3 and Note 2)
    • Charging

    Fortunately, the lima project exists for OpenGL on Mali 400. So far, it can render spinning cubes - but I don't think it's quite far enough to handle Android yet...

    That leaves the main things left to figure out:
    • GPS (will require a lot of work - reversing the protocol used...)
    • Modem (I've started working on i9300/n7100, but it's not yet booting fully)
    • BT (should be super easy)
    • Audio
    • Note 2 sensors
    • Note 2 S-Pen support

    You can see my progress in my github repository.
    61
    Reserved

    Builds are up! :)
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone