[OFFICIAL][X82X&X910][TREBLE] LineageOS 18.1 (Android 11) for LeEco Le Max 2

Search This thread

Shished

Senior Member
Nov 8, 2016
443
99
Hey, can someone tell if x2 supports WPA3 for WIFI? My phone cannot find networks with it enabled.
 

lamarkreis

Member
May 14, 2019
15
5
Pradópolis
Dears, my phone lose WIFI sign frequently. Disconect and keep on off msgs, app, specially when use BANKs app, then app aborting operation 'cause NO CONECTION with internet, it doing I need do ever pass to open Bank app, etc... Oh, so borried!
 

ThE_MarD

Recognized Developer
Dec 10, 2014
3,304
3,774
Grande Prairie
LeEco Le Max 2
Moto X4
Heyyo @RussianNeuroMancer , hmm maybe there's something different for them as they're on a 4.4 kernel... unless on LOS 19.1 something else changed in the system? I have been slowly tinkering with 4.4 kernel for us but it's a very hard project for me since I'm not a kernel guru lol so I'm not sure if I can get something that works with all our kernel drivers and still be stable
 
Dec 6, 2014
6
0
Heyyo @RussianNeuroMancer , hmm maybe there's something different for them as they're on a 4.4 kernel... unless on LOS 19.1 something else changed in the system? I have been slowly tinkering with 4.4 kernel for us but it's a very hard project for me since I'm not a kernel guru lol so I'm not sure if I can get something that works with all our kernel drivers and still be stable
Oh, indeed, that could be because of the kernel version.

As for Linux 4.4 - did you ever consider shooting to mainline instead?
https://wiki.postmarketos.org/wiki/MSM8996_Mainlining
Some things you are currently struggling with could be already fixed in mainline long time ago. Other may require more effort, but this eventually should payoff, as with mainline kernel newer Android release could live on device as long as they fits into RAM and storage.
 

Jobser

New member
Nov 7, 2022
1
0
Hello everyone,

I have the problem that I can't get lineage 18.1 to run.

X829:

Method:

- Boot into TWRP.

- Do a factory reset.

- Flash firmware (466D) - -> wipe cache/dalvik.

- Flash LineageOS (lineage-18.1-20221021-nightly-x2-signed) -> wipe cache/dalvik.

-Install the Google Apps addon package (MindTheGapps-11.0.0-arm64-20220217_100228) -> wipe cache/dalvik.

- Reboot.

After that, the phone keeps getting stuck in the LineageOS loading screen (that blue 1/4 circle) and the phone crashes and goes back into TWRP.

I've tried different versions of LineageOS/MindTheGapps. Rarely do I get to Android and then the WiFi doesn't work.

Does anyone know what could be the reason ?
 

Neppomuk_

Senior Member
Jul 19, 2015
117
37
Last time a did a clean install, I did it this way:

1. Boot recovery (TWRP recommended)
2. Wipe the System and Cache, format Data
3. Transfer ROM and MindTheGapps to your device
4. Flash the ROM zip file (not reboot needed)
5. Flash the MindTheGapps
6. Reboot and set up your device, enable developer settings and in them, OEM unlock/Advanced reboot/USB tethering.

Optional:
7. Reboot back into TWRP recovery.
8. Flash the root solution of your choice
9. Reboot your device.
 
  • Like
Reactions: Jobser
Good evening!

One particular app won't work on my phone - during the startup, I'm getting the message that "the phone is not supported." I suspect that it has something to do with microG but I'm not sure. Perhaps someone else can try the app and report back? The app is called "glasseson" and you can find it here.

many thanks in advance!
 

Likimba

Member
Jun 23, 2009
6
2
Hi guys, I had previously read about LineageOS 19.1, but is there any news? I wouldn't mind fixing the camera focus problem that keeps jerky since I put the 18.1.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Heyyo @Nonsmoker that app checks for SafetyNet, so you would need to use either ih8sn or check Magisk and SafetyNet mods for it
    1
    Heyyo @Likimba, the only way LineageOS 19.1 for x2 would happen is if kernel 4.4 works properly for us due to the requirement of eBPF. I tried working on AICP s12.1 but I haven't found a fix for eBPF haxxs with selinux enforcing...
  • 10
    2okPze5.png

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restores the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.



    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit our Gerrit Code Review.



    Code:
    #include
    
    /*
    
    * Your warranty is now void.
    
    *
    
    * I am not responsible for bricked devices, dead SD cards,
    
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    
    * do some research if you have any concerns about features included in this ROM
    
    * before flashing it! YOU are choosing to make these modifications, and if
    
    * you point the finger at me for messing up your device, I will laugh at you.
    
    */


    SUPPORTED DEVICES

    - LEX820 (X2_CN)

    - LEX821 (X2_WW)

    - LEX822 (X2_CN)

    - LEX829 (X2_NA)

    - LEX910 (MAX_PLUS. Currently only supported on unofficial test builds)



    HOW TO INSTALL LINEAGEOS WITH LINEAGE RECOVERY

    - Make sure your phone is running firmware from at least 466d for x2 and pseudo 466d for max_plus. If not? Please either the minimum recommended version below (or optional updated versions) and install it via Lineage Recovery. It can be flashed before or after the ROM

    Please follow the official LineageOS Wiki instructions for our device






    HOW TO INSTALL LINEAGEOS WITH TWRP

    - Make sure your phone is running firmware from at least 466d for x2 and pseudo 466d for max_plus. If not? Please either the minimum recommended version below (or optional updated versions) and install it via TWRP. It can be flashed before or after the ROM

    - Unlock bootloader and install TWRP 3.4.0-0 (designed for Pie and above and for treble) or higher. TWRP instructions are here.

    - Download the LineageOS and firmware zips. (see Downloads)

    - Boot into TWRP.

    - Copy the downloaded zip files to internal sdcard.

    - Perform a backup of your current ROM. (Optional)

    - RECOMMENDED: Do a factory reset (clean wipe)! No support if you didn't! (Wipe Dalvik, system, cache and data)

    - Flash firmware and LineageOS zips.

    - Optional: Install the Google Apps addon package. (see Downloads)

    - Reboot to system.



    HOW TO UPGRADE LINEAGEOS FROM 17.1

    Please follow the official LineageOS Wiki instructions for our device. You can use either TWRP or Lineage Recovery.




    HOW TO UPDATE LINEAGEOS WITH LINEAGE RECOVERY

    Please follow the official LineageOS Wiki instructions for our device




    HOW TO UPDATE LINEAGEOS WITH TWRP

    - Download the LineageOS zip(s). (see Downloads)

    - Copy the LineageOS zip to internal sdcard.

    - Reboot to TWRP.

    - Flash LineageOS. (Wiping Dalvik and Cache is optional, but recommended)

    - Reboot to system.





    MAIN DOWNLOADS

    Lineage Recovery for x2:

    - Official:
    https://download.lineageos.org/x2

    - Unofficial:
    https://osdn.net/projects/lineageos-for-x2/releases/p17327


    TWRP for x2: Official https://twrp.me/leeco/leecolemax2.html

    TWRP for max_plus: Official https://twrp.me/leeco/leecolemaxpro.html



    Lineage:

    - Official:
    https://download.lineageos.org/x2

    - Unofficial 18.1:
    https://osdn.net/projects/lineageos-for-x2/releases/p17328




    GOOGLE APPS (GAPPS) DOWNLOADS

    - MindTheGapps




    GOOGLE CAMERA (GCAM) DOWNLOADS

    Google Camera:


    Enable "Fix tint on front camera" and set it to "Fix green tint." Found inside Settings > Advanced > Experimental settings.





    MISC DOWNLOADS

    ThE_MarD's LineageOS for x2 Sourceforge, directory: (also contains some mods and tweaks)
    https://sourceforge.net/projects/lineageos-for-x2/





    FIRMWARE DOWNLOADS

    Minimum required versions:

    - LEX820 (X2_CN) 466D

    - LEX821 (X2_WW) 466D

    - LEX829 (X2_NA) 466D

    - LEX910 (MAX_PLUS) 13s



    Link for x2 firmware:
    https://sourceforge.net/projects/lineageos-for-x2/files/Firmware Updates/

    Link for max_plus firmware:
    https://sourceforge.net/projects/lineageos-for-max-plus/files/firmware/




    DEVELOPER RESOURCES










    HOW TO CONTRIBUTE?

    Send your patches up for review: https://review.lineageos.org/

    Read the guides on the LineageOS Wiki: https://wiki.lineageos.org/



    XDA:DevDB Information

    [OFFICIAL][X82X][10.x][TREBLE] LineageOS 18.1 (Android 11) for LeEco Le Max 2, ROM for the LeEco Le Max 2



    Contributors

    ThE_MarD, mosimchah, Lucchetto00, CrisBalGreece,Tortel1210,codeworkx,moto999999,1nfrag,shivatejapeddi,KuranKaname,GalaticStryder,andr68rus,visionary,zhaoguomanong

    Source Code: https://github.com/LineageOS



    ROM OS Version: Android 11

    ROM Kernel: Linux 3.x

    ROM Firmware Required: X820, X821, X822 and x829 466d. x910 13s.

    Based On: AOSP


    DONATIONS

    8
    Heyyo my fellow x2 users,

    So an update on LineageOS 19.0 for x2... Tbh? It's not looking good. Android 12 requires Extended Berkeley Packet Filter (eBPF) support and it seems only 4.9 kernel is officially supported, but it seems it can be backported to potentially work on 4.4 kernels. The major issue there? We are on 3.18 kernel, so we're too old to support it... So there's a chance that LineageOS 19.0 might never go official for us... Plus we have stability issues where our screen doesn't always wake from sleep. Oof.

    So our options are? Someone (or I somehow without any proper kernel knowledge) get 4.4 kernel stable for us and we add support for the eBPF backports.

    Or, we leave x2 on LineageOS 18.1 official until LineageOS team drops support for it and I focus my efforts for x2 on a different ROM that allows disabling eBPF on our very legacy 3.18 kernel and just live with the intermittent black screen issues when waking the device... One annoying issue with this besides that screen wake bug is we wouldn't have any internet usage tracking, so you wouldn't know how much data you have used...

    Or, once LOS 18.1 official builds end? I can continue doing unofficial builds. Maybe do them once a month when security updates are backported? There are some legacy LOS branches that still get Android Security Bulletins when LOS team members backport them.

    So it is unfortunate for us... LeEco msm8996 has had a great run, but future support was never guaranteed on legacy devices, but I still plan on maintaining x2 in one form or another.
    5
    Heyyo, the official build for today was broken and I had it taken down. Sorry for anyone affected. I'll try to do a local build and check if it's our sources or if it was a build server issue
    4
    Reserved

    Frequently Asked Questions


    • I've been asked to provide logcat, how do I do that?
      You can either root and use an app like MatLog, or if boot logcat is required? You will need adb logcat from a PC. Here's a simple guide from the LineageOS Wiki https://wiki.lineageos.org/logcat.html
    • My lock screen crashes after reboot, what should I do to fix it?
      https://forum.xda-developers.com/le-max-2/how-to/guide-to-fixing-x2-lockscreen-crash-t3918911
    • I don't see an option for call recording, what's going on?
      Only the stock dialer app supports it. If you install a Gapps package that overwrites the stock dialer app? It won't have call recording as well. Only the included dialer app of LineageOS is compatible to call recording since it needs to be a ROM implementation and I haven't seen a Play store app that adds support for custom ROM call recording. Please also note that call recording is blocked for countries and carriers that have laws against any form of call recording.
    • What is Power-off Alarm?
      This feature allows you to set an alarm clock with the stock clock app included with LineageOS and then turn off the phone, and it will boot up a minute before the designated alarm time and then properly alarm. It works with the device either powered off and also offline charging. :)
      Using a clock app from OpenGapps Stock or from the Play store is not compatible with custom ROM implementations of power-off alarm... So consider this your heads up if you didn't know that already... As I am not responsible for anyone being late for their wedding/work/school/vacation if you tried a non-stock clock app with your LeEco msm8996 device powered off. :silly:
    • What apps are recommended with the Open Source ConsumerIR?
      Zaza Remote (only with selinux enforcing) and Mi Remote work great. Smart Remote for Sharp TV also works. I'd recommend avoiding Peel Universal Smart Remote as it hijacks the lock screen with ads...
    • Pls sir, I can't connect to my network or IMS/VoLTE doesn't work! What can I try?
      Please look below at the "APNS Update from Google" section and try that. I can't offer much else for help sorry as I have zero experience with IMS/VoLTE as Canada blacklists BYOD from that feature... Otherwise, if you need extra help? Hopefully, someone else in the x2 community can give you advice.
    • What is the difference between the official LineageOS builds and unofficial?
      Unofficial test builds are builds I put out to test changes before I push them to the Official builds... So please stick with Official builds if you want to play it safe... But if you wish to help test and provide feedback on changes before they go official? Unofficial test builds are the best way to do so.
    • Where is the QuickCharge toggle?
      Settings > System > Advanced > LeEco Settings
    • The rear-facing camera won't focus, what should I try?
      Please go into Settings > System > Advanced > LeEco Settings, and then enable the focus fix. You may need to restart any open camera app or potentially reboot the system in order for the focus fix values to work... If that doesn't resolve it? Please try EUI ROM... If it still won't focus? I'm sorry, but your hardware camera actuator is defective and you either need to try the Le Max 2 rear camera magnet trick (please Google it) or replace the rear camera hardware.
    • Why is our Widevine level only L3?
      Unfortunately, Widevine L1 failed to work correctly on X2 and zl1/0... It would report we have L1 hardware support but vp9.secure and avc.secure codecs were failing to render, thus apps that used L1 like Amazon Prime would error out and revert to L3 and worst-case scenario apps like Vudu would crash.
      I haven't seen any fixes for those codec issues, so I gave up on it as L3 works fine.
      Also, Netflix HD will never work on LeEco devices as they never got them "Netflix certified" which sounds like a money-grab move since L1 is all they should need. For example, Asus Zenfone 5z is L1 certified but not "Netflix certified" just like we are and they don't get the option to stream in HD.
      This explains it a lot better
      https://androidpcreview.com/netflix-hd-android-tv-box/
    • My device doesn't show any apps in the Play Store what should I do?
      https://lineageos.org/Google-Play-Certification/
    • exfat does not work on LineageOS, what is up with that?
      LeEco Le Max 2 does not ship with exFAT licensing so we are not allowed to incorporate it in LineageOS Le Max 2 builds. This was tested by both CrisBalGreece and I. If by chance there is an OFFICIAL EUI ROM build that includes exfat? Please let me know so I can test it as well... Here are the LineageOS device charter requirements on exfat
      https://github.com/LineageOS/charter/blob/master/device-support-requirements.md#exfat-support

    KNOWN BUGS for x2 and max_plus
    • WiFi randomly disconnects when the device is asleep
    • Lockscreen may sometimes fail to unlock after a reboot (seems to mainly happen when the battery is low and power-saving mode is on. The workaround is to reboot again and it will unlock. Please note, this is NOT related to the lock screen crash bug where it always fails to unlock due to the encryption footer getting corrupted by an old beta build of TWRP. The fix for that is still in the lock screen crash fix thread I have linked up in the FAQ.)
    • Updating using the built-in LineageOS updater with TWRP as your recovery when encrypted causes Google Play Services to crash repeatedly (Lineage Recovery works without issue or updating manually via TWRP is fine though)
    • Microphone and button on 3.5mm headsets using the 3.5mm to Type-C adaptor only works with reversed orientation (IE, official LeEco adaptor with the logo facing downwards)
    • Dual-role USB does not work (our Type-C port can't detect if it should offer the option to host data transfer, charge the other device, or charge while using Aux out).
    • Taking a photo during 4K UHD video recording produces a photo with green static instead of a photo. This bug only happens in Snap camera... Google Camera Mod and Open Camera (with Camera API v2 enabled) produces pictures without issue.
    • Infinity focus not working (for panoramas, AR and some QR code scanners. Infinity focus also doesn't work in EUI ROM hmm... oddly enough some imx230_lg modules infinity focus can work if you don't need focus fix... so I blame LeEco for the messed up camera haxxs they did since s2 and zl1 have the same issues.)

    KNOWN BUGS for max_plus
    • ES9018 Hi-Fi Audio DAC for 3.5mm headsets to Type-C adaptors does not work (this is the bug that is preventing official unified builds of LineageOS of x2 and max_plus...)
    • Fingerprint does not work when the device is asleep (this is due to the ancient device firmware on max_plus being officially stuck on 13s... there is a pseudo 466d modem firmware fix attempt I made but have not received feedback on yet)
    • Boot animation does not work unless you tap the power button twice to turn the display off and on again (this is due to a fix for screen tearing... maybe one day I'll figure out a fix for boot animation to work with the screen tearing fix)
    • When launching a camera app, viewfinder goes green for a second and then works normally
    • After using the USB port with Type-C headset or OTG with a flash drive, the device cannot charge until a reboot is performed (known bug even on EUI ROM)

    APNs Update from Google

    This is an optional update if the current APN settings from LineageOS might not be up to date for your carrier and you need newer ones. This is the official APNs list from Google.

    After flashing it? Please reboot to system and then go into Settings > Network & Internet > Mobile Internet > Advanced > Access Point Names > "..." menu button > reset to default.

    https://sourceforge.net/projects/lineageos-for-x2/files/Mods and Tweaks/APNs Update from Google/

    The official Google source git for this file can be found here:
    https://android.googlesource.com/device/sample/+/refs/heads/master/etc/apns-full-conf.xml

    Please note! This APNs list WILL get overwritten by the ROM on any ROM update and will need to be reinstalled.
    4
    I installed the new zip, here is the report.

    • YouTube and Vanced: 2160p60 working.
    • Instagram (version 150): working.
    • Instagram (version 197): artifacts in videos.
    Great.. thanks for your reply.
    So we have the permanent solution with them and v150..