[OFFICIAL XDA][BETA][MAR 19]XDA Labs: Forum App + App Installer + Xposed Repo

Status
Not open for further replies.

yochananmarqos

Recognized Contributor
Feb 15, 2013
3,371
2,484
253
www.androideputies.com
EDIT: Per-app logcat attached from a random crash after using another app in the middle of posting then using the Back button to leave said app hoping to return to XDA Labs. Nice run-on sentence, eh? I'm too tired to revise it. :p

The Chrome Tab option is awesome, it let me quickly switch to the mobile site to edit my post & attach the log.

Hi... how to insert image / attach image when i replying a thread ?

Didn't find an option for it.


Thank you
More features coming, hold tight. ;)

Update notification is cool but would be nice to have option to enable or disable it for users watching data usage.
The update check uses an infinitesimal amount of data. Wait until you're on WiFi to download it.
 

Attachments

Last edited:

Px80

Senior Member
Feb 19, 2012
639
105
73
Great question. XDA One was intended to be a jumping off point until we could have a better app plan, and that's what XDA Labs is. So we aren't 100% sure what we will do (open to suggestions!) but as of now, our focus is on Labs. :cowboy:
I totally like the idea of labs with fully integrated forum! Maybe you could go further with this and integrate open source apps like fdroid does or maybe team up with them about the apps.


As for the xposed part in labs? Is this already fully working or is it a bug that "enable mod" shows up a pop up that I need xposed be installed? (Because it already is :D )
 

kunal1540

Senior Member
Jun 6, 2013
1,170
527
148
City of oranges
Thankyou for such a beautiful app. I do want to point out a bug. I subscribed to android themes forum.. But when going in subscribed forums and clicking on android themes it FC's
 

blk_jack

XDA Labs & Feed Dev/RD
Jun 7, 2010
3,306
11,410
0
Toronto
Update notification is cool but would be nice to have option to enable or disable it for users watching data usage.
Like previously mentioned, the notification is just a notification, it uses an incredibly tiny amount of bandwidth. You can choose to actually download updates at your own discretion, like when you're on wifi. That said, the ability for users to pick/choose when to receive notifications is something we're working on adding to the settings.

Hi... how to insert image / attach image when i replying a thread ?
This feature is being worked on as we speak :)

As for the xposed part in labs? Is this already fully working or is it a bug that "enable mod" shows up a pop up that I need xposed be installed? (Because it already is :D )
Hmm that ain't good! The app will only do that if it can't get root or if it can't find the XposedInstaller's data dir (since it inserts your enabled mods there). If you could provide a log and let me know more info on your setup that would be great.

You should get and post here some logs. That way, blk_jack or other devs will be able to analyse :)

As a reminder, in post #2 , in FAQ :
THIS GUY! Thank you @FLooDW!

Since 0.54a I've been able to fix 3 bugs that were directly related to logs I received in this thread. Logs and more detailed info on crashes, bugs & strange occurrences will not only make our job easier but also better the app for the community as a whole.
 

Manuel15

Senior Member
Oct 5, 2014
371
168
0
I subscribed to the "Ask ANY questions" thread, but today if I try to open it with both XDA One and XDA Labs apps I get a "problems with your request" message , I'll provide a logcat later (XDA apps don't let me attach it)

Inviato utilizzando XDA One
 

kryzeK

Senior Member
Jul 17, 2012
1,201
821
143
Cachoeira Paulista
Chrome Custom Tab is working for you guys? Here in my Nexus 4 running Chroma ROM (Android 6.0) and latest Chrome Dev when I open a link I'm redirected to the browser, not custom chrome tab
 

blk_jack

XDA Labs & Feed Dev/RD
Jun 7, 2010
3,306
11,410
0
Toronto
Chrome Custom Tab is working for you guys? Here in my Nexus 4 running Chroma ROM (Android 6.0) and latest Chrome Dev when I open a link I'm redirected to the browser, not custom chrome tab
Could you gimme a bit more info on this? Where are you trying to open a link in particular? We use custom chrome tabs in the Discover article page, Forums and App/Xposed details. There is, however, a setting to explicitly disable Custom Chrome Tabs in Settings. It's enabled by default though so I don't suppose you manually toggled it off?
 
  • Like
Reactions: kryzeK
G

GuestK0036

Guest
Very weird to see this navdrawer issue. What device/resolution/etc? More info is better.

I personally love Crowdin. Have used it for a few projects and would love to use it for this one too. I also love & use F-Droid for an app of mine. I think we're open to a lot of things right now, but we'll see based on feedback from you guys.
My device is a Samsung Galaxy S2 - HDPI 480x800. Indeed a bit strange because this bug was fixed on XDA One first version by @-BioHaZard-, thanks to him for his work btw, commit: Navigation drawer width fix for HDPI phones .
 

blk_jack

XDA Labs & Feed Dev/RD
Jun 7, 2010
3,306
11,410
0
Toronto
My device is a Samsung Galaxy S2 - HDPI 480x800. Indeed a bit strange because this bug was fixed on XDA One first version by @-BioHaZard-, thanks to him for his work btw, commit: Navigation drawer width fix for HDPI phones .
Ah right, that's one mighty small resolution.

I may ping you later to be my HDPI tester ;)

Anyway XDA Labs uses its own NavDrawer that wasn't any part of One, so that's why you're seeing this issue. I'll add in the appropriate dimension changes for your device, though.
 
  • Like
Reactions: ANDR01DN00B
Status
Not open for further replies.