[OFFICIAL XDA] Navigation Gestures - Get iPhone X/OnePlus style gesture control

claudchan

Senior Member
Dec 21, 2012
85
7
38
After upgraded to android 11, the app not working anymore.
Why the developer not support anymore? I even have paid the premium add on. If you not working on the app please at least pass on to someone to continue your work.
 

jeanxx

Senior Member
Nov 30, 2010
632
377
93
Phoenix
After upgraded to android 11, the app not working anymore.
Why the developer not support anymore? I even have paid the premium add on. If you not working on the app please at least pass on to someone to continue your work.
Hey dev, you around?
Note note 20 ultra not liking the nav app with the One UI 3.0 update, any update to this app? Please I as many others have the paid version as well, thanks

For everyone wondering what is going on, in Android 11, Google removed the overscan API which was brutally essential to making navigation gestures work. It manipulated the pixels and shifted them so that the gestures could work properly. Without this API to hook into, google has essentially crippled navigation gesture apps from being able to integrate these types of special gestures. This is not the developers fault and most likely, they are working on trying to find a way to work around this disability, but for now, there isnt much the developer themselves can do as google removed the key component that makes this work; out of Android 11 framework.

Citing: https://www.xda-developers.com/goog...for the feedback,used by any products anymore.
 

MCT_

Senior Member
Nov 2, 2010
1,486
904
143
Simferopol
My Black Shark 2 supports gestures, but I bought a premium version for my tablet with the Intel-based Android x86 operating system pre-installed. I also read comments in the Google Play Store, where many of the people simply do not understand how the premium version works, and complain that the premium patch does not open, the program notification window on the installed device cannot be translated and is in English, and in the patch description does not understand what it is. So you guys either add a comment in the Google play store, or give a branch to translate the program. Well, the program works fine, although the Kernel of my Android is modified and does not get a "powersave" governor, (I did not have problems with sticking gestures), but I still observe some dead zones of the screen when switching from landscape mode (these are more likely problems of the Android itself and the screen type, than the application). In addition, this app is disabled by me in the settings to save battery power. That is, I have no problems with it at all. A set of gestures that I use only return, recent applications and switching between applications, but I still thank you for your work and wish you success in the future.
 
Last edited:

goldybewon

Senior Member
Jun 11, 2016
462
1,350
113
Android 11 Support



I agree: It would be great to see this package support Android 11.

The application fails under Android Studios, trying to start it in the emulated Android 11 virtual phone. It appears to be a permission problem. I tried to get around this by using the System Settings --> Apps & notifications --> Navigation Gestures --> Permissions, then granting camera (while in use), Contacts, Files and media (all files). Also, under Notifications, All Navigation Gestures notifications is on, as is Allow notification dot. Next, under System Settings --> Accessibility --> Downloaded Apps --> Navigation Gestures, Use Navigation Gestures is on, along with option Navigation Gestures shortcut is on.

When I start Navigation Gestures on Android 11 it seems to be trying to display the screen with the warning Make sure "Hide Navigation Bar" is off before uninstalling, and showing the toggle switches for Enable Gesture Pill, and so forth. Said differently, it's not trying to show the big red panel used for walking a new user through the settings for application permissions. (See the YouTube demo
)

I don't know how to issue ADB commands to an emulated Android device created in Android Studio. For this reason I've not yet tried issuing the: adb shell pm grant com.xda.nobar android.permission.WRITE_SECURE_SETTINGS

If someone can confirm Navigation Gestures works on a physical or emulated device using some of these tips, I think we'd all be happy to hear of success.

25 Sep 2020: I didn't see this article regarding why this package won't be working on Android 11:

https://www.xda-developers.com/goog...ndroid-11-crippling-third-party-gesture-apps/

This is a real shame for Google to cripple a useful customization tool. I suppose it would be nice to see the opening post changed to let users know the SDK/API level where the package breaks. :(
Too much disappointment after buying Galaxy S21 Ultra. Due to Google current policy. I can't use navigation gesture anymore. My favorite app Navigation Gesture not working anymore.

Thanks,
goldybewon
 

bieeest

New member
Dec 3, 2008
2
0
21
Hi,
I encountered a bug after hiding my nav bar on my galaxy s20 and going to my recent apps page I can't hit the close all or the multi window apps button. The only way I can get it to work is to enable the nav bar again. Does anyone know a fix?
Did you find a solution for this?
I'm having the same problem (S9+).

Changing the pill dimensions or position does not seem to help.
 
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone