• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OFFICIAL][ZS620KL] LineageOS 17.1 (Android 10) for the Asus Zenfone 5z

Search This thread


Senior Member
Dec 10, 2014
Grande Prairie
LeEco Le Max 2
Moto X4
Heyyo, new test build going up! Link as always in the first post. lineage-17.1-20210407-UNOFFICIAL-Z01R contains some fixes to Bluetooth properties so anyone with Bluetooth a2dp offload issues please try this build. I also updated the vendor blobs to the latest build so please test all functions like camera and performance.


Senior Member
Dec 10, 2014
Grande Prairie
LeEco Le Max 2
Moto X4
Heyyo, a new test build is going up! Link as always in the first post and I'm uploading meow so it'll be ready in about 10 minutes. lineage-17.1-20210408-UNOFFICIAL-Z01R contains the Bluetooth prop fixes from the last build for those having issues with Bluetooth A2DP offload. There's also the blob updates from our stock ROM and also device firmware too! Boot times should be a little more snappy and @aqua_hopps that annoying power on issue you mentioned is fixed with the updated device firmware! So please test this build out. It also switches us back to QTI Power HAL as we never properly switched to the Pixel power-libperfmgr... so the camera perf hints should work correctly for us (smoother camera performance, mainly in dark environments). The last build I accidentally broke the fingerprint sensor lol oops, so anyone on the previous build should definitely upgrade.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 3

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restores the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit our Gerrit Code Review.

    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.


    - ZS620KL (Asus Zenfone 5z)


    Please follow the official LineageOS Wiki instructions for our device



    - Official:

    - Unofficial test builds:


    - Open GApps (pico or nano):


    Google Camera:



    Send your patches up for review:

    Read the guides on the LineageOS Wiki:

    XDA: DevDB Information

    [OFFICIAL][ZS620KL][10.x] LineageOS 17.1 (Android 10) for the Asus Zenfone 5z


    Jackeagle, ThE_MarD, rohanpurohit, TARKZiM

    Source Code:

    ROM OS Version: Android 10

    ROM Kernel: Linux 4.9

    Based On: AOSP
    Heyyo! It is time! Official LineageOS 17.1 for Z01R is released!!! :love:

    Heyyo @iShaKinGameR and @HtMawia , the step after ROM flash and reboot to recovery is very important for us as Z01R is an A/B partitioned device. The ROM always flashes to the inactive slot and then it tells the bootloader to switch slots which requires a reboot. So the reboot to recovery is to get recovery to reload onto the slot that the ROM was flashed so that you can then install gapps and such.

    Devices that are A-Only, such as the Lenovo Z6 Pro (Zippo) do not need this step as there is only one slot it can flash to. I think the Asus Zenfone Max Pro M1 (X00TD) Is only A-Only as well.
    I tried to install GAPPS nano for it, but when it starts, G Apps as (Play Store) does not appear on the system. First time I had this error. I ended up going back to Stock, i tried 5x... :confused:

    Assuming that you used the Lineage Recovery, the same thing happened to me on my first attempt. Right after flashing the ROM, i continued to flash GAPPS and reboot. Like your problem, Google apps did not show up when i boot the system.

    However, i missed one step as stated in the installation process. As per the instruction, right after flashing the ROM itself, you have to click Advanced, then Reboot to Recovery, then when your device reboots, click Apply Update, then Apply from ADB, then adb sideload <filename>.zip, which in this case is the gapps.zip. Then, reboot to system. The google apps will now appear in the system. Hope it works for you also (y)
    Features over Stock
    FM Radio, File-Based Encryption (which allows power-off Alarm to actually work and no annoying PIN prompt half-ways through boot)

    Known Bugs
    • 4K UHD Video recording does not work in LineageOS Snap Camera app. (A workaround is to use other camera apps like OpenCamera or Gcam Mods)
    • Touch sometimes doesn't work in Lineage Recovery. The workaround is to use the volume buttons to move around the menu and power to select or to reboot to recovery.
    • Bluetooth A2DP can cause crashes during voice calls with certain Bluetooth devices (a workaround is to disable Bluetooth A2DP offload via developer options)
    • The current official build of TWRP doesn't support File-Based Encryption. The workaround is to use my modified build of TWRP found here