[OLD VERSION] [ROM] Aidan's ROM [S905X] [Android TV 9] [OLD VERSION]

Search This thread


New member
May 6, 2023
I have a t95z plus 3/32 s912 with ap6255 chip

I hate the stock screen this box has and would like to have atv if possible. which img would I use for this box, there are some from your site which i tried
usb burn tool gives me this error



Senior Member
Jan 31, 2022
Motorola Defy
Samsung Galaxy S4 Mini
this ROM will support AlfaWise H96 PRO+ 3/32! android box?


New member
Jun 4, 2023
Let's see Aidan or someone can lend a hand.

The roms work correctly for me, I only have a small problem or inconvenience. And it is that I cannot load my arcade from my SD, the aidan rom always starts.
I put the original firmware back and if I can do it. Come on, if I leave the sd inside and start it, it loads the sd, if I don't put an sd it starts the internal memory.

Is there a way to modify that?

Thanks, and good job.


Nov 9, 2008
Hi Aidan, great job with this.
I just tried it on my Nexbox A95X-B7N (16GB ROM/2GB RAM) and it works fine so far, have not done any in-depth testing yet.
No Wifi as it stands as mine uses the AP6630 chip, I picked your 6212 variant hoping it might work but no dice.
Remote doesn't work either but that's to be expected. (MiBox works with BT Remote whereas the original Nexbox A95X with an IR one)

I own a Mi Box S as well, and the experience is very comparable.

Let me know if you need anything tested, I'll check LAN later in the day as well
Which version exactly you burned. NOR the 8 or 9 work on the NEXBOX A95X I tested (no remote or wifi)


New member
Jul 6, 2023
Hello and thanks for the awesome ROM!

I successfully installed it in a t95z plus 3/32 s912, this version "2. [v9] Aidan's ROM [S912] [ATV 9] [DDR3 & DDR4] [LAN1000].img" with usb burning tool

Problem is I am getting frequent but random reboots. The only thing I believe plays a role is the reboots happen when installing an app, or doing sth intensive. Also happened during the initial setup phase of connecting to a google account.

Any ideas what could be the problem?
Last edited:


Senior Member
Jan 16, 2007
hi from Spain, i update a mini m8s ii with a megabox 112 firm without problem, now, when i burn this image,test v7 and v9 universal, whe push the update buttom appears a simbol of android with a "X" and not continue, any help?


Jan 31, 2018
Nexus 7
Huawei P8lite/P8 Lite
I finally managed to burn Aidan's rom onto my Mecool M8S Pro W (905W) Android TV box.

Took several attempts, but what finally did the trick was to burn with all the wipe-options disabled and then doing it immediately again with them on. (maybe that information could help someone later on...)

Now I'm just hoping someone could help me with these two issues I'm having:

1. The remote doesn't work. Or actually it does, but only certain buttons, and they're all wrong :D For example the TV IN button seems to act as OK, and the right button is volume +. And then numbers are scattered all over the place.

I'm assuming this could be fixed by editing the keymap files (/vendor/etc/remote.conf/tab1/tab2/tab3 or /system/keymaps/*.kl) but the information about what to edit is so widely scattered all over the place that my head explodes when I try to decipher it.

2. WiFi (and Bluetooth) doesn't work. I don't use bt on it so I don't care about that, but the place I'm intending to use this device at is a bit far from my mesh AP's, so ethernet cables are out of the question. I imagine this could also be solved by using the wifi drivers from the original FW, but again, the information is all over the place. I also kinda assumed this would just work as the image I used was for the exact chip my device has, but nope. The remote only works on this one by the way - when I burned one for a different chip, the remote did absolutely nothing.

This said, I haven't tried a usb wifi dongle yet - I have a spare one, and if that works, I don't care about the wifi issue anymore. Nope, dongle didn't work either :(
But the remote would be pretty nice to get to work...
Last edited:


Sep 4, 2023
Hello, I have a tvbox x96max plus and the remote control does not work, I don't know how to enter the system and change some file, is there any other solution? please I ask for your help.


Sep 4, 2023
Does anyone have the aidan rom for s905x3 (tvbox x96 max plus), with the file ready to use the remote control? please


Sep 4, 2023
Hi everyone, since my remote control doesn't work and I can't fix it (because I don't understand), any USB control that will work for me? Any air mouse that works? I use a usb keyboard but only the mouse cursor works, the direction, volume and key buttons do not work, I appreciate your help.

Top Liked Posts

  • There are no posts matching your filters.
  • 30
    New XDA post

    to brighten.png

    Home Screen With Apps

    ^^^NEW Home Screen, Update From Play Store ^^^

    Preinstalled Apps

    Initial Set Up Screen

    Initial Set Up Screen 2


    New Google Dream X Included
    Screenshot_20201116-025413 - Copy.png

    Google Play Protect Certified

    Android TV Netflix! (Install Apk From Website)

    Aidan's Custom Android TV 9 ROM For S905X

    This is My Android 9.0 Firmware, This Is Based On The Official Mi Box Android TV 9.0 Firmware

    This Is A Firmware Port Of The Xiaomi Mi Box Firmware Designed To Run On Other Amlogic S905X Devices

    This Firmware Is FAST & STABLE

    WARNING: This Is Experimental & Requires Multiple Steps, Please Read About "Mask Rom Mode" To Know How To Recover Your Device If Installation Fails!
    This Has The New Amlogic Kernel And As Such Will Not Work On All S905X Devices, My Older Android 7 Based Firmware Works On Most Devices

    How To Install

    Use USB Burning Tool, See Website

    Wait Up To 5 Mins For Firmware To Boot For First Time & Proceed Through Initial Set Up

    NEW Website! Check it out & Download!
    >>>> Website Click Here <<<<

    v8 New Features (25.July.2021)
    BASED ON LATEST MI BOX Official Pie Build 3595
    Security Patch 5.March.2021
    Low Ram False All Roms
    Forceencrypt Disabled
    Default Volume MAX
    New Bootanimation
    More Debloating
    DPI Set At 320/213
    New Welcome (Thanks AcidIce18)
    No Remote Pair Screen
    More Cleaned & De Bloat
    More Tweaks...

    v7 New Features (29.April.2021)
    BASED ON LATEST MI BOX Official Pie Build 3409
    Security Patch 5.January.2021
    NEW Mygica ATV495x (maybe more) Version Available
    NEW F30UP (maybe more) Version Available
    Now Includes App Drawer (Non Tv Apps)
    Now Includes File Browser
    Now 11 Wi-Fi Versions Available
    Cleaned & De Bloat
    More Tweaks...

    v6 New Features (21.Jan.2021)
    Netflix TV Version (APK Provided)
    Stability Improved (Fixed Random Reboot Bug)
    Now 10 Wi-Fi Versions Available
    Cleaned Further & De Bloat
    More Video Playback Performance Improvements
    More Key layout Files Added
    More Tweaks...

    v5 New Features (08.Jan.2021)
    Universal Version Now Available
    More WIFI Chips supported
    Cleaned Further & De Bloat
    Now The Versions Are More Similar Than Ever
    Video Playback Performance Improvements
    More Key layout Files Added
    More Tweaks...

    v4 New Features (16.Nov.2020)
    1st Update After OTA Update Available Notification
    BASED ON LATEST MI BOX Official Pie Build 3139
    Security Patch 5.October.2020
    NTFS & exFAT USB Drive Support Added
    Removed Mi Tv Analytics
    Bug Report Sender Removed

    v3 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    New Google Keyboard From Chromecast With Google TV
    New Boot animation
    Enabled 14 Wi-Fi Channels
    Updated Google Play Store
    De Bloat System
    Remove Chromecast
    Remove Google Play Games, Music & Video
    Remove Netflix & Prime Video
    Reduced img Size For Faster Download
    Reduced Install Time
    More Tweaks

    v2 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Created USB Burnig tool Image
    New Install Method Now 1 Step Install

    v1 New Features
    BASED ON STABLE MI BOX Official Pie Build 2696
    Security Patch 5.April.2020
    Original Install Method Using base ROM & Update.ZIP

    Help & FAQ

    USB Burning Tool Cant See Device
    if usb burning tool cant detect your device, and youve tried other ports, cables ect then Mask ROM Mode May Be Needed, See Here
    Youtube Unbrick Guide

    Netflix wont work from play store
    The TV Version of Netflix needs Widevine Level 1 DRM, This cannot be added to your device with a firmware, Patched Netflix Apk Now Available

    Amazon Prime Wont Work
    A. Like Netflix Install the mobile app, the TV version needs Widevine Level 1

    Disney+ No Sound
    A. Fixed Earlier Release

    No Root
    There Is No Root In This Firmware Because This Is a User Build (Not User Debug)
    User Build: This Is Like The official Android Tv Devices (Like Mi Box), it does not have root or TWRP, Uses Release Keys and is SELINUX enforced
    This Makes More Apps Show Up In The Play Store that didn't show before, (Example: Isp Android TV live tv app, only shows in Play Store On non rooted and SELINUX enforced devices, also the streams in the app do not even play in rooted devices.) And other Apps With Similar Issues On Non Certified Devices....

    myCANAL App No Sound...
    See This Post

    [OLD] How To Install: [OLD]
    1) Download One Of The Base Firmwares That We Will Write Over (By Wi-Fi Chip If Possible But This Will Work Without Wi-Fi Using Ethernet)
    1.2) Download Reboot Revovery.zip & TWRP 3.3.1 AML By ViT
    1.3) Download One Of My Custom Mi Box Update Zip File
    1.4) Download USB Burning Tool (I Use v2.2.0 Download On My Website)
    2) Flash The Base Firmware Image Using USB Burn Tool,
    2.1) See If Wi-Fi & Bluetooth Seem To Work And Try The Other Version If Not
    3) Open The Update App And Choose Select, Choose Reboot To Recovery.zip & Chose Update & Update Again
    4) You Will Be Inside Recovery Now, Choose Update From EXT, And Choose (USB/SD Depending What You Use)
    5) Choose TWRP 3.3.1 .zip, This Will Boot Into TWRP, Slide The Screen To Accept (Mouse Needed) & Choose Install
    6) Flash My Custom Mi Box Update Zip File By WiFi Chip If Possible, If You Don't Have One Of These Chips You Will Have To Try The Versions & See Or Use Ethernet
    7) You Will Be Rebooted Automatically After Installation And Put Into The Stock Android Recovery
    8) Choose "Wipe/Factory Data Reset" Option Here, And Then Once Done Choose Reboot
    9) Wait Up To 5 Mins For Firmware To Boot For First Time & Proceed Through Initial Set Up
    10) Open Settings & Navigate To "Apps", Then Choose "See All Apps" Then "Show System Apps" Find The App "Chromecast Android Shell" And DISABLE It (Wont Work Without Widevine Level1 & slows device down)
    11 Disable "Movie Player" & Any Other Apps You Want To Hide
    12 Enjoy!


    Thanks DiogoSilva48

    Thanks for the reply and eagerly waiting for manual update. The existing rom is almost like stock one. Happy with it, and the manual update would enhance it further.

    I tried sideloading many .apk for prime video of different versions and both platforms - mobile and android tv. Even tried aptroid.tv app store with someone's suggestions on google.
    However, the mobile versions did not even install. And the TV versions though installed but returned with the same error. Only trailers are able to play. Main content isn't playing and the error "Something went wrong" shows up.

    If you could help me with any working apk for prime video, kindly provide. Just like the netflix you provided.

    Thank you so much in advance Aidan.
    hey v7 is now available, most are uploaded 2 still uploading :)
    Hello Timosat, as I understood I have to find ly remote file and then after several step sut this folder in aidans rom... Where to find the right remote folder for my box? I have the remote.conf from a previous rom can I use this file?
    I read that you use Atvx 4 rom to do this ? You choosed this rom because your remote works with this rom?
    It's a long process with patience. Your remote.conf file has to be renamed to remote.tab1 and use any good file explorer eg mixexplorer and transfer tthe remote file to vendor/etc folder .But before you do this make sure you are rooted. You may try and root Aidan's rom first by patching recovery.Partition method.And see if your remote will work. As for my case yes I use atvx4 rom because I've tried Aidan's rom my remote did not work. So I made (should I call it hybrid) rom.By taking system.PARTITION from Aidan's rom and substitute it in atvx4 and also patching atvx4 recovery.PARTITION with Magisk.Then I repacked and flashed to my box.
    3. [V6](Qualcomm QCA9377 & LTM8830)

    Wifi working perfectly fine on my 8189etv.