Question OnePlus 10 Pro Bootloader Unable to unlock [NE2215]

Search This thread


New member
Aug 15, 2022

I am trying to unlock the bootloader as it show status as "Device Lock"

When I try to use the command "fastboot oem unlock", it showed
FAILED (remote: unknown command)
finished. total time: 0.001s

I then tried "fastboot flashing unlock" but it showed this
usage: fastboot [ <option> ] <command>

update <filename> reflash device from
flashall flash boot, system, vendor and if found,
flash <partition> [ <filename> ] write a file to a flash partition
erase <partition> erase a flash partition
format[:[<fs type>][:[<size>]] <partition> format a flash partition.
Can override the fs type and/or
size the bootloader reports.
getvar <variable> display a bootloader variable
boot <kernel> [ <ramdisk> [ <second> ] ] download and boot kernel
flash:raw boot <kernel> [ <ramdisk> [ <second> ] ] create bootimage and
flash it
devices list all connected devices
continue continue with autoboot
reboot reboot device normally
reboot-bootloader reboot device into bootloader
help show this help message

-w erase userdata and cache (and format
if supported by partition type)
-u do not first erase partition before
-s <specific device> specify device serial number
or path to device port
-l with "devices", lists device paths
-p <product> specify product name
-c <cmdline> override kernel commandline
-i <vendor id> specify a custom USB vendor id
-b <base_addr> specify a custom kernel base address.
default: 0x10000000
-n <page size> specify the nand page size.
default: 2048
-S <size>[K|M|G] automatically sparse files greater

Any solution to this?
Last edited:


New member
Aug 15, 2022
Still the same. This is what I kept getting


  • Screenshot 2022-08-16 032609.png
    Screenshot 2022-08-16 032609.png
    95.2 KB · Views: 45


Senior Member
Aug 24, 2010
Huawei Watch 2
OnePlus 10 Pro
When you type in fastboot press tab and it'll populate the actual filename.

I get this with certain setups. Same with ADB, just press tab after typing fastboot or ADB then continue with the same commands as you have..

Could just be your fastboot/ADB files.
. I've got the ones I use in my root guide in this forum, grab it and pop it in the root of C then give it another shot.

Hope you get it sorted 👍🏻