[OnePlus 8][ROM][OTA][Oxygen OS] Repo of Oxygen OS Builds

Search This thread

Norbosz

Member
Jun 23, 2009
21
2
Budapest
I would like to ask for help, how can I install the latest OP8 rom with a clean install to erase all data? The device has the bootloader open and Magisk on it. Device model: IN2013
 

Norbosz

Member
Jun 23, 2009
21
2
Budapest
The easiest way is probably factory reset -> OTA upgrade -> re-root.
The reason I want a clean install is because when I bought the device, it had the 11.0.8.8 ROM on it, and I installed Magisk and rooted the device. Then I upgraded to the 11.0.9.9 rom, which I installed after deleting the Magisk program and root. However, after I installed the 11.0.9.9 rom, and with it I put the Magisk program back and rooted the device again, since then the notifications only come when I unlock the device screen. Sometimes it doesn't even ask for the SIM card code, as if there is no SIM card in it, the device behaves like that. Therefore I would like to have a completely clean installation.
 

djmcnz

Retired Recognized Developer
Oct 13, 2009
5,734
1,671
Auckland, NZ
The reason I want a clean install is because when I bought the device, it had the 11.0.8.8 ROM on it, and I installed Magisk and rooted the device. Then I upgraded to the 11.0.9.9 rom, which I installed after deleting the Magisk program and root. However, after I installed the 11.0.9.9 rom, and with it I put the Magisk program back and rooted the device again, since then the notifications only come when I unlock the device screen. Sometimes it doesn't even ask for the SIM card code, as if there is no SIM card in it, the device behaves like that. Therefore I would like to have a completely clean installation.

It sounds like you've installed the incorrect kernel (boot image), the .img file with Magisk. You need to make sure you have the correct model (AA, BA, DA etc.) for your original ROM.

If you find the correct one and flash it, it will probably fix your problem.
 

Norbosz

Member
Jun 23, 2009
21
2
Budapest
It sounds like you've installed the incorrect kernel (boot image), the .img file with Magisk. You need to make sure you have the correct model (AA, BA, DA etc.) for your original ROM.

If you find the correct one and flash it, it will probably fix your problem.
I found the boot.img file here: https://forum.xda-developers.com/t/guide-magisk-for-oxygenos-11.4160833/page-20
As I can see, only GLOBAL is uploaded from version 11.0.9.9. I need the IN2013 version of this 11.0.9.9 boot.img file. Where can I download it?
 

Norbosz

Member
Jun 23, 2009
21
2
Budapest
Unfortunately the boot file you uploaded causes a bootloop on my phone. :( I discovered a mysterious thing with the rom version. My device's "model" type is IN2013 (which I think is Europe region), but the rom type is Oxygen OS 11.0.9.9.IN21AA (which is Global region). Am I right? Because then my device has for some reason a Global ROM installed by the manufacturer, although the model type is European. This could be the cause of the problems I sometimes have, for example when I turn on the device, sometimes it doesn't recognise the SIM card.

How do you suggest I can fix my device?

Screenshot_20211221-010451.jpg
 

djmcnz

Retired Recognized Developer
Oct 13, 2009
5,734
1,671
Auckland, NZ
Unfortunately the boot file you uploaded causes a bootloop on my phone. :( I discovered a mysterious thing with the rom version. My device's "model" type is IN2013 (which I think is Europe region), but the rom type is Oxygen OS 11.0.9.9.IN21AA (which is Global region). Am I right? Because then my device has for some reason a Global ROM installed by the manufacturer, although the model type is European. This could be the cause of the problems I sometimes have, for example when I turn on the device, sometimes it doesn't recognise the SIM card.

How do you suggest I can fix my device?

View attachment 5488183

Have you tried with the files in my post here:


?

It shouldn't matter that you have an IN2013, the Global ROM should still work. However, if you want to factory reset your phone back to European ROM you'll need to use the full IN2013 package.
 

Norbosz

Member
Jun 23, 2009
21
2
Budapest
Have you tried with the files in my post here:


?

It shouldn't matter that you have an IN2013, the Global ROM should still work. However, if you want to factory reset your phone back to European ROM you'll need to use the full IN2013 package.

Yes, I am currently using this Global version boot.img on my phone. So then the model type of the phone and the rom type are independent, not the one causing the anomalies? Also the icons are slipping on the screen.

In any case, I discovered the following problems in the rom:
- When the phone is switched on, sometimes it does not see the SIM card, it does not ask for the sim card code either. When I restart it again it fixes many cases.
- I have slipped these two icons in the menu.

If there is a way, I would like to reinstall my phone with a completely clean installation. I just don't want to brick it.

Screenshot_20211221-090810.jpg
 

djmcnz

Retired Recognized Developer
Oct 13, 2009
5,734
1,671
Auckland, NZ
I also have the slipped icons since 11.0.9.9.

If you want to return to stock just have a look at some of the stock ROM threads around here, it's reasonably difficult to brick your phone, don't be too concerned.
 

Danny1976

Senior Member
Sep 27, 2009
661
162
Sanford
Will the full OTA OxygenOS 11.0.10.10.IN21AA for OP8 will ever come out?
 

Attachments

  • Screenshot_20220126-212854.jpg
    Screenshot_20220126-212854.jpg
    343.9 KB · Views: 28

Top Liked Posts