Oneplus 8T (Cyberpunk Edition)

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Update worked, however I need to highlight that seems buggy to me (Stutter and other stuff)

    Ok. So I got Global update (OTA, incremental, around 500 MB size).
    I updated and it worked (with all cyberpunk elements working and nothing changed).


    1) Cyberpunk8T Phone at Global OOS, and showing receiving new update under system-update:

    2) Downloading Global OOS update. Not full update, OTA, incremental, around 500 MB size:

    3) Booting to Global OOS after update and restart (it took a bit more time while booting, but worked at the end):

    4) Showing updated phone to Global OOS with cyberpunk elements intact:

    So, I think flashing cyberpunk cust on both slots before, and then relocking and updating did work.
    Below I will put the steps I took (please note that I tried this on Global version, no idea if EU or IN is the same).


    -1) If you received phone on HOS, do full local update into next HOS in order to ensure cust is flashed to the other slot. (preferably do 2 HOS full local updates just to ensure, recommended versions are OnePlus8T_Hydrogen_11.0.4.5_15.H.19_KB05, and OnePlus8T_Hydrogen_11.0.5.6_15.H.20_KB05. (another option would be to flash cust at this stage, but I am just stating what I did personally).

    0) Use MSM tool to convert to Global OOS (check thread and forums for this step)

    1) Now your cyberpunk 8T phone should be on OOS, and you have all cyberpunk elements working (this is important as it points that param flag for cyberpunk is active)

    2) Unlock bootloader and root the phone (credit to @Kihara777 )
    (for full info about this step check )
    (for root info read )

    2a) download this image:!AsJy8Rcn_wjLhLwuunq7W9seKfKT7Q?e=vTKQd0
    2b) Use below commands in adb to push the cust images (google how to to adb commands).
    adb push H19_OTA-oem_cust1-raw.img /sdcard/oc1.img
    (I actually unziped and copied the file to phone root through windows and renamed it to oc1.img, then did adb shell in cmd, and ran the below commands)
    dd if=/sdcard/oc1.img of=/dev/block/bootdevice/by-name/oem_cust1_a
    dd if=/sdcard/oc1.img of=/dev/block/bootdevice/by-name/oem_cust1_b
    2c) remove root and relock the bootloader (optional)

    [Alternative to step 2 if you cannot root][Tested by @lexcyn Thanks! ]
    2) Unlock bootloader
    2i) download this file:!AsJy8Rcn_wjLhLwtuwnEWCG4E1bNMQ?e=iRf5jm
    2ii) flash through fastboot using these commands
    fastboot flash oem_cust1_a H19_OTA-oem_cust1-sparse.img
    fastboot flash oem_cust1_b H19_OTA-oem_cust1-sparse.img
    2iii) relock the bootloader (optional)

    3) After rebooting the phone, you should have all elements, and OTA incremental updates should not affect your cyberpunk elements or cause bootloop

    This what have worked for me. Please familiarize yourself on how to unbrick just in case things did not go well.

    Edit: fixed OOS video link, and info about the adb commands
    Edit2: flashing cust files using "dd" commands require the phone to be rooted. Alternatively, I added another flash commands using fastboot that not require root.
    So I have some good news (I think).

    I was trying to flash OxygenOS (Global and EU) on my HydrogenOS ( Cyberpunk8T. It ended me bricking my device. (Yes, I was fooling around with fastbootd >_<)
    I went to this thread:
    and used the MSM tool @OniAraAra linked:

    I was able to get back to HOS ( So this even downgraded my version, and I had all cyberpunk elements.

    Then it hit me. I was trying to figure out how did the sellers flash the global OOS.... and most of xda members here state that their device came on " ", and it had " SOME Cyberpunk things ".

    So I went and did an MSM restore on my Cyberpunk8T HOS ( to EU OOS (from unbrick-tool thread above). Guess what it worked. I was able to boot to EU OOS

    Then right away, I did a local OTA upgrade using full package EU OOS (

    I booted to EU OOS, have cyberpunk boot animation, wallpapers, theme, icon pack, and sounds (basically everything, let me know if I should check something specific).

    ps: I also heard that local upgrade is not available on Global or India OOS, thats why I tried it on EU. Not sure if one does EU MSM, then flash Global Full OTA locally if that might work or not.

    Uploading some videos (higher quality might some time to process)
    I received a Oneplus 8t (Cyberpunk Edition). The phone was supposed to have HydrogenOS as it is a Chinese phone. However, the vendor installed Global OxygenOS (KB05AA). After OTA updates, the phone wouldn't reboot and would get stuck on the Cyberpunk boot animation.



    I tried updating/restoring OxygenOS using the the MSM download tools here:

    Pros: Google Apps and a Global ROM.
    Cons: No OTA updates and no original Cyberpunk theme.

    Best case scenario for OxygenOS users would be for Oneplus to fix the OTA updates for Cyberpunk phones. This would stop the bootloop problem people are having.



    I have made a guide on how to restore HydrogenOS and add Google Apps:

    Pros: Working OTA updates, the original Cyberpunk theme, and Google Apps!
    Cons: A little bit of time and maintenance.


    Overall I would highly recommend trying the HydrogenOS solution I've linked above. It works excellent for me, so I won't be pursuing a solution for OxygenOS unless things change. The guide I wrote and linked above should get anyone with a Cyberpunk phone on to HydrogenOS (with OTA updates, original theme, and Google Apps).


    Bounty: Claimed by @Steve0007

    Up to @Arr6 if he still wants to match my donation for the HydrogenOS solution.
    Still stuck at bootloop...
    I have done the following

    MSM to HOS then MSM to OOS (GLOBAL) - local update to newest update full zip (GLOBAL)= bootloop

    MSM to HOS then MSM to OOS (EU) - local update to newest update full zip (EU) = bootloop

    Cyberpunk goodies only work on HOS so far...

    I'm kind of out of ideas, any suggestion?

    OK, so i finally got Oxygen OS (Global/USA) Running on my Oneplus 8T Cyberpunk edition (KB2000) with all the Cyberpunk goodies.. .

    After all the previously mentioned attempts this is what got me through:

    1.- MSM to Hydrogen OS using the link provided at OP.
    2.-- Update Hydrogen OS to using OTA update (incremental update directly on the phone).
    3.- Once Hydrogen complete update to Turn phone OFF.
    4.- MSM to Oxygen OS to
    5.- Once Oxygen OS boot up, loaded FULL zip update (Provided on OnePlus website) to the phone's root directory.
    6.- Perform a Local update through the "gear" icon under the system update section.
    7.- voilà!!!

    If you guys have any questions in regards of what i did, feel free to ask me.
    Best of luck~
    So to flash using dd commands, you need to be rooted (sorry I did not notice that at first). See

    However, I think flashing the parse images through fastboot might work without being rooted. if someone want to test that here are the steps:

    i) download this file:!AsJy8Rcn_wjLhLwtuwnEWCG4E1bNMQ?e=iRf5jm
    ii) flash through fastboot using these commands
    fastboot flash oem_cust1_a H19_OTA-oem_cust1-sparse.img
    fastboot flash oem_cust1_b H19_OTA-oem_cust1-sparse.img

    I will update my original post to state that flashing through dd command need root, and add this above info as unconfirmed (until someone can test?)
    Was just going to post this - the other command is if you are rooted.

    This worked for me by the way, THANK YOU.

    I was already on OOS so I:

    1) Unlocked bootloader
    2) Flashed cust to a & b via fastboot
    3) Relocked bootloader
    4) Set up phone and restored from my OnePlus backup
    5) Downloaded / installed OTA

    Worked a treat and still have all of the Cyberpunk goodies!

    [Edit] Also worth mentioning I don't have any of the lag issues on the new update, but probably since I wiped the phone and updated.