• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Oneplus 9 pro bricked, impossible to get to EDL

Search This thread

Tornadeur

Member
Apr 29, 2017
5
0
Hey all,

So i've unlocked by bootloader, flashed a custom recovery to then proceed with LineageOS flashing. However it went completely wrong as on reboot i'm stuck with the bootloader unlocked warning and then a blackscreen.

I still have access to fastboot mode however it's impossible to flash a customer recovery ("No Such Partition") and also impossible to directly "fastboot boot recovery.img" as the phone simply reboots on the warning and then blackscreen.

The only solution seems to get the device to qualcomm EDL mode and reflash all with the MSM tool (which I have as well as all the drivers) however I cannot get my Oneplus 9 pro to EDL mode...

I've tried all the fastboot commands (fastboot oem EDL, fastboot reboot EDL, none of them work) as well as the combination volume UP + volume DOWN + plugging the cable (it just boots the fastboot mode.


Honestly would greatly appreciate any help as it is the first time in a decade I hard bricked a phone like this as it seems all the partitions are broken.
 

dkcats3

Senior Member
Sep 13, 2013
242
109
OnePlus 9 Pro
Google Pixel 6 Pro
Make sure you have it unplugged when you do the button combos, as it will just start to boot while it's plugged in. Also, if you can reach fastboot, you can almost definitely reach EDL. Try unplugging and holding power+vol up for a bit which forces it to completely power off. Then try getting into EDL through the normal button combo/plugging. This is what I had to do since once it got into the booting/no-booting cycle I couldn't get to EDL.
 
  • Love
Reactions: SomeRandomGuy

djsubterrain

Senior Member
Jan 4, 2012
4,023
3,746
Livingston
OnePlus 9 Pro
1] Make sure you have it connected directly to your computer via USB port rather than via a USB Hub, I've seen that cause the device not to show up in the device manager.
2] You might have to restart your computer with driver signing disabled, check here for instructions for that
3] I've uploaded the Qualcomm drivers here
4] Make sure you use POWER + VOL DOWN + VOL UP and watch your device manager to see if the device is there
5] Make sure you choose the correct MSM tool from here for your region/provider
6] Remember to use MsmDownloadTool V4.0.exe, choose "User type : Others" and choose the correct device/region under the top "Target" dropdown.
7] If you don't see any COM device showing connected then try changing USB port or rebooting the device back into EDL mode.
 

terlynn4

Senior Member
Aug 18, 2012
404
211
Fort Worth, TX
Nexus 9
OnePlus 9 Pro
Good advice above.

Last time I couldn't reach EDL with my previous phone, it turned out to be an issue with the drivers I had installed. I uninstalled all Android-related drivers including some generic thing that showed up in device manager when plugging in the phone, then reinstalled the latest Qualcomm drivers.

Also possibly try a different USB cable if you have one. My OP9P didn't show up when the cable it came with was plugged into my USB-C port for some reason, but it worked fine with a generic Type-A to C cable I had sitting around.
 

Tornadeur

Member
Apr 29, 2017
5
0
Thanks a lot for the different guidelines !
i'm 100% sure the drivers are working. I have another oneplus 9 pro that is detected when booted on EDL mode on the PC. The faulty one however cannot reach it. Also it cannot get any charge as whenever I plug it on it just goes on a boot loop. Tried to leave it to charge for a full night but still shows the "out of battery logo" with the red cable.

When plugged to the PC while pressing VOLUME UP + VOLUME DOWN I keep getting the windows sound of device plugged/unpluged, etc etc...

To be honest I think the flashing messed up the partitions as it is now hard to do anything with this device...
 
Last edited:

Hunar999

Member
Sep 18, 2020
15
1
27
Thanks a lot for the different guidelines !
i'm 100% sure the drivers are working. I have another oneplus 9 pro that is detected when booted on EDL mode on the PC. The faulty one however cannot reach it. Also it cannot get any charge as whenever I plug it on it just goes on a boot loop. Tried to leave it to charge for a full night but still shows the "out of battery logo" with the red cable.

When plugged to the PC while pressing VOLUME UP + VOLUME DOWN I keep getting the windows sound of device plugged/unpluged, etc etc...

To be honest I think the flashing messed up the partitions as it is now hard to do anything with this device...
I can fix it bro pm me telegram .. @Hunar71
 

null0seven

Senior Member
Oct 1, 2013
3,279
1,316
Iasi
If you use Windows, you need to see "QDLOADER 9008" in Device Manager > Portable Devices.
When you got this it will work, 100% .
It worked for me a few days ago. My laptop runs on Windows 11 x64. And only have usb 3.0. NO usb 2.0.
 

Alberhasky

Senior Member
Mar 1, 2011
164
104
33
Jeffersonville
was having the hardest time as well, it's not that the device wasn't going to EDL mode, it was but it had the wrong driver installed, thus making MSM tool not detect it in time, it is a very small window that you have where the device goes into EDL mode and the MSM tool detects it, makes a handshake with it and starts the process, but if you have the wrong driver, MSM tool will not detect the device and the device will just turn back into fastboot mode, I'm attaching a picture of the device manager where the said driver is under "Ports" ( COM & LTP ) make sure you download the above mentioned drivers, if there is any other driver under Ports, uninstall it and whenever you plug in your phone with the VOL + VOL - combo, you will see the device appear under PORTS, upgrade the currently installed driver for the one called qcmdm.inf which you'll find after you extract the .cab file that you downloaded previously, after that open MSM Tool and hit start, the port number should match the one on the device manager, now unplug the cable from your phone, power it off and do the button combination and then plug in the cable, MSM should instantly recognize the device and start the restoration.
 

Attachments

  • Device Manager.png
    Device Manager.png
    43.7 KB · Views: 232
  • Like
Reactions: xontax

xontax

Senior Member
Dec 17, 2011
224
41
was having the hardest time as well, it's not that the device wasn't going to EDL mode, it was but it had the wrong driver installed, thus making MSM tool not detect it in time, it is a very small window that you have where the device goes into EDL mode and the MSM tool detects it, makes a handshake with it and starts the process, but if you have the wrong driver, MSM tool will not detect the device and the device will just turn back into fastboot mode, I'm attaching a picture of the device manager where the said driver is under "Ports" ( COM & LTP ) make sure you download the above mentioned drivers, if there is any other driver under Ports, uninstall it and whenever you plug in your phone with the VOL + VOL - combo, you will see the device appear under PORTS, upgrade the currently installed driver for the one called qcmdm.inf which you'll find after you extract the .cab file that you downloaded previously, after that open MSM Tool and hit start, the port number should match the one on the device manager, now unplug the cable from your phone, power it off and do the button combination and then plug in the cable, MSM should instantly recognize the device and start the restoration.
Yeah make sure it's exactly the same name of that driver - worked for me on oneplus 9
 

ecera

Senior Member
Jun 11, 2013
217
99
If you have access to fastboot still. Try switching slots. Then going into EDL
 
1] Make sure you have it connected directly to your computer via USB port rather than via a USB Hub, I've seen that cause the device not to show up in the device manager.
2] You might have to restart your computer with driver signing disabled, check here for instructions for that
3] I've uploaded the Qualcomm drivers here
4] Make sure you use POWER + VOL DOWN + VOL UP and watch your device manager to see if the device is there
5] Make sure you choose the correct MSM tool from here for your region/provider
6] Remember to use MsmDownloadTool V4.0.exe, choose "User type : Others" and choose the correct device/region under the top "Target" dropdown.
7] If you don't see any COM device showing connected then try changing USB port or rebooting the device back into EDL mode.
Thanks a lot man. Saved my Day. First 9Pro successfully restored ;-) Thank you and merry Christmas to all.
 

rawshn

Senior Member
Sep 1, 2017
80
34
OnePlus 9R
Realme GT
Guys I do not need to use the MSM Tool Anywhere until I reach the step where my device is being successfully detected as "QDLOADER 9008" in my windows device manager correct?

Or does the MSM Application need to be running when I reboot to EDL mode?

I am following this guide.

Please help
 

Shooter7889

Senior Member
Mar 24, 2019
144
65
FLORENCE
OnePlus 7 Pro
OnePlus 8T
I always have phone powered off, and while holding both volume keys I plug it into USB cord(that is already plugged to pc) and then click on enum(button in msm screen) until it says connected then hurry and click start. Once it starts I can let go of volume keys.. Also more than likely u will need to click the box to "use lite firehose" or "Sahara communicaion" will keep failing.
 
  • Like
Reactions: rawshn

jwidel

Member
Jun 25, 2021
26
7
make sure you have oneplus 9 pro drivers and " qaulcomm incorporated - Ports" Driver) and ("qaulcomm communications inc-Net" Driver) so your phone in edl which will be already most likely be running before you plug it in. just hold down both volume buttons and plug in to the usb port to your pc and release once plugged in and start the msm tool and hit enum it should say connect provided that you have all the necessary drivers above so the pc usb port will be able to communicate/recognize you device. its never usually A 1 and done type of thing. everytime i brick my phone its always the 100th try before i get a com port connected and the software communicating successfully, so just be patient and take your time. you will get it back up and running,
 
  • Like
Reactions: rawshn

awsan

Senior Member
Apr 22, 2015
65
42
Hey, I wanted to ask in here instead of starting a new thread.

Right now I have an OP9p that wont boot to EDL (Only fastboot or Corrupt page)

I tried the fastboot commands but it won't work and it won't shut down, I have fixed multiple phones using MSM and know all the small issues and how to get around them but it's the first time finding a device that won't shut down and will keep rebooting tried volume up + Power for several seconds tried holding only power or the three.

Nothing it keeps rebooting and won't shut down for me to get into EDL.

Any ideas?

Thanks
 
  • Like
Reactions: galaxys

hallo dare

Senior Member
Jan 23, 2012
764
234
Hey, I wanted to ask in here instead of starting a new thread.

Right now I have an OP9p that wont boot to EDL (Only fastboot or Corrupt page)

I tried the fastboot commands but it won't work and it won't shut down, I have fixed multiple phones using MSM and know all the small issues and how to get around them but it's the first time finding a device that won't shut down and will keep rebooting tried volume up + Power for several seconds tried holding only power or the three.

Nothing it keeps rebooting and won't shut down for me to get into EDL.

Any ideas?

Thanks
 
  • Like
Reactions: awsan and galaxys

jwidel

Member
Jun 25, 2021
26
7
Hey, I wanted to ask in here instead of starting a new thread.

Right now I have an OP9p that wont boot to EDL (Only fastboot or Corrupt page)

I tried the fastboot commands but it won't work and it won't shut down, I have fixed multiple phones using MSM and know all the small issues and how to get around them but it's the first time finding a device that won't shut down and will keep rebooting tried volume up + Power for several seconds tried holding only power or the three.

Nothing it keeps rebooting and won't shut down for me to get into EDL.

Any ideas?

Thanks
 

jwidel

Member
Jun 25, 2021
26
7
Well you have a corrupted boot.img or you would not be trying to edl. Also you probably are holding down multiple buttons to power off to your phone and your either not remembering or forgot that these combination of buttons are booting you into other modes fastboot, recovery or system.
 
  • Like
Reactions: awsan

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hey, I wanted to ask in here instead of starting a new thread.

    Right now I have an OP9p that wont boot to EDL (Only fastboot or Corrupt page)

    I tried the fastboot commands but it won't work and it won't shut down, I have fixed multiple phones using MSM and know all the small issues and how to get around them but it's the first time finding a device that won't shut down and will keep rebooting tried volume up + Power for several seconds tried holding only power or the three.

    Nothing it keeps rebooting and won't shut down for me to get into EDL.

    Any ideas?

    Thanks
    1
    I always have phone powered off, and while holding both volume keys I plug it into USB cord(that is already plugged to pc) and then click on enum(button in msm screen) until it says connected then hurry and click start. Once it starts I can let go of volume keys.. Also more than likely u will need to click the box to "use lite firehose" or "Sahara communicaion" will keep failing.
    1
    make sure you have oneplus 9 pro drivers and " qaulcomm incorporated - Ports" Driver) and ("qaulcomm communications inc-Net" Driver) so your phone in edl which will be already most likely be running before you plug it in. just hold down both volume buttons and plug in to the usb port to your pc and release once plugged in and start the msm tool and hit enum it should say connect provided that you have all the necessary drivers above so the pc usb port will be able to communicate/recognize you device. its never usually A 1 and done type of thing. everytime i brick my phone its always the 100th try before i get a com port connected and the software communicating successfully, so just be patient and take your time. you will get it back up and running,
    1
    Hey, I wanted to ask in here instead of starting a new thread.

    Right now I have an OP9p that wont boot to EDL (Only fastboot or Corrupt page)

    I tried the fastboot commands but it won't work and it won't shut down, I have fixed multiple phones using MSM and know all the small issues and how to get around them but it's the first time finding a device that won't shut down and will keep rebooting tried volume up + Power for several seconds tried holding only power or the three.

    Nothing it keeps rebooting and won't shut down for me to get into EDL.

    Any ideas?

    Thanks
    1
    Well you have a corrupted boot.img or you would not be trying to edl. Also you probably are holding down multiple buttons to power off to your phone and your either not remembering or forgot that these combination of buttons are booting you into other modes fastboot, recovery or system.
  • 3
    1] Make sure you have it connected directly to your computer via USB port rather than via a USB Hub, I've seen that cause the device not to show up in the device manager.
    2] You might have to restart your computer with driver signing disabled, check here for instructions for that
    3] I've uploaded the Qualcomm drivers here
    4] Make sure you use POWER + VOL DOWN + VOL UP and watch your device manager to see if the device is there
    5] Make sure you choose the correct MSM tool from here for your region/provider
    6] Remember to use MsmDownloadTool V4.0.exe, choose "User type : Others" and choose the correct device/region under the top "Target" dropdown.
    7] If you don't see any COM device showing connected then try changing USB port or rebooting the device back into EDL mode.
    2
    Hey, I wanted to ask in here instead of starting a new thread.

    Right now I have an OP9p that wont boot to EDL (Only fastboot or Corrupt page)

    I tried the fastboot commands but it won't work and it won't shut down, I have fixed multiple phones using MSM and know all the small issues and how to get around them but it's the first time finding a device that won't shut down and will keep rebooting tried volume up + Power for several seconds tried holding only power or the three.

    Nothing it keeps rebooting and won't shut down for me to get into EDL.

    Any ideas?

    Thanks
    1
    Make sure you have it unplugged when you do the button combos, as it will just start to boot while it's plugged in. Also, if you can reach fastboot, you can almost definitely reach EDL. Try unplugging and holding power+vol up for a bit which forces it to completely power off. Then try getting into EDL through the normal button combo/plugging. This is what I had to do since once it got into the booting/no-booting cycle I couldn't get to EDL.
    1
    was having the hardest time as well, it's not that the device wasn't going to EDL mode, it was but it had the wrong driver installed, thus making MSM tool not detect it in time, it is a very small window that you have where the device goes into EDL mode and the MSM tool detects it, makes a handshake with it and starts the process, but if you have the wrong driver, MSM tool will not detect the device and the device will just turn back into fastboot mode, I'm attaching a picture of the device manager where the said driver is under "Ports" ( COM & LTP ) make sure you download the above mentioned drivers, if there is any other driver under Ports, uninstall it and whenever you plug in your phone with the VOL + VOL - combo, you will see the device appear under PORTS, upgrade the currently installed driver for the one called qcmdm.inf which you'll find after you extract the .cab file that you downloaded previously, after that open MSM Tool and hit start, the port number should match the one on the device manager, now unplug the cable from your phone, power it off and do the button combination and then plug in the cable, MSM should instantly recognize the device and start the restoration.
    1

    Well you have a corrupted boot.img or you would not be trying to edl. Also you probably are holding down multiple buttons to power off to your phone and your either not remembering or forgot that these combination of buttons are booting you into other modes fastboot, recovery or system.
    Thanks a lot both of you for the help.

    I am well aware of the situation, as I mentioned this is not my first rodeo nor my 10th, and it was not the button combination.

    After the phone died EDL/fastboot worked normally and its now fixed.

    A tip for anyone in the future, if you are stuck in a fastboot/crashdump/corrupt bootlood and cant access EDL letting the phone's battery die is the best way to go.

    I tried switching boot slots, multiple fastboot commands, fastboot batch files that should force EDL, fastboot tools that should force EDL and everything under the sun.

    Other than the generic fastboot commands nothing worked and learned that Android when an OTA fails keeps trying to boot from either slots and will protect the system from a full wipe until the battery dies.