How To Guide OnePlus 9 Pro Notification Fix (UPDATED)

Search This thread

GreaterLesser

Senior Member
Sep 19, 2014
494
194
Chicago
OnePlus 9 Pro
Found this fix on Reddit - So far it has worked for me so I thought I'd share it here.

Non-Root Method:

Go to Settings -> Apps & Notifications -> Special app access -> Adaptive Notifications and Select NONE.

- Restart the phone

Rooted Method from ADB Shell (More of a semi-permanent fix) :

To Disable:
adb shell
su
pm disable com.google.android.ext.services/android.ext.services.notification.Assistant


To Enable: (if you want it back on)
adb shell
su
pm enable com.google.android.ext.services/android.ext.services.notification.Assistant

Hope this helps!!

Big thanks to @Sld_Ultra for finding/sharing the rooted Method!

(I've only tested this fix on OOS - I do NOT know how this affects custom ROMs)

Screenshot_20210912-122500.jpg
 
Last edited:

mlord

Senior Member
Aug 18, 2014
141
47
Tried it here. Still no notifications, but one change is that I no longer need to swipe down from within Gmail to see the new (non-notified) messages now.
 

RikiBez

Member
Feb 4, 2019
40
7
Milan
Found this fix on Reddit - So far it has worked for me so I thought I'd share it here.

In short, do the following:

Go to Settings -> Apps & Notifications -> Special app access -> Adaptive Notifications and Select NONE.

Restart the phone and enjoy on time notifications! So far I haven't noticed any impact on battery life.

Hope this helps!!

(I've only tested this fix on OOS - I do NOT know how this affects custom ROMs)

View attachment 5408221
Awesome. It worked.
Before finding this I've tried everything else without success.

Thanks a lot dude
 
  • Like
Reactions: tathagatab
D

Deleted member 11873231

Guest
Testing on the 9 non pro to see if any changes are made
 

Sld_Ultra

Senior Member
May 5, 2012
60
11
If anyone is still having an issue where settings are changing back to Adaptive Notifications from None, you can disable Adaptive Notifications with adb shell. Tested on OOS11 and MIUI (have to disable MIUI notification also), not sure if this is an issue on custom ROMs, but this may help and with other phones too. Root is required.

Disable:
adb shell
su
pm disable com.google.android.ext.services/android.ext.services.notification.Assistant

Enable: (if you want it back on)
adb shell
su
pm enable com.google.android.ext.services/android.ext.services.notification.Assistant

Now I finally get my Ring doorbell notifications on time.
 
  • Like
Reactions: GreaterLesser

GreaterLesser

Senior Member
Sep 19, 2014
494
194
Chicago
OnePlus 9 Pro
If anyone is still having an issue where settings are changing back to Adaptive Notifications from None, you can disable Adaptive Notifications with adb shell. Tested on OOS11 and MIUI (have to disable MIUI notification also), not sure if this is an issue on custom ROMs, but this may help and with other phones too. Root is required.

Disable:
adb shell
su
pm disable com.google.android.ext.services/android.ext.services.notification.Assistant

Enable: (if you want it back on)
adb shell
su
pm enable com.google.android.ext.services/android.ext.services.notification.Assistant

Now I finally get my Ring doorbell notifications on time.
Thanks for finding a more permanent fix - Do you mind if I add this to the original post so this doesn't get lost? I will of course mention you as thanks
 

Sld_Ultra

Senior Member
May 5, 2012
60
11
Do not have this on Color Os 12 C.36 stable global, phone LE2113, in Europa.
I think the notification system on Android 12 is different now. Think it's called "Enhanced Notifications", and when disabled it reverts back to android 11 notification system. Not sure what it means by it reverts back to "android 11 notification system." I don't plan on upgrading to android 12 yet, but hope android 12 fixed the notification issues.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    Found this fix on Reddit - So far it has worked for me so I thought I'd share it here.

    Non-Root Method:

    Go to Settings -> Apps & Notifications -> Special app access -> Adaptive Notifications and Select NONE.

    - Restart the phone

    Rooted Method from ADB Shell (More of a semi-permanent fix) :

    To Disable:
    adb shell
    su
    pm disable com.google.android.ext.services/android.ext.services.notification.Assistant


    To Enable: (if you want it back on)
    adb shell
    su
    pm enable com.google.android.ext.services/android.ext.services.notification.Assistant

    Hope this helps!!

    Big thanks to @Sld_Ultra for finding/sharing the rooted Method!

    (I've only tested this fix on OOS - I do NOT know how this affects custom ROMs)

    Screenshot_20210912-122500.jpg
    1
    Found this fix on Reddit - So far it has worked for me so I thought I'd share it here.

    In short, do the following:

    Go to Settings -> Apps & Notifications -> Special app access -> Adaptive Notifications and Select NONE.

    Restart the phone and enjoy on time notifications! So far I haven't noticed any impact on battery life.

    Hope this helps!!

    (I've only tested this fix on OOS - I do NOT know how this affects custom ROMs)

    View attachment 5408221
    Awesome. It worked.
    Before finding this I've tried everything else without success.

    Thanks a lot dude
    1
    If anyone is still having an issue where settings are changing back to Adaptive Notifications from None, you can disable Adaptive Notifications with adb shell. Tested on OOS11 and MIUI (have to disable MIUI notification also), not sure if this is an issue on custom ROMs, but this may help and with other phones too. Root is required.

    Disable:
    adb shell
    su
    pm disable com.google.android.ext.services/android.ext.services.notification.Assistant

    Enable: (if you want it back on)
    adb shell
    su
    pm enable com.google.android.ext.services/android.ext.services.notification.Assistant

    Now I finally get my Ring doorbell notifications on time.