• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ONLY FOR MDL BOOTLOADER] How to use 4.3 MK2 Modem and Retain Sound

Search This thread

shiamatsu

Senior Member
Nov 13, 2013
86
203
Cloudsdale
Note: This is for 4.2.2 MDL bootloader only! Not for 4.3 MK2 bootloader!
Note2: A 4.3 bootloader looks like this (i9505 is same as our phone):
attachment.php_.jpg

KNOX kernel lock and KNOX warranty void are the new things in the 4.3 bootloader that can break warranty easily via CF-Auto-Root.

So just now I remembered something from here: http://forum.xda-developers.com/showthread.php?t=2253528
To sum up, it says that the LTE Modem from 4.3 (MK2) would break sound. So to avoid that, just use the LTE modem from MDL and the GSM modem from MK2. I tried it and it works!

How to:
1. Download this zip: https://www.mediafire.com/?7tj2smth2vp1b7m
2. Extract the files inside the zip into anywhere you want, as long you remember where it is.
3. Put your phone into download mode (vol down+home)
4. Open odin, click on phone, select Modem_UVUAMDL.tar, untick auto-reboot, and press start.
5. When the install finishes, manually reboot it back to download mode.
6. Using odin again, click on phone, select modem.bin, untick auto-reboot, and press start.
7. When finished, reboot and you're done!
If you already have the MDL modem installed, just ignore steps 4 and 5.

To revert to MDL, skip steps 5-7 and only flash Modem_UVUAMDL.tar.

Credits to: @j_r0dd for the 4.3 modem, @mrvirginia for the 4.2.2 modem, and the devs over at the i9505 section for figuring out the trick
 
Last edited:

gdmlaz

Senior Member
Jul 16, 2010
1,976
606
Miami
If this works you are ****ing awesome lol

Question ??? Have you tried putting the phone to sleep in 4g mode on a 4.3 tw rom ??? or does it lose date like before ????
 

epsix

Senior Member
Aug 29, 2010
2,112
334
So just now I remembered something from here: http://forum.xda-developers.com/showthread.php?t=2253528
To sum up, it says that the LTE Modem from 4.3 (MK2) would break sound. So to avoid that, just use the LTE modem from MD8 and the GSM modem from MK2. I tried it and it works!

How to:
1. Download this zip: https://www.mediafire.com/?7tj2smth2vp1b7m
2. Extract the files inside the zip into anywhere you want, as long you remember where it is.
3. Put your phone into download mode (vol down+home)
4. Open odin, click on phone, select Modem_UVUAMDL.tar, untick auto-reboot, and press start.
5. When the install finishes, manually reboot it back to download mode.
6. Using odin again, click on phone, select modem.bin, untick auto-reboot, and press start.
7. When finished, reboot and you're done!

Finger cross :D

Sent from my SGH-M919 using Tapatalk 2
 
  • Like
Reactions: Tetin

gdmlaz

Senior Member
Jul 16, 2010
1,976
606
Miami

Crosses fingers..... Thinking about it I don't think this will work since we are basically staying with our old 2g/3g/4g Modem and just flashing the new LTE MODEM..... Our problem is the 2g/3g/4g modem which is the one that loses data when the screen is off our LTE modem works just fine


I HOPE I'M WRONG THO LOL
 
Last edited:

mrvirginia

Senior Member
Jun 12, 2010
4,403
2,699
36
Charlotte, NC
So just now I remembered something from here: http://forum.xda-developers.com/showthread.php?t=2253528
To sum up, it says that the LTE Modem from 4.3 (MK2) would break sound. So to avoid that, just use the LTE modem from MD8 and the GSM modem from MK2. I tried it and it works!

How to:
1. Download this zip: https://www.mediafire.com/?7tj2smth2vp1b7m
2. Extract the files inside the zip into anywhere you want, as long you remember where it is.
3. Put your phone into download mode (vol down+home)
4. Open odin, click on phone, select Modem_UVUAMDL.tar, untick auto-reboot, and press start.
5. When the install finishes, manually reboot it back to download mode.
6. Using odin again, click on phone, select modem.bin, untick auto-reboot, and press start.
7. When finished, reboot and you're done!

Credits to: @j_r0dd for the 4.3 modem @mrvirginia for the 4.2.2 modem

hahahaha :laugh: thanks mate! i thought i was going crazy for a second and that i was the only one with no sound!
 

gdmlaz

Senior Member
Jul 16, 2010
1,976
606
Miami
I have sound using the 4.3 modem and baseband on a 4.3 leak. No data drops either

you tried putting it on 4g mode and turning the screen off ?? Waiting on CWM to restore my backup to try it out also I really hope this works

Just tried it..... Doing this lets you make phone calls but DATA DROPS ARE STILL THERE WHEN USING A 4.3 TW ROM Blahhhh
 
Last edited:

omnifarious

Senior Member
Jul 6, 2010
378
288
Jacksonville
http://forum.xda-developers.com/showthread.php?t=2532714
I'm using the 1.4 full deodexed version. Used odin to flash the bin files and thats it. I lost root after flashing this rom but got it back by flashing superuser 1.43 zip

LOL, so my rom is the only one working with the new baseband? Maybe it was a build.prop edit.

Like my OP says, I used stock mj5 as the base. I simply copied and pasted all the files in the system dump over to the mj5 folder, overwriting any like files.

I'm thinking it's a simple build.prop edit. Why would the new baseband work with stock files if they don't work for other "stock" 4.3 tw international roms? That's the only difference I can see at the moment.

Looks like I'll have to continue my work on that rom. I can't download the odin image for MK2 from hotfile. I got to 1.1GB/1.4 one time and then it finally failed. I've tried at least 5 times and they all crap out. Hopefully someone will post a mirror soon.
 

philliman

Senior Member
Nov 23, 2007
1,175
280
Philly
LOL, so my rom is the only one working with the new baseband? Maybe it was a build.prop edit.

Like my OP says, I used stock mj5 as the base. I simply copied and pasted all the files in the system dump over to the mj5 folder, overwriting any like files.

I'm thinking it's a simple build.prop edit. Why would the new baseband work with stock files if they don't work for other "stock" 4.3 tw international roms? That's the only difference I can see at the moment.

Looks like I'll have to continue my work on that rom. I can't download the odin image for MK2 from hotfile. I got to 1.1GB/1.4 one time and then it finally failed. I've tried at least 5 times and they all crap out. Hopefully someone will post a mirror soon.

Your rom is the only leak I flashed and that was today!! Lol its pretty decent with the new modem/baseband!
 

The Sickness

Retired Recognized Developer
Oct 27, 2012
9,780
22,733
Somewhere in Texas
LOL, so my rom is the only one working with the new baseband? Maybe it was a build.prop edit.

Like my OP says, I used stock mj5 as the base. I simply copied and pasted all the files in the system dump over to the mj5 folder, overwriting any like files.

I'm thinking it's a simple build.prop edit. Why would the new baseband work with stock files if they don't work for other "stock" 4.3 tw international roms? That's the only difference I can see at the moment.

Looks like I'll have to continue my work on that rom. I can't download the odin image for MK2 from hotfile. I got to 1.1GB/1.4 one time and then it finally failed. I've tried at least 5 times and they all crap out. Hopefully someone will post a mirror soon.

Deleted....link aint working

I Think My S4 Is Insane

SICK MADE DEVELOPMENT
 
Last edited:
  • Like
Reactions: gquint90

gdmlaz

Senior Member
Jul 16, 2010
1,976
606
Miami
LOL, so my rom is the only one working with the new baseband? Maybe it was a build.prop edit.

Like my OP says, I used stock mj5 as the base. I simply copied and pasted all the files in the system dump over to the mj5 folder, overwriting any like files.

I'm thinking it's a simple build.prop edit. Why would the new baseband work with stock files if they don't work for other "stock" 4.3 tw international roms? That's the only difference I can see at the moment.

Looks like I'll have to continue my work on that rom. I can't download the odin image for MK2 from hotfile. I got to 1.1GB/1.4 one time and then it finally failed. I've tried at least 5 times and they all crap out. Hopefully someone will post a mirror soon.

Don't know how..... I was on ur rom and after installing the new basebands phone goes crazy when you try to make a phone call freezes up and u basically have to wait like 5min to use it again...... Have you tried flashing the new basebands and making a phone call ???
 

Top Liked Posts

  • There are no posts matching your filters.
  • 86
    Note: This is for 4.2.2 MDL bootloader only! Not for 4.3 MK2 bootloader!
    Note2: A 4.3 bootloader looks like this (i9505 is same as our phone):
    attachment.php_.jpg

    KNOX kernel lock and KNOX warranty void are the new things in the 4.3 bootloader that can break warranty easily via CF-Auto-Root.

    So just now I remembered something from here: http://forum.xda-developers.com/showthread.php?t=2253528
    To sum up, it says that the LTE Modem from 4.3 (MK2) would break sound. So to avoid that, just use the LTE modem from MDL and the GSM modem from MK2. I tried it and it works!

    How to:
    1. Download this zip: https://www.mediafire.com/?7tj2smth2vp1b7m
    2. Extract the files inside the zip into anywhere you want, as long you remember where it is.
    3. Put your phone into download mode (vol down+home)
    4. Open odin, click on phone, select Modem_UVUAMDL.tar, untick auto-reboot, and press start.
    5. When the install finishes, manually reboot it back to download mode.
    6. Using odin again, click on phone, select modem.bin, untick auto-reboot, and press start.
    7. When finished, reboot and you're done!
    If you already have the MDL modem installed, just ignore steps 4 and 5.

    To revert to MDL, skip steps 5-7 and only flash Modem_UVUAMDL.tar.

    Credits to: @j_r0dd for the 4.3 modem, @mrvirginia for the 4.2.2 modem, and the devs over at the i9505 section for figuring out the trick
    4
    Mk2 modem flashing

    If anyone here is still having MK2 modem.bin issues here is what I recommend:

    What I recommend is if you want the latest Wicked v9.1 Jellybean 4.3 based custom rom
    and you are still using Wicked v8 or any other custom rom which is based on Samsung 4.2.2
    firmware then all you need to do is to Odin flash the modem.bin in Odin's PHONE tab and
    then follow the step by step below in order to flash the MK2 modem.bin successfully.

    Download the MK2 Modem.bin if you don't already have it.
    Here is the direct download link for it: http://www.mediafire.com/download/1g...l89x/modem.bin

    Here are the exact step by step instructions for doing that, doing it this way worked fine for me.
    Before flashing anything be sure to make a nandroid backup of your rom.

    You can Odin flash the MK2 modem while you are still on the 4.2.2 rom or
    flash it after flashing the Wicked v9.1 rom the procedure is exactly the same.

    Before starting remove the battery from the phone for 20 seconds and put it back in.

    #1: Unplug the usb cable from your phone if it's already plugged in.
    #2: Start ODIN and put the MODEM.BIN file into ODIN'S PHONE tab.
    #3: Un-Check the "Auto-Reboot" checkbox in ODIN.
    #4: Put the phone into download mode
    #5: Plug the USB cable into the phone and into the computer.
    #6: Make sure that ODIN'S [COM:xx] lights up and click START..
    #7: After Odin is done flashing unplug the usb cable.
    #8: Manually power off the phone by using the power button only.
    #9: Wait 20 seconds or so and power on the phone.

    After flashing is done the baseband of the phone should display MK2 in
    Settings>More>About Device> Baseband version.

    If you crossed all your t's and dotted all your i's then you should be good to go.

    If all went well you can flash the Wicked v9.1 rom or any other 4.3 custom rom using cwm/twrp
    recovery just like when you flashed other roms in the past.

    KNOX - You only need to worry about knox if you are concerned about your phone's warranty
    in case you wanted to exchange or have it repaired other than that it really means nothing at all.

    All the information in this post applies equally whether you are concerned about KNOX or not.
    There's nothing in this post which effects the knox status of the phone unless you odin flash the stock 4.3 firmware.

    Before flashing any custom roms be sure you do a full clean wipe which includes wipe data, wipe
    system, wipe cache, wipe dalvik cache and last but not least do a "factory reset" in recovery.

    Before flashing anything you should always make a Nandroid backup first.

    Good luck!
    3
    I use T-Mobile S4 (M919) but with AT&T service. Would it benefit me if I update to Mk2? Has anyone done it yet?

    If you are not having any issues, then the MK2 modem will not provide any noticeable difference. Stick with MDL.

    hi,sorry for the nood question i'm on wicked 9.1 ROM,with baseband MK2 (odin modem.bin) my phone shows 4G/LTE now do I need to odin something else to get the full LTE? so confuse now.....how I know bootloader i'm? I was on wicked 4.2.2 before,only thing I did was to flash wicked 9.1 and odin modem.bin(so my baseband shows MK2) any Info will be appreciated.......

    I could be wrong but I believe that is only an icon difference. Check in your settings, more, about device, status to make sure you are on full LTE. And yes, you are on MDL bootloader with MK2 baseband. You can go into download mode and see if you have KNOX. If you don't, you are on 4.2.2 MDL. You can only flash the 4.3 modem on the MDL bootloader, you can't in a KNOX bootloader. So you are on 4.2.2 MDL bootloader and MK2 baseband ;)

    I know this might be a stupid question but I flashed the MK2 baseband for 4.2.2 on tmobile now sometimes my signal drops when I switch it to gsm so should I switch it to back to mdl ?

    This is a well known problem. The solution is to simply flash the 4.3 MK2 modem again. It will fix any signal issues you are having. Simply Odin (use the Phone slot instead of PDA) or MobileOdin (use modem#2 slot) to flash the 4.3 modem. Search for "4.3 modem" and you will find it. If it still doesn't fix it, then check your APN settings to make sure they are correct. If it still fails, go back to MDL baseband. You are only supposed to flash the 4.3 MK2 baseband when you are having issues with MDL. It is not a requirement when you go to 4.3 or 4.4. :)

    Sent from my SGH-M919 using XDA Premium 4 mobile app
    3
    i think OP deserves more thanks for figuring this out ;)

    edit: also adding this to the OP of my thread as soon as we get a 4.4 Kernel. big thanks again!
    2
    mine is C4B3D2DD0E24F48D208BC3987F163B5F

    That matches mine (and it worked):

    File: `G:\sgh919root\rootn_MK2modemOnly\modem.bin`
    md5sum: `c4b3d2dd0e24f48d208bc3987f163b5f` MATCH FOUND!
    SHA1: `6cf7bb48864f4192297dd25c115bcb72a43be6ca`
    SHA256: `89c645e77b2de2515ac8d3988095ac120e99a9c7e3977091698635fbdd88d74b`

    I started on a rooted MDL bootloader/modem/baseband running darthstalker 4.3 and only flashed the MK2 modem using odin(PC):
    Notes:
    i started odin first,
    then put the phone in download mode using the volume down+power+home button combo,
    then I plugged in the phone,
    unchecked auto-reboot and flashed only the MK2 modem,
    I waited ~2 minutes after the flash to unplug the phone and manually power cycle by holding down the power button.
    This was done on a US T-mobile sgh-m919.
    It worked the first time.

    -chlor3