[OP3/3T] Flashable Firmware+Modem ZIPs

Search This thread

storchp

Member
Mar 28, 2013
20
1
To update to the latest LOS 16 nightly (my previous one was from April this year) I had to update the modem firmware. So I downloaded and flashed the 9.0.5 for my OnePlus 3 here (+ Wipe Dalvik).
After the first reboot my unlock PIN didn't work anymore. I found a solution via TWRP to delete some unlock files from /data/system. After that I could unlock again and set a new PIN. So far so good. But the fingerprint sensor doesn't work anymore.
I searched around and found this thread: https://forums.oneplus.com/threads/fingerprint-not-working-atall.1054488/
According to it I should have a system app called "com.fingerprints.service.fingerprint", but that doesn't exist. Also the debug test via *#808# doesn't work (Error: Connection problem or invalid MMI code).
I also tried to downgrade to 9.0.4 according to this: https://www.reddit.com/r/oneplus/comments/cq623g/oneplus_3_power_button_issue_solved_905_firmware/
But didn't work either. Even more problems (e.g. hanging after unlocking). So I flashed 9.0.5 again.

I don't know if this is a problem of the 9.0.5 modem firmware or the latest LOS 16 nightly. Any hints what else I could try to fix it?
 

hellcat50

Senior Member
To update to the latest LOS 16 nightly (my previous one was from April this year) I had to update the modem firmware. So I downloaded and flashed the 9.0.5 for my OnePlus 3 here (+ Wipe Dalvik).
After the first reboot my unlock PIN didn't work anymore. I found a solution via TWRP to delete some unlock files from /data/system. After that I could unlock again and set a new PIN. So far so good. But the fingerprint sensor doesn't work anymore.
I searched around and found this thread: https://forums.oneplus.com/threads/fingerprint-not-working-atall.1054488/
According to it I should have a system app called "com.fingerprints.service.fingerprint", but that doesn't exist. Also the debug test via *#808# doesn't work (Error: Connection problem or invalid MMI code).
I also tried to downgrade to 9.0.4 according to this: https://www.reddit.com/r/oneplus/comments/cq623g/oneplus_3_power_button_issue_solved_905_firmware/
But didn't work either. Even more problems (e.g. hanging after unlocking). So I flashed 9.0.5 again.

I don't know if this is a problem of the 9.0.5 modem firmware or the latest LOS 16 nightly. Any hints what else I could try to fix it?
Already answered this question before in this thread. Search before posting/flashing
 

hearthacker1

Member
Aug 4, 2018
14
0
I am using skydragon Android 9 os on my OnePlus 3.
How can i upgrade to latest firmware 9.0.5?
Should i download the firmware and flash it normally? Or do i need to do something else?
 

nvertigo67

Senior Member
Dec 28, 2011
6,038
12,396

CyberCaptainKaz

Senior Member
Mar 1, 2015
137
24
Faced an issue with 9.0.6 for op3, tried flashing 9.0.6 with havoc (pie) and nano gapps gives an error. Error says that gapps cant be installed due to difference in architecture and tells that my device is 'arm' and not 'arm64'. Tried 9.0.5 and 9.0.4 I faced no issues its only when i try to install 9.0.6 will redownload 9.0.6 and update the post later.
 
  • Like
Reactions: Not-Aus

Viper The Ripper

Senior Member
Nov 6, 2012
2,457
1,245
Faced an issue with 9.0.6 for op3, tried flashing 9.0.6 with havoc (pie) and nano gapps gives an error. Error says that gapps cant be installed due to difference in architecture and tells that my device is 'arm' and not 'arm64'. Tried 9.0.5 and 9.0.4 I faced no issues its only when i try to install 9.0.6 will redownload 9.0.6 and update the post later.
You were on Havoc OS and tried to flash 9.0.6 FW? Isn't?
Which Gapps are you using? It's weird, just to know...
 
Last edited:
  • Like
Reactions: nvertigo67

nvertigo67

Senior Member
Dec 28, 2011
6,038
12,396
Faced an issue with 9.0.6 for op3, tried flashing 9.0.6 with havoc (pie) and nano gapps gives an error. Error says that gapps cant be installed due to difference in architecture and tells that my device is 'arm' and not 'arm64'. Tried 9.0.5 and 9.0.4 I faced no issues its only when i try to install 9.0.6 will redownload 9.0.6 and update the post later.

Would you like to share a detailed description of your starting setup (including software versions), a detailed description of the update procedure (what's exactly flashed [exact versions!] in which order, including reboots) and a recovery log (from the architecture error)?
 

CyberCaptainKaz

Senior Member
Mar 1, 2015
137
24
Would you like to share a detailed description of your starting setup (including software versions), a detailed description of the update procedure (what's exactly flashed [exact versions!] in which order, including reboots) and a recovery log (from the architecture error)?

Tried clean flashing havoc v2.9 (pie) with fw 9.0.6 and got the 'arm' error.

Steps I did,
Wiped cache, dalvik, data (as you do during for clean flashing a rom)
Installed fw 9.0.6
Installed havoc
Installed gapps and got the error saying that gapps is incompatible and that i had to use the 'arm' varient.

Now i flashed fw 9.0.5
Flashed havoc with nano gapps and magisk successfully.

But the weird thing is that, fw 9.0.6 worked fine with msm xtended 4.0 (Q) and nano gapps.

Gapps used were opengapps.
For pie - 20191029
For Q - 20191209-BETA
 

nvertigo67

Senior Member
Dec 28, 2011
6,038
12,396
Tried clean flashing havoc v2.9 (pie) with fw 9.0.6 and got the 'arm' error.

Steps I did,
Wiped cache, dalvik, data (as you do during for clean flashing a rom)
Installed fw 9.0.6
Installed havoc
Installed gapps and got the error saying that gapps is incompatible and that i had to use the 'arm' varient.

Now i flashed fw 9.0.5
Flashed havoc with nano gapps and magisk successfully.

But the weird thing is that, fw 9.0.6 worked fine with msm xtended 4.0 (Q) and nano gapps.

Gapps used were opengapps.
For pie - 20191029
For Q - 20191209-BETA

Too much different information: let us leave q alone for now. Let's use filename for exact versions.

Do you say if you flash Stable9.0.6 Firmware+Modem_OnePlus3.zip, havoc 2.9 (btw: which exact version? build or filename) and open_gapps-arm64-9.0-nano-20191029.zip with twrp-3.3.1-0 you get that architecture mismatch error?

But if you flash Stable9.0.5 Firmware+Modem_OnePlus3.zip, havoc 2.9 and open_gapps-arm64-9.0-nano-20191029.zip with twrp-3.3.1-0 it's working flawlessly?

Make sure with the exact filenames, before answering!

If that is the case, we need to see the log from the first case in order to help you.
 
Last edited:
  • Like
Reactions: accuphase

CyberCaptainKaz

Senior Member
Mar 1, 2015
137
24
Too much different information: let us leave q alone for now. Let's use filename for exact versions.

Do you say if you flash Stable9.0.6 Firmware+Modem_OnePlus3.zip, havoc 2.9 (btw: which exact version? build or filename) and open_gapps-arm64-9.0-nano-20191029.zip with twrp-3.3.1-0 you get that architecture mismatch error?

But if you flash Stable9.0.5 Firmware+Modem_OnePlus3.zip, havoc 2.9 and open_gapps-arm64-9.0-nano-20191029.zip with twrp-3.3.1-0 it's working flawlessly?

Make sure with the exact filenames, before answering!

If that is the case, we need to see the log from the first case in order to help you.

Yes and yes.

Well i tried to recreate the issue, but for some odd reason i couldn't. This time i didn't get the architecture error and the installation was a success. That's y i didn't reply till now. The rom was Havoc-OS-v2.9-20190913-oneplus3-Official.zip
 

mangokm40

Senior Member
Jan 13, 2019
159
85
I just flashed the 9.0.6. Neither the baseband, nor the Vendor patch date changed. Is that normal?

Thanx
 

Top Liked Posts

  • There are no posts matching your filters.
  • 86
    Flashable Firmware+Modem ZIPs by hellcat50

    Note:
    Code:
    This flashable zip will update or downgrade your Firmware and Modem Files of your OnePlus 3 or 3T.

    If you encounter any errors during the installation process, feel free to report it to me.
    Normally I test all the .zip files before I upload them, so everything should work fine.




    Current stable firmware version: OP3T: 9.0.6 | OP3: 9.0.6

    Download

    Dropbox
    MEGA


    Note: You will lose your data if you are coming from 5.0.x firmware and your storage is encrypted! If you want to upgrade from 5.0.x to 9.0.x firmware and update the ROM and don't want to clean flash, you can follow this guide in order to keep your data (only applies if your data is encrypted) (thanks to @nvertigo67):
    [GUIDE][MODDED FIRMWARE][9.0.6][OP3/T]The least annoying 9.0.x firmware
    29
    Stable 9.0.5 Firmware+Modem ZIPs for OP3 and 3T are now available!
    26
    OP3 and 3T Firmware+Modem ZIPs are up!
    22
    Stable 5.0.6 Firmware+Modem ZIPs added for OnePlus 3 and 3T!
    21
    Added Stable 5.0.5 Modem+Firmware ZIP