• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

OP7P need help, in process of rooting. stuck at Qualcomm crashdump screen.

Search This thread

mcd6288

New member
Apr 2, 2020
3
0
I've unlocked the boot loader, that was working fine and booting normally.
got a boot image and flashed it, now I boot to Qualcomm crashdump mode with the text:
dm-verity device corrupted Force Dump
kernel_restart

I can get back to the fastboot screen, where I've tried several methods of restoring my device.
I've since been back here to xda, and gotten both gm21AA and gm21ba folders from androidfilehost and neither one works with the flash-all.bat or extracting the images and flashing them manually via instructions from another thread https://forum.xda-developers.com/oneplus-7-pro/how-to/rom-stock-fastboot-roms-oneplus-7-pro-t3931424

I can't get it to connect to msmdownloadtool, even after downloading the qualcomm drivers to let it show ...9008... I'm stuck at the qualcomm crashdump screen and I need help please <3
 

harpin14789

Senior Member
Nov 17, 2012
1,799
789
Dallas
I've tried wiping everything I can, I can't wipe the usb storage but I'm assuming that's what the TWRP boot image is using so it won't let me do that xD. nothing changed I still boot to the qualcomm crash dump screen.

Try to switch to other slot and then wipe internal then yes. This happened to me a couple months back because I had corrupted data, you can't get rid of the crashdump till you wipe userdata. Twrp is on boot partition which is okay that's why you're able to get into Twrp.

Let me go and check my history and see what exactly I did to recover. I didn't have to use EDL and Qcm tool to recover.