[OP7TPRO TMO 5G][OOS 11.0.1.5 HD61CB] Unbrick tool to restore your device to OxygenOS

Search This thread

Shadow12347

Senior Member
Oct 26, 2011
79
21
Hey, so I am getting the same issue of "SMT config not found" error everytime I click start while the device is showing as 'connected'. Can you specify what you did that helped you solve this issue. I have spent a few hours re-downloading and using different PC's, and still cant figure it out.

Update: attached is a screenshot of what I am getting... Sadly, I just realized that I already had Persist.img from previously using 'Read Back' function, but I realized this as I saw it get overwritten when I decided to use Read Back function again today... :crying:

If anyone has an idea of what can help with this SMT issue, please let me know.

Update 2: I guess I should also ask, does anyone know if I need to lock my bootloader in order for this tool to work?


It should work regardless if the bootloader is unlocked or not. The problem is I think some parts of the program are set to expire after a certain date. I don't have the phone anymore, but what I did was close the program. Then disconnect your computer from the internet physically, so turn off WiFi, or remove ethernet cable. Assuming you're on Windows, right click the clock on the bottom right, and click "Change Date/Time". Turn off setting time automatically, and then change the date to something in December 2018 (at least I think that's what I used)... After that, it should open up and run normally, but if not try restarting (keeping internet disconnected), or try a different date either further back or closer to today's date.

Once the phone's restored, you can reset auto date/time, reconnect to internet, and then have windows update the time in the same menu so that the computer's back to normal.

This worked for me on one of the older versions, and I haven't had the phone for some time now, so I'm not sure if this will still work, but this is what fixed it for me.
 

pyckvi

Senior Member
Oct 16, 2009
54
2
Sacramento, CA
It should work regardless if the bootloader is unlocked or not. The problem is I think some parts of the program are set to expire after a certain date. I don't have the phone anymore, but what I did was close the program. Then disconnect your computer from the internet physically, so turn off WiFi, or remove ethernet cable. Assuming you're on Windows, right click the clock on the bottom right, and click "Change Date/Time". Turn off setting time automatically, and then change the date to something in December 2018 (at least I think that's what I used)... After that, it should open up and run normally, but if not try restarting (keeping internet disconnected), or try a different date either further back or closer to today's date.

Once the phone's restored, you can reset auto date/time, reconnect to internet, and then have windows update the time in the same menu so that the computer's back to normal.

This worked for me on one of the older versions, and I haven't had the phone for some time now, so I'm not sure if this will still work, but this is what fixed it for me.

OMG, It worked. I spent all day yesterday and couldn't figure it out. I even tried adjusting the time as you suggested here but didn't bother re-booting or disconnecting from the internet. Thank you man, This worked like a charm.
 

starcms

Senior Member
Hey, so I am getting the same issue of "SMT config not found" error everytime I click start while the device is showing as 'connected'. Can you specify what you did that helped you solve this issue. I have spent a few hours re-downloading and using different PC's, and still cant figure it out.

Update: attached is a screenshot of what I am getting... Sadly, I just realized that I already had Persist.img from previously using 'Read Back' function, but I realized this as I saw it get overwritten when I decided to use Read Back function again today... :crying:

If anyone has an idea of what can help with this SMT issue, please let me know.

Update 2: I guess I should also ask, does anyone know if I need to lock my bootloader in order for this tool to work?

I see the problem but I have no idea what's causing it or how to fix. The little drop-down menu that lets you select TMO is just missing from the MSM tool in your screenshot. It should be there as soon as you open the app -- has nothing to do with the phone. Maybe you either got a bad download or bad unzip of MSM tool? That's bizarre.

And u can run it with your bootloader locked or unlocked, makes no difference. But when you run it, it locks your bootloader if it was unlocked.

And works fine on Windows 10 here. 64bit Pro on a home-made desktop and a MSI laptop. Laptop only has USB 3.0/3.1 ports. Desktop has ATI GPU, Laptop is integrated Intel + discrete Geforce. So quite a bit of diversity there. Only ever used the original 1+ usb cable. I had the desktop on 1809 and the laptop on 1903 (19H1). Just upgraded both to 2004 (20H1) yesterday so hopefully that's not causing it.
 
Last edited:

pyckvi

Senior Member
Oct 16, 2009
54
2
Sacramento, CA
I see the problem but I have no idea what's causing it or how to fix. The little drop-down menu that lets you select TMO is just missing from the MSM tool in your screenshot. It should be there as soon as you open the app -- has nothing to do with the phone. Maybe you either got a bad download or bad unzip of MSM tool? That's bizarre.

And u can run it with your bootloader locked or unlocked, makes no difference. But when you run it, it locks your bootloader if it was unlocked.

And works fine on Windows 10 here. 64bit Pro on a home-made desktop and a MSI laptop. Laptop only has USB 3.0/3.1 ports. Desktop has ATI GPU, Laptop is integrated Intel + discrete Geforce. So quite a bit of diversity there. Only ever used the original 1+ usb cable. I had the desktop on 1809 and the laptop on 1903 (19H1). Just upgraded both to 2004 (20H1) yesterday so hopefully that's not causing it.

Its all good Starcms, Shadow12347 helped me figure it out already as I mentioned in the post above. As for the TMO not showing in the drop down menu, look like that isn't an issue at all, as I initially thought when I first tried using this program to backup my entire device before rooting it earlier in the year. I didn't realize it at first, but this tool did work exactly as intended without that TMO drop down menu being present. I did notice though that when I used the MSM download tool exe from the OnePlus 8 forum and replaced it with the one from this thread, the TMO option starts to show, so it looks like its a build issue of the program that doesnt really have any effects on the way it performs. Either way, Its all figured out thankfully.
 

flayzeraynx

Senior Member
i feel like an idiot now. Downloaded the 10.37 and unzipped the rar file. Then, when i run the app, it is asking me login.. and i select "other".. after that, can't see the target button at all.

and the other problem is, where i can see my device under device manager? to check if the drivers are correct, should i look under usb devices or what?
 

mslezak

Senior Member
Dec 12, 2016
409
403
Houston
Google Pixel 2
OnePlus 8T
It should work regardless if the bootloader is unlocked or not. The problem is I think some parts of the program are set to expire after a certain date. I don't have the phone anymore, but what I did was close the program. Then disconnect your computer from the internet physically, so turn off WiFi, or remove ethernet cable. Assuming you're on Windows, right click the clock on the bottom right, and click "Change Date/Time". Turn off setting time automatically, and then change the date to something in December 2018 (at least I think that's what I used)... After that, it should open up and run normally, but if not try restarting (keeping internet disconnected), or try a different date either further back or closer to today's date.

Once the phone's restored, you can reset auto date/time, reconnect to internet, and then have windows update the time in the same menu so that the computer's back to normal.

This worked for me on one of the older versions, and I haven't had the phone for some time now, so I'm not sure if this will still work, but this is what fixed it for me.

This in fact worked for me as well - I set the date to 2019, turned off auto-time and time-zone, and disconnected from WiFi and then there was no SMT Config file not found error!
 

batch519

Member
Oct 9, 2008
22
4
Omaha, NE
Thank you so much for doing this. You sir, are a mushroom cloud layin mofo!!

EDIT: If I re-unlock the bootloader so I can root, flash my kernel of choice, etc... this will happen again where OTA's won't work I'm assuming... Does anyone know why they won't allow unlocked bootloader 7t pro's to get OTAs?

Thanks,
Eric
 
Last edited:

Rx8Driver

Senior Member
Jan 12, 2014
1,800
1,282
My City
OnePlus 7T Pro McLaren
Thank you so much for doing this. You sir, are a mushroom cloud layin mofo!!



EDIT: If I re-unlock the bootloader so I can root, flash my kernel of choice, etc... this will happen again where OTA's won't work I'm assuming... Does anyone know why they won't allow unlocked bootloader 7t pro's to get OTAs?



Thanks,

Eric
It's not so much that they don't allow it, it's that the act of unlocking removes the reserve.img which is necessary to get the OTA... Whether this is by design, or just a side effect I can't begin to say...

Sent from my HD1925 using Tapatalk
 
It's not so much that they don't allow it, it's that the act of unlocking removes the reserve.img which is necessary to get the OTA... Whether this is by design, or just a side effect I can't begin to say...

That's definitely by design, all non carrier variants of OnePlus devices can get OTAs without any effort even if their bootloader is unlocked.
@batch519 you can restore reserve.img after unlocking bootloader if needed, see https://forum.xda-developers.com/7t...-fastboot-rom-ota-fixer-t4040629/post81591665 (last pages of the thread contain a .39 reserve.img)
 

Rx8Driver

Senior Member
Jan 12, 2014
1,800
1,282
My City
OnePlus 7T Pro McLaren
That's definitely by design, all non carrier variants of OnePlus devices can get OTAs without any effort even if their bootloader is unlocked.
@batch519 you can restore reserve.img after unlocking bootloader if needed, see https://forum.xda-developers.com/7t...-fastboot-rom-ota-fixer-t4040629/post81591665 (last pages of the thread contain a .39 reserve.img)

Yeah, that's the carriers for you. They're scared to death that someone will get something for nothing, smh. Oh well.....I, personally, am working with a T-mo branded 5G McLaren and I'm sitting here with a problem where I'm not getting the OTA's at all....Device just says I'm on the latest version, which is obviously wrong, because I'm on April's security update lol But when I unroot and check for updates? Nothing. I ran the reserve.img restore process the last time when I updated to .36, do I need to do it again? And if so, will it matter that I don't see the reserve.img for the version I'm on currently? I think it will matter. It'll be a real pain to have to reverse back to a version I've got just to update to the latest OTA....I'm curious about what all this "Standalone 5G" is going to mean for us McLaren users in real terms, out in the wild....
 

NotATreoFan

Senior Moderator / Developer Committee
Staff member
Yeah, that's the carriers for you. They're scared to death that someone will get something for nothing, smh. Oh well.....I, personally, am working with a T-mo branded 5G McLaren and I'm sitting here with a problem where I'm not getting the OTA's at all....Device just says I'm on the latest version, which is obviously wrong, because I'm on April's security update lol But when I unroot and check for updates? Nothing. I ran the reserve.img restore process the last time when I updated to .36, do I need to do it again? And if so, will it matter that I don't see the reserve.img for the version I'm on currently? I think it will matter. It'll be a real pain to have to reverse back to a version I've got just to update to the latest OTA....I'm curious about what all this "Standalone 5G" is going to mean for us McLaren users in real terms, out in the wild....

You only need to run the reserve.img repair one time, after unlocking the bootloader. As long as you didn't relock between updates, the file is still there.

I too had an issue with not getting the .34 (I think) OTA even with everything repaired, and the only fix was MSM back to stock. The OTA was immediately available after, even with the bootloader unlocked and the repair script ran. I've since gotten every OTA without having to do anything other than unroot.
 

Rx8Driver

Senior Member
Jan 12, 2014
1,800
1,282
My City
OnePlus 7T Pro McLaren
You only need to run the reserve.img repair one time, after unlocking the bootloader. As long as you didn't relock between updates, the file is still there.

I too had an issue with not getting the .34 (I think) OTA even with everything repaired, and the only fix was MSM back to stock. The OTA was immediately available after, even with the bootloader unlocked and the repair script ran. I've since gotten every OTA without having to do anything other than unroot.

Ahh man don't tell me that smh....and without TWRP to do a backup? ****. :eek: Just what I need......Guess I'll have to employ good ole Titanium Backup and backup everything at the app level, freaking MSM this thing, and then I guess I should get the OTA's....Idk why they're not coming....I wonder if there isn't a way to trigger them with a dialer code or something? Because you know, I got the first update after restoring the reserve.img file way back when I did it, but I never got another after that I don't think. And seriously, SOMEONE'S gotta get on this thing and get us a working TWRP recovery so we're not stuck having to MSM all the time just to restore a ROM back to stock. We should REALLY be able to backup and install zips and all that fun nonsense lol This stone age **** is getting me down! I just don't have time to work on it, and I don't think I can talk UITA into it since he doesn't have one lol
 

mexicandroid

Senior Member
Aug 12, 2011
1,532
320
Houston
Google Pixel 4a 5G
Ahh man don't tell me that smh....and without TWRP to do a backup? ****. :eek: Just what I need......Guess I'll have to employ good ole Titanium Backup and backup everything at the app level, freaking MSM this thing, and then I guess I should get the OTA's....Idk why they're not coming....I wonder if there isn't a way to trigger them with a dialer code or something? Because you know, I got the first update after restoring the reserve.img file way back when I did it, but I never got another after that I don't think. And seriously, SOMEONE'S gotta get on this thing and get us a working TWRP recovery so we're not stuck having to MSM all the time just to restore a ROM back to stock. We should REALLY be able to backup and install zips and all that fun nonsense lol This stone age **** is getting me down! I just don't have time to work on it, and I don't think I can talk UITA into it since he doesn't have one lol

So I just got this phone and I think it was a Retail unit. The IMEI number is clean, I was able to add my Gmail account and set it up just fine. The fingerprint sensor work just fine. I think it was a Retail unit because it has a Specs app and Retail app. The retail app doesn't give me an option to uninstall and it is different than the one available in the Playstore. That's ones if my issues which is minor.

The other issue is that it is stuck on the October 2019 security patch firmware. I also don't have the original cable. I just want to have everything stock, including locked bootloader encase I have to warranty out later on through my TMobile insurance.

Can I use any of the files to restore to stick so I can have OTA updates available?

Thanks in advance
 

NotATreoFan

Senior Moderator / Developer Committee
Staff member
So I just got this phone and I think it was a Retail unit. The IMEI number is clean, I was able to add my Gmail account and set it up just fine. The fingerprint sensor work just fine. I think it was a Retail unit because it has a Specs app and Retail app. The retail app doesn't give me an option to uninstall and it is different than the one available in the Playstore. That's ones if my issues which is minor.

The other issue is that it is stuck on the October 2019 security patch firmware. I also don't have the original cable. I just want to have everything stock, including locked bootloader encase I have to warranty out later on through my TMobile insurance.

Can I use any of the files to restore to stick so I can have OTA updates available?

Thanks in advance
I replied to your questions in the other thread. This is where you will find the files you need.
 

mexicandroid

Senior Member
Aug 12, 2011
1,532
320
Houston
Google Pixel 4a 5G
Had anybody attempted this process without the original cable? I haven't flashed anything since the Galaxy S4 and I read some people had issues with the factory cable on The Essential PH1 using that cable. ???? Kind of nervous
 

mexicandroid

Senior Member
Aug 12, 2011
1,532
320
Houston
Google Pixel 4a 5G
Had anybody attempted this process without the original cable? I haven't flashed anything since the Galaxy S4 and I read some people had issues with the factory cable on The Essential PH1 using that cable. ???? Kind of nervous


Quick easy clear instructions for the noobs or people that haven't flashed in years like lol

1. Ignore the part that says download the msm download

2. Just download one of the OTA files in the OP and look
For the msm download tool in there and open that file up and run as administrator just to be safe. When it asks for login just select other and click on next. I did mines in Windows 10 laptop.

3. I used a generic USB C cable from Amazon, didn't have the original cable and took a chance??. Mines kept jumping out of EDL mode so as soon the software recognized it I clicked on start and it finished the while process in 333 seconds.

4. If your computer doesn't recognize it in EDL mode install the Qualcomm drivers from here. It's an install file and you don't have to manually install it, it does it automatically https://androidfilehost.com/?fid=11410963190603862036



For my particular case it got rid of the retail Mode app and Tech Specs app. I was able to carrier unlock again. Good luck everybody
 
Last edited:

Rx8Driver

Senior Member
Jan 12, 2014
1,800
1,282
My City
OnePlus 7T Pro McLaren
Quick easy clear instructions for the noobs or people that haven't flashed in years like lol

1. Ignore the part that says download the msm download

2. Just download one of the OTA files in the OP and look
For the msm download tool in there and open that file up and run as administrator just to be safe. When it asks for login just select other and click on next. I did mines in Windows 10 laptop.

3. I used a generic USB C cable from Amazon, didn't have the original cable and took a chance??. Mines kept jumping out of EDL mode so as soon the software recognized it I clicked on start and it finished the while process in 333 seconds.

4. If your computer doesn't recognize it in EDL mode install the Qualcomm drivers from here. It's an install file and you don't have to manually install it, it does it automatically https://androidfilehost.com/?fid=11410963190603862036



For my particular case it got rid of the retail Mode app and Tech Specs app. I was able to carrier unlock again. Good luck everybody


You got it...the EDL mode only waits like maybe 3 seconds before it reboots on it's own, so you need to be ready with the MSM tool to start the reset before the device reboots...which is exactly what it sounds like you did :good:
 

mexicandroid

Senior Member
Aug 12, 2011
1,532
320
Houston
Google Pixel 4a 5G
You got it...the EDL mode only waits like maybe 3 seconds before it reboots on it's own, so you need to be ready with the MSM tool to start the reset before the device reboots...which is exactly what it sounds like you did :good:

I wasted so much time trying to find the correct msm download tool looking all around XDA and the internet when the whole time it was in the OTA files ?*♂️?*♂️?*♂️.
Also getting windows to manually update the Qualcomm EDL driver was a pain also. Luckily I find that installation software. After that it was smooth sailing.

At first I installed 10.0.39 and out of curiosity I tried to install 10.0.36 to see the of the OTA updates would work directly from TMobile. It didn't let me downgraded to that version so I tried to install 10.0.27 and it installed just fine.
I proceeded check for updates in the settings app and voila it worked and updated just fine. That was the main reason I went through all this and wanted to verify. Couldn't go back to sleep until I was sure it would work lol.

Also my phone was carrier unlocked before. After the installation I checked off it would unlock in the settings app and at first it said it was carrier locked at this time and not eligible to carrier unlock at this time. I excited the app and entered the network unlock section again and it said "this mobile device is permanently unlocked and can be used with any carrier".

I know I made a few posts but just want to help anybody that struggled and had the same questions about this process as me
 

Top Liked Posts

  • There are no posts matching your filters.
  • 31
    Disclaimer: By attempting any of the processes listed in this thread you accept full responsibility for your actions. I will not be held responsible if your device stops working, catches fire, or turns into a hipster and claims to have been modified before it was cool.

    Hi everyone, similar to the previous threads for
    OP3, OP3T, OP5, OP5T, OP6, OP6T, OP7, OP7PRO, regular OP7T, T-Mobile OP7T and regular OP7TPRO here are the EDL packages (also known as MSM tools or unbrick tools) that can revive a bricked OnePlus 7T Pro 5G McLaren bought from T-Mobile.
    They can also be used to rollback your phone to a previous release of OOS if for some reason you want to go back to an older firmware :)

    It will only work with 5G T-Mobile variant HD1925

    You can download the following versions:

    ANDROID 10:


    ANDROID 11:

    11.0.1.5 HD61CB

    Mirror for first and last MSMs: https://onepluscommunityserver.com/


    Instructions:

    Launch MsmDownloadTool V4.0.exe.

    Specific to 10.0.27 and up

    On the login prompt select "Other" in the dropdown menu and click on Next.
    Wait a few seconds until main window shows up.


    Click on Target button and select T-MO if it hasn't been automatically.
    Power your device off.
    Maintain volume up and volume down keys to get into Qualcomm EDL mode.
    Plug your device to your computer using stock OnePlus cable.
    Click on Enum to be sure your device is detected and press Start.
    Wait ~300 seconds.
    Enjoy your brand new device.

    FAQ:

    Will this fix OTAs I couldn't receive after unlocking bootloader?

    Yes. Mind it will however wipe all of your internal storage and relock bootloader automatically (but you shouldn't have to reapply for an unlock token if your bootloader was unlocked previously).

    Does this work on Mac or on Linux?

    Unfortunately no, tool is Windows only. You should need at least Windows 7.

    Why is my antivirus freaking out when unzipping the archive or running the tool?

    In an effort to protect reverse engineering from being done (and by extension prevent conversion process like it was done on 6T and 7Pro), OnePlus now use VM Protect V3 in their MSM tools. As this tries to detect debug environment, this is seen as malicious behaviour by some antivirus.

    My device isn't detected when I click on "Enum" button

    Go to device manager and make sure your phone shows up as QDLOADER 9008.
    If it shows up as QHUSB_BULK, it means Qualcomm driver wasn't installed automatically by Windows Update. Download the latest one from Microsoft website at http://download.windowsupdate.com/c..._fba473728483260906ba044af3c063e309e6259d.cab (source https://www.catalog.update.microsof...updateid=8ee52ba0-bdef-4009-88cf-335a678dd67a ) and install it manually by right clicking on QHUSB_BULK and selecting "Update driver software" and "Browse my computer for driver software" to where you downloaded CAB file.

    MSM tool is stuck on "Param pre-processing"

    Ensure you're using the Qualcomm drivers linked above.

    MSM tool is stuck on "Sahara communication failed"

    Unplug your phone, get in fastboot mode, turn off phone, wait 15 secondes and get back in Qualcomm EDL mode. You can also try using a USB 2.0 port instead of a 3.0 one.

    What is SMT Download mode?

    Just don't try to unlock that mode, it will wipe your IMEI and your Widevine certificate if you use it.

    How can I fix "SMT config not found" error?

    Please refer to https://forum.xda-developers.com/showpost.php?p=83448961&postcount=61, all credits to @Shadow12347 for finding it out.

    Credits:

    @omariscal1019 for getting 10.0.27 version from OnePlus
    @a63548 for getting 10.0.19 version from OnePlus
    An anonymous user for unblocking situation with OnePlus CS (they kept sending package meant for 7T T-Mobile)
    @jhofseth for decryption of 10.0.19 tool
    @xian1243 and @omariscal1019 for testing 10.0.13 version, @twinnfamous for testing 10.0.13 and 10.0.16 versions, @ntzrmtthihu777 for testing 10.0.13 , 10.0.16 and 10.0.19 versions, @DanDroidOS for testing 10.0.19 version, and @me2151 for testing 11.0.1.5 version.
    @Titokhan for being a friend and providing inspiration in writing
    @headsh0t95 for being a friend and suggesting me to request an access to upload files on AndroidFileHost now one year ago for my previous threads
    @AndroidFileHost for the hosting
    Votton for providing a server as an alternative mirror
    OnePlus for the device and OS
    6
    Added OOS 10.0.42 MSM tool.
    6
    It's real and was tested extensively. We also used them to complete our reserve.img collection.
    6
    Added OOS 10.0.41 MSM tool.
    5
    Added OOS 10.0.34 MSM