[OP7TPRO TMO 5G][OOS 11.0.1.5 HD61CB] Unbrick tool to restore your device to OxygenOS

Search This thread

abdelaziz88

New member
Oct 14, 2022
2
0
guys Please I need help !!!
so now On My OnePlus 7t pro-maclaren HD1910 after I install the Qualcomm driver and it shows to me in the device manager as ( Qualcomm HS-USB QDLoader 9008 COM9) and I think until that moment everything is okay Then I run MSM as an administrator then I pressed Volume UP + Down until it's gone to EDL Mode then I plugged the phone and it doesn't connect at all I have tried that thousand time and it doesn't work what should I do guys please Help !!!???
 

Attachments

  • IMG_20221014_035756.jpg
    IMG_20221014_035756.jpg
    1.6 MB · Views: 10
  • IMG_20221014_014007.jpg
    IMG_20221014_014007.jpg
    7.3 MB · Views: 11
  • IMG_20221014_012953.jpg
    IMG_20221014_012953.jpg
    4.6 MB · Views: 12
Last edited:

LillyLaFrog

New member
Apr 3, 2022
2
0
my sound stopped working after this. I heard that some devices need the battery unplugged, but it still didn't work after that. I got them working once for like 4 hours, but stopped working at the next restart. Does anyone know how to solve my issue?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 32
    Disclaimer: By attempting any of the processes listed in this thread you accept full responsibility for your actions. I will not be held responsible if your device stops working, catches fire, or turns into a hipster and claims to have been modified before it was cool.

    Hi everyone, similar to the previous threads for
    OP3, OP3T, OP5, OP5T, OP6, OP6T, OP7, OP7PRO, regular OP7T, T-Mobile OP7T and regular OP7TPRO here are the EDL packages (also known as MSM tools or unbrick tools) that can revive a bricked OnePlus 7T Pro 5G McLaren bought from T-Mobile.
    They can also be used to rollback your phone to a previous release of OOS if for some reason you want to go back to an older firmware :)

    It will only work with 5G T-Mobile variant HD1925

    You can download the following versions:

    ANDROID 10:


    ANDROID 11:

    11.0.1.5 HD61CB

    Mirror for first and last MSMs: https://onepluscommunityserver.com/


    Instructions:

    Launch MsmDownloadTool V4.0.exe.

    Specific to 10.0.27 and up

    On the login prompt select "Other" in the dropdown menu and click on Next.
    Wait a few seconds until main window shows up.


    Click on Target button and select T-MO if it hasn't been automatically.
    Power your device off.
    Maintain volume up and volume down keys to get into Qualcomm EDL mode.
    Plug your device to your computer using stock OnePlus cable.
    Click on Enum to be sure your device is detected and press Start.
    Wait ~300 seconds.
    Enjoy your brand new device.

    FAQ:

    Will this fix OTAs I couldn't receive after unlocking bootloader?

    Yes. Mind it will however wipe all of your internal storage and relock bootloader automatically (but you shouldn't have to reapply for an unlock token if your bootloader was unlocked previously).

    Does this work on Mac or on Linux?

    Unfortunately no, tool is Windows only. You should need at least Windows 7.

    Why is my antivirus freaking out when unzipping the archive or running the tool?

    In an effort to protect reverse engineering from being done (and by extension prevent conversion process like it was done on 6T and 7Pro), OnePlus now use VM Protect V3 in their MSM tools. As this tries to detect debug environment, this is seen as malicious behaviour by some antivirus.

    My device isn't detected when I click on "Enum" button

    Go to device manager and make sure your phone shows up as QDLOADER 9008.
    If it shows up as QHUSB_BULK, it means Qualcomm driver wasn't installed automatically by Windows Update. Download the latest one from Microsoft website at http://download.windowsupdate.com/c..._fba473728483260906ba044af3c063e309e6259d.cab (source https://www.catalog.update.microsof...updateid=8ee52ba0-bdef-4009-88cf-335a678dd67a ) and install it manually by right clicking on QHUSB_BULK and selecting "Update driver software" and "Browse my computer for driver software" to where you downloaded CAB file.

    MSM tool is stuck on "Param pre-processing"

    Ensure you're using the Qualcomm drivers linked above.

    MSM tool is stuck on "Sahara communication failed"

    Unplug your phone, get in fastboot mode, turn off phone, wait 15 secondes and get back in Qualcomm EDL mode. You can also try using a USB 2.0 port instead of a 3.0 one.

    What is SMT Download mode?

    Just don't try to unlock that mode, it will wipe your IMEI and your Widevine certificate if you use it.

    How can I fix "SMT config not found" error?

    Please refer to https://forum.xda-developers.com/showpost.php?p=83448961&postcount=61, all credits to @Shadow12347 for finding it out.

    Credits:

    @omariscal1019 for getting 10.0.27 version from OnePlus
    @a63548 for getting 10.0.19 version from OnePlus
    An anonymous user for unblocking situation with OnePlus CS (they kept sending package meant for 7T T-Mobile)
    @jhofseth for decryption of 10.0.19 tool
    @xian1243 and @omariscal1019 for testing 10.0.13 version, @twinnfamous for testing 10.0.13 and 10.0.16 versions, @ntzrmtthihu777 for testing 10.0.13 , 10.0.16 and 10.0.19 versions, @DanDroidOS for testing 10.0.19 version, and @me2151 for testing 11.0.1.5 version.
    @Titokhan for being a friend and providing inspiration in writing
    @headsh0t95 for being a friend and suggesting me to request an access to upload files on AndroidFileHost now one year ago for my previous threads
    @AndroidFileHost for the hosting
    OnePlus for the device and OS
    6
    Added OOS 10.0.42 MSM tool.
    6
    It's real and was tested extensively. We also used them to complete our reserve.img collection.
    6
    Added OOS 10.0.41 MSM tool.
    5
    Added OOS 10.0.34 MSM