How To Guide [OPNORDCE][OOS EB13BA/DA] Unbrick tool to restore your device to OxygenOS

Search This thread


Senior Member
May 25, 2009
Any help from anyone would be great at this point...ive tried different cables, 3 different pc's (2 relatively new laptops and one old core i7 3rd gen pc with a usb 2.0 port. Everytime i get the same message "firehose communication handshake failed" is it something to do with timing?


New member
Jan 30, 2022
Thanks for you post, I tried to recover my Soft Bricked One Plus Nord CE 5G, but I always get the error: "Param preload failed".

Reinstallted Drivers, using Admin mode, changed the Cable (usend the original one) and changed USB ports, nothing seems zu help.




Senior Member
May 6, 2012
New Delhi
Xiaomi Mi 10T Lite
Xiaomi Mi 10i
I struggle for almost 1 day to get it restored but found it very difficult to make it . Change windows version from windows 10 to win7 install drivers again .Start msm tool and tried flash but failed again in windows 7 too ,then remove the sim tray and connect again then tried the msm tool again and this time it get successful .
Apr 18, 2022
the other day my nord ce EU model started bootlooping, sometimes it will show oxygen logo, and sometimes it shows crash dump mode with no codes but in each situation just instantly restarts. i have used msm flash tool, it goes through as says completed. but phone is still bootlooping. previously i had erased all data from recovery to try and fix it, so i dont think usb debugging is enable.
Apr 18, 2022
follow up to my previous comment, i had originally downloaded EU version listed. flashed 3 times and the msm tool said it completed, but phone still bootlooped. last night i downloaded indian version, flashed it same thing, after about 30 minutes of boot looping, it finally powered on, and was still the EU version.


  • WIN_20220418_21_24_34_Pro.jpg
    89.9 KB · Views: 30
Has anyone tried this?
Apologies, I have just realised this is the MSM tools thread, not OxygenOS OTA zips repo one, I haven't noticed the thread title from mobile notification. Utility used to perform flash on Mediatek devices isn't the MSM Download Tool but rather SP Flash Tool, and to the best of my knowledge it requires OnePlus employee login for flash to be performed (consequence of OPPOification).

With that said, @deadman96385 has been able to obtain and and shared them, so after extracting the ofp files present in the zips using you may be able to create a fastboot rom to recover devices with (although it requires that device bootloader is unlocked, it's better than nothing).


New member
Oct 3, 2022
I have global version (EB2103) and need to install Android 11. I am using MSM tool (is the website down, can't access it) and using thread from this post ,which gives error : Firehose Communication Handshake Failed .

Can someone help, my device is unusable , thanks .

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    Disclaimer: By attempting any of the processes listed in this thread you accept full responsibility for your actions. I will not be held responsible if your device stops working, catches fire, or turns into a hipster and claims to have been modified before it was cool.

    Hi everyone, similar to the previous threads for
    OP3, OP3T, OP5, OP5T, OP6, OP6T, OP7, OP7PRO, regular OP7T, T-Mobile OP7T, regular OP7TPRO, T-Mobile OP7TPro 5G, regular OP8, T-Mobile OP8, Verizon OP8, Visible OP8, OP8Pro, OP Nord, regular OP8T, T-Mobile OP8T, regular OPN10 5G, T-Mobile OPN10 5G, Metro by T-Mobile OPN10 5G, regular OPN100, T-Mobile OPN100 and Metro by T-Mobile OPN100 here is the EDL package (also known as MSM tool or unbrick tool) that can revive a bricked OnePlus Nord CE. Please do note that as of writing only Indian version is available, it may not work for EU devices (feel free to report back if it does).

    You should also be able to rollback your phone to a previous release of OOS with them if for some reason you want to go back to an older firmware :)

    You can download the following version:

    EB13BA tools (european firmware):
    ANDROID 11:


    Alternative download to AFH will be provided later, MD5 of the file is ee7f0220900f34a0b4c42b7381e962c4.

    EB13DA tools (indian firmware):
    ANDROID 11:


    Alternative download to AFH will be provided later, MD5 of the file is da34ba81da8ca81c9541ca901f013b09.


    Launch MsmDownloadTool V4.0.exe.

    On the login prompt select "Other" in the dropdown menu and click on Next.
    Wait a few seconds until main window shows up.

    Press Start button so that it waits for your device to be connected
    Power off your device
    Maintain volume up and down buttons to get into Qualcomm EDL mode.
    Plug your device to your computer.
    Should you not manage to do that and have adb access, you can use adb reboot edl instead
    Wait ~300 seconds.
    Enjoy your brand new device.


    Does this work on Mac or on Linux?

    Unfortunately no, tool is Windows only. You should need at least Windows 7.

    Why is my antivirus freaking out when unzipping the archive or running the tool?

    In an effort to protect reverse engineering from being done (and by extension prevent conversion process like it was done on 6T and 7Pro), OnePlus now use VM Protect V3 in their MSM tools. As this tries to detect debug environment, this is seen as malicious behaviour by some antivirus.

    My device isn't detected

    Go to device manager and make sure your phone shows up as QDLOADER 9008.
    If it shows up as QHUSB_BULK, it means Qualcomm driver wasn't installed automatically by Windows Update. Download the latest one from Microsoft website at (source https://www.catalog.update.microsof...updateid=8ee52ba0-bdef-4009-88cf-335a678dd67a ) and install it manually by right clicking on QHUSB_BULK and selecting "Update driver software" and "Browse my computer for driver software" to where you downloaded CAB file.

    If you can't get into EDL mode by hardware keys, you may use adb reboot edl (will require your phone to still have ADB access)

    MSM tool is stuck on "Param pre-processing"

    Ensure you're using the Qualcomm drivers linked above.

    MSM tool is stuck on "Sahara communication failed"

    Unplug your phone, get in fastboot mode, turn off phone, wait 15 secondes and get back in Qualcomm EDL mode. You can also try using a USB 2.0 port instead of a 3.0 one.

    What is SMT Download mode?

    Just don't try to unlock that mode, it will wipe your IMEI and your Widevine certificate if you use it.

    How can I fix "SMT config not found" error?

    Please refer to


    @Venkat.Yadlapati for getting file from OnePlus and sharing it
    @murchu27 for getting file from OnePlus and sharing it
    OnePlus for the device and OS
    Added OOS MSM tool to OP, credits to @murchu27 for sharing it
    Wrote instructions for switching to any version via fastboot
    The instruction is in Russian and on the Russian website. I'm too lazy to translate..
    After performing this procedure, the flash to "vbmeta_system.img" was successful, but "fastboot reboot fastboot" After execution

    I get the error "fastboot: usage: unknown restart target fastboot" and cannot continue.

    [Was self resolved]
    After installing, launching a command window in that folder and executing "fastboot reboot fastboot", it became "OKAY".

    The rest of the files were also flashed.

    But the device is in a boot loop ...
    Restore by another method...


    Boot in Fastbootd mode using "platform-tools_r31"



    Flash "EB13AA Global" in this article with FastbootEnhance.
    Flash "payload.bin" without changing any settings.


    I recovered from brick.
    It took a whole day.
    I learned a lot.
    Awesome! , is there any plan for native EB2103 ? Or what if i flash this rom to my global device? Someone booted on telegram group with global and i afraid widevine and on screen fingerprint sensor
    Awesome! , is there any plan for native EB2103 ? Or what if i flash this rom to my global device? Someone booted on telegram group with global and i afraid widevine and on screen fingerprint sensor
    Got the same worries about my Nord CE EU version