• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Oppo A5 2020 (CPH1931) won't go in to fastboot mode/bootloader

Search This thread

Anteino

Senior Member
Oct 14, 2011
61
5
I want to root my phone, install custom recovery and eventually a custom ROM. For this, I need to unlock the bootloader.

I have an Oppo A5 2020 CPH1931. It should go into bootloader when I press volume+ and power buttons together for 5 seconds after completely turning off the phone. But when I do this, it boots like normal. Tried all different combinations and durations. I am able to boot into recovery but not fastboot mode. I have turned on the "OEM unlocking" option in developer options.

I tried it through ADB, it says fastboot on the screen for half a second and then once again jumps back to normal booting. I also tried to already put the fastboot command "fastboot oem unlock". When it says <waiting for device> I use another terminal to try to boot into fastboot with ADB. But this does not work (also tried this with "fastboot flashing unlock").

By the way, my devices only shows up with adb devices when I select transfer files upon connecting the USB cable. When I select just charge it doesn't even show.