OrangeFox Recovery Xiaomi Redmi 8A unofficial (beta)

Search This thread

justj0sh

Senior Member
Feb 5, 2017
50
7
Followed the instructions, got stuck at this step. Now bootloop into fastboot. Only fixed by reflashing stock MIUI.
>fastboot flash recovery recovery.img
Sending 'recovery' (31688 KB) OKAY [ 1.020s]
Writing 'recovery' OKAY [ 0.366s]
Finished. Total time: 1.499s
> fastboot boot recovery.img
Sending 'boot.img' (31688 KB) OKAY [ 0.999s]
Booting FAILED (remote: 'unknown reason')
fastboot: error: Command failed
 
  • Like
Reactions: verdugon

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    ChioTGanysLeVg

    OrangeFox Recovery (Beta)
    Requirements: Unlocked Bootloader
    1.Download recovery.img
    2. Put the phone in fastboot mode (Volume - and Power)
    3.Download adb fastboot (Google to help)
    4.Connect the phone and check if the driver installer (device manager) is correct (Google)
    5. Teams :
    Code:
    fastboot devices
    fastboot flash recovery recovery.img
    fastboot boot recovery.img
    6.After, button (Volume+ and Power),
    7.Install (addition) OrangeFox-Unofficial-olivelite.zip and ClassicTheme.zip
    File :
    recovery.img un7zip
    OrangeFox-Unofficial-olivelite.zip
    ClassicTheme.zip

    Bootloop ?
    vbmeta.img unzip
    Put the phone in fastboot mode (Volume - and Power)
    Code:
    fastboot devices
    fastboot flash vbmeta vbmeta.img

    Nourish stock recovery? (such as indian 11.0.3 miui )
    recovery.img copy in the phone's memory ,
    and repeat again ,
    and install recovery.img after paragraph 6 of twrp section ,, recovery " and reboot in recovery .

    I do a lot of other than Redmi 8a for this I can not know about the bug on this email me about that notice. (I know about and looking for a solution point ,,applications " .

    thanks:
    source : developers orange fox ,
    build : altsec , @altscd (telegram )

    ps: Bad English . I know ;)
    3
    Actually if you will install MIUI through any recovery it will get stuck at bootloop or boot in download.
    To overcome this issue simply flash you recovery again by your pc and enter in the recovery, from there press reboot system.

    And you have solved the issue of the bootloop or stuck on download.

    ---------- Post added at 12:38 PM ---------- Previous post was at 12:19 PM ----------

    Actually if you install MIUI by any recovery you will see that your phone is stuck in BOOTLOOP or in DOWNLOAD.
    To overcome this problem, simply flash your vbmeta and RECOVERY again from you PC on to DOWNLOAD.

    Now when you will boot in your CUSTOM RECOVERY, from there chose to REBOOT into SYSTEM.

    This will solve your problem of being stuck in BOOTLOOP or stuck in DOWNLOAD.

    When your MIUI will start it will automatically replace your CUSTOM RECOVERY to the STOCK RECOVERY which you can replace again in future.

    I really hope that I helped you in some way. ?

    (And also remember to delete compatability.zip file from MIUI.zip, you can easily do it by "MiX File Explore". To do it DOWNLOAD "MiX File Explore" click to see your MIUI.zip file and you will see "compatibility.zip". Just delete it.
    You can now flash it by any RECOVERY)

    ??
    1
    It

    View attachment 4922743View attachment 4922745Screenshot_2020-01-10-02-04-11.jpgScreenshot_2020-01-10-02-04-28.jpg

    Sorry for my bad english. I am not literate and in Russian )))
    1
    Google translate:
    Hello everyone, I send you my best regards.
    I comment. -
    I have a global 8th redmi (olivelite), I unlocked the bootloader and continued to install the unofficial TWRP, but there is a problem, my touch screen does not work.
    That's why I tried Orangefox and the touch panel worked without problems, I could erase everything except the micro SD, and continued to install Mi Globe 11.0.7, the most recent.
    But at the time of finishing and restarting, restart only in recovery, no more, again and again.
    Try once installed the rom my globe, flash twrp and force start by fastboor reboot, but it didn't work either.
    Also install by fastboot, boot.img of the rom eu, of the global and also the patched by magysk and it didn't work either.
    I am NOT looking for root, I am NOT looking for magysk, just install rom MY GLOBE clean, as in all my xiaomis, then I ask.

    Has anyone been able to install Xiaomi.eu successfully on your device? With orangefox what was your process? With TWRP and the OTG, do you think I can start?

    I would greatly appreciate your response.

    Hola a todos, les envío un gran saludo.
    Les comento. -
    Tengo un redmi 8a global (olivelite), desbloqueé el bootloader y proseguí a instalar el TWRP no oficial, pero hay un problema, mi pantalla táctil no funciona.
    Por ello probé Orangefox y en ese me funciono sin problemas el panel táctil, pude borrar todo excepto la micro SD, y proseguí a instalar Mi Globe 11.0.7, la más reciente.
    Pero al momento de terminar y reiniciar, reinicia solamente en recovery, no más, una y otra vez.
    Intente una vez instalada la rom mi globe, flashear twrp y forzar inicio por fastboor reboot, pero tampoco tuvo resultado.
    También instale por fastboot, boot.img de la rom eu, de la global y también la parchada por magysk y tampoco funciono.
    NO busco root, NO busco magysk, solo instalar a rom MI GLOBE limpia, como en todos mis xiaomis, entonces pregunto.

    ¿Alguien ha podido instalar Xiaomi.eu con éxito en su dispositivo? ¿Con orangefox cual fue su proceso? ¿Con TWRP y el OTG, creen que si podre iniciar?

    Agradecería mucho su respuesta.
    1
    I had a similar issue with OrangeFox repeatedly booting into Recovery. I think I fixed it by going Menu > Manage Partitions > Data > Format Data (this will delete all your stuff)

    Excellent, thanks for your response.
    Could you be a little more specific about the steps you took?
    Formatting before installing the ROM, or after?
    For example, I followed these steps.

    Unlock the bootloader.
    Fastboot, install the vbmeta first (or something like that).
    install the Orange fox recovery, then the orangefox zip.
    Clean EVERYTHING (dalvik cache, intertnal storage, etc), except SD.
    Install MY GLobe ROm Olivelite.
    Start in recovery, restart again, without changes, continue to start in recovery, and so, for eternity.

    I did not do the formatting, and I do not use TWRP because the touch panel does not work with that, so I only have Orangefox as an alternative, could you try to install the MI Globe ROM please? https://mi-globe.com/miui-firmware-rom-builder-features/41/
    Thanks for everything.


    So since you're trying to install a rom you'll have to "Wipe" data, system, cache, dalvik before you flash.. and then after you flash and you're booting into recovery over and over you'll have to "format" data. There seems to be a difference between "Wipe" and "Format" in recovery.

    So once you're ready to "Format" data go to Menu >Manage Partitions > Data > Format Data exactly like that.

    Basically the same steps as you did originally just be sure to "Format" data once you're stuck booting into orangefox recovery.

    Let me know how it goes
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone