• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[oreo]XZ1-drmfix-root-ricoff:o

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 16
    [oreo]XZ1-drmfix-root-ricoff
    Available for any version of the official 8.0 oreo
    First you have twrp https://forum.xda-developers.com/xperia-xz1/development/twrp-t3716488

    Be sure to use the zip I provided,Make sure your rom is clean.If you want wipe data,cache and dalvik, please execute it first.

    1,flash drmpatch.zip
    2,flash SuperSU.zip
    3,flash RicOff.zip
    4,reboot

    Perfect, please enjoy.:D

    download
    https://mega.nz/#F!s8QlGD7S!cSlNJcZArwwdvZGGE5sVdA


    drmfix.so/drm****.so thank @sToRm// :good:

    The secd of 47.1.A.12.34 is the same as 47.1.A.8.49.
    secd original file(G8441_47.1.A.8.49_CE) https://mega.nz/#!IpYg1Q4Q!ONXXqHoP6JkrFQ9jGUHMMXlzHcPAfog3ISrMgogO8go
    modify
    E803003206000014E8031F3204000014E807003202000014E8031E32
    for
    08008052060000140800805204000014080080520200001408008052

    drmpatch.zip
    Install XperiFIX
    In C:\XperiFIX\DATA\XZP\G8142\Oreo2
    Modify the update binary
    ui_print "******************************"
    ui_print "Sony XZ Premium *OREO* DRM restore by //sToRm"
    ui_print "******************************"
    change
    ui_print "******************************"
    ui_print "Sony XZ1/XZ1C *OREO* DRM restore by //sToRm"
    ui_print "******************************"

    / system
    change
    /vendor

    And replace secd


    SuperSU.zip
    Modify init.supersu.rc.24 and init.supersu.rc.24.bindsbin

    on post-fs
    exec u:r:supersu:s0 root root -- /sbin/fbe_bypass.sh
    export LD_PRELOAD drmfix.so:drm****.so

    #RIC disable
    mount securityfs securityfs /sys/kernel/security nosuid nodev noexec
    write /sys/kernel/security/sony_ric/enable 0

    RicOff.zip
    The status of SELinux changes to permissive

    The original machao44 account is lost
    I do not know how to misunderstand me
    5
    Totally agree, but as of today we do not have a working solution for the DRMFix and Magisk, we have unfortunatly to choose. We can flash a working Magisk, but then the current DRMFIx does not work.
    Fortunately there is talented persons working with the issue and hopefulle we will be able to run Magisk with working camera shortly :)

    I'm already on my way. :cowboy:
    3
    I opened bootloader , my phone 47.1.A.2.374 I tried to flash 47.1.A.8.49 flashtool does not work in xperia g8342 :(
    At the start of the show the message glows ( your device hes been unlocked and can"t be trusted - your device will boot in 5 Seconds ) Currently I can not access developer options and the camera picks up green images
    What should I do؟
    all Respect and appreciation for you Senior Member
    .
    Green pictures are because you unlocked bootloader. Will be fixed by DRMFix.
    your device hes been unlocked and can"t be trusted-message will allways be there on unlocked BL
    Download G8342_MY_47.1.A.8.49 .rar according to this post, it contains latest ROM and newflasher

    You need to install drivers for flashtool. It may be a little tricky and it was soooo long ago I set it up myself I simply do not remember. Google it. Maybe This or http://www.**********.com/setup-androxyde-flashtool-sony-xperia-devices-windows/may help.

    With drivers installed:
    Turn off phone. Hold Vol down while connecting USB to computer (Green light on phone). Open commandprompt on computer and cd to unpacked G8342_MY_47.1.A.8.49 .rar directory. Run
    Code:
    newflasher.exe
    .
    This installs lastest stock kernel and firmware.
    When finished reboot phone

    Download DRMPatck package , unpack it and move the three zip files to phone

    Turn off phone

    Download twrp-3.2.1-0-poplar-1-patchlevel-2017-12-01.img and move the file to the same directory on computer where flashtool is installed
    Commect the phone to computer USB while holding Vol UP (Blue light on phone)
    Open commandprompt on computer and cd to flashtool directory (where also twrp-3.2.1-0-poplar-1-patchlevel-2017-12-01.img exists)
    Run command
    Code:
    fastboot flash recovery twrp-3.2.1-0-poplar-1-patchlevel-2017-12-01.img
    Disconnect phone.
    Hold Vol Down while starting the phone which brings you to TWRP.
    Flash DRMFix according to OP.
    DONE
    3
    Problem solved.
    Fix works also for latest 12.34 kernel.
    The error from the SuperSU-flashing gave me the lead to the problem. The new FW and/or TWRP does not provide unzip functionallity.
    In order to get the fix in OP working on FW47.1.A.12.34 follow this procedure:
    1. Make sure you're on a clean stock kernel, FW47.1.A.12.34 with Jan 5, 2018 security level
    2. Flash twrp-3.2.1-0-poplar-2-patchlevel-2018-01-05.img by @modpunk as stated in the [RECOVERY] TWRP 3.2.1-0 thread
    3. Boot into recovery
    4. Push busybox and softlink unzip as stated by @N1ghtr08d here in the post#20 of the TWRP thread
    5. Flash according to OP
    6. Reboot and enjoy

    A ton of respect and a busload of thanks to @sToRm// for his engagement and for pushing me in the direction of the solution (maybe without realizing it himself:)) by making me realize the flashing of the OP zips which did not give any errors still actually left the system unchanged. And a lot of thanks to @N1ghtr08d for pointing out the unzip problem earlier on. And certainly must also @ M-Rom be mentioned who have only the best of intentions. And of course @modpunk where further explaination is totally unnecessary. That´s what communities like this is all about. Get it or get out!

    and remember.....Don´t bother me, I bother you :)
    2
    Any chance to backup TA Partition?