• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[OTA] 4.3 OTA Zip for GT-I9505G Google Edition

Search This thread

illogic6

Senior Member
Jul 10, 2009
1,064
96

Attachments

  • 19907_404623196315715_1126683488_n.jpg
    19907_404623196315715_1126683488_n.jpg
    152.5 KB · Views: 3,847
Last edited:
J

jetlitheone

Guest
Can anyone get a full tar file of this and is it different than the leaked one?

Sent from my GT-I9505G using Tapatalk 4 Beta
 

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
Can anyone get a full tar file of this and is it different than the leaked one?

I am looking for one maybe I can update mine dump it and make one if I get time

Sent from my GT-I9505G using Tapatalk 4 Beta



Sent from my GT-I9505G using Tapatalk 2

---------- Post added at 05:30 PM ---------- Previous post was at 05:23 PM ----------

Having trouble getting this to install in stock recovery on my I9505G. :(

Here's the error I get when applying the OTA in stock recovery after reverting to stock with this method: http://forum.xda-developers.com/showthread.php?t=2360346

Looks like some firmware patch possibly. Are you rooted? If so that's why its not updating. If I make an unrooted .tar package for 4.2.2 the update should go

Sent from my GT-I9505G using Tapatalk 2
 
Last edited:

illogic6

Senior Member
Jul 10, 2009
1,064
96
Sent from my GT-I9505G using Tapatalk 2

---------- Post added at 05:30 PM ---------- Previous post was at 05:23 PM ----------



Looks like some firmware patch possibly. Are you rooted? If so that's why its not updating. If I make an unrooted .tar package for 4.2.2 the update should go

Sent from my GT-I9505G using Tapatalk 2

Willing to try anything at this point.

Downloading your 4.2.2 Odin restore files to see if that helps.
 
Last edited:

WhiteSRT69

Senior Member
Sep 21, 2012
323
85
Budd Lake
Sent from my GT-I9505G using Tapatalk 2

---------- Post added at 05:30 PM ---------- Previous post was at 05:23 PM ----------



Looks like some firmware patch possibly. Are you rooted? If so that's why its not updating. If I make an unrooted .tar package for 4.2.2 the update should go

Sent from my GT-I9505G using Tapatalk 2

Please do!!

Sent from my GT-I9505G using xda premium
 

tublah

Senior Member
Jul 22, 2005
201
56
Sent from my GT-I9505G using Tapatalk 2

---------- Post added at 05:30 PM ---------- Previous post was at 05:23 PM ----------



Looks like some firmware patch possibly. Are you rooted? If so that's why its not updating. If I make an unrooted .tar package for 4.2.2 the update should go

Sent from my GT-I9505G using Tapatalk 2

It's some kind of pre-patch check, for sure. It's odd, I got the OTA update and was still rooted - no problems. I had to re-root, obviously - but it didn't seem to care.

Have you frozen or uninstalled any system apps, per chance?
 

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
e2areved.jpg
Got it here's how.Go into SuperSU do a full unroot and reboot then after you reboot boot back into boot loader and relock boot loader "fastboot oem lock" then reboot. Then reboot into stock recovery and apply update.

PROFIT! just did mine

The downside you will have to re unlock (wipe data) and reroot if you want root

Sent from my GT-I9505G using Tapatalk 2
 
Last edited:
J

jetlitheone

Guest
I'm gonna create a flashable zip I'm pretty positive I can do this but give me some time guys.

Sent from my GT-I9505G using Tapatalk 4 Beta
 

illogic6

Senior Member
Jul 10, 2009
1,064
96
It isn't possible I can see in the updater script its calling for ceraint parameters

Sent from my GT-I9505G using Tapatalk 4 Beta

Yeah, I was looking at that too. Looks like it's failing on checking my modem image. Wonder if there's a way to revert that to stock.

Betting I picked up a different version from one of the 4.3 leaks.
 
Last edited:

MJHawaii

Senior Member
Aug 13, 2011
892
433
Honolulu, HI
www.androidhawaii.org
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 56
    There was a list of specific apps that this particular build had problems with. TiBU was on the list. As is HBO Go and a few others I use. That's why the Nexus devices got a new build pushed to them so quickly. I'm HOPING maybe we get one too.

    I have a fix. I did a little research and found that you can edit /etc/permissions/platform.xml and add a group to WRITE_EXTERNAL_STORAGE

    Original:
    <permission name="android.permission.WRITE_EXTERNAL_STORAGE" >
    <group gid="sdcard_rw" />
    </permission>

    Add the media_rw group:
    <permission name="android.permission.WRITE_EXTERNAL_STORAGE" >
    <group gid="sdcard_rw" />
    <group gid="media_rw" />
    </permission>

    Done. Doing a TiBU right now to my external card.
    This _may_ fix other apps that have issues writing to the card, I personally didn't find any.

    Suggest that you do an adb pull of the file for safekeeping before doing this.
    If you pull the file, edit it, and push it back make sure the permissions are set to 644.

    Thanks to everyone who made this "OTA" happen.
    I was able to do a no wipe update to MH1 :)
    8
    Here's a stock boot.img + hack for those of you who wants to try..

    it's completely unsupported.

    http://faux.androidro.ms/irc/beta/jfltetmo-stock-GE-JB43-patched.zip

    Have fun.
    6
    @faux123 this is using the bone stock OTA kernel.

    got it

    ---------- Post added at 02:45 PM ---------- Previous post was at 02:28 PM ----------

    @mrvirginia @AJ Newkirk here's the stock GE kernel should work with exFat modules from the stock GE ROM

    http://faux.androidro.ms/irc/beta/jgedlte-stock-GE-JB43-patched_r2.zip

    again. no support from me for this. enjoy!
    5
    a pm would be appreciated. so the problem is kernel related?

    no, the issue is in the TrustZone app itself.. (Keymaster app is an ARM TrustZone secure app). The app will return an unknown response when talking to a non-MH1 baseband. Then the error is propagated all the way back to the userspace (in this case the QSEECOM HAL). Once the HAL failed, then the application on using the HAL also failed (in this case, Settings app).

    What I've done is to stop this propagation of error back to userspace from the kernel side so the userspace can continue without crashing ;)