OTA and Non-OTA Firmware for N986U and N986U1

rjohnstone

Senior Member
Jan 31, 2011
933
228
73
Phoenix, AZ.
Wanted to clean up my last response as I'm a real noob at this. So after further research I understand that within the phone dialer you enter in the info you provided me of *#*#27262826#*#* which should bring up the CSC tool right after I type in the last the character "*", however it doesn't. I'm finding some other posts where others are experiencing this same issue as me where they are unable to access the CSC tool menu saying the last update or so prevents accessing the phone's CSC menu? Do you have any recommendations what I can do?
My bad... You have to use Google's dialer to get to the CSC app.
 

Attachments

rwd0530

Member
Jan 14, 2021
13
0
1
My bad... You have to use Google's dialer to get to the CSC app.
Yeah I figured so downloaded the Google Dialer and it still didn't work for me. When typing in the code using Google Dialer, right after I type in the last the character "*" the code string disappears and nothing happens. I know it's very straight forward and I even watched a youtube video showing how it's done but for some reason I'm not getting the CSC tool menu. Any suggestions?
 

rjohnstone

Senior Member
Jan 31, 2011
933
228
73
Phoenix, AZ.
Yeah I figured so downloaded the Google Dialer and it still didn't work for me. When typing in the code using Google Dialer, right after I type in the last the character "*" the code string disappears and nothing happens. I know it's very straight forward and I even watched a youtube video showing how it's done but for some reason I'm not getting the CSC tool menu. Any suggestions?
That's very odd. I'm running "U" CTLB firmware and it's working.
Try flashing that first and then it should work. I'm on AT&T and the code isn't blocked.
 

rwd0530

Member
Jan 14, 2021
13
0
1
That's very odd. I'm running "U" CTLB firmware and it's working.
Try flashing that first and then it should work. I'm on AT&T and the code isn't blocked.
I'm currently running the N986USQU1CTLA for VZW. It was recommended that I flash with that version since I have an ATT SM-N986U (I got unlocked) and my current carrier is Verizon. My goal is to get my phone up to the latest firmware and start receiving FOTA updates. So for my situation and what I'm trying to accomplish am I running the right firmware for my phone? Appreciate your help. Thank you.
 

rjohnstone

Senior Member
Jan 31, 2011
933
228
73
Phoenix, AZ.
I'm currently running the N986USQU1CTLA for VZW. It was recommended that I flash with that version since I have an ATT SM-N986U (I got unlocked) and my current carrier is Verizon. My goal is to get my phone up to the latest firmware and start receiving FOTA updates. So for my situation and what I'm trying to accomplish am I running the right firmware for my phone? Appreciate your help. Thank you.
CTLC would be the most current for VZW.
 

kangi26

Retired Forum Moderator
Nov 8, 2006
5,557
2,383
253
Seattle
OK I flashed my phone with CTLC firmware using Odin3 v3.13.1_3B_PatcheD BL+AP+CP & HOME_CSC then tried the code with the Google Dialer again and same result. Ahhh...don't know what else to do.
Pull your SIM card and reboot and see if it comes up. I'm out of other ideas at the moment.
I would try to remove the SIM, flash the BL, AP, CP, CSC, and USERDATA. Shut the device off, insert the SIM and power the device on
 
Last edited:
  • Like
Reactions: rjohnstone

adj998

Senior Member
Aug 13, 2011
490
96
53
Texas
Anyone that uses Google Assistant having issues on their device? Specifically CTLC? It won't work whatsoever. I can train my voice etc but actually trying to open the Assistant app is a no go. I've cleared cache/data and also uninstall and reinstall and nothing works. I tried manually launching it with Alliance Shield app (replacement for package disabler) and still nothing
 

kangi26

Retired Forum Moderator
Nov 8, 2006
5,557
2,383
253
Seattle
Anyone that uses Google Assistant having issues on their device? Specifically CTLC? It won't work whatsoever. I can train my voice etc but actually trying to open the Assistant app is a no go. I've cleared cache/data and also uninstall and reinstall and nothing works. I tried manually launching it with Alliance Shield app (replacement for package disabler) and still nothing
I'm on CTLB, I'm not having any issues with GA
 

bblanski

Senior Member
Jan 6, 2008
507
32
58
MN
Anyone that uses Google Assistant having issues on their device? Specifically CTLC? It won't work whatsoever. I can train my voice etc but actually trying to open the Assistant app is a no go. I've cleared cache/data and also uninstall and reinstall and nothing works. I tried manually launching it with Alliance Shield app (replacement for package disabler) and still nothing
No issues here and I am on CTLC.
 

rwd0530

Member
Jan 14, 2021
13
0
1
Pull your SIM card and reboot and see if it comes up. I'm out of other ideas at the moment.
Thank you for your continued support. Per your recommendation above I pulled the SIM card, rebooted, dialed the code in Google Dialer and same result.

From what I'm observing is the behavior acts like that feature is being blocked as right after I type in the last the character "*" the code string disappears and nothing happens. Like it try to do something but doesn't. I can type in *#*#27262826#*# ######## and will allow to type in unlimited characters but if I type in *#*#27262826#*#* the character string disappears.
I would try to remove the SIM, flash the BL, AP, CP, CSC, and USERDATA. Shut the device off, insert the SIM and power the device on
@kangi26 - I flashed my phone per your recommendation above and still having the same result. Crazy. Do you think I should try putting in the ATT SIM that came with the phone and try or does that not make any difference?
 

rjohnstone

Senior Member
Jan 31, 2011
933
228
73
Phoenix, AZ.
Thank you for your continued support. Per your recommendation above I pulled the SIM card, rebooted, dialed the code in Google Dialer and same result.

From what I'm observing is the behavior acts like that feature is being blocked as right after I type in the last the character "*" the code string disappears and nothing happens. Like it try to do something but doesn't. I can type in *#*#27262826#*# ######## and will allow to type in unlimited characters but if I type in *#*#27262826#*#* the character string disappears.


@kangi26 - I flashed my phone per your recommendation above and still having the same result. Crazy. Do you think I should try putting in the ATT SIM that came with the phone and try or does that not make any difference?
Never hurts to try. I know AT&T isn't blocking the CSC dialer code from Google Dialer.
 

eelpout

Senior Member
Aug 19, 2007
327
20
48
Quick question (I think). I've been looking at getting a Note 20 Ultra to replace a Note 10+ 5G. I'm on T-Mobile. I notice a lot of the refurbs out there are unlocked on Verizon. So, in order to get T-Mobile's b71/n71 bands with one of these I'd I'd likely have to re-flash.

So the question, better to flash with T-Mobile firmware or unlocked U1? I can't seem to find for sure if the 71 bands are part of U1.

thanks!

ps. and I may end up using this with Google Fi, for carrier switching, which I think then needs the unlocked variant.
 

rwd0530

Member
Jan 14, 2021
13
0
1
Never hurts to try. I know AT&T isn't blocking the CSC dialer code from Google Dialer.
So I found a thread on XDA about someone having the exact issues I'm experiencing. This person resolved it by downgrading to a firmware with One UI 2.5 and was then able to access the CSC menu using Google Dialer. Can you recommend a firmware rev that has One UI 2.5 that I can try?
 

rjohnstone

Senior Member
Jan 31, 2011
933
228
73
Phoenix, AZ.
So I found a thread on XDA about someone having the exact issues I'm experiencing. This person resolved it by downgrading to a firmware with One UI 2.5 and was then able to access the CSC menu using Google Dialer. Can you recommend a firmware rev that has One UI 2.5 that I can try?
The last one right before Android 11 rollout. N986USQS1BTK3
 

supurman182

Member
Feb 20, 2014
7
0
21
Ok so I have unlocked a T-Mobile phone and am currently using it on Verizon. I just change the CSC to Verizon using the *#*#27262826#*#* method. I did not flash any firmware but it seems to have worked all the Verizon apps are here and the Verizon logo is at start up. I'm I okay here. Do I need to flash to Verizon firmware???
 

kangi26

Retired Forum Moderator
Nov 8, 2006
5,557
2,383
253
Seattle
Ok so I have unlocked a T-Mobile phone and am currently using it on Verizon. I just change the CSC to Verizon using the *#*#27262826#*#* method. I did not flash any firmware but it seems to have worked all the Verizon apps are here and the Verizon logo is at start up. I'm I okay here. Do I need to flash to Verizon firmware???
Only if you want OTA updates. If youre not too concerned with the OTA and would just manually flash the next security update you can stay with the one youre on
 

DigitalMenace

Member
Dec 8, 2012
15
2
23
48
Bridgeton, Missouri
Help getting Verizon features on unlocked Note Ultra

Does anyone here have any advice for me as to what files to flash in order to get Verizon features on an unlocked Note Ultra?
I see discussion here about U and U1 and I don't see both flies posted.
I also don't see anything specifically for Verizon. Any help or advice would be greatly appreciated! I'm new to all this and just trying to make sure it's even possible, all the while not bricking my phone.
I know this is from a while back... I posted somewhere in this thread about installing an unbranded unlocked ROM and was looking for it when I happened past this question. Your question is exactly why I wanted to flash a Verizon free version.

Since Android 11 came out, and my phone is unlocked, I installed the U1 universal rom updated to Android 11 (link in original post). I did a "dirty" update, so I didn't lose any data or apps. I then uninstalled all there Verizon crap, which removed the restrictions they impose on the phones. I did have to put a sim card from another carrier and I was able to re-enable the calling and messaging on other devices and other disabled features. Video calling shows up, but as Duo so I'm not sure what's up with that. The only thing I "lost" was the 4G logo; I get LTE+ instead, but 5G works perfectly as does wifi calling. I've received 2 OTA updates from Verizon, but not branded. For all intents and purposes my phone is acting like a 100% Samsung Factory unlocked phone.
 

supurman182

Member
Feb 20, 2014
7
0
21
Only if you want OTA updates. If youre not too concerned with the OTA and would just manually flash the next security update you can stay with the one youre on
So if I flash N986USQS1CTLC I will start getting ota through Verizon?

Also i ran into a problem after I changed the csc to Verizon. I reset my phone and now RCS is not working. It says network doesn't support this feature. It's there anything I can do. Would this have happened anyways when I flash the Verizon firmware?