• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

How To Guide Other ways to improve missing notifications

Search This thread

Si1encio

Member
Jun 6, 2021
6
7
Xiaomi Mi 11 Ultra
I've recently got my hands on the Mi 11 Ultra, and the top issue I was having was that none/only some notifications will show up. I've searched around the forums and some say that setting the app's battery limit to none, having the app set to auto-start etc. I've followed all those tips and it wasn't really working out for me until I stumbled onto another option.

First, you'll have to enable the developer's option. Once inside, find the setting that says " Adaptive Notification Priority". Turn this OFF and all of your notifications should show up properly now.

Before turning this off, I wasn't getting any of my Instagram Direct notifications and only part of my WhatsApp notifications. Now they all pop up like they're suppose to.

Hope this helps out those with similar issues!
 

Parkourhaderatt

Senior Member
Dec 2, 2015
82
5
I've recently got my hands on the Mi 11 Ultra, and the top issue I was having was that none/only some notifications will show up. I've searched around the forums and some say that setting the app's battery limit to none, having the app set to auto-start etc. I've followed all those tips and it wasn't really working out for me until I stumbled onto another option.

First, you'll have to enable the developer's option. Once inside, find the setting that says " Adaptive Notification Priority". Turn this OFF and all of your notifications should show up properly now.

Before turning this off, I wasn't getting any of my Instagram Direct notifications and only part of my WhatsApp notifications. Now they all pop up like they're suppose to.

Hope this helps out those with similar issues!
I dont have notifications too, tried to search all over the internet without any real help, hope this one works!
Do you have the Chinese or Global version?
 

picitup

Senior Member
Jan 9, 2011
274
86
Deal
Xiaomi Mi 11 Ultra
Thnks very much for this. I've just turned adptive notifications off and will report back.Like you, I've spent a lot of time with permissions/battery etc. I've turned them off and will report back when I get a calendar event!

Cheers

Steve
 

Si1encio

Member
Jun 6, 2021
6
7
Xiaomi Mi 11 Ultra
Thnks very much for this. I've just turned adptive notifications off and will report back.Like you, I've spent a lot of time with permissions/battery etc. I've turned them off and will report back when I get a calendar event!

Cheers

Steve
Hope it helps! I'm still messing with the settings to this very day! I'm way too accustomed to the stock android setting as my daily driver before the 11 Ultra was a Pixel 3 XL
 

Parkourhaderatt

Senior Member
Dec 2, 2015
82
5
Didnt help me... still not Gmail notifications and some apps require to turn on in order to get notifications even when auto-start is enabled and battery consumption is turnd off
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    I've recently got my hands on the Mi 11 Ultra, and the top issue I was having was that none/only some notifications will show up. I've searched around the forums and some say that setting the app's battery limit to none, having the app set to auto-start etc. I've followed all those tips and it wasn't really working out for me until I stumbled onto another option.

    First, you'll have to enable the developer's option. Once inside, find the setting that says " Adaptive Notification Priority". Turn this OFF and all of your notifications should show up properly now.

    Before turning this off, I wasn't getting any of my Instagram Direct notifications and only part of my WhatsApp notifications. Now they all pop up like they're suppose to.

    Hope this helps out those with similar issues!
    2
    To get notifications, you need to do 2 things:

    Go in apps and toggle on Autostart, change notification setting to "Important"