OWNICE K7 (C970) (TS10) uis7862

Search This thread

mariodantas

Senior Member
Sep 7, 2015
130
21
45
Essonne, France
Hi fellows, maybe I'm in the wrong section of the forum to post a question:

I have a OWNICE K7 TS10 HeadUnit and I see that the unit is taking too much time to get GPS signals, I tried with another unit (and the same antenna) and it works very well, but not with the OWNIKE K7

Does anyone have the same issue ?,

Does anyone know how to fix it ?, specific app ?, firmware related ?

Thanks in advance
 

nick1964

Member
Jun 2, 2020
28
4
Italy
Hi fellows, maybe I'm in the wrong section of the forum to post a question:

I have a OWNICE K7 TS10 HeadUnit and I see that the unit is taking too much time to get GPS signals, I tried with another unit (and the same antenna) and it works very well, but not with the OWNIKE K7

Does anyone have the same issue ?,

Does anyone know how to fix it ?, specific app ?, firmware related ?

Thanks in advance
Download GPS TEST.
Connect the radio to internet, open gps test, settings, clear and update AGPS, wait 2-3 minutes and restart(not shut down and open, I reset, restart).
After the radio it's ON again, open gps test (car in open place, no garage, need to see well the sky) and wait.
At the begining you"ll see 2-3 satellites, minures passing the number increase.
After this operation, the next time the radio "fix" 10-15 satellites in 10-15 seconds.
 
  • Love
Reactions: mariodantas

mariodantas

Senior Member
Sep 7, 2015
130
21
45
Essonne, France
Download GPS TEST.
Connect the radio to internet, open gps test, settings, clear and update AGPS, wait 2-3 minutes and restart(not shut down and open, I reset, restart).
After the radio it's ON again, open gps test (car in open place, no garage, need to see well the sky) and wait.
At the begining you"ll see 2-3 satellites, minures passing the number increase.
After this operation, the next time the radio "fix" 10-15 satellites in 10-15 seconds.
Oh great instructions fellow, I'll check it tomorrow morning

Many thanks for your tip
 

mariodantas

Senior Member
Sep 7, 2015
130
21
45
Essonne, France
Problem solved, I enter the engeneering mode, SGPS app and set it to custom (and let default values) instead of GPS+GLONASS+BEIDOU default option

I tried with other options (GPS+BD2+GLONASS, etc... and it idin't work well)

Using default option the GPS seems to warm quicly and catch 13, 15, 18 satellites quickly (2, 4 max 5 before chaging options)

FYI: These people from OWNICE also leave RADIO area settings pointing to CHINA, I bought it to be used in france.

Meaning that the unit hasn't been pre-configured to be used in the customers'country

My opinion: Chinese people want money money money money money, that's all
 

mariodantas

Senior Member
Sep 7, 2015
130
21
45
Essonne, France
Some of the pre-installed APKs on the OWNIKE K7 (970) With 360camera support and carplay
 

Attachments

  • Ambient Light-com.topway.ambientlight-1-1.0.apk
    541.4 KB · Views: 10
  • AndroiTS GPS Test Pro-com.androits.gps.test.pro-148-1.48 Pro.apk
    2.3 MB · Views: 15

nigella87

Member
Jul 16, 2018
12
7
Problem solved, I enter the engeneering mode, SGPS app and set it to custom (and let default values) instead of GPS+GLONASS+BEIDOU default option

I tried with other options (GPS+BD2+GLONASS, etc... and it idin't work well)

Using default option the GPS seems to warm quicly and catch 13, 15, 18 satellites quickly (2, 4 max 5 before chaging options)

FYI: These people from OWNICE also leave RADIO area settings pointing to CHINA, I bought it to be used in france.

Meaning that the unit hasn't been pre-configured to be used in the customers'country

My opinion: Chinese people want money money money money money, that's all
Hi... I bought the same product you use...
I have the same problems...
Wouldn't it be rude to ask how to get into engineering mode???
 
  • Like
Reactions: mariodantas

Top Liked Posts

  • 1
    Thanks bro. I see that software is still som bug. If you stick some option in setting menu. Until now, It have been good with me but new MCU 21.4.2021 is conflict with my canbus box and trajectory can not use.
    @Jennythuytien It seems that they sell their radios and the customers are the beta testers (or even alpha testers)

    Everyday I think about selling the OWNICE: very good hardware but a piece of **** firmware
  • 2
    Problem solved, I enter the engeneering mode, SGPS app and set it to custom (and let default values) instead of GPS+GLONASS+BEIDOU default option

    I tried with other options (GPS+BD2+GLONASS, etc... and it idin't work well)

    Using default option the GPS seems to warm quicly and catch 13, 15, 18 satellites quickly (2, 4 max 5 before chaging options)

    FYI: These people from OWNICE also leave RADIO area settings pointing to CHINA, I bought it to be used in france.

    Meaning that the unit hasn't been pre-configured to be used in the customers'country

    My opinion: Chinese people want money money money money money, that's all
    2
    This is my firmware. Can you look for different with yours?
    I'm Korean. It's night and rainy... TT . I can't go out to parking lot.... don't have an umbrella. I will massage to you about firmware i recieved.
    1
    Hi fellows, maybe I'm in the wrong section of the forum to post a question:

    I have a OWNICE K7 TS10 HeadUnit and I see that the unit is taking too much time to get GPS signals, I tried with another unit (and the same antenna) and it works very well, but not with the OWNIKE K7

    Does anyone have the same issue ?,

    Does anyone know how to fix it ?, specific app ?, firmware related ?

    Thanks in advance
    Download GPS TEST.
    Connect the radio to internet, open gps test, settings, clear and update AGPS, wait 2-3 minutes and restart(not shut down and open, I reset, restart).
    After the radio it's ON again, open gps test (car in open place, no garage, need to see well the sky) and wait.
    At the begining you"ll see 2-3 satellites, minures passing the number increase.
    After this operation, the next time the radio "fix" 10-15 satellites in 10-15 seconds.
    1
    Try to Install this app

    Drivers Widget - Speedometer​


    and add widget to home screen.
    This will keep the gps running all the time.
    1
    Thanks bro. I see that software is still som bug. If you stick some option in setting menu. Until now, It have been good with me but new MCU 21.4.2021 is conflict with my canbus box and trajectory can not use.
    @Jennythuytien It seems that they sell their radios and the customers are the beta testers (or even alpha testers)

    Everyday I think about selling the OWNICE: very good hardware but a piece of **** firmware
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone