Oxygen OS 11 OPEN Beta 4 is out.

Search This thread

Eddiemc

Senior Member
Mar 15, 2010
1,397
534
133
Download xXx magisk module. Edit the .profile settings and debloat the entire India.img

Just do a search for xXx module XDA and read up on it. Really solid module for our phone when using OOS ROM

I can't seem to find a version for 7t and oos11.
Are you willing to give more info on version and process to delete the India Folder using the module on oos11 beta 3?
 

Wimmme

Senior Member
Nov 9, 2012
487
270
93
OB3 is a great update. Wifi definitely more stable, and overal it seems snappier and more responsive.
Good job OnePlus!
 

VIZT

Member
Sep 24, 2014
18
2
23
Does anyone have the OB3 for 7T as a .zip? I need the boot.img to root pls

EDIT: Nvm, Found it and payload dumped the boot.img, root and safetynet working great!
 
Last edited:

bynarie

Senior Member
Aug 2, 2013
295
134
63
Hilliard OH
OnePlus 7T
Generally I didn't have a problem with ADB on Ubuntu and OOS 11... And I use it after instalation to disable head notification (i hate that) and to force 90Hz everywhere.
But... I recall taht I didn't manage to flash OOS ROM with ADB (file by file) ... I wanted to do a fresh installation, I formatted the memory from recovery but I couldn't flash the ROM. Fortunately for me I already had OOS 11 which was a dirty update over the previous Beta), so practically restarting after deleting everything with Recovery was a fresh start. After I just root it as usual and without any problem. Obviously I don't know how to correctly flash ROM from Ubuntu, but after some reconsideration, maybe I made a mistake because i delet all data from recovery so USB debugging is turned off by this procedure... I don't know and it's doesn't matter much now (I will not do that again, just for now).
Yes, my apologies for not being specific. On windows 10, I had the driver issue. On xubuntu, no issues what so ever.
 

Edgehead123

Senior Member
Jun 4, 2015
57
8
28
Montreal
I've had the same issue since OB1 (OB2 + 3 too) :(
Same! I think mine is a T-Mobile destined 7T that was refreshed to be sold by a 3rd party (B&h in my case).
It's really frustrating because basically since I've had it, OTA doesn't work on the unstable builds.
Also, kinda worries me that the oneplus website still says OB1...
 

VQ30DE

Senior Member
Nov 13, 2010
264
62
58
Portland
OK, I tried installing OB3 from Android 10 using Oxygen Updater. I downloaded the full file. Installed, and now I get this 1+ screen where I have to tap English, then it gives me three options:

Wipe data and cache
Advanced
Exit

I have tried wiping cache and system data and it just keeps rebooting into the same menu. Why won't it boot? I don't want to wipe all data if I don't have to, and I thought it wasn't required.

UPDATE: OK, I had to wipe data. Then it rebooted into Android 10. Then I installed the OTA for beta 3 again and it worked. I have T-Mobile variant which I had previously converted to international unlocked variant. Phone is HD1907.

Happy with the way OOS 11 looks so far.
 
Last edited:

Eddiemc

Senior Member
Mar 15, 2010
1,397
534
133
Mmm, 1 issue with OB3. Wide angle camera not working., both in stock camera and Google lens.

Yea, hd1903
Issue with beta 3. Beta 2 worked fine.
Wide angle crashes the camera app, and for me I have to reboot to get it working again. FC camera isn't enough.
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone