OxygenOS 10.0.1 for OP6 is out

Status
Not open for further replies.
Search This thread

Ice_machinE

Senior Member
Jun 7, 2014
109
16
london
  • Like
Reactions: ThomiiTom

lm089

Senior Member
Jun 26, 2011
487
157
Munich
Just finished upgrading to 10.0.1 from 9.0.9; did it the standard way (install but don't reboot, flash A/B retention script from Magisk, then flash Magisk 20.1 to "the other" slot, then rebooted).
Everthing appears to be fine, can reboot to TWRP from extended power menu, device is rooted
(must admit I was a bit nervous after having read all those negative posts over the past weeks)
Only thing I'm missing is the recent apps pop up from the navigation bar. As far as I can tell I have all standard settings for my navigation bar. Anyone else is seeing this?
--------------- UPDATE --------------
Solved.
Reason was my custom launcher (Smart Launcher 5). Had to switch to OP Launcher, then back to SL5. Now I have the recent apps functionality back.
 
Last edited:

xpakage

Senior Member
Oct 23, 2010
2,094
685
Oklahoma
  • Like
Reactions: johnypl

lm089

Senior Member
Jun 26, 2011
487
157
Munich
What is the version of camera? Can i replace over mine on 9.09?

10 seems a pain to update....jesus.
After upgrading to 10.0.1 Camera app gives me V 3.8.75.
Placing over 9.0.9 Camera? Dunno, make a backup then try ;)
Pain to update? I've been a bit nervous with all those tales of horror everywhere on xda. Maybe I was just plain lucky, but here everything went smooth coming from 9.0.9, exactly the same as with updating from any 9.0.x to 9.0.y. Just been patient until I got notified by OP about the OTA update, then followed the standard rules (plus my own) as in:
- remove security PIN/pattern to decrypt data
- take a Nandroid backup (thus the decryption)
- restart to system, leave phone unencrypted
- download and install, but don't reboot
- run a/b retention script from Magisk Manager, but don't reboot
- flash Magisk "to the other slot", then reboot
- don't forget to reapply security PIN/pattern
After that everything is there: Twrp, root, whatever. Only had to reset the odd notification and alarm sound
Good luck
 
Last edited:

langer_hans

Member
Apr 30, 2015
28
2
I am on Android 9 and want to update my device to Android 10.
I have downloaded the full version, moved the file to my phone and boot my phone in TWRP.

Now I get this error:

Error applying update: 7 (Errorcode: : kInstallDeviceOpenError)
Updater Process ended with ERROR: 1
Error installing zip file Oneplus6Oxygen_22_OTA_41_all......zip

what does this mean? Is it because it will upgrade my Android version? I have to edit the zip file?
 

xpakage

Senior Member
Oct 23, 2010
2,094
685
Oklahoma
I am on Android 9 and want to update my device to Android 10.
I have downloaded the full version, moved the file to my phone and boot my phone in TWRP.

Now I get this error:

Error applying update: 7 (Errorcode: : kInstallDeviceOpenError)
Updater Process ended with ERROR: 1
Error installing zip file Oneplus6Oxygen_22_OTA_41_all......zip

what does this mean? Is it because it will upgrade my Android version? I have to edit the zip file?

I think you have to be on 9.0.9 to upgrade to 10, depending on how you are doing it.
 

langer_hans

Member
Apr 30, 2015
28
2
I think you have to be on 9.0.9 to upgrade to 10, depending on how you are doing it.

I am on the latest Version before Android 10

OnePlus6Oxygen_22_OTA_034_all_1909112343_31f86cec5f8d4c7b.zip

Now i tried to update with two files, both failed.
OTA_040 and OTA_041

I tried an other TWRP version, now it is loading and i hope it will work. 1min at step 1/2
 
Last edited:

xpakage

Senior Member
Oct 23, 2010
2,094
685
Oklahoma

langer_hans

Member
Apr 30, 2015
28
2
The below will help you get root after you update and reboot.

https://forum.xda-developers.com/showpost.php?p=81135935&postcount=10

Thanks, TWRP works.
I flashed BluSpark TWRP and installed Android 10, and again BluSpark TWRP.
Booted my phone - showed me a long time the boot logo animation, but finally it ends succesfully.

But i have no Magisk installed - back to the recovery and installing magisk 20.1

Now i am really stuck at the boot animation, now im waiting for more than 10 minutes. What can I do now?
If I use the Magisk uninstaller i can boot my phone again successfully.
 
Last edited:

xpakage

Senior Member
Oct 23, 2010
2,094
685
Oklahoma
Thanks, TWRP works.
I flashed BluSpark TWRP and installed Android 10, and again BluSpark TWRP.
Booted my phone - showed me a long time the boot logo animation, but finally it ends succesfully.

But i have no Magisk installed - back to the recovery and installing magisk 20.1

Now i am really stuck at the boot animation, now im waiting for more than 10 minutes. What can I do now?
If I use the Magisk uninstaller i can boot my phone again successfully.

Follow the steps. Did you flash the stock bootloader after fastboot TWRP?

You can use Blu zip but have to follow the rest since Blu has no img TWRP
 

xpakage

Senior Member
Oct 23, 2010
2,094
685
Oklahoma
No, i didnt use any fastboot img since the first install of TWRP years ago.

I just booted in TWRP and flashed the zip files.

I do not have good luck using TWRP to do major upgrades. I use the local upgrade and reboot phone, and let phone run through update process, then follow the fastboot process.

---------- Post added at 08:25 PM ---------- Previous post was at 08:11 PM ----------

No, i didnt use any fastboot img since the first install of TWRP years ago.

I just booted in TWRP and flashed the zip files.


Try starting at flashing the stock boot loader in TWRP for your rom version and keep following the instructions from there. It should work.
 
Status
Not open for further replies.

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone