OxygenOS Android 11 Betas (OnePlus 7 Pro) released (Open Beta 2 now available)

Oct 26, 2016
34
8
8
You are probably making the same mistake I was.

Once you flast rooted boot image and boot phone, go to Magisk, click on install and select Direct install. It will then install magisk and you will have phone even after reboot.
That fixed it, thank you very much!!!!

Does anyone know who the original dev for OP7P TWRP was? Any way to contact them?
 

diopskill

Senior Member
Dec 26, 2010
306
76
48
You need to first flash the rooted boot image in fastboot mode from PC. Once thats done and you boot phone, the option will appear in magisk manager.
Did that 50 times lol. What version of magisk manager is needed? I'm using the latest and don't have that option after booting rooted img.
Thanks
 

rohitvaranasi23

Senior Member
May 18, 2015
97
14
38
Hyderabad
You need Magisk to mask the fact that your bootloader is unloacked.
I was on an unlocked bootloader, unrooted and I upgraded to the beta. Google pay kept working for me until now when I installed Magisk. I tried to open Google pay and it just shows a plain white screen. I installed Magisk hide props, tried to pass Safetynet, didn't work. I decided that root wasn't worth losing Gpay over, and I de-rooted my phone. Still no luck. Is there ANYTHING I can do apart from relocking my bootloader now to get Gpay working again?
 

Xumit

Senior Member
Mar 7, 2009
472
74
63
Mumbai
www.sumits.org
Magisk > settings > hide magisk manager.
I was on an unlocked bootloader, unrooted and I upgraded to the beta. Google pay kept working for me until now when I installed Magisk. I tried to open Google pay and it just shows a plain white screen. I installed Magisk hide props, tried to pass Safetynet, didn't work. I decided that root wasn't worth losing Gpay over, and I de-rooted my phone. Still no luck. Is there ANYTHING I can do apart from relocking my bootloader now to get Gpay working again?
 

vegetaleb

Senior Member
Feb 26, 2010
10,426
2,390
253
Beirut
Flashed OOS11 and kept Root Magisk, I lost TWRP as others, checked Safetynet with Magisk and it's all good.
Though if I want to paste an apk to System partition I can't neither with Root Explorer nor with ADB Push, it will say it's Read only.
ADB doesn't see the phone as rooted
 
Oct 26, 2016
34
8
8
This worked for me too. Thanks!
Magisk has code to disable all modules when you boot into safe mode, which is a fantastic thing to know about.

Call recorder module always causes bootloops

This Magisk feature doesn't seem to be well publicised

I only discovered it yesterday looking at PR comments in Magisk's Github repo and didn't see it mentioned anywhere online.
 

trevorkauf

New member
Nov 23, 2013
3
0
21
Flashed OOS11 and kept Root Magisk, I lost TWRP as others, checked Safetynet with Magisk and it's all good.
Though if I want to paste an apk to System partition I can't neither with Root Explorer nor with ADB Push, it will say it's Read only.
ADB doesn't see the phone as rooted
System is read only unless you can mount it (requires TWRP). So for now to install an app as system, just install it normally then app systemizer magisk module.
 

diopskill

Senior Member
Dec 26, 2010
306
76
48
You need to first flash the rooted boot image in fastboot mode from PC. Once thats done and you boot phone, the option will appear in magisk manager.
Finally!!! I did everything you said! Only worked after I patched my own boot IMG. Weird. But worked! Thanks for the help all!!!
 

spheady

Member
Jan 12, 2017
36
10
18
Oroville
Okay so far yeah the display is flickery till I set it up ( how ever I do) and reboot. About 15 minutes it must update a driver on the display chase it flips again. So I rebbot and 24 hours later its still good. Main problem is the Bluetooth audio is way low volume. So running a split os with OJ twrp, and using Oxy 10.3.7 for my music stuff. The os 11is way cool. So its worth the trouble since I'm pro at modding Q Os 10. I'll probly keep my 10 for net hunter stuff 2. I recommend doing avsimure setup. Which is Dual boot orangefox cut the data in three and have 10 on one side and 11 on another till they they get the bugs fixed. Anyone want to chat msg me. Also heres the profile's from xxx extra build to copy into your Viper stuff if needed. Try the audiophile one. Later
 

Attachments

Jammmmm

Senior Member
May 10, 2013
115
33
48
Has anyone installed the downgrade package to get back to using TWRP and installing custom ROMs etc? Just curious how it went if so.
 

tino73

Member
May 12, 2011
39
9
28
brooklyn, new york
I just updated from OOS 10 Beta 19 to Beta 1 Android 11 and Magisk is working fine.
What I have noticed is that none of my computers, Mac and PC can detect my phone with ADB or Fastboot. I can not even transfer files anymore between the phone and computer because the phone is not being recognized anymore.
Anyone else having this issue?. Any idea how to fix this?.....
 

BossNexusS

Senior Member
May 25, 2011
1,260
247
83
Has anyone been able to enable chat bubbles? I'm trying on the google messages app and I enable the option but I don't see where to actually open the bubble