[OxygenOS System Mods] RENOVATE ICE 14.0 | OP7/OP7PRO//OP7T/OP7TPRO

crapa

Member
Sep 12, 2012
13
2
0
I have flashed the latest RICE stable (the 191 mb one from the 1st page of this thread) over 10.0.3.GM21 and it does not boot.
I had to delete the flashed files (in /data/adb/modules/) with TWRP for the phone to boot.
Did the process twice with same problem.
There's a guy in another forum that has the exact same OOS version with me but says that he has flashed another RICE rom (from telegram) which is around 270 mb and this works fine with him.
Any idea of what's wrong?
 
Last edited:

zak.ns

Senior Member
Nov 12, 2013
729
505
123
I have flashed the latest RICE stable (the 191 mb one from the 1st page of this thread) over 10.0.3.GM21 and it does not boot.
I had to delete the flashed files (in /data/adb/modules/) with TWRP for the phone to boot.
Did the process twice with same problem.
There's a guy in another forum that has the exact same OOS version with me but says that he has flashed another RICE rom (from telegram) which is around 270 mb and this works fine with him.
Any idea of what's wrong?
If look back a few pages you will know everything, it has already been discussed
 

Ton11512

Senior Member
Apr 13, 2007
66
2
8
You first have to become a member of the channel: Renovate Ice-Oneplus 7/7 Pro. Do a search in Telegram and become a member of this channel. After that click the link.
 
  • Like
Reactions: misc6207

crapa

Member
Sep 12, 2012
13
2
0
If look back a few pages you will know everything, it has already been discussed
ok, just read it. Because not all people read dozens of pages before flashing and because no one wants to have a non bootable phone, perhaps a moderator should post in the 1st page of this thread with bold letters that latest available rom to download in this thread is not compatible with 10.0.3.GM21 (EU Version).
 

zak.ns

Senior Member
Nov 12, 2013
729
505
123
ok, just read it. Because not all people read dozens of pages before flashing and because no one wants to have a non bootable phone, perhaps a moderator should post in the 1st page of this thread with bold letters that latest available rom to download in this thread is not compatible with 10.0.3.GM21 (EU Version).
You should read it first if you don't want to have problems!
 

mark1611

New member
Jan 3, 2020
4
1
0
I posted the link to the latest renovate module above. Download it and flash in magisk.
No one can give this link on this page, you only need to be a member of this telegram, not everyone wants to be a member and create accounts for a telegram.

---------- Post added at 06:36 AM ---------- Previous post was at 06:34 AM ----------

Just wait the next update of Renovated Ice, since the last update of OnePlus on 7Pro. Can't use it !
Please read it as well and be patient.
No one can give this link on this page, you only need to be a member of this telegram, not everyone wants to be a member and create accounts for a telegram.
 
  • Like
Reactions: khalisz

docnok63

Senior Member
Nov 22, 2012
2,145
2,553
203
Memphis, TN
Anyone elses build number show 10.0.3 renovate 9.0 but the system notification to update to 10.0.3 is still there? I can't get rid of it!
You're not on 10.0.3 and have flashed a version of RiCE that just puts in in your About Phone. When the new build is posted here, you should disable RiCE, update your firmware, reroot your phone, and then update RiCE.

ok, just read it. Because not all people read dozens of pages before flashing and because no one wants to have a non bootable phone, perhaps a moderator should post in the 1st page of this thread with bold letters that latest available rom to download in this thread is not compatible with 10.0.3.GM21 (EU Version).
I understand how that can be confusing. I'll ask mwilky to update the post ASAP. For clarity until he does, build 9.0 is only for Global 10.0.3/10.0.2 builds.

Just wait the next update of Renovated Ice, since the last update of OnePlus on 7Pro. Can't use it !
Please read it as well and be patient.
Hello all,

I'm an admin from the Telegram group. @mwilky stated earlier today that RiCE 10.0 will be released on XDA later this week. It is currently being tested and modified accordingly on the Telegram group. It's compatible with the latest firmware for both EU (10.0.3) and Global (10.3.0.) If you can't wait and you'd like to test these builds with us, we welcome all to join the Telegram Group chat. For those that are complaining that they have to make a Telegram account, I'm sure you'l manage. You did, after all, make an XDA account and I'm sure several others online.
@Gordietm and all others, please respect @mwilky's wishes and do not post Telegram builds here on XDA. The builds on the Telegram are meant for testing (you can call it Beta if you want) whereas XDA is meant for stable releases only. Thank you.
 
Last edited:

SubjectGinger

Senior Member
Oct 6, 2010
91
20
0
You're not on 10.0.3 and have flashed a version of RiCE that just puts in in your About Phone. When the new build is posted here, you should disable RiCE, update your firmware, reroot your phone, and then update RiCE.



I understand how that can be confusing. I'll ask mwilky to update the post ASAP. For clarity until he does, build 9.0 is only for Global 10.0.3/10.0.2 builds.



Hello all,

I'm an admin from the Telegram group. @mwilky stated earlier today that RiCE 10.0 will be released on XDA later this week. It is currently being tested and modified accordingly on the Telegram group. It's compatible with the latest firmware for both EU (10.0.3) and Global (10.3.0.) If you can't wait and you'd like to test these builds with us, we welcome all to join the Telegram Group chat. For those that are complaining that they have to make a Telegram account, I'm sure you'l manage. You did, after all, make an XDA account and I'm sure several others online.

@Gordietm and all others, please respect @mwilky's wishes and do not post Telegram builds here on XDA. The builds on the Telegram are meant for testing (you can call it Beta if you want) whereas XDA is meant for stable releases only. Thank you.
Do we know if RiCE 10.0 will still support the non-pro 7 series?
 

docnok63

Senior Member
Nov 22, 2012
2,145
2,553
203
Memphis, TN
Do we know if RiCE 10.0 will still support the non-pro 7 series?
Yes, it most certainly does. The first boot will take longer than a normal RiCE update as the deodex refills. There's many new features and this build is currently sitting at 269 MB (this is obviously subject to change.) Please give it a minute or two to boot before thinking/reporting your device is in a bootloop.

-------

Administratively, the first post has been edited for clarity as to which firmware version 9.0 works with and obviously should not be flashed with any other firmware or it will result in a bootloop.

If you're stuck in a bootloop because you flashed it on the wrong firmware, thanks to @Steve0007, there's a small .zip file to use within TWRP to remove the module. Use TWRP's Install feature and follow the prompts on the screen. It can be used to remove just RiCE or all Magisk modules currently installed if that doesn't work.

Alternatively, use TWRP's File Manager found under the Advanced section to navigate to \data\adb\modules and delete the OP7_RENOVATEICE folder
 

Attachments

Last edited: