• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

P30 Pro can't connect via USB and Fastcharge not working after firmware downgrade

Search This thread

Emperon

Senior Member
Mar 31, 2013
79
7
Hİ all

11.0 firmwares were really terrible for my phone since it drained battery considerably and battery life was way worse compared to 10.1 or 10.0. Hisuite did not show an option to downgrade so I decided to use the Hiproxy method to downgrade my phone.

I successfully downgraded it from 11.0 to 10.0, it opened without an error and I'm using it without any problems except one. After the downgrade, my phone cannot connect to my computer via charging cable. It even doesn't show USB preferences on screen like file transfer, only charging etc. It just charging and doesn't prompt anything and because of that I cannot connect to Hisuite. Also when I plug it in to the charger, it does not fast charging. However when tried to use a USB-C to USB-C cable, it can connect to my computer and Hisuite as normal.

All of this happened after the downgrade. Do you think it's because of the cable or something happened to the usb-c port on the phone? It's really awkward since it was working normally before downgrading.
 

Emperon

Senior Member
Mar 31, 2013
79
7
I just tried another usb charging cable and phone still not connecting to my laptop. When I use a regular usb cable, it just charges, nothing pops up on the phone and laptop doesn't see it. However when I try to connect it with a usb-c to usb-c cable (Spiegen) it connects and Hisuite pops up.

Any idea what could be the cause of this? It's really weird that it doesn't connect with a regular usb charging cable when it successfully connects and recognises with a usb-c to usb-c cable. I really don't want to send my phone to service center.

Also supercharging is not working. I'm okay with that but could it cause any problems to the phone?
 

Kiran_Ku

New member
Sep 17, 2021
1
0
I just tried another usb charging cable and phone still not connecting to my laptop. When I use a regular usb cable, it just charges, nothing pops up on the phone and laptop doesn't see it. However when I try to connect it with a usb-c to usb-c cable (Spiegen) it connects and Hisuite pops up.

Any idea what could be the cause of this? It's really weird that it doesn't connect with a regular usb charging cable when it successfully connects and recognises with a usb-c to usb-c cable. I really don't want to send my phone to service center.

Also supercharging is not working. I'm okay with that but could it cause any problems to the phone?
Same thing happened to me. I had to upgrade it back to latest firmware to get the port working properly
 

borispavlov

Member
Nov 7, 2017
32
7
Hİ all

11.0 firmwares were really terrible for my phone since it drained battery considerably and battery life was way worse compared to 10.1 or 10.0. Hisuite did not show an option to downgrade so I decided to use the Hiproxy method to downgrade my phone.

I successfully downgraded it from 11.0 to 10.0, it opened without an error and I'm using it without any problems except one. After the downgrade, my phone cannot connect to my computer via charging cable. It even doesn't show USB preferences on screen like file transfer, only charging etc. It just charging and doesn't prompt anything and because of that I cannot connect to Hisuite. Also when I plug it in to the charger, it does not fast charging. However when tried to use a USB-C to USB-C cable, it can connect to my computer and Hisuite as normal.

All of this happened after the downgrade. Do you think it's because of the cable or something happened to the usb-c port on the phone? It's really awkward since it was working normally before downgrading.
Hi when you say USB c to USB c, how did you connect it to the PC? Does your pc have a USB C port?
 

AveryDennison_VT

New member
Oct 8, 2021
3
0
The only way you can recover USB port function is to update the lastest fw.
I got the same problem with my Mate 20x. I dowgrade from 11.0.0.150 ( C636 ) to 10.0.x.x ( C432 ) and stuck there with only quick charge 18W ( No supercharge, no usb connection ). Then i used an Usg otg 3.0 with Transend brand to update from 10.0.x.x ( C432 ) to 10.0.x.x (C636) and then OTA back to 11.0.0.150. Now, everything is ok, just only battery life get worse than emui 10.
 

Attachments

  • IMG_20211026_104255.jpg
    IMG_20211026_104255.jpg
    3.7 MB · Views: 15

andrei80

Senior Member
Jul 30, 2012
592
88
Barlad
Having the same problem, only I don't know what caused it. Just bought the phone today. Super charging and headphones work, but phone only charges when connected to computers(tried 2), no other reaction. Fw is .159