Paranoid Android Ruby Beta 5 - OnePlus 8/Pro

nyzoli72

Senior Member
Mar 6, 2015
563
166
68
49
Budapest
i'm on latest oos stable on op8pro , if i want to flash PA what is the perfect way to do it? i read all forum but it is too chaotic to me. need a step by step instruction. i'm downloaded the latest beta 3 zip file for 8pro.
 
  • Like
Reactions: peddy2k

KokkoM

Senior Member
Jan 13, 2014
121
48
58
42
Lappeenranta
is it buggy? but ok, i will if i get a good way:)
Its not officially out.
Beta2 is very stable/good everyday usage.

  1. Download the latest fastboot zip we released (hint: it has an -image appended to zip name)
  2. Reboot to bootloader.
  3. Flash the fastboot zip with "fastboot update pa-*-signed-image.zip"
  4. Reboot into recovery after it is done flashing & wipe userdata.
It maybe ended to crasdump mode dont scare, just reboot to recovery and do factory reset.
 
  • Like
Reactions: nyzoli72

nyzoli72

Senior Member
Mar 6, 2015
563
166
68
49
Budapest
Its not officially out.
Beta2 is very stable/good everyday usage.

  1. Download the latest fastboot zip we released (hint: it has an -image appended to zip name)
  2. Reboot to bootloader.
  3. Flash the fastboot zip with "fastboot update pa-*-signed-image.zip"
  4. Reboot into recovery after it is done flashing & wipe userdata.
It maybe ended to crasdump mode dont scare, just reboot to recovery and do factory reset.
thanks a lot, now i booted so start set it up.
 

nyzoli72

Senior Member
Mar 6, 2015
563
166
68
49
Budapest
It's in the original post. I know the rest of the thread has lots to read, but OP is the most important. Shows where to download and how to install. Happy you're up and working though!
i know that but i was unsure about that because on other custom rom is different. One more question, the aod is ok with burn in protection?
 

FoxyDrew

Senior Member
Aug 18, 2014
969
297
93
East Taunton
Can someone try to help me out? Coming from stock OOS11 I flash this per the instructions in OP. Then wipe data in recovery.

Every time I boot the ROM it boots successfully and I get about half way through the Android setup, then the whole screen goes black with the message "Rebooting to recovery, Factory Data Reset". Recovery gives me the error "Cannot load Android System, your data may be corrupt.

This problem persists if I try to wipe data again. I've tried beta 2 and beta 3.

Edit: After like 10 tries, I found the (very small and weird) issue. You HAVE to set up a wifi network in the Android setup. I usually never do to avoid the Google Activity prompt and the install 3rd party apps prompt. But after doing the same exact thing 10 times in a row like a crazy person, and only getting halfway through the Android setup, this fixed it for whatever reason. Ill try and grab a log right now and post it.
 
Last edited:
  • Like
Reactions: spoeckes

mattie_49

Senior Member
Feb 4, 2010
2,630
795
193
Seymour Tn
Can someone try to help me out? Coming from stock OOS11 I flash this per the instructions in OP. Then wipe data in recovery.

Every time I boot the ROM it boots successfully and I get about half way through the Android setup, then the whole screen goes black with the message "Rebooting to recovery, Factory Data Reset". Recovery gives me the error "Cannot load Android System, your data may be corrupt.

This problem persists if I try to wipe data again. I've tried beta 2 and beta 3.

Edit: After like 10 tries, I found the (very small and weird) issue. You HAVE to set up a wifi network in the Android setup. I usually never do to avoid the Google Activity prompt and the install 3rd party apps prompt. But after doing the same exact thing 10 times in a row like a crazy person, and only getting halfway through the Android setup, this fixed it for whatever reason. Ill try and grab a log right now and post it.
I always had the same issue as well and I do indeed skip wifi set-up to rush through and see if I have data. Because nothing custom has had data for my variant. Cool bit of info. Thank you. So I actually have never had this up and working past the rebooting recovery error to factory reset. So I actually have never known if I can even aquire data. Good to know. I'll try again later this evening cause it always flashes perfectly with no errors
 

dladz

Senior Member
Aug 24, 2010
12,138
3,514
253
Liverpool
To anyone having issues with the camera, when I had CRDroid and PEx installed I used two.

FV camera and Camera pro X.

Think they're both premium but you can try both, they offered a lot of options I simply didn't get with the stock ones.
 

dladz

Senior Member
Aug 24, 2010
12,138
3,514
253
Liverpool
Is there a changelog / bug list anywhere for this?

Also the OP still says beta 2.

Brilliant that this is still being worked on, still haven't flashed it but I'm getting a bit bored with OOS.

Would be great to know what's working or not before committing.
 

Raylon00

Senior Member
Apr 8, 2013
113
107
63
Atlanta
Got Beta 3 to install on 8t. Had to edit the android-info.txt inside of the zip file. It said target board was "kona" which threw target errors in install process. After changing board to OnePlus8T, installed fine with update command in fastbootd.

Change txt file
Re-zip Rom with new txt file
Reboot to fastbootd
>fastboot update ROM.zip
Wait
CRASHDUMP
reboot phone > It prompts for Factory Reset

Rom seems really quick. No problems so far while installing apps and changing settings. I used previous advise to connect to wifi during setup to prevent problems.
 

mattie_49

Senior Member
Feb 4, 2010
2,630
795
193
Seymour Tn
Try and try again with every update. Rom just continually tries rebooting into recovery to wipe data after I've already wiped data. Makes no sense. Maybe I do need A11 on both slots because this behavior is after everything flashes without errors . But A10 is still on slot_a. I'll try again after Verizon throws a security patch my way and puts A 11 on both sides.
 

scott45333

Senior Member
Jan 4, 2012
421
205
73
Pittsburgh
Try and try again with every update. Rom just continually tries rebooting into recovery to wipe data after I've already wiped data. Makes no sense. Maybe I do need A11 on both slots because this behavior is after everything flashes without errors . But A10 is still on slot_a. I'll try again after Verizon throws a security patch my way and puts A 11 on both sides.
I would recommend putting A11 on both slots. I have never had an issue with this rom.
 
  • Like
Reactions: mattie_49

dladz

Senior Member
Aug 24, 2010
12,138
3,514
253
Liverpool
Try and try again with every update. Rom just continually tries rebooting into recovery to wipe data after I've already wiped data. Makes no sense. Maybe I do need A11 on both slots because this behavior is after everything flashes without errors . But A10 is still on slot_a. I'll try again after Verizon throws a security patch my way and puts A 11 on both sides.
You'd need Android 11 on the slot that you're using.

It's just easier to have it on both..

Least that's how I understand the slot system.

Every major update it switches, so in theory you could have switched active slots after your installation.

Or just do as @scott45333 says and either fastboot or MSM Android 11 then go from there.

It just works that way
 
  • Like
Reactions: mattie_49