• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[PATCH]**Adoptable storage enabler** MARSHMALLOW

Search This thread

Dikus_Z2

Member
Aug 8, 2016
6
2
samsung tab a sm-t580. twrp 3.1.1-1. magisk. no-verity.
tried with n without adoptable storage patch.
tried with unformatted. formatted with windows 10 as fat.
none worked.
well as soon as i clicked to use sd card as adoptable storage, i got into a boot loop. i could not get out of it regardless of what combination i tried in TWRP. for mounting. for storage.
my aim is to have slow apps on sd card n fast apps on tab. if thats not possible then i would like all apps on sd card, new install as well as updates. any solutions? i am running liquid remix 10 rom.
when just to check, i tried to use sd card formatted as storage from tab, the screen kept shutting off every 15 second or so making it unusable. thinking of clean install hoping at least will work formatted as storage.

The only way I could convert my SD card in internal storage with my Samsung Galaxy Tab A10 was with Magisk and Root Essentials.
 
Does anyone know how to revert this patch?
Flashing stock image with Odin doesn't work. Flashing with Re-Partion option enabled interrupts at the beginning because of the patch. I want to flash the new LineageOS for the SM-T580 but it doesn't work in TWRP when the /data and /storage partitions are messed up.

I also can't get root to work after flashing the stock image. Neither magisk nor SuperSU will work after flashing in twrp... always running in dm-verity messages or bootloops.

EDIT:
Got the solution with the help of @TALUAtXDA.
If you want to get rid of the patch then use the "Format Data" option in the Wipe function in TWRP.
 
Last edited:

TALUAtXDA

Senior Member
Nov 8, 2018
347
572
EDIT:
Got the solution with the help of @TALUAtXDA.
If you want to get rid of the patch then use the "Format Data" option in the Wipe function in TWRP.
Just for everyone to clear possible confusion for anyone that might look at this reply in this old thread: To get rid of this patch, you can just reinstall a firmware, thereby replacing the system and boot image. That is completely sufficient. Formatting data absolutely does not get rid of it.

In this persons case, the actual problem was nothing in relation to this patch. The actual issue was that the data partition was encrypted with Samsung's encryption scheme, which is no good when going from stock to a custom firmware, and therefore, data just had to be formatted for a clean filesystem without it.

My advice was misinterpreted.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 66
    As you may all know Samsung disabled the Adoptable storage function in the Tab S. Even the well known S7 hack doesn't work. Well now it's back...

    Thanks to some legwork (no pun intended) by @longshanks197 we now have a workable solution.
    As previously thought, Samsung disabled adoptable storage in the framework.

    I have created this patch to fix the issue by patching the boot image and replacing sm.jar in system.
    This will enable the adoptable storage feature in Settings>Storage



    NOTE: I advise making a backup with TWRP before proceeding.


    INSTALL:

    Copy the zip below to your device then install with TWRP.

    adoptable_storage_enabler_ashyx

    For information how to enable adoptable storage see the guide below:

    how-to-use-adoptable-storage-on-android-6-0-marshmallow

    This may also be worth a read for more info:

    guidelines_for_marshmallow_users_formatting/



    DONATE ME HERE IF YOU WANT TO BUY ME A BEER OR HIT THE THANKS BUTTON IF I HELPED YOU


    .
    2
    This is great news. Is it possible to make it work for the SM-T700?
    It should work on all models.
    2
    Since adoptable storage option is due to a patch, what happens to internal sd partition (and related data) when we update the firmware?
    Most likely nothing as the partitions are handled by vold so it should still work regardless
    However you may lose the settings in storage.
    You can always reapply the patch.
    2
    Does it work on a non rooted device? Thanks for this fix!

    Sent from my HUAWEI P7-L10 using XDA-Developers mobile app
    Yes

    Sent from my SM-T815 using Tapatalk
    2
    Looks like how much combined storage is messed up, I have 20gb of video`s and a few ebook, but the storage manager says i have used 96%

    Just noticed maximum storage is showing as 256GB, I have an 16gb tablet with an 128gb microsd that`s an maximum of 144GB so it`s wrong by 112GB

    Is there anyway to correct this?

    Nbs4Rqv.png


    John.
    I would take the combined storage info with a pinch of salt and just pay attention to the individual storage info which seems to be correct.
    It's the same issue for the S7 and other Samsung devices.
    Looks like Samsung cobbed something else or maybe this is one of the reasons they disabled it?