• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

People who call me can hear themselves back.

Search This thread

dave-ro-mex

Senior Member
Apr 28, 2009
75
6
Mexborough
Hi. Got the Z5 Compact White on Friday and have a problem with call echos.

So, when I call people, or they call me... The other person can hear themselves back on echo. Really loudly. I tested this myself and it is true. But, eventually the noise cancelling kicks in and this disappears. But then if the voice changes the echo comes back.

When I plug in headphones the problem goes away.
The phone software seems to have no options at all for call noise suppression. Nothing at all, so nothing to tweak or test.
I hear no echo on my end.
Tested with many calls to different people and phones.
I did to a Software reset and Sony PC Companion reflashed the firmware but still the same.
The echo is there even if they talk with a very low voice and whisper.

Is anyone else experiencing this? I'm calling Sony Support in the morning. Kind of hoping its a software issue since it will need to be sent back to the Czech Republic from the UK I am guessing (bought from Sony Mobile website).

If its not a common thing I'll get another.

Apart from it failing to work as a basic phone its butter smooth and 'looks' flawless from the outside. Grrrr.
 

thesebastian

Senior Member
Sep 25, 2012
1,874
445
Barcelona
Are you experiencing this issue with GSM calls or VoIP calls?


Regarding VoIP calls:

In VoIP calls, in which applications are you having this issue? Hangouts? Whatsapp? Skype? Viber? other?.


I used to have a similar problem years ago with the Nexus 4.
In the Nexus 5 I don't suffer this anymore. However, sometimes still happen with a low chance.

Here are some reasons that could generate this:
- High lag/latency between you and the other person.
- One of the 2 phones lacks echo cancellation / is using "Speaker" (instead of Earpiece) / is using Earpiece with a really high volume that is captured by the mic in the same phone.
- And sometimes just the echo cancellation function stop working until your next call or reboot or whatever. (Based in my experience).

Regarding GSM calls:

I don't know too much about it. But I remember that when I had the Nexus 4 (with issues in VoIP) there was no problem here, because the echo cancellation is handled by the carrier's technology.
 
Last edited:
  • Like
Reactions: desalesouche

dave-ro-mex

Senior Member
Apr 28, 2009
75
6
Mexborough
This echo happens on all calls. GSM and VoIP and it just happens on a normal call with nobody on speaker.
Called Sony Mobile this morning who agreed it is faulty and are refunding me when it gets back to the Czech Republic.

They wanted 10+ days to replace the handset. So just ordered the same Z5 Compact again for next day delivery to a Store near me. Shame as it's more expensive this way. But I don't want to wait 10+ days.
 

knutmartin

New member
Oct 6, 2015
1
0
Hi, I do have the exact same problem. I hoped there was a easy fix, but might have to get it replaced.
 

dave-ro-mex

Senior Member
Apr 28, 2009
75
6
Mexborough
Hi, I do have the exact same problem. I hoped there was a easy fix, but might have to get it replaced.
I got a replacement. So i have 2 Z5 compacts right now.

I am sending the original back for a refund. The new one I got today does not have this issue and works perfectly. So I would send yours back for replacement as soon as you can. Don't let them 'repair' it.

It isn't a software issue. just unlucky.
 

thesebastian

Senior Member
Sep 25, 2012
1,874
445
Barcelona
I got a replacement. So i have 2 Z5 compacts right now.

I am sending the original back for a refund. The new one I got today does not have this issue and works perfectly. So I would send yours back for replacement as soon as you can. Don't let them 'repair' it.

It isn't a software issue. just unlucky.
Great news!

Could you post the rev and the batch number (in the box) just to know whether it's the same or not?

Sent from my Nexus 5
 

thesebastian

Senior Member
Sep 25, 2012
1,874
445
Barcelona
Is the batch number on the pull-out tab under the flap? Not sure what number I'm looking for.

At the Box. The first (i think) 8 digits corresponds to the batch and (maybe) the country, and the there is a revision too.

For example:

Amazon.it ships: 1298-2019
Amazon.es ships: 1298-2057

I assume there is a revision concatenated to the right too.
 
  • Like
Reactions: Just2Cause

thesebastian

Senior Member
Sep 25, 2012
1,874
445
Barcelona
Ok I wanted to report that VoIP is working fine on my Z5C (is a Rev3 device).

I made a lot of calls with VoIP using WiFi or mobile network. At the metro, my house, office. WhatsApp and Hangouts.

(Yes sometimes could appear some echo, but that depends on network quality and a lot of factors. 98% of the talked time so far was fine

The last call was a WhatsApp one of 17 minutes with WiFi, between my Z5C and a MotoE2015 and it was perfect ).

I also had a GSM call at the office just fine.

Sent from my E5823
 
Last edited:

Sean09

Senior Member
May 6, 2008
795
195
I've got to say,I really do not believe Sony knows what's going on. I've been dealing with support only to find out Sony won't fix my phone in Canada. They told me they will provide an international warranty, however, their repair vendor only services phones carried in Canada.

In addition, when I contact Sony about the echo issue they provide the same silly scripted nonsense solutions you see here - do a repair, followed by updating firmware, then they'll reference the software fix they've been claiming is in the works since November with no eta.

The consistent and scripted responses that fail to address the issue tell me Sony doesn't know or care to investigate a solution. They just give you the runaround.

I've been posting on their forums, but any time I indicate their solution doesn't work they moderate the message and remove responses other users have given. It's a great phone, but Sony support is utterly useless.
 

Enrico2828

Senior Member
Jan 19, 2009
62
10
I received my new z5 compact yesterday. Did a few test calls. GSM call and receive. Native voip call. Hangouts call. No echoing was noticed on either side. GSM quality is excellent. Voip was very delayed. Hangouts almost as good as GSM. I use the latest firmware. 32.0.A.6.200
 

Xenoswe

New member
Jan 20, 2016
1
0
I have noticed this on my Z5C as well and for me it only seem to happen if i call with speakerphone active before they answer, for me it seems to help to turn off the speaker and then turn it back on, so switching audio source seem to be a solution for me.
 

jibe.v

New member
May 4, 2016
1
0
I've got exactly the same probleme here : I bought my Z5C end of February and discover this echo problem couple of days after when people I was calling were all complaining.
I sent the device to the repair center but nothing has changed... I called the Sony Support and they still want me to sent again the phone for additional repairs but I already know that nothing will change.
It's a real shame from Sony to treat like this their customer : I had a Z3C before and was really excited to get the new Sow flagship but now after all this ****, i think it will be my last adventure with Sony.
 

Proday

Senior Member
Sep 19, 2010
274
36
I sad excatly the same 1 week after I have purchased z5c...sony = worst support ever!

Sent from my SM-G930F using Tapatalk
 

xda.xperia

Member
Apr 3, 2017
12
0
I've got exactly the same probleme here : I bought my Z5C end of February and discover this echo problem couple of days after when people I was calling were all complaining.
I sent the device to the repair center but nothing has changed... I called the Sony Support and they still want me to sent again the phone for additional repairs but I already know that nothing will change.
It's a real shame from Sony to treat like this their customer : I had a Z3C before and was really excited to get the new Sow flagship but now after all this ****, i think it will be my last adventure with Sony.

Yes, this is true. I had the same issue with 3 different Z5 Compact phones, two of them sent straight from Sony quality control. It's a systemic issue with the phone design.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Are you experiencing this issue with GSM calls or VoIP calls?


    Regarding VoIP calls:

    In VoIP calls, in which applications are you having this issue? Hangouts? Whatsapp? Skype? Viber? other?.


    I used to have a similar problem years ago with the Nexus 4.
    In the Nexus 5 I don't suffer this anymore. However, sometimes still happen with a low chance.

    Here are some reasons that could generate this:
    - High lag/latency between you and the other person.
    - One of the 2 phones lacks echo cancellation / is using "Speaker" (instead of Earpiece) / is using Earpiece with a really high volume that is captured by the mic in the same phone.
    - And sometimes just the echo cancellation function stop working until your next call or reboot or whatever. (Based in my experience).

    Regarding GSM calls:

    I don't know too much about it. But I remember that when I had the Nexus 4 (with issues in VoIP) there was no problem here, because the echo cancellation is handled by the carrier's technology.
    1
    Is the batch number on the pull-out tab under the flap? Not sure what number I'm looking for.

    At the Box. The first (i think) 8 digits corresponds to the batch and (maybe) the country, and the there is a revision too.

    For example:

    Amazon.it ships: 1298-2019
    Amazon.es ships: 1298-2057

    I assume there is a revision concatenated to the right too.
    1
    It is 1298-3811
    Hope that helps.