• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Philips 55OLED803/12 home screen icons missing...

Search This thread

IAmHuha

New member
Nov 17, 2020
2
0
Hi everyone,

I'm hoping someone can help me with an annoying problem with my Philips 55OLED803/12. I got the newest firmware (TPM171E: 107.1.132.0) installed.
On the Android Home screen (Oreo), where the apps channels (recommended videos etc) are, the app icons are not showing up for almost all apps (except YouTube,Netflix and Google Play Movies/Music).
There is only a grey circle where the app icon should show up. Here's what it looks like:
TjX13ez.jpg


I've tried everything I could come up with, including:
- reinstalling the apps, clearing the cache, clearing internet cache etc
- reinstalled the whole tv
- redownloaded the newest firmware and loaded it with upgrade_loader.pkg from USB

But the icons still won't show. I looked everywhere and only found a single reddit thread with no solution. I also tried contacting Philips support and got some general information with no solution. Perhaps You guys can help :)
 

psychodracon

Member
Jun 9, 2012
8
3
Any news on this? I'm having same issue, in addition lately my youtube recomendations stopped refreshing itself... I wanted to install Google TV launcher but unfortunately this tv has android 8 base firmware.
 

psychodracon

Member
Jun 9, 2012
8
3
That's wierd, i'm not able to find any version compiled for ATV8 as well as my TV won't update launcher or firmware.
 

MFKR1

New member
Oct 28, 2021
3
0
Hi everyone,

I'm hoping someone can help me with an annoying problem with my Philips 55OLED803/12. I got the newest firmware (TPM171E: 107.1.132.0) installed.
On the Android Home screen (Oreo), where the apps channels (recommended videos etc) are, the app icons are not showing up for almost all apps (except YouTube,Netflix and Google Play Movies/Music).
There is only a grey circle where the app icon should show up. Here's what it looks like:
TjX13ez.jpg


I've tried everything I could come up with, including:
- reinstalling the apps, clearing the cache, clearing internet cache etc
- reinstalled the whole tv
- redownloaded the newest firmware and loaded it with upgrade_loader.pkg from USB

But the icons still won't show. I looked everywhere and only found a single reddit thread with no solution. I also tried contacting Philips support and got some general information with no solution. Perhaps You guys can help :)
I got the exact same issue for the exact same TV for the last two years. Have you found any solution to this? Philips support is telling me to reinstall the TV but I got a feeling that it will not work...
 

IAmHuha

New member
Nov 17, 2020
2
0
No, unfortunately no solution for this. Icons still missing. And the new google-like launcher interface is still not available in my country, so still stuck with the grey circles instead of icons.
 

MFKR1

New member
Oct 28, 2021
3
0
No, unfortunately no solution for this. Icons still missing. And the new google-like launcher interface is still not available in my country, so still stuck with the grey circles instead of icons.
I'm talking to Philips support over email right now. I'll catch you up when I've get some news.
 

MFKR1

New member
Oct 28, 2021
3
0
@IAmHuha Ok so I got some response from Philips support. They basically said, "ask Google...". They couldn't do anything about it due to a compatibility issue between the apps and Android 8 and it's up to Google to fix it. So they obviously knew about the issue in the first place and could have said this waaay earlier so I didn't have to send loggfiles, reinstall the TV etc. I asked them if I would get the Google TV update and they had no idea. But later that day I got the update (I live in Sweden) so problem solved for me. Bottom line: Try Google support or wait for the Google TV update. And Philips support sucks...