Philips Android TV

Search This thread


Feb 4, 2018
Someone before said that after one year finally have perfect tv... Well, not really.

Tested on POS9002. 50 and 60 fps files STILL not played correctly. Everyone can test by themself –


Sep 17, 2018
Someone before said that after one year finally have perfect tv... Well, not really.

Tested on POS9002. 50 and 60 fps files STILL not played correctly. Everyone can test by themself –

Yes true, but don't know why it is much less visible for me when watching movies than with previous android 7 versions. I purchased the nvidia shield last year mainly for this reason and know i'm able to watch movies directly on the TV without feeling this judder due to framerate switching issue.. :eek:


Senior Member
Oct 25, 2011
Yes true, but don't know why it is much less visible for me when watching movies than with previous android 7 versions. I purchased the nvidia shield last year mainly for this reason and know i'm able to watch movies directly on the TV without feeling this judder due to framerate switching issue.. :eek:

If you bought nVidia Shield, then why bother buying a TV with Android TV OS at all?

Ambilight is the only feature that you will miss if you had bought an OLED directly from LG.

In every other aspect, LG WebOS is much more stable and performs way better in all apps, like YouTube, HBO Go, NetFlix, etc.

And you can connect the nVidia Shield to it and tadaaaaa, you have WORKING Android TV on your LG.
  • Like
Reactions: VangelisGi


Sep 17, 2018
1: because philips oled was much cheaper than lg when i bought it (1000€)

2: because the purpose was to get rid of any external box, and use kodi which is not available on webos. This is much more convenient for my wife and daughters to use than switching source. And has also more apps than lg webos.

3:I bought the Shield 6months after the tv when seeing i was not able yo play smoothly high bitrate movies, having judder issues, and dts issues, which would have been almost the same for every brand of tv because they all have 100mbit lan and no e-arc at that time.

4: now as i said i'm very happy with my philips tv and oreo, And use shield very very rarely.

Then, not disappointed at all, quite happy with my Philips even if i agree maybe not perfect i don't think others are better. ?


New member
May 14, 2007
Please help. The native NVM files for Philips 55 PUS7600 \ 60 (NVM.bin and NVM.eed) TV for 2015 are very necessary. Revision R3 is not suitable.
Last edited:


New member
Jan 14, 2019

Hello, looks like lot’s of AV recievers updated to support earc. Do we have any chances for such update on TPM171E (pus8102)?


Senior Member
Oct 26, 2017
  • Like
Reactions: jadded_rus


Senior Member
Apr 15, 2007
I upgraded my 43PUS7100 with a motherboard and wifi/bluetooth module of the 43PUS6401.
It's not possible to use the old connector for the wifi/bluetooth module to the motherboard as it requires a larger connector.

Does anyone know what this connector is called so I can buy it on the internet?
Last edited:


New member
May 28, 2019
Hello, need firmware for tv philips 55PUS7303 / 12 in the TPM171E _ version and this file upgrade_loader.pkg
Hello. I have 43pus7303 and I also searched for this firmware. And I finally found it. I can not post links to the forum. You need to go to www-philips-co-uk (replace "-" to ".") and search "49pus7502/05", open the page of this TV, go to Support, go to Software Updates. But there is one difficulty - it is supposedly for TPM172E (as I understood it just renamed TPM171E, for UK-Models), therefore TV will not start the firmware process. Must be installed from recovery mode. I am pleased with this firmware. All the problems with the asprect ratio in all the applications that I use to watch movies online disappeared (I tried all possible firmware on Android 7 and Android 8 and everywhere there were some problems). The only thing that upset is that on there is no access to NTFS from third-party applications (only the system Media app has access), so this firmware is still not perfect, but for me this is the best solution, since I don’t need ntfs.
to install TPM172E_R. at 55pus7303 you need:
1) perform a firmware version downgrade with any upgrade_loader.pkg for TPM171E from toengel_net/philipsblog/firmware-archiv (replace "_" to ".")
2) put the TV into recovery mode (I used adb)
3) select "Apply update from SD card"
Last edited:


New member
Jun 12, 2019

I have a 43PUS6401_12 which is unusable. It has been cycling colours on screen and I cannot find any way to exit this mode.

It started during a software update. The TV responds to the remote, but there is no display other than the cycling colours (red>yellow>green etc).

I cannot get to any menus. Previously I could hear broadcast TV, but it's no longer connected to the aerial as I've replaced the TV. I'd like to bring it back to life as a second set however.

Does anyone have any idea how to solve this?

I've tried uploading firmware, but without a display I cannot do much. And it's not connecting to wifi, so I can't remotely access recovery mode.

When I put a USB stick in, the below output is written to the drive.

1.1 Set type:43PUS6401/12
1.2 Production code:FZ1A1629045144
1.4a Options 1:00036 33073 40963 10304
1.4b Options 2:51782 00366 14371 00000
1.5 18AC SSB:705TXGSC43000100SX
1.6 18AC display:750TBV430EQMHBN000
1.7 18AC supply:PLTVFQ461XAO2
1.8 18AC sensor board:

2.1 Current main software:QM163E.
2.2 Standby software:
2.3 e-UM version:MTK_PPR4_N_v13_20180123
2.4 Strings database version:FRS 1.0a - 2018/March/29
2.8 FRC-V software:0.1.22
2.10 Channel package version:45.1
2.15 E-Sticker version:
2.16 DemoMe version:demo files not found

3.1 Signal quality:
3.4 Ethernet MAC address:1c:5a:6b:e5:ce:93
3.5 Wireless MAC address:54:2a:a2:c8:6b:1c
3.6 Netflix key:NFANDROID2-PRV-PHTV16AMT2-PHILIQM163E-6465-(removed)
3.7 CI module:NO
3.8 CI+ protected service:NO
3.9 Event counter:D:0001 R:0000 H:0000
Last edited:


Jun 5, 2019
Hi Guy,

I recently buy a Android TV Philips PUS7909. It's an android tv based with 4.2.2 on board, unfortunatly Philips make the choice to block LOTS of android function...

I can't install unallowed apps, enabling dev mod....

I just want to know if someone here have this tv, or another philips android tv, and if someone can root it etc etc :D

Yes i know, it's not even christmas , but maybe someone can do amazing thing on android tv, specially on xda !

I too tried to install apps from third party. But I failed to do so.


Apr 19, 2011
Hello everyone! Does any of you encountered any problem with the update of the easy remote on 55OLED803 after the last update? I get an annoying message after every start and it cannot be upgraded.


Senior Member
May 26, 2014
Anyone knows if there is an app or tweak you could install to make the philips tv display a samsung like frame screensaver ?
For now i found "Aerial - Live Wallpapers" and the chromecast default screen.
That's just wallpapers not the fancy frame border you see.

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Guys! To disable Philips Collections bar or also known as Philips Apps Tray at top of Android TV leanback launcher. All you have to do is find leanbackcustomizer in System Apps or Running Apps and turn off its notifications which can be turned off at button of the menu when you click on the service.

    I couldn't find a single source which mentioned these steps to take to disable Philips bloatware. I figured these out on own. I am not aware of any other methods that has the same results.

    Enjoy your less of a pain Android TV by Philips

    Hope this helps.

    ---------- Post added at 02:03 AM ---------- Previous post was at 01:56 AM ----------

    To disable recommendations, disable org.droidtv.nett_launcherapp in system apps or running apps. Hope this also helps debloat your Philips Android TV to a manageable level. However, this doesn't get rid of the recommendations field only apps that shows up.
    firmware decryption + rooting attempts

    WARNING: don't look at the following information nor try to use any of it if you have no clue about linux or android as it is most likely that you are going to break your expensive gadget. For every one else: don't blame philips if you brick your device -> think before actually trying. If you post about vulnerabilities and stuff better cover your ass - who knows what the legal department of philips thinks about your cool stuff.

    So as you decided to ignore my warning, here we go:

    I already spent plenty of time researching the internals of the device in order to get root privileges. Unluckily without the final breakthrough - but at least I found out some very interesting details.

    You might ask what those extended privileges should be good for? Well in my eyes android - a project available as open source with uncountable possibilities for developers and users - should not be closed down by profit oriented manufacturers. As those are often forcing the users into their own "crappy" software without given them any chance to escape. I like to develop at system base, use the underlying linux tools and most important check what the manufacturer does (behind my back) in my own living room. Hell I bought this expensive device and have no idea and can't nearly control what is sent to Philips nor Google.

    1. I wrote a tool to decrypt the official firmware. It was created via reverse-engineering the "upgrade.bin" arm-file (thanks for the trace, snoerenberg).

    Some interesting details about the used cryptography:
    - openssl library functions
    - used algorithm: aes-256 in CBC mode
    - the encryption key is generated via "EVP_BytesToKey" using only the first 127 byte of the keyfile + an eight byte salt found near the beginning of every input file

    Source-Code: attachment or pastebin_com / z3nA2r3J
    maybe mirroring this paste and the source would be a good idea (Google for the HASH if link is down)

    The decrypted firmware archive contains the following files: kernel + initrd + ramdisk (unknown file format) bootloader (unknown file format) ? maybe recovery (unknown file format) content of /user_setting content of /system (ext4-img) content of /firmware (ext4-img),,, different binary files - supposedly firmware for these components

    As you see I was not able to extract the most interesting part (kernel + ramdisk) - Hopefully some android experts could help!

    The current and some older firmware files could be downloaded at philips_samipupu_com (thanks for hosting)

    2. General information:
    - Kernel version: Linux version 3.4.70+ ([email protected]) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP PREEMPT Fri Nov 14 01:52:21 IST 2014
    - Kernel cmd-line: androidboot.hardware=AND1E quiet lpj=11935744 root=/dev/ram0 androidboot.console=ttyS0 console=ttyS0,115200 init=/init vmalloc=448M quiet macaddr=00:00:00:00:00:00 emmc_ts.dev_id=1 emmc_ts.size=16777216 emmc_ts.erasesize=524288 emmc_ts.writesize=512
    - lsmod:
    usb8797 359014 3 - Live 0x00000000
    usb97mlan 290809 1 usb8797, Live 0x00000000 (P)
    mbtusbchar 52685 0 - Live 0x00000000
    usbfwdnld 8530 0 - Live 0x00000000
    fusion 96777 0 - Live 0x00000000 (O)
    tpvinput 7132 2 - Live 0x00000000 (O)
    trcext 333860 0 - Live 0x00000000 (O)
    gal3d 161434 16 - Live 0x00000000
    amp_core 72528 2 - Live 0x00000000 (O)
    tzlogger 1199 0 - Live 0x00000000 (O)
    tzd 32013 30 amp_core,tzlogger, Live 0x00000000 (O)

    3. The trcext module seems to be very interesting as a short look with a disassembler revealed that it might be able to read and manipulate process memory of any process. Maybe someone good at kernel-drivers could take a look?

    4. There are two world-readable directories containing very interesting information:
    - /data/debugdump: stack-traces, process-lists, short memory excerpts based on crashes of the native binaries (could be very helpful for exploiting)
    - /data/anr: davlik crash-dumps of android applications

    5. There are 3 SGUID and 1 SUID binaries (visible):
    -rwxr-s--- root inet 5500 netcfg
    -rwxr-sr-x root net_raw 26072 ping
    -rwsr-s--- root shell 9464 run-as

    6. The recovery menu which could be used to install a "new" firmware if the device does not boot properly could be reached via the following steps:
    - unplug the power
    - press and hold the joypad on the backside of the TV downwards
    - replug
    - release the joypad after 10 sec

    7. There is a Customer-Service-Menu at “123654” which contains read only information about the current firmware and so one. However there is also the real service menu (062?96i) which could be used for much more things. But you need to be really careful with this, i already managed to break booting without changing something important.

    8. The settings-app calls the "su" command inside of CSMActivity. If this is no obsolete debug code (i was not able to trigger this part yet) than there could be a "su" inside /sbin. The Manifest also shows this strange "" permission. Therefore i tried to write my own app with the same permission and call "su" which did however not work out (even if I use the same namespace org.droidtv.?)

    9. Every time you pop in an usb stick android creates an backup folder on it. The filenames are "hidden" via base64 and there are some junk bytes at the beginning of the files which you need to crop in order to read them. However the content is quite boring mostly some sqlite3 databases with configuration parameters.

    10. By default the usb sticks you plug in is read-only for user apps. However there is in option in the settings to re-format it. This will result in an XFS formatted, read-write mounted stick where you could even outsource your apps.

    11. There is a soap (http) service running on port 1925 which is used by the philips remote app and allows different things for example starting one of the installed apps. More details could be found if you decompile the XTV-App.

    Hope some of you guys could do something fancy with those information.
    @snoerenberg(xda): did you manage to send commands over your cable yet - If you do rooting should be quite easy from this point (maybe /system/bin/run-as).


    ps: some of the information were dumped on an older firmware and some with the current one
    Steps for install any APK in 2014 Philips Android TV AND1E


    For install any application in 2014 Philips Android TV AND1E :

    1º You must download "Developer Settings" from "Google Play" and enable "Usb Debugging" in "Developer options".
    2º Connect ADB via WIFI -> adb start-server" , adb connect IP:5555
    3º Install APK -> adb install "app.apk" (download apk from google play with evozzi apk downloader in web or in chrome extension)

    I've tried it in 55PUS8909 and it works!.

    I've tried for root framaroot, towelroot and vroot and exploits not run.
    I've tried all for "Unknown Sources" and nothing.

    sorry for my english....thanks, regards!
    [GUIDE] How to root 2015 Philips Android TV

    [GUIDE] How to root 2015 Philips Android TV moved to separate thread here

    Please vote regardless you were successful with rooting or not...